Announcement

Collapse
No announcement yet.

Pixelated Cockpit View

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Nice try

    fr24ad.jpg

    Leave a comment:


  • peterhr
    replied
    Originally posted by Matt C View Post
    I know nothing about computers so I apologise if this is a really silly suggestion! I too have the same issue with the 3D view where the whole horizon is really glitchy and pixelated but works okay when I put it into plane mode so that the plane appears in the middle of the screen. However, when I change the orientation of the camera to show the front of the plane I can see the front part of the plane where the nose and cockpit is glitching! But only the front part of the plane, no where else. So what I'm suggesting is that it could be possible that it's the software for displaying something as simple as the plane in the middle of the screen that is causing the issue. The glitching seems to be happening on the front of the plane in the exact same rhythm (if that makes sense) as the glitching on the horizon when in cockpit view. So it's possible that that is to blame.
    This uses the Google earth API - I found that setting Google earth (main product) to start in OpenGL mode by default. Closing Google eath that using 3D view in FR24 the break up doesn't happen.
    ... I think this is a bug in google earth - maybe with scaling where they are trying to display their repetitively high res data in low res at an angle where it's showing something near the horizon at a distance.

    Leave a comment:


  • Matt C
    replied
    I know nothing about computers so I apologise if this is a really silly suggestion! I too have the same issue with the 3D view where the whole horizon is really glitchy and pixelated but works okay when I put it into plane mode so that the plane appears in the middle of the screen. However, when I change the orientation of the camera to show the front of the plane I can see the front part of the plane where the nose and cockpit is glitching! But only the front part of the plane, no where else. So what I'm suggesting is that it could be possible that it's the software for displaying something as simple as the plane in the middle of the screen that is causing the issue. The glitching seems to be happening on the front of the plane in the exact same rhythm (if that makes sense) as the glitching on the horizon when in cockpit view. So it's possible that that is to blame.

    Leave a comment:


  • pjg
    replied
    Firstly, thanks for the response. "We've put effort into this but haven't resolved it" is a much much better response than the "must be a problem with your graphics card" or "update your drivers" type of response in the past. Secondly (and please don't take this the wrong way)I don't recognise "there is no solution". I would recognise "there is a solution but I/we don't know what it is". That's not a trite statement, it comes from writing all kinds of applications in pretty much every language for well over 40 years.
    The offer of help still stands. Cheers.

    Leave a comment:


  • Jarod
    replied
    Originally posted by pjg View Post
    (I'm not nagging here, just reporting what I see in the hope it will mean something to those who know how all this works).
    I've been playing with this this afternoon. When it works, ie sometimes when I make a fresh visit to the site and pick the first plane, the "AIRCRAFT" switch does not display the aircraft, there's just a slight shift in the picture when I click it up and down. When it breaks and the pixelation comes back, either by clicking the Rotate View button one or more times or exiting the cockpit view and clicking 3d again, then clicking the aircraft button does show the plane, and the pixelation goes away. Clicking the aircraft button again removes the plane but brings the pixelation back.

    It seems the problem is something to do with 3d. The stuff at the bottom of the screen, ie what we would be looking almost straight down at, is almost ok, just the faintest flicker. The closer to the horizon we get, ie the more shallow the angle of view is and the more 3d we need to do, the worse the problem is, and the pixelation looks more vertical cliff-like. The sky, with no 3d work to do, is perfect.

    I said in my earlier post that this didn't happen some time ago. With hindsight, it's possible it worked the first time and I didn't try a second. Too long ago...
    I can confirm this on Google Chrome (winxp 32bit).
    It has worked before, but was a long time since i checked it. Seems the problem lies with Google indeed.

    Leave a comment:


  • Mike
    replied
    We have put about 100+ hours on solving this and there is no solution. Running an app in full screen, is not the same as running something in a browser window. I'm absolutely no expert about how this works but from what I have had explained there are several different 3D modes and some combinations of hardware<->software<->driver just don't work together. We just can't put unlimited resources to this, there are other issues with higher priority. I have seen that there are threads on Google forums about this, so we are not the only ones having this issue.

    Leave a comment:


  • pjg
    replied
    Yet the problem doesn't happen in Google Earth Flight Simulator, which I guess must be doing something very similar to what you are doing. I've just been through every option in the nvidia control panel & changed it, and it made no difference. I haven't tried every combination of every option, life's too short, but I changed every option to something else. It's interesting (to me anyway) that the problem doesn't happen when the aircraft is displayed, something must be different there.

    Mike, if the problem doesn't happen for you then you aren't going to have much luck finding out what it is, is there any way I can help? I'm a retired software developer & quite willing to put some time into this. Is there any way you can send me some code snippets or whatever? - pete

    Leave a comment:


  • Mike
    replied
    The are absolutely no settings/options for us to change/adjust/optimze. We just tell Google Earth "plot this". It's up to Google Earth to plot it and how they do it. There may be some settings in how 3D is handled and drawn in your graphic cards settings.

    Leave a comment:


  • ChuckinKona
    replied
    Aloha,

    Just another two cents worth on the subject. I have reported the problem in the past, and received the "drivers must be out of date/card inadequate" response, although both current and capable. Same problems on brand new laptop. Both running windows 64 bit (7 & 8 respectively). There is a problem beyond driver/card. Something in the system isn't working. Would like to hear that some substantial effort is being made to sort the issue out.

    Love the site, would hope that this wart could get removed.

    Chuck

    Leave a comment:


  • pjg
    replied
    Originally posted by Amper View Post
    When you change to AIRCRAFT wait a bit...it will show aircraft...
    You're right, it does after a few minutes. Once it does, clicking it off brings the problem back.

    Leave a comment:


  • Amper
    replied
    Originally posted by pjg View Post
    I make a fresh visit to the site and pick the first plane, the "AIRCRAFT" switch does not display the aircraft, there's just a slight shift in the picture when I click it up and down.
    When you change to AIRCRAFT wait a bit...it will show aircraft...

    Leave a comment:


  • pjg
    replied
    (I'm not nagging here, just reporting what I see in the hope it will mean something to those who know how all this works).
    I've been playing with this this afternoon. When it works, ie sometimes when I make a fresh visit to the site and pick the first plane, the "AIRCRAFT" switch does not display the aircraft, there's just a slight shift in the picture when I click it up and down. When it breaks and the pixelation comes back, either by clicking the Rotate View button one or more times or exiting the cockpit view and clicking 3d again, then clicking the aircraft button does show the plane, and the pixelation goes away. Clicking the aircraft button again removes the plane but brings the pixelation back.

    It seems the problem is something to do with 3d. The stuff at the bottom of the screen, ie what we would be looking almost straight down at, is almost ok, just the faintest flicker. The closer to the horizon we get, ie the more shallow the angle of view is and the more 3d we need to do, the worse the problem is, and the pixelation looks more vertical cliff-like. The sky, with no 3d work to do, is perfect.

    I said in my earlier post that this didn't happen some time ago. With hindsight, it's possible it worked the first time and I didn't try a second. Too long ago...

    Leave a comment:


  • Amper
    replied
    same here
    regards

    Leave a comment:


  • pjg
    replied
    I see the pixelated cockpit view, running W7 64 bit too. Huge GTX560 ti graphics card, have updated drivers, now dated 4 days ago. Doesn't happen if I display the aircraft. Sometimes, very rarely, doesn't happen for the first plane I select after going to the web site, but in that case the problem will start happening if I click Rotate View, or exit, select another, or even the same, aircraft & click 3D again. Doesn't happen in Google Earth flight simulator. Happens with Firefox and Chrome, haven't tried IE. I'm sure it wasn't happening some while ago, but can't put a date on when that was. There is definitely something wrong here.

    Leave a comment:


  • Birdie
    replied
    Maybe your video card problem.

    Leave a comment:

Working...
X