Announcement

Collapse
No announcement yet.

How to Install dump1090-mutability_1.15~dev on RPi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wiedehopf
    replied
    Disable MLAT then.
    And maybe remove the graphs.

    The recent 1.024 versions of fr24feed seem to be using more CPU.

    Leave a comment:


  • Scroggie
    replied
    What was strange was the sudden increase in that network traffic AFTER doing test gain changes. I hadn't got a browser running for most of the time. I think using Pi 1s is asking a lot anyway - cpu is running at 100% all the time. Christmas is coming..... Pi4?

    Leave a comment:


  • wiedehopf
    replied
    Don't leave the page open if the traffic matters to you?

    It's not like it's an issue on an internal network.
    And even over the internet, 50 kB/s is usually not an issue.

    Leave a comment:


  • Scroggie
    replied
    Originally posted by wiedehopf View Post
    That's just network traffic.

    Having the graph page auto refreshing alone will be some part of that.

    So is there a setting to change the auto updating?

    Leave a comment:


  • wiedehopf
    replied
    That's just network traffic.

    Having the graph page auto refreshing alone will be some part of that.

    Leave a comment:


  • Scroggie
    replied
    Originally posted by wiedehopf View Post
    No clue, have never seen that. Just reboot?

    I'd tell you to check sudo journalctl -u dump1090-fa ... but this is mutability, i'm not really familiar with it.

    Yes, tried a couple of reboots - no change.
    This particular installation is using a very old 1st generation Pi with very cheap eBay USB receiver. - one I just experiment with, so it's not a problem really. I was just intrigued.

    There is this going on now as well I see.system-localhost-network_bandwidth-6h.png
    Last edited by Scroggie; 2019-11-07, 18:17.

    Leave a comment:


  • wiedehopf
    replied
    No clue, have never seen that. Just reboot?

    I'd tell you to check sudo journalctl -u dump1090-fa ... but this is mutability, i'm not really familiar with it.
    Last edited by wiedehopf; 2019-11-07, 17:52.

    Leave a comment:


  • Scroggie
    replied
    Graphs query

    I don't understand what happened here. At approximately 14:10 I did a test gain change to from -10 to 40.2 and seeing the worsening tried 49.6. That too was poor so I went back to -10. That's showing clearly in the signal level graph - just as expected. It's the "ADS-B Message Rate" chart that puzzles me. The wavy nature of the plot is completely different to what it was before the tests. (The reboot at 16:50 is unrelated)

    EGSY1
    Attached Files

    Leave a comment:


  • Scroggie
    replied
    Many thanks for that rapid reply, exactly what I was looking for.

    EGYSY1

    Leave a comment:


  • wiedehopf
    replied
    Edit /usr/share/dump1090-mutability/html/config.js

    You should find around line 100 something like this:
    Code:
    SiteCircles = true; // true to show circles (only shown if the center marker is shown)
    // In miles, nautical miles, or km (depending settings value 'DisplayUnits')
    SiteCirclesDistances = new Array(100,150,200,250);
    Should be self explanatory what you need to change.

    If you use at the local interface often, consider trying this: https://github.com/wiedehopf/tar1090#tar1090

    For all details (like indicated air speed and such extended data) to be shown, you'll need dump1090-fa though.
    Oh it also depends if the ATC radar in your area queries aircraft for such details, otherwise they can't be shown.

    Leave a comment:


  • Scroggie
    replied
    Hi Captain

    After yet another SD card failure I've done another re-build. At least I am getting quicker at the process! (and I'm going to take a full image of this completed install this time)
    I'm wondering how (or If) I can add 2 more range circles to my map. I'd like 250nm and 300nm as many of my received aircraft are in that range.
    Running Buster Lite (and Full) Pi1, Pi2 and Pi3B+

    Help would be much appreciated
    EGSY1

    Leave a comment:


  • abcd567
    replied
    perseus68

    Glad to know your problem is solved by installing dump1090-fa.

    You have made a wise decision to install wiedehopf's graphs. These graphs are very useful tool.

    Leave a comment:


  • perseus68
    replied
    Originally posted by abcd567 View Post
    (1) seems some file got corrupted during installation process. Please purge dump1090-mutability by following commands, then reinstall.
    Note:
    Which method you use to install dump1090(method-1 prebuilt package or method-2 built from source code)?

    The pre-built package is built for Raspbian on Raspberry Pi. You have Armbian on Orange Pi.
    Code:
    sudo dpkg --purge dump1090-mutability
    sudo rm -rf /usr/share/dump1090-mutability
    (2) Delete following lines:

    path="/usr/lib/fr24/dump1090"
    procargs="--net --gain 46 --fix"

    Above two lines are for fr24feed's builtin dump1090 ver 1.14, which you are not using. These have no effect whatsoever on ver 1.15~dev installed independently.

    The correct path to the binary "/usr/bin/dump1090-mutability" is specified in the file "dump1090-mutability.service" . You dont have to specify it anywhere. It is the service file which starts dump1090-mutability ver 1.15 at boot.
    Thanks abcd567 & wiedehopf

    Finally I purged tha installation of Dump1090-mutability and decided to give a try to Dump1090-fa.
    I used the automatic script as indicated by wiedehopf and it worked at the first attempt.

    So cool!

    Iīm back to feeding.
    Next step will be install some nice performance graphs

    Cheers
    Mark
    Last edited by perseus68; 2019-09-30, 07:13.

    Leave a comment:


  • abcd567
    replied
    (1) seems some file got corrupted during installation process. Please purge dump1090-mutability by following commands, then reinstall.
    Note:
    Which method you used to install dump1090 (method-1 prebuilt package, or method-2 built from source code)?

    The pre-built package is built for Raspbian on Raspberry Pi. You have Armbian on Orange Pi.
    Code:
    sudo dpkg --purge dump1090-mutability
    sudo rm -rf /usr/share/dump1090-mutability
    (2) Delete following lines:

    path="/usr/lib/fr24/dump1090"
    procargs="--net --gain 46 --fix"

    Above two lines are for fr24feed's builtin dump1090 ver 1.14, which you are not using. These have no effect whatsoever on ver 1.15~dev installed independently.

    The correct path to the binary "/usr/bin/dump1090-mutability" is specified in the file "dump1090-mutability.service" . You dont have to specify it anywhere. It is the service file which starts dump1090-mutability ver 1.15 at boot.
    Last edited by abcd567; 2019-09-26, 23:40.

    Leave a comment:


  • perseus68
    replied
    Originally posted by wiedehopf View Post
    Don't feel like debugging that, maybe someone else can help you.

    Or use this, it just works: https://github.com/wiedehopf/adsb-sc...for-dump1090fa
    Thanks wiedehopf. That was my second choice. Letīs see if I can fix it in a reasonable amount of time

    Leave a comment:

Working...
X