Announcement

Collapse
No announcement yet.

How to Install dump1090-mutability on RPi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • abcd567
    replied
    Originally posted by Banthum View Post
    I have the same problem. Installed it a second time.
    But still this error 403-forbidden.
    What do you mean by "the same problem"?
    What you were trying to do when you got "error 403-forbidden"?
    Please give details.

    .

    Leave a comment:


  • abcd567
    replied
    Originally posted by Banthum View Post
    But dump1090 is a EB-version and not V1.15 -dev.
    The version v1.15~dev is no more maintained by its author Oliver Jowett, and he has archived its source code at Github/mutability.

    However Debian has forked it and the forked branch at Debian is being maintained by Debian Hamradio Maintainers.

    When installed by command "sudo apt-get install dump1090-mutability", the dump1090-mutability gets installed from Debian repository. This one has ver changed from v.15~dev to EB_VER. It uses the same source code as the ver1.15~dev at Github/mutability.

    https://tracker.debian.org/pkg/dump1090-mutability

    NOTE:
    The Debian Repisitory version's actual name intended to be displayed on map was DEB_VER (Debian Version). However due to some bug in the code, the first letter D gets ommited, displaying only EB_VER

    .
    Last edited by abcd567; 2020-12-22, 21:11.

    Leave a comment:


  • Banthum
    replied
    I have the same problem. Installed it a second time.
    But still this error 403-forbidden.

    Leave a comment:


  • Oblivian
    replied
    Unfortunately changing the forum also edited some previously put in code/text converting it to HTML. And some people re-pasting from their lanuage settings can do it too (as above)

    amp; = &

    Linux knows &, but not amp;

    Put those in place of any amp; and it will function. Just hard to locate them across all posts after the fact

    Leave a comment:


  • Banthum
    replied
    Problem solved,
    Error in the line:
    sudo wget -O /usr/share/dump1090-mutability/html/upintheair.json "http://www.heywhatsthat.com/api/upintheair.json?id=XXXXXXXX&refraction=0.2 5&alts=12192"
    Removed the item: amp;amp;

    Leave a comment:


  • Banthum
    replied
    To abcd567: Installed all on a brand new SD card. But dump1090 is a EB-version and not V1.15 -dev. So no max range rings.
    So what went wrong on my PI4B with Buster


    1090.JPG


    Leave a comment:


  • Oblivian
    replied
    That's the software or your language settings not recognizing ampersand

    &

    after upgrades

    Leave a comment:


  • sibaar
    replied
    abcd567

    Code:
    (d) Install data feeders FR24, Flightaware, & Planefinder (Steps 11, 12, & 13).
    
    You can create as many rings as you want by adding elevations (in meters) at the end of URL given in the wget command above after "&alts=", separated by commas.
    
    http://<ip address of your RPi on your LAN>/dump1090/gmap.html
    
    (A) RPi 2 & 3 with Raspbian STRETCH

    Referring to these "amp" references on the first tutorial page. There's also an amp;amp reference in the json sudo wget command


    I ran the purge and re-installation command you suggested, it didn't change anything. systemctl still reports a failure to start.

    Leave a comment:


  • abcd567
    replied
    Originally posted by sibaar View Post

    You mention "amp" a few times. Not sure what it is.
    Where did I mention "amp"?
    Please give my full sentence or full command. Just saying "amp" does not give any clue.


    Originally posted by sibaar View Post
    I do have lighttdp installed however it won't start. Returns "failed to start lighttdp daemon" and "exited code."
    Seems you got a corrupted install of lighttpd. Purge it, then reinstall

    sudo apt purge lighttpd

    sudo apt install lighttpd


    .

    Leave a comment:


  • sibaar
    replied
    Originally posted by abcd567 View Post
    (1) What do you mean by "amp command"?

    (2) A web server is required to display map. By default dump1090 requires lighttpd as web server. It is installed as dependency of dump1090. May be you did not install it. The output of following command will show if you have it installed:

    apt policy lighttpd


    If lighttpd is not installed, please install it by following command:

    sudo apt install lighttpd


    .
    You mention "amp" a few times. Not sure what it is.

    I do have lighttdp installed however it won't start. Returns "failed to start lighttdp daemon" and "exited code."

    Leave a comment:


  • sibaar
    replied
    I'm also getting enable mod errors from lighttdp stating that "dump1090-mutability" is not recognize. Can't start lighttdp either. Some other forums suggested installing gamin, which didn't work either.

    Leave a comment:


  • abcd567
    replied
    (1) What do you mean by "amp command"?

    (2) A web server is required to display map. By default dump1090 requires lighttpd as web server. It is installed as dependency of dump1090. May be you did not install it. The output of following command will show if you have it installed:

    apt policy lighttpd


    If lighttpd is not installed, please install it by following command:

    sudo apt install lighttpd


    .
    Last edited by abcd567; 2020-07-21, 01:09.

    Leave a comment:


  • sibaar
    replied
    What is this amp command? I get 404 error when I try to access pi/dump1090. Does it require a webserver like nginx or apache2 installed?

    Leave a comment:


  • abcd567
    replied
    Graeme2812:

    The DVBT/dump1090 do NOT display absolute value of signal in dBm (dB miliwatt). They provide relative signal strength on a scale of 0 to -50 dBFs, 0 being the strength of strongest signal recieved. Hence a signal with an RSSI of -3 dBFs is stronger than a signal with an RSSI of -10 dBFs.

    Leave a comment:


  • Graeme2812
    replied
    I've installed the RSSI display into gmap.html aircraft list, however whenever aircraft are listed it only shows RSSI and not the actual signal. Any ideas?

    I'm running v1.15 dump.

    Leave a comment:

Working...
X