Announcement

Collapse
No announcement yet.

Newbie with Raspberry Pi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbie with Raspberry Pi

    Hello!

    (I tried to make another post before containing the logs, but I might have beed deleted due to unwanted links :-) So I try one more time.

    I am having a Raspberry Pi (first generation with an Soundtek MediaTV DVB receiver), I installed the fr24 feeding software on PI, all up and running (according to service fr24feed status) but... I see the following thing in my logs:

    Code:
    2016-03-22 21:13:27 | [reader][i]Connecting to Beast receiver via (exe: / / / usr/lib / fr24 / dump1090  --raw)
    2016-03-22 21:13:27 | [reader][i]Connected to the receiver, configuring
    2016-03-22 21:13:27 | [reader][i]Configured, processing messages
    2016-03-22 21:13:27 | [reader][i]Connection terminated
    2016-03-22 21:13:27 | [main][i]Terminating child process 2380 with SIGETERM
    2016-03-22 21:13:33 | [reader][i]Connecting to Beast receiver via (exe: / / / usr / lib / fr24 / dump1090  --raw)
    2016-03-22 21:13:33 | [reader][i]Connected to the receiver, configuring
    2016-03-22 21:13:33 | [reader][i]Configured, processing messages
    2016-03-22 21:13:33 | [reader][i]Connection terminated
    2016-03-22 21:13:33 | [main][i]Terminating child process 2382 with SIGETERM
    and this keeps repeating over and over again. I don't believe my PI is feeding any data to FR24, but I do not know why. Anyone has any idea?

    (PS: I added a space before every backslash in the log above.)

    Thank you!

  • #2
    Well unless you have a Beast receiver, you configured it incorrectly. Should have chosen DVBT

    ]Connecting to Beast receiver via (exe: / / / usr/lib / fr24 / dump1090 --raw)

    While running you need to goto the web setup in browser and reconfigure it to DVBT

    See my sticky under the feeder thread area for further.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      I believe I have it configured as DVBTV. This is what the web setup shows
      Screen Shot 2016-03-22 at 22.03.03.jpeg

      What should I do now?

      Comment


      • #4
        This is also the settings in the web setup:
        Screen Shot 2016-03-22 at 22.13.57.jpg

        Comment


        • #5
          Now restart and re-run and post an updated start log if its still got issues.

          It may be that your reception is too low, or the stick does not support the right frequency range and will not get data to initiate the network upload.
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            Done. It still behaves the same... Please find a more complete log (after the saved settings and restarted) on pastebin with ID: eQWadpUH (please reconstitute the pastebin url as I still can't post URLs). Thanks!

            Comment


            • #7
              On the same pastebin there is the list of the status variables too: pastebin . com / CVHkxf6v

              Comment


              • #8
                Originally posted by crapufish View Post
                Done. It still behaves the same... Please find a more complete log (after the saved settings and restarted) on pastebin with ID: eQWadpUH (please reconstitute the pastebin url as I still can't post URLs). Thanks!
                Thats in beast mode again!

                Its not initializing Dump1090 as it should. I'm not at a PC to confirm but I think you can remove the path to the Dump1090 instance. It should be called automatically.

                Per my example. You should be seeing this:

                [main][i]Version: 1.0.16-7/generic
                Connecting to Generic receiver via (exe://mr-dump1090.exe --raw --net --net-http-port 8080) (slightly diff for non windows)
                Found 1 device(s):
                0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                Found Rafael Micro R820T tuner
                Max available gain is: 49.60 dB
                Setting gain to: 49.60 dB
                Exact sample rate is: 2000000.052982 Hz
                Gain reported by device: 49.60 dB
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  It seems it doesn't change anything to remove the path to the dump1090: http://pastebin.com/Q2mdsqFz

                  Comment


                  • #10
                    It seems it didn't change anything removing the path: see on pastebin Q2mdsqFz

                    Comment


                    • #11
                      Wont do much at all until you have a saved fr24feed.ini file that says DVBT and not beast.

                      You can see its not even trying to instate the USB port - Dump1090 handles a beast totally different from a USB device that it needs to open the hardware for.
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • #12
                        This is everything I have in the ini file:

                        Code:
                        receiver="dvbt"
                        bs="yes"
                        raw="yes"
                        logmode="1"
                        windowmode="0"
                        mpx="no"
                        mlat="no"
                        mlat-without-gps="no"
                        (I removed the fr24key)

                        Can I add something here by hand?

                        Comment


                        • #13
                          So what command are you starting it with? as it should be automatic if you used the service command. All pointers are the version you are running is misconfigured or not using the right config file.

                          It should clearly access the USB stick and yours is not. If you are manually running it you are possibly starting a 2nd instance as it runs in the background.

                          What does sudo service fr24feed status show

                          If it says its running, you do NOT want to re-run it. But stop it until you can confirm you have confirmed it works properly.

                          sudo service fr24feed stop
                          sudo service fr24feed status (ensure nothing there)
                          sudo fr24feed start

                          That will give actual output
                          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                          Comment


                          • #14
                            So, An update?

                            I must apologise also, it seems there is a bug with the new version - I'm about to report it... they have the labels wrong!

                            However, it's still not connecting to the USB in your instance - This is what I would expect if you are running the single copy configured to DVBT (yet it now says beast!)

                            Code:
                            2016-03-23 20:39:01 | [main][i]FR24 Feeder/Decoder
                            2016-03-23 20:39:01 | [main][i]Version: 1.0.18-5/generic
                            2016-03-23 20:39:01 | [main][i]Built on Mar  4 2016 15:21:10 (HEAD-d11ca48.git/Linux/armv7l)
                            2016-03-23 20:39:01 | [main][i]Copyright 2012-2016 Flightradar24 AB
                            2016-03-23 20:39:01 | [main][i]http://flightradar24.com
                            2016-03-23 20:39:01 | [main][i]DNS mode: LIBC
                            2016-03-23 20:39:01 | [main][i]Automatic updates are DISABLED
                            2016-03-23 20:39:01 | ERROR
                            2016-03-23 20:39:01 | [httpd][i]Server started, listening on 0.0.0.0:8754
                            2016-03-23 20:39:01 | [main][i]Reader thread started
                            2016-03-23 20:39:01 | [reader][i]Initializing reader
                            2016-03-23 20:39:01 | [main][i]MLAT data feed started
                            2016-03-23 20:39:01 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw --mlat)
                            2016-03-23 20:39:01 | [mlat][i]Waiting for MLAT configuration
                            2016-03-23 20:39:01 | [master][i]Starting processing thread
                            2016-03-23 20:39:01 | [reader][i]Connected to the receiver, configuring
                            2016-03-23 20:39:01 | [reader][i]Configured, processing messages
                            Found 1 device(s):
                            0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                            Found Rafael Micro R820T tuner
                            Max available gain is: 49.60
                            Setting gain to: 49.60
                            Exact sample rate is: 2000000.052982 Hz
                            Gain reported by device: 49.60
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #15
                              Hey!

                              I tried what you said but sadly the same results. The config remained unchanged since my previous post and here is the actual output:

                              Code:
                              sudo fr24feed start
                              2016-03-23 19:36:01 | [main][i]FR24 Feeder/Decoder
                              2016-03-23 19:36:01 | [main][i]Version: 1.0.18-5/generic
                              2016-03-23 19:36:01 | [main][i]Built on Mar  4 2016 15:21:10 (HEAD-d11ca48.git/Linux/armv7l)
                              2016-03-23 19:36:01 | [main][i]Copyright 2012-2016 Flightradar24 AB
                              2016-03-23 19:36:01 | [main][i]http://flightradar24.com
                              2016-03-23 19:36:01 | [main][i]DNS mode: LIBC
                              2016-03-23 19:36:01 | [main][i]Automatic updates are DISABLED
                              2016-03-23 19:36:01 | ERROR
                              2016-03-23 19:36:01 | [main][i]Reader thread started
                              2016-03-23 19:36:01 | [main][i]Socket server started
                              2016-03-23 19:36:01 | [time][i]Synchronizing time via NTP
                              2016-03-23 19:36:01 | [httpd][i]Server started, listening on 0.0.0.0:8754
                              2016-03-23 19:36:01 | [reader][i]Initializing reader
                              2016-03-23 19:36:01 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:01 | [master][i]Starting processing thread
                              2016-03-23 19:36:01 | [bs][i]Initializing server
                              2016-03-23 19:36:01 | [bs][i]Starting server on 0.0.0.0:30003
                              2016-03-23 19:36:01 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:01 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:01 | [reader][i]Connection terminated
                              2016-03-23 19:36:01 | [main][i]Terminating child process 1160 with SIGETERM
                              2016-03-23 19:36:05 | [time][i]Time synchronized correctly, offset -0.0001 seconds
                              2016-03-23 19:36:05 | [main][i]Feed Network client started
                              2016-03-23 19:36:05 | [main][i]RAW data server started
                              2016-03-23 19:36:05 | [raw][i]Initializing server
                              2016-03-23 19:36:05 | [raw][i]Starting server on 0.0.0.0:30002
                              2016-03-23 19:36:05 | [feed][i]Downloading configuration
                              2016-03-23 19:36:05 | [feed][c]Interval: 5s
                              2016-03-23 19:36:05 | [feed][c]Latitude: 47.4141
                              2016-03-23 19:36:05 | [feed][c]Longitude: 8.5395
                              2016-03-23 19:36:05 | [feed][c]GND: YES
                              2016-03-23 19:36:05 | [feed][c]NonADSB: YES
                              2016-03-23 19:36:05 | [feed][c]Timestamps: optional
                              2016-03-23 19:36:05 | [feed][c]Max range AIR: 350.0nm
                              2016-03-23 19:36:05 | [feed][c]Max range GND: 100.0nm
                              2016-03-23 19:36:05 | [feed][i]defined 5 servers
                              2016-03-23 19:36:05 | [feed][n]LSZH120@83.140.21.112:28099/UDP
                              2016-03-23 19:36:05 | [feed][n]connecting
                              2016-03-23 19:36:05 | [stats][i]Stats thread started
                              2016-03-23 19:36:05 | [feed][n]connected via UDP (fd 8)
                              2016-03-23 19:36:05 | [feed][n]working
                              2016-03-23 19:36:07 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:07 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:07 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:07 | [reader][i]Connection terminated
                              2016-03-23 19:36:07 | [main][i]Terminating child process 1165 with SIGETERM
                              2016-03-23 19:36:12 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:12 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:12 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:12 | [reader][i]Connection terminated
                              2016-03-23 19:36:12 | [main][i]Terminating child process 1167 with SIGETERM
                              2016-03-23 19:36:18 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:18 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:18 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:18 | [reader][i]Connection terminated
                              2016-03-23 19:36:18 | [main][i]Terminating child process 1169 with SIGETERM
                              2016-03-23 19:36:24 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:24 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:24 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:24 | [reader][i]Connection terminated
                              2016-03-23 19:36:24 | [main][i]Terminating child process 1171 with SIGETERM
                              2016-03-23 19:36:29 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090  --raw)
                              2016-03-23 19:36:29 | [reader][i]Connected to the receiver, configuring
                              2016-03-23 19:36:29 | [reader][i]Configured, processing messages
                              No supported RTLSDR devices found.
                              2016-03-23 19:36:29 | [reader][i]Connection terminated
                              2016-03-23 19:36:29 | [main][i]Terminating child process 1173 with SIGETERM
                              ^C
                              2016-03-23 19:36:33 | [main][i]Terminating on user request
                              2016-03-23 19:36:33 | [main][i]Terminating worker threads
                              2016-03-23 19:36:34 | [reader][i]Terminating on request
                              2016-03-23 19:36:35 | [bs][i]Server terminated!
                              2016-03-23 19:36:35 | [raw][i]Server terminated!
                              2016-03-23 19:36:35 | [feed][n]ping 1
                              2016-03-23 19:36:36 | [feed][n]syncing stream: 1
                              2016-03-23 19:36:37 | [master][i]Terminating on request
                              2016-03-23 19:36:37 | [feed][n]busy
                              2016-03-23 19:36:37 | [feed][n]disconnected
                              2016-03-23 19:36:37 | [feed][x]Feeding thread terminated
                              The tuner seems to be installed properly and running, although I am not 100% sure of anything at this point.

                              There is a new error which I didn't notice so far: No supported RTLSDR devices found. Would that mean that my tuner is not supported?

                              Thank you!

                              Comment

                              Working...
                              X