Announcement

Collapse
No announcement yet.

Problems with Linux 1.01.17-5_i386.deb version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • antonov_124
    replied
    there is a changelog for this version 1.01.17-5 ? I found nothing for my rpi
    1.01.17-5 works fine on rpi 2
    Last edited by antonov_124; 2016-02-24, 12:11.

    Leave a comment:


  • elljay
    replied
    Don't think I can post a link.

    Moderator Edit:

    HERE
    Last edited by Amper; 2016-02-24, 09:48. Reason: Download Link

    Leave a comment:


  • equi
    replied
    Good Morning,

    sounds good

    Would you please Upload it and post a download link ? At the moment I'm useing my Banana Pi to feed, but that is...

    Leave a comment:


  • elljay
    replied
    I've got a copy of fr24feed_1.0.13-2_i386.deb if that helps?

    Leave a comment:


  • equi
    replied
    It would be nice to have a new package by tomorrow, my feeder is Offline since yesterday because of this broken package...

    Does someone have the old feeder client by chance ?

    Leave a comment:


  • John-h
    replied
    What a silly work!

    [feed][c]Timestamps: optional
    [feed][c]Max range AIR: 350.0nm
    [feed][c]Max range GND: 100.0nm
    [feed][i]defined 1 server
    [feed][n]RJTY52@83.140.21.66:8099/UDP
    [feed][n]connecting
    [stats][i]Stats thread started
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][e]Could not connect to avr-tcp://192.168.1.23:30002
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][e]Could not connect to avr-tcp://192.168.1.23:30002
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][e]Could not connect to avr-tcp://192.168.1.23:30002
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][e]Could not connect to avr-tcp://192.168.1.23:30002
    [feed][n]connected via TCP (fd 5)
    [feed][n]working
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][e]Could not connect to avr-tcp://192.168.1.23:30002
    [reader][i]Connecting to Beast receiver via (avr-tcp://192.168.1.23:30002)
    [reader][i]Connected to the receiver, configuring
    [reader][i]Configured, processing messages
    [reader][w]Setting new UTC offset: 0!
    [feed][i]sent 1, filtered 0 AC in 1 packet
    [feed][i]sent 7, filtered 0 AC in 1 packet
    [feed][n]ping 1
    [feed][n]syncing stream: 1
    [feed][n]ping 2
    [feed][n]syncing stream: 1
    [feed][n]ping 3
    [feed][n]syncing stream: 1
    [feed][n]ping 4
    [feed][n]syncing stream: 1
    [feed][n]ping 5
    [feed][n]syncing stream: 1
    Segmentation fault
    nya@nya-su:~$

    Leave a comment:


  • equi
    replied
    Code:
    root@DEB-Server /home/norm > /usr/bin/fr24feed
    2016-02-23 05:23:51 | [main][i]FR24 Feeder/Decoder
    2016-02-23 05:23:51 | [main][i]Version: 1.0.17-5/generic
    2016-02-23 05:23:51 | [main][i]Built on Feb 19 2016 15:04:31 (master-7ec40a3.git/Linux/i686)
    2016-02-23 05:23:51 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-02-23 05:23:51 | [main][i]http://flightradar24.com
    2016-02-23 05:23:51 | [main][i]DNS mode: LIBC
    2016-02-23 05:23:51 | [main][i]Automatic updates are DISABLED
    2016-02-23 05:23:51 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-02-23 05:23:51 | [main][i]Reader thread started
    2016-02-23 05:23:51 | [master][i]Starting processing thread
    2016-02-23 05:23:51 | [reader][i]Initializing reader
    2016-02-23 05:23:51 | [main][i]MLAT data feed started
    2016-02-23 05:23:51 | [reader][i]Connecting to Beast receiver via (avr-tcp://localhost:30008)
    2016-02-23 05:23:51 | [mlat][i]Waiting for MLAT configuration
    2016-02-23 05:23:51 | [reader][i]Connected to the receiver, configuring
    2016-02-23 05:23:51 | [reader][i]Configured, processing messages
    2016-02-23 05:23:51 | [reader][w]Setting new UTC offset: 0!
    2016-02-23 05:23:52 | [time][i]Synchronizing time via NTP
    2016-02-23 05:23:56 | [time][i]Time synchronized correctly, offset +1.0236 secon                                                                                                                                                             ds
    2016-02-23 05:23:56 | [main][i]Feed Network client started
    2016-02-23 05:23:56 | [feed][i]Downloading configuration
    2016-02-23 05:23:56 | [feed][c]Interval: 5s
    2016-02-23 05:23:56 | [feed][c]Latitude: 50.9832
    2016-02-23 05:23:56 | [feed][c]Longitude: 11.0424
    2016-02-23 05:23:56 | [feed][c]GND: YES
    2016-02-23 05:23:56 | [feed][c]NonADSB: YES
    2016-02-23 05:23:56 | [feed][c]Timestamps: optional
    2016-02-23 05:23:56 | [feed][c]Max range AIR: 350.0nm
    2016-02-23 05:23:56 | [feed][c]Max range GND: 100.0nm
    2016-02-23 05:23:56 | [feed][i]defined 1 server
    2016-02-23 05:23:56 | [feed][n]EDDE7@83.140.21.66:8099/UDP
    2016-02-23 05:23:56 | [stats][i]Stats thread started
    2016-02-23 05:23:56 | [feed][n]connecting
    2016-02-23 05:23:57 | [mlat][i]MLAT configuration received, service ENABLED
    2016-02-23 05:23:57 | [mlat][i]Starting MLAT with preconfigured position: xxx (Lan/Lon removed)
    2016-02-23 05:23:57 | [mlat][i]MLAT bandwidth reduction active, level 1
    2016-02-23 05:23:57 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-02-23 05:23:57 | [mlat][i]Registering MLAT station
    2016-02-23 05:23:57 | [mlat][i]Registering MLAT station: SUCCESS
    2016-02-23 05:24:11 | [mlat][i]Pinging the server
    2016-02-23 05:24:11 | [mlat][i]Stats 0/0
    2016-02-23 05:24:16 | [feed][n]connected via TCP (fd 9)
    2016-02-23 05:24:16 | [feed][n]working
    2016-02-23 05:24:30 | [mlat][i]Pinging the server
    2016-02-23 05:24:30 | [mlat][i]Stats 0/0
    2016-02-23 05:24:46 | [feed][n]ping 1
    2016-02-23 05:24:47 | [feed][n]syncing stream: 1
    2016-02-23 05:24:51 | [mlat][i]Pinging the server
    2016-02-23 05:24:51 | [mlat][i]Stats 0/0
    2016-02-23 05:25:11 | [mlat][i]Pinging the server
    2016-02-23 05:25:11 | [mlat][i]Stats 0/0
    2016-02-23 05:25:16 | [feed][n]ping 2
    2016-02-23 05:25:17 | [feed][n]syncing stream: 1
    2016-02-23 05:25:31 | [mlat][i]Pinging the server
    2016-02-23 05:25:31 | [mlat][i]Stats 0/0
    Speicherzugriffsfehler

    Leave a comment:


  • elljay
    replied
    Ok, so I deleted all existing fr24 files, config files etc and started from scratch.

    Reinstalled the fr24feed_1.0.17-5_i386.deb file using dpkg -i
    Ran "/usr/bin/fr24feed --fr24key=<my key> --reconfigure"
    Which defaults to using dump1090 and complains about an invalid email address provided, but creates a new ini file.

    Ended up running fr24feed from the command line so I could see what was happening:

    root@sam:~# /usr/bin/fr24feed
    2016-02-22 18:48:25 | [main][i]FR24 Feeder/Decoder
    2016-02-22 18:48:25 | [main][i]Version: 1.0.17-5/generic
    2016-02-22 18:48:25 | [main][i]Built on Feb 19 2016 15:04:31 (master-7ec40a3.git/Linux/i686)
    2016-02-22 18:48:25 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-02-22 18:48:25 | [main][i]hxxp://flightradar24.com
    2016-02-22 18:48:25 | [main][i]DNS mode: LIBC
    2016-02-22 18:48:25 | [main][i]Automatic updates are DISABLED
    2016-02-22 18:48:25 | ERROR
    2016-02-22 18:48:25 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-02-22 18:48:25 | [main][i]Reader thread started
    2016-02-22 18:48:25 | [reader][i]Initializing reader
    2016-02-22 18:48:25 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090 --raw)
    2016-02-22 18:48:25 | [time][i]Synchronizing time via NTP
    2016-02-22 18:48:25 | [master][i]Starting processing thread
    2016-02-22 18:48:25 | [reader][i]Connected to the receiver, configuring
    2016-02-22 18:48:25 | [reader][i]Configured, processing messages
    Found 1 device(s):
    0: Generic, RTL2832U, SN: 77771111153705700 (currently selected)
    Found Rafael Micro R820T tuner
    Max available gain is: 49.60
    Setting gain to: 49.60
    Exact sample rate is: 2000000.052982 Hz
    Gain reported by device: 49.60
    2016-02-22 18:48:26 | [reader][w]Setting new UTC offset: 0!
    2016-02-22 18:48:28 | [time][i]Time synchronized correctly, offset -0.0000 seconds
    2016-02-22 18:48:28 | [main][i]Feed Network client started
    2016-02-22 18:48:28 | [main][i]RAW data server started
    2016-02-22 18:48:28 | [feed][i]Downloading configuration
    2016-02-22 18:48:28 | [raw][i]Initializing server
    2016-02-22 18:48:28 | [raw][i]Starting server on 0.0.0.0:30002
    2016-02-22 18:48:28 | [feed][c]Interval: 5s
    2016-02-22 18:48:28 | [feed][c]Latitude: 51.1100
    2016-02-22 18:48:28 | [feed][c]Longitude: -0.1600
    2016-02-22 18:48:28 | [feed][c]GND: YES
    2016-02-22 18:48:28 | [feed][c]NonADSB: YES
    2016-02-22 18:48:28 | [feed][c]Timestamps: optional
    2016-02-22 18:48:28 | [feed][c]Max range AIR: 350.0nm
    2016-02-22 18:48:28 | [feed][c]Max range GND: 100.0nm
    2016-02-22 18:48:28 | [feed][i]defined 1 server
    2016-02-22 18:48:28 | [stats][i]Stats thread started
    2016-02-22 18:48:28 | [feed][n]EGKK39@83.140.21.66:8099/UDP
    2016-02-22 18:48:28 | [feed][n]connecting
    2016-02-22 18:48:48 | [feed][n]connected via TCP (fd 7)
    2016-02-22 18:48:48 | [feed][n]working
    Segmentation fault

    Leave a comment:


  • elljay
    replied
    Originally posted by Amper View Post
    seem fine to me.
    Yup - that was with the old version running

    Leave a comment:


  • equi
    replied
    The new SW is crashing for me on my Debian8 System.

    I have 2 Dump1090 instances running, one of them is an ADS-B Hub where the Feeder get its aircrafts. The 2nd instance is for the DVB-T Stick to receive Signals. The Hub is connected via nc to the 2nd Instance on the Debian8 and with nc connected to the Banana Pi. Everytime I start the feeder it looks good, until something happens and the app crashs

    root@DEB-Server /home/norm > sudo fr24feed start
    2016-02-22 18:59:33 | [main][i]FR24 Feeder/Decoder
    2016-02-22 18:59:33 | [main][i]Version: 1.0.17-5/generic
    2016-02-22 18:59:33 | [main][i]Built on Feb 19 2016 15:04:31 (master-7ec40a3.git /Linux/i686)
    2016-02-22 18:59:33 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-02-22 18:59:33 | [main][i]http://flightradar24.com
    2016-02-22 18:59:33 | [main][i]DNS mode: LIBC
    2016-02-22 18:59:33 | [main][i]Automatic updates are DISABLED
    2016-02-22 18:59:33 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-02-22 18:59:33 | [main][i]Reader thread started
    2016-02-22 18:59:33 | [reader][i]Initializing reader
    2016-02-22 18:59:33 | [main][i]MLAT data feed started
    2016-02-22 18:59:33 | [reader][i]Connecting to Beast receiver via (avr-tcp://localhost:30008)
    2016-02-22 18:59:33 | [master][i]Starting processing thread
    2016-02-22 18:59:33 | [mlat][i]Waiting for MLAT configuration
    2016-02-22 18:59:33 | [reader][i]Connected to the receiver, configuring
    2016-02-22 18:59:33 | [reader][i]Configured, processing messages
    2016-02-22 18:59:33 | [reader][w]Setting new UTC offset: 0!
    2016-02-22 18:59:34 | [time][i]Synchronizing time via NTP
    2016-02-22 18:59:38 | [time][i]Time synchronized correctly, offset +0.0170 seconds
    2016-02-22 18:59:38 | [main][i]Feed Network client started
    2016-02-22 18:59:38 | [feed][i]Downloading configuration
    2016-02-22 18:59:38 | [feed][c]Interval: 5s
    2016-02-22 18:59:38 | [feed][c]Latitude: 50.9832
    2016-02-22 18:59:38 | [feed][c]Longitude: 11.0424
    2016-02-22 18:59:38 | [feed][c]GND: YES
    2016-02-22 18:59:38 | [feed][c]NonADSB: YES
    2016-02-22 18:59:38 | [feed][c]Timestamps: optional
    2016-02-22 18:59:38 | [feed][c]Max range AIR: 350.0nm
    2016-02-22 18:59:38 | [feed][c]Max range GND: 100.0nm
    2016-02-22 18:59:38 | [feed][i]defined 1 server
    2016-02-22 18:59:38 | [stats][i]Stats thread started
    2016-02-22 18:59:38 | [feed][n]EDDE7@83.140.21.66:8099/UDP
    2016-02-22 18:59:38 | [feed][n]connecting
    2016-02-22 18:59:39 | [mlat][i]MLAT configuration received, service ENABLED
    2016-02-22 18:59:39 | [mlat][i]Starting MLAT with preconfigured position: 50.98,11.04,660.0
    2016-02-22 18:59:39 | [mlat][i]MLAT bandwidth reduction active, level 1
    2016-02-22 18:59:39 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-02-22 18:59:39 | [mlat][i]Registering MLAT station
    2016-02-22 18:59:39 | [mlat][i]Registering MLAT station: SUCCESS
    2016-02-22 18:59:53 | [mlat][i]Pinging the server
    2016-02-22 18:59:53 | [mlat][i]Stats 0/0
    2016-02-22 18:59:58 | [feed][n]connected via TCP (fd 9)
    2016-02-22 18:59:58 | [feed][n]working

    Leave a comment:


  • equi
    replied
    Is the new Version with MLAT Support ?

    Leave a comment:


  • John-h
    replied
    Silly? Yes, you should so smart.

    Leave a comment:


  • Amper
    replied
    2016-02-21 09:10:29 | [feed][n]EGKK39@83.140.21.66:8099/UDP
    2016-02-21 09:10:29 | [feed][n]connecting
    2016-02-21 09:10:49 | [feed][n]connected via TCP
    2016-02-21 09:10:49 | [feed][n]switching to UDP
    2016-02-21 09:10:49 | [feed][n]working
    2016-02-21 09:10:49 | [feed][i]sent 2 AC in 1 packet
    2016-02-21 09:10:53 | [feed][i]removed 1 of 35 AC
    2016-02-21 09:10:54 | [feed][i]sent 37 AC in 1 packet
    seem fine to me.
    Last edited by Amper; 2016-02-22, 10:33.

    Leave a comment:


  • Oblivian
    replied
    Silly question, restarted?

    Timing out of the config page tends to indicate there is still a child process running - it didnt stop properly during update.

    I'm not seeing the web page service load post update

    Leave a comment:


  • John-h
    replied
    Originally posted by elljay View Post
    Hi, noticed there was a new release. Have been running 1.0.13-2_i386.deb for a while successfully.

    Downloaded the new version and installed it with dpkg -i. The log file reads:

    2016-02-21 09:03:36 | [stats][i]Stats thread started

    ...but then nothing else happens. Trying to view the status page on port 8754 times out.
    Same here also..
    I'm using Debian 3.16.7..

    Leave a comment:

Working...
X