Announcement

Collapse
No announcement yet.

Kinetics SBS-3 direct USB connection - Problem with SBS 10001 Output

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kinetics SBS-3 direct USB connection - Problem with SBS 10001 Output

    Hi,

    Short version:

    Is BS 10001 output working on linux with a SBS-3 connected up via USB?



    Long version:

    I have a Kinetics SBS-3 running firmware V119.

    I am running the SBS-3 via a USB connection on the Raspberry PI with build 1.0.16-7. I want to have the raspberry PI running the SBS-3 as I can put it in the roof on a short antenna run. I can then run basestation when a PC is on if so desired. The 10001 feed does not appear to be working. I also can't see output on the RAW feed (although the port is open).

    I have the following config:
    receiver="sbs3usb"
    fr24key="XXXXXXXXX"
    host="localhost"
    path="/dev/ttyUSB1"
    baudrate="921600"
    bs="no"
    raw="yes"
    mpx="yes"
    baudrate="921600"
    logmode="2"
    windowmode="0"
    mpx="yes"
    mlat="yes"
    mlat-without-gps="yes"

    MPX is the switch for the 10001 output, BS for 30003 and RAW 30334. BS output works fine. I am unsure if RAW is working but you can see it open the port in the log. 10001 is not opened.
    2015-12-27 13:14:48 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2015-12-27 13:14:48 | [main][i]Version: 1.0.16-7/generic
    2015-12-27 13:14:48 | [main][i]Built on 20151214-1410 (r:master-d6572f3.git/Linux/armv7l)
    2015-12-27 13:14:48 | [main][i]Copyright 2012-2015 Flightradar24 AB
    2015-12-27 13:14:48 | [main][i]hxxp://flightradar24.com)
    2015-12-27 13:14:48 | [main][i]DNS mode: LIBC
    2015-12-27 13:14:48 | [main][i]Automatic updates are ENABLED
    2015-12-27 13:14:48 | [main][i]Reader 0 started
    2015-12-27 13:14:48 | [main][i]MLAT data feed started
    2015-12-27 13:14:48 | [reader][i][0]Initializing reader
    2015-12-27 13:14:48 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2015-12-27 13:14:48 | [master][i]Starting processing thread
    2015-12-27 13:14:48 | [reader][i][0]Connecting to SBS3 receiver via USB (/dev/ttyUSB1)
    2015-12-27 13:14:48 | [mlat][i]Waiting for MLAT configuration
    2015-12-27 13:14:48 | [reader][i][0]Connected to the receiver, authenticating
    2015-12-27 13:14:49 | [reader][i][0]Authenticated, processing messages
    2015-12-27 13:14:49 | [time][i]Synchronizing time via NTP
    2015-12-27 13:14:57 | [time][i]Time synchronized correctly, offset -0.0003 seconds
    2015-12-27 13:14:57 | [main][i]Feed Network client started
    2015-12-27 13:14:57 | [main][i]RAW data server started
    2015-12-27 13:14:57 | [raw][i]Initializing server
    2015-12-27 13:14:57 | [raw][i]Starting server on 0.0.0.0:30334
    2015-12-27 13:14:57 | [feed][i]Downloading configuration
    2015-12-27 13:14:58 | [feed][c]Interval: 5s
    2015-12-27 13:14:58 | [feed][c]Latitude: -XX.XXXX
    2015-12-27 13:14:58 | [feed][c]Longitude: 1XX.XXXX
    2015-12-27 13:14:58 | [feed][c]GND: YES
    2015-12-27 13:14:58 | [feed][c]NonADSB: YES
    2015-12-27 13:14:58 | [feed][c]Timestamps: optional
    2015-12-27 13:14:58 | [feed][c]Max range AIR: 350.0nm
    2015-12-27 13:14:58 | [feed][c]Max range GND: 100.0nm
    2015-12-27 13:14:58 | [feed][i]defined 2 servers
    2015-12-27 13:14:58 | [feed][n]YMXXX@aus-1.fr24.com:8099/TCP
    2015-12-27 13:14:58 | [feed][n]connecting
    2015-12-27 13:14:58 | [stats][i]Stats thread started
    2015-12-27 13:14:58 | [mlat][i]MLAT configuration received, service ENABLED
    2015-12-27 13:14:58 | [mlat][i]Starting MLAT with preconfigured position: -XX.XX,XXX.XX,XXX.0
    2015-12-27 13:14:58 | [mlat][i]MLAT bandwidth reduction active, level 1
    2015-12-27 13:14:58 | [mlat][i]Configuring UDP connection udp:54.XX.XXX.XXX:19788
    2015-12-27 13:14:58 | [mlat][i]Registering MLAT station
    2015-12-27 13:14:58 | [mlat][i]Registering MLAT station: SUCCESS

    Things also look fine on the feeder status page:
    ac_map_size="3072"
    build_arch="armv7l"
    build_flavour="generic"
    build_os="Linux"
    build_revision="master-d6572f3.git"
    build_timetamp="20151214-1410"
    build_version="1.0.16-7"
    cfg_baudrate="921600"
    cfg_bs="no"
    cfg_host="localhost"
    cfg_mpx="yes"
    cfg_path="/dev/ttyUSB1"
    cfg_raw="yes"
    cfg_receiver="sbs3usb"
    cfg_windowmode="0"

    Netstat:
    tcp 0 0 *:30334 *:* LISTEN
    tcp 0 0 *:8754 *:* LISTEN
    tcp 0 0 *:ssh *:* LISTEN

    Any thoughts or suggestions on how I can get the BS 10001 feed and the 30034 RAW feed going properly?

    Thanks
    Chris
Working...
X