No announcement yet.

dump1090 not working well on MIPS?

  • Filter
  • Time
  • Show
Clear All
new posts

  • dump1090 not working well on MIPS?


    I have an odd issue here and I wonder where to start looking.

    I've managed to get dump1090 running on a Fritz!Box DSL router. This is in many ways like a Raspberry Pi, it also runs Linux, but not quite a standard distro (www·freetz·org) and with a big-endian (I think) dual core MIPS CPU instead of ARM. It works, but strangely not as well as on a PC.

    On a PC by average I can capture ~20% or so more messages than on the Fritz!Box, using the same cmdline arguments exactly, using the same receiver+antenna installed on the same roof, and I can't think of an obvious explanation. Has anyone else tried this out/seen similar issues?

    In both cases, the receiver is connected to the machine through the same 10m USB cable + simple powered USB hub. In both cases it's dump1090_mr compiled from the same source tree (though with different compiler flags, I'll see if -O3 is somehow killing it though this would seem unlikely). Frequency and sample rate are also the same, it's not like it's dropping the sample rate to shed load on this slow CPU.

    And really the CPU seems fast enough as dump1090 is running with only 20% CPU utilisation, it could easily spend a little more to try harder. :-D

    Since I think the MIPS CPU is running in big-endian mode and PCs + RasPi's are little-endian I wonder whether this could be an issue, but the dump1090 src tree is huge enough that figuring that out is not going to be simple. Does anyone have other ideas of what could cause differences in messages received or at least decoded successfully?

  • #2
    Well at least with the same bytestream I get the same results as confirmed using --ifile.

    Maybe I'm getting buffer overruns or so somehow but with 20-25% CPU utilisation I hope not.


    • #3
      Looks like nobody else ever tried this or at least I'll guess so from the lack of responses. :-(

      More experimentation did not get me any further. The fact that the same bytestream from a file gives the same result already took most of the blame away from dump1090 and indeed rtl_tcp shows similar issues (stream captured on the F!B gives 33% fewer decoded messages than a stream captured a few mins later through the PC).

      I guess that somehow either tuning is not set up correctly, with dump1090 ending up with a slightly-off feed, or the dongle is getting just a little to low power to do its work properly. Though since there's a powered USB hub in between I really thought that shouldn't happen (or at least it should happen regardless of the machine on the other end).

      Some debugging added to rtlsdr shows no obvious endianness/etc issues either that could break communication with the device. I guess I'll have to give up on this. :-(


      • #4
        I have dump1090 running on a GL-inet 6416 router, which uses an Atheros 9331 MIPS core @ 400MHz. I installed the librtlsdr and dump1090 packages from and they work great. Only tested for a day so far but coverage seems as good as using dump1090 on my laptop. CPU usage hovers around 60-75%.

        Now if only we have an FR24 feeder app cross-compiled for MIPS...