Announcement

Collapse
No announcement yet.

Problems feeding with Windows/generic/i386/1.0.14-9

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vanmie
    replied
    contacted them... lets wait and see what they come back with... I will post here once we get this sorted, as it might help others with the same symptoms...

    Leave a comment:


  • Oblivian
    replied
    I'm seeing 2 posts fine try mailing support with your key and location to get it manually activated. Else delete the configuration and redo the reg process

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • vanmie
    replied
    so, I typed a long email, hit submit, and it is not posting... very frustrating !

    basically, I took wireshark out, and captured the packets between my laptop and feed.flightradar24.com

    it is the feed.flightradar24.com which actually sends the following "{"result":"failure","info":"Not found, check your key!"}"

    so, the request from the FR24feed.exe running on my laptop (which is GET request) makes it to the host, and the host answers with this error.
    The problem therefore is not local to me.

    It seems that the "key" is not "accepted"

    so what do I need to do to get my key "accepted"... or... what do I need to do to get an "acceptable" key ??

    (ps, I have all the packets captured, but as I said the long post I typed with all the details dissapeard or so... )

    Leave a comment:


  • vanmie
    replied
    OK, just some wireshark testing

    So the FR24feed on my laptop, sends a proper HTTP request
    GET /key.php?key=b713686576f8f41a&version=250&system=&o s=Windows&v=1.0.14-9&rx=avr-tcp&receiver=avr-tcp HTTP/1.1
    Host: feed.flightradar24.com
    Connection: close

    Raw data of that GET packet here:
    0000 00 11 22 33 44 55 00 05 9a 3c 7a 00 08 00 45 00 .."3DU...<z...E.
    0010 00 cd 16 2b 40 00 80 06 4f fd 0a 42 20 dc 53 8c ...+@...O..B .S.
    0020 15 59 de 6f 00 50 f7 16 26 c5 37 33 e7 8b 50 18 .Y.o.P..&.73..P.
    0030 00 45 04 63 00 00 47 45 54 20 2f 6b 65 79 2e 70 .E.c..GET /key.p
    0040 68 70 3f 6b 65 79 3d 62 37 31 33 36 38 36 35 37 hp?key=b71368657
    0050 36 66 38 66 34 31 61 26 76 65 72 73 69 6f 6e 3d 6f8f41a&version=
    0060 32 35 30 26 73 79 73 74 65 6d 3d 26 6f 73 3d 57 250&system=&os=W
    0070 69 6e 64 6f 77 73 26 76 3d 31 2e 30 2e 31 34 2d indows&v=1.0.14-
    0080 39 26 72 78 3d 61 76 72 2d 74 63 70 26 72 65 63 9&rx=avr-tcp&rec
    0090 65 69 76 65 72 3d 61 76 72 2d 74 63 70 20 48 54 eiver=avr-tcp HT
    00a0 54 50 2f 31 2e 31 0d 0a 48 6f 73 74 3a 20 66 65 TP/1.1..Host: fe
    00b0 65 64 2e 66 6c 69 67 68 74 72 61 64 61 72 32 34 ed.flightradar24
    00c0 2e 63 6f 6d 0d 0a 43 6f 6e 6e 65 63 74 69 6f 6e .com..Connection
    00d0 3a 20 63 6c 6f 73 65 0d 0a 0d 0a : close....

    The host (feed.flightradar24.com) replies, with a "[TCP Window update]" packet and an "[ACK]" packet-- which is normal protocol standard

    The host (feed.flightradar24.com) then replies with a duplicate "[ACK]" -- which is ok, but I wonder why.... ? -- but this is not a problem and still OK.

    The host (feed.flightradar24.com) then replies with a http packet, containing:
    {"result":"failure","info":"Not found, check your key!"}

    raw data of that packet here:
    0000 7b 22 72 65 73 75 6c 74 22 3a 22 66 61 69 6c 75 {"result":"failu
    0010 72 65 22 2c 22 69 6e 66 6f 22 3a 22 4e 6f 74 20 re","info":"Not
    0020 66 6f 75 6e 64 2c 20 63 68 65 63 6b 20 79 6f 75 found, check you
    0030 72 20 6b 65 79 21 22 7d r key!"}

    Now, this means to me, that for some reason, the original GET request containing my key is someway "rejected / not found" by feed.flightradar24.com

    so now the question is: how do I generate a new/acceptable key ? or how do I get my key "accepted" ?

    Leave a comment:


  • Oblivian
    replied
    Tried to hook to the same port as the basestation port? Or the adsbscope one. The output for each may differ slightly. And not sure what the Fr feed app accepts and considers enough to bundle and send.

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • vanmie
    replied
    OK, I am at my set location, and I have plenty of ADSB contacts....
    I cannot see my feeds under my premium login, as my premium login is probably not activated due to missing feeds (catch-22 really)

    I might change FR24 to run on its own... but I really do NOT want to !
    My full setup is like this, and working perfectly

    ADSBSharp --> Virtual Radar Server
    |
    |--> Rebroadcast/BaseStation --> SBSPlotter (100% ok)
    |--> Rebroadcast/BaseStation --> PlaneFinder feed (100% ok)
    |
    |--> Rebroadcast/PassThru --> adsbScope (100% ok)
    |
    |--> Rebroadcast/AVR --> FR24feed

    In all fairness, I still believe that the AVR rebroadcast from VRS to FR24feed is working, because on the status screen you can see airplanes tracked, and connect status to the receiver.
    It is the feed that has problems...

    Thanks for all your help Oblivian, thing is; I don't need to feed to FR24... I like to share my data to "give back to the community"... but it seems that this app is not really "friendly" to me.
    I guess I will experiment a little further from my side, maybe even take wireshark out to see what is going on...

    thanks,
    vanmie
    Last edited by vanmie; 2015-09-14, 09:44.

    Leave a comment:


  • Oblivian
    replied
    Within 300nm from your set location and at least 4 full adsb contacts..

    The alternate would be close your daisy chain apps and try FR24 on its own to see if it is getting the sort of data it needs.

    Uuuhhmmm I can see mine via premium login, under additional feed info. But if yours has not activated yet you may not get there.

    Leave a comment:


  • vanmie
    replied
    Hi
    Originally posted by Oblivian View Post
    I wonder if you have not met the min requirements for the upload alias to activate.
    Ok, so what are the min requirements for the "upload alias" to "activate" ?

    Originally posted by Oblivian View Post
    Or the geo location was entered wrong and therefore the data from aircraft is being ignored as false.
    My coordinates when registering were correct, please explain what I can do/check to rectify this

    Thanks!
    vanmie

    Leave a comment:


  • Oblivian
    replied
    If the link status has now changed, I wonder if you have not met the min requirements for the upload alias to activate. Or the geo location was entered wrong and therefore the data from aircraft is being ignored as false.

    Leave a comment:


  • vanmie
    replied
    dropped the FW, and removed the "path" in the settings....

    Now my status screen shows this:

    FR24 Link: Disconnected (Not found, check your key!)
    FR24 Radar Code: N/A
    Aircraft Tracked (ModeS & ADS-B): 8
    Aircraft Uploaded: N/A
    Receiver: avr-tcp, Connected
    MLAT running: N/A

    I checked the key... it is correct
    I checked the ini file with a hex-editor, to ensure that there are no "funny" characters in the file... 100% correct.

    what else can I check ?

    Leave a comment:


  • Oblivian
    replied
    I'm not sure if the path is ignored when you select AVRTCP, but it probably shouldn't say the mr-dump line.

    It may be the firewall popup was not answered when it was run and is being blocked. Try dropping it for a moment and re-running the feed.exe to see to be sure.

    Leave a comment:


  • Problems feeding with Windows/generic/i386/1.0.14-9

    Ok, this is my first attempt.

    I have ADSBSharp --> Virtual Radar Server --> Rebroadcast/AVR --> Windows/generic/i386/1.0.14-9

    The status page lists as follows:
    FR24 Link: Not configured, go to Settings
    FR24 Radar Code: N/A
    Aircraft Tracked (ModeS & ADS-B): 4
    Aircraft Uploaded: N/A
    Receiver: avr-tcp, Connected
    MLAT running: N/A

    That to me means:
    - connection to the rebroadcase/AVR server is correct
    - the app is tracking planes

    Now the problem is, how do I feed to FR24 ?
    as "FR24 Link" shows "Not configured, go to Settings"

    My settings are as follows:
    receiver="avr-tcp"
    fr24key="****************" <-- using * to protect privacy, but I checked the key with the original registration and that is correct
    host="localhost:33003"
    path="mr-dump1090.exe"
    bs="no"
    raw="no"
    logmode="0"
    windowmode="0"
    mpx="no"
    mlat="no"
    mlat-without-gps="no"

    what am I missing ???
    any help/tips/tricks welcome !

    thanks,
    vanmie
Working...
X