Announcement

Collapse
No announcement yet.

Feed not working after Win 10 upgrade and loading of latest fr24feed application

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feed not working after Win 10 upgrade and loading of latest fr24feed application

    Zadig drivers have been reloaded following removal by Win 10 upgrade.
    fr24feed.exe updated to latest version
    Settings as per web status/config:

    Flightradar24 Feeder/Decoder
    Windows/generic/i386/1.0.14-9
    Updated: 10:07:53 GMT+1000 (E. Australia Standard Time)
    FR24 Link: Connected via UDP
    FR24 Radar Code: T-YBBN43
    Aircraft Tracked (ModeS & ADS-B): 0
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: N/A


    The connection keeps terminating as per this dump:
    2015-09-09 10:13:21 | [reader][i][0]Connecting to Generic receiver via (exe://mr-dump1090.exe --raw --mlat)
    2015-09-09 10:13:21 | [reader][i][0]Connected to the receiver, authenticating
    2015-09-09 10:13:21 | [reader][i][0]Authenticated, processing messages
    2015-09-09 10:13:24 | [reader][i][0]Connection terminated
    2015-09-09 10:13:29 | [reader][i][0]Connecting to Generic receiver via (exe://mr-dump1090.exe --raw --mlat)
    2015-09-09 10:13:29 | [reader][i][0]Connected to the receiver, authenticating
    2015-09-09 10:13:29 | [reader][i][0]Authenticated, processing messages
    2015-09-09 10:13:32 | [reader][i][0]Connection terminated

    Any suggestions for resolution would be appreciated.

  • #2
    COuple of people struck this in the established feeder talk thread

    Windows10 installs drivers it thinks you need. Including USB TV stick

    /edit - ah. you did

    Did you make sure you got the new one that supports 10?

    And no other standalone dump1090 running etc is there?
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Answers in bold

      Originally posted by Oblivian View Post
      .....................

      Did you make sure you got the new one that supports 10? Got the latest Windows version 1.0.14-9

      And no other standalone dump1090 running etc is there? No, but the one that is running in Task Manager is continually stopping and restarting- which presumably is connected to the "Connection terminated" message on the fr24feed window

      Comment


      • #4
        Actually meant the latest zadig pack (april this year) not the windows feeder ver

        Odd.

        Though it seems people have had issues and had to do a full uninstall of all drivers first and run-as admin:
        The Windows 10 upgrade process appears to replace the WinUSB drivers with the Windows DVB-T ones, so reinstalling the SDR drivers is necessary. It shouldn’t be necessary, but one user also reported the need to log in to Windows with an administrator account and to uninstall the current drivers before running Zadig, so try that if you continue to have problems.
        Also wonder if its windows UAC blocking the dump1090 task from running until approved.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Hi Bro!!
          The FR24 App Available only for Windows 8 you can go and check it out by yourself by clicking on the button get the FR24 app and the you'll see all the systems that authorized using the FR24 app

          Comment


          • #6
            Originally posted by aymanlamnadi View Post
            Hi Bro!!
            The FR24 App Available only for Windows 8 you can go and check it out by yourself by clicking on the button get the FR24 app and the you'll see all the systems that authorized using the FR24 app
            There are plenty of people running it on Windows10
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Actually could be barking up the wrong tree. The zadig fault ends up with not being able to find the USB, seems this is a step after that. No more running instances of it in task manager that have crashed out or anything? (normally would clear after a reboot etc)
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • #8
                Originally posted by Oblivian View Post
                ... No more running instances of it in task manager that have crashed out or anything? (normally would clear after a reboot etc)
                Definitely not.

                Have tried uninstalling hardware & deleting drivers, then reinstall everything. Still the same
                2015-09-09 15:50:45 | [reader][i][0]Connected to the receiver, authenticating
                2015-09-09 15:50:45 | [reader][i][0]Authenticated, processing messages
                2015-09-09 15:50:48 | [reader][i][0]Connection terminated
                2015-09-09 15:50:49 | [feed][n]ping 4
                2015-09-09 15:50:53 | [reader][i][0]Connecting to Generic receiver via (exe://mr-dump1090.exe --raw)


                Managed to capture the mr-dump.exe lopgging before it stops:
                Found 2 device(s):
                0: Dz↓, ┤■↓, SN: i (currently selected)
                1: Realtek, RTL2838UHIDIR, SN: 00000001
                usb_open error -12
                Error opening the RTLSDR device: No error

                Not sure where the Realtek, RTL2838UHIDIR label is coming from for device 1 - doesn't show anywhere in Device manager.

                Comment


                • #9
                  The realtek is the chipset inside the stick. It looks like the wrong USB device ID may have been selected during the Zadig install and dump1090 is trying to use that. (note the currently selected one is garbaged)

                  Might need to double check the drop-down box in the installer and or device IDs

                  https://github.com/pbatard/libwdi/wiki/Zadig
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    Hello Sir,
                    Did you find any solution for this? I'm encountering the same problem.
                    Found 2 device(s):
                    0: Dz↓, ┤■↓, SN: i (currently selected)
                    1: Realtek, RTL2838UHIDIR, SN: 00000001
                    usb_open error -12

                    Comment


                    • #11
                      Originally posted by Sainath View Post
                      Hello Sir,
                      Did you find any solution for this? I'm encountering the same problem.
                      Found 2 device(s):
                      0: Dz↓, ┤■↓, SN: i (currently selected)
                      1: Realtek, RTL2838UHIDIR, SN: 00000001
                      usb_open error -12
                      --device-index 1

                      Add to additional parameters.

                      I'm not sure, but try.

                      Sent from my XT1092 using Tapatalk
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • #12
                        Originally posted by Oblivian View Post
                        --device-index 1

                        Add to additional parameters.

                        I'm not sure, but try.

                        Sent from my XT1092 using Tapatalk
                        -------------------------------------------------------
                        Yes Sir,
                        I've tried this...
                        i put both the interfaces on WinUSB drivers ...
                        but when i start feed this happens.....
                        -------------------------------------------------------
                        [reader][i]Connecting to DVBT receiver via (exe://mr-dump1090.exe --raw)
                        [reader][i]Connected to the receiver, configuring
                        [reader][i]Configured, processing messages
                        [time][i]Time synchronized correctly, offset +0.0227 seconds
                        [main][i]Feed Network client started
                        [feed][i]Downloading configuration
                        [feed][c]Interval: 5s
                        [feed][c]Latitude: 12.9839
                        [feed][c]Longitude: 77.6738
                        [feed][c]GND: YES
                        [feed][c]NonADSB: YES
                        [feed][c]Timestamps: optional
                        [feed][c]Max range AIR: 350.0nm
                        [feed][c]Max range GND: 100.0nm
                        [feed][i]defined 5 servers
                        [stats][i]Stats thread started
                        [feed][n]VOBL34@83.140.21.112:28099/UDP
                        [feed][n]connecting
                        [feed][n]connected via UDP (fd 880)
                        [feed][n]working
                        [feed][n]ping 1
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 2
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 3
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 4
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 5
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 6
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 7
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 8
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 9
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 10
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 11
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 12
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 13
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 14
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 15
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 16
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 17
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 18
                        [feed][n]syncing stream result: 1
                        [feed][n]ping 19
                        [feed][n]syncing stream result: 1
                        [time][i]Synchronizing time via NTP
                        [stats][e]Cached feed_id=20920 for network T
                        [stats][i]sent 16 bytes
                        [time][i]Time synchronized correctly, offset +0.0235 seconds
                        ---------------------------------------------------------------------
                        only pings and no reply.

                        Comment


                        • #13
                          That is still no reception. Do not appear to have added the command correctly.

                          exe://mr-dump1090.exe --raw

                          This needs to say mr-dump1090.exe --raw --interface-index 2

                          Run mr-dump1090. Not fr24feed

                          When you find it working, run fr24feed and configure the web page with the same commands.

                          Or post what is showing. Not fr24feed. But mr-dump1090

                          Sent from my XT1092 using Tapatalk
                          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                          Comment


                          • #14
                            This is what Dump shows. Guess its working fine?
                            --------------------------------------------------------
                            Found 1 device(s):
                            0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                            Found Rafael Micro R820T tuner
                            Max available gain is: 49.60
                            Setting gain to: 49.60
                            Exact sample rate is: 2000000.052982 Hz
                            Gain reported by device: 49.60
                            ----------------------------------------------------------

                            Comment


                            • #15
                              Yes. Right tuner and chipset.

                              Leave it going when you see that, if the screen does not scroll with any data after running for a while, you have no reception
                              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                              Comment

                              Working...
                              X