Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wiedehopf
    replied
    Originally posted by Oblivian View Post
    Anyone managed to stop the latest rendition auto update check unless you manually do.
    To stop the fr24feed autoupdate you can put a hashtag # in front of the only line in the file:

    /etc/cron.d/fr24feed_updater

    But chmod should also work.
    sudo chmod a-x /usr/lib/fr24/fr24feed_updater.sh

    But it runs at 7 in the morning, so maybe there is another problem.
    Have you checked the fr24feed logs for the timeframe?

    Leave a comment:


  • lucaberta
    replied
    Happy to reply to myself on this thread which just was made active again, albeit on another topic, with an update on my workaround regarding IPv6.

    I went back to my configuration, which I had changed back in August 2018, and tested again IPv6 which right now seems to be working fine, so I removed the /etc/hosts workaround and now my machine is happily feeding FR24 over IPv6.

    Not sure about the problem raised by @Oblivian, I am not seeing that kind of behaviour.

    Bye, Luca

    Leave a comment:


  • Oblivian
    replied
    Anyone managed to stop the latest rendition auto update check unless you manually do.

    Something seems to kill internal webserver and clients connections at about midnight UTC every couple of days for me.

    Made the fr24feed_updater.sh no execution as located elsewhere but something still is.

    Sent from my EML-L09 using Tapatalk

    Leave a comment:


  • lucaberta
    replied
    FYI, I too have run into connection issues, which might be related to IPv6, which is strange as I have a full IPv6-enabled network at home, and the connection would work the same via IPv4 or IPv6. Go figure.

    Nonetheless, it was clear that the issue was related to IPv6 when I decided to create a simple hack which would force IPv4-only connections, of a very different kind than blocking completely IPv6 (which I DON'T want to do!) and neither changing the configuration of the getaddrinfo config file /etc/gai.conf.

    The hack consists of fixing the IP address of the initial connection to feed.flightradar24.com and its CloudFlare counterpart to a fixed IPv4 address, which will take precedence over a DNS-resolved IP address.

    Here is what I added in /etc/hosts:

    # hack to fix the IPv6 issue with feed.flightradar24.com.cdn.cloudflare.net (104.20.0.101) - solved on 2018-08-25

    104.20.0.101 feed.flightradar24.com
    104.20.0.101 feed.flightradar24.com.cdn.cloudflare.net


    Obviously I now have a fixed IP address and not a dynamic one out of a pool, and if FR24 someday decides to change the IP address of the feed, I will need to modify it by hand.

    By doing this I was able to make my newly refreshed RasPi 3, which used to run Jessie and now runs Stretch, work again after the dist-upgrade which crippled fr24feed.

    Bye, Luca

    Leave a comment:


  • marcel2351
    replied
    Originally posted by abcd567 View Post
    Same here in Canada.

    Last night I made a fresh install (Raspbian Stretch + dump1090-mutability v1.15~dev + fr24feed). The fr24feed-status showed feed failure.
    [FAIL] FR24 Link: unknown ... failed!

    Thanks to tech007 for his post #24[/b][/url] and post #893[/url], I fixed it by following command given by him.

    Code:
    sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
    Thank you, now i have a Connection

    Leave a comment:


  • abcd567
    replied
    Same here in Canada.

    Last night I made a fresh install (Raspbian Stretch + dump1090-mutability v1.15~dev + fr24feed). The fr24feed-status showed feed failure.
    [FAIL] FR24 Link: unknown ... failed!

    Thanks to tech007 for his post #24 and post #893, I fixed it by following command given by him.

    Code:
    sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
    Last edited by abcd567; 2018-06-16, 14:04.

    Leave a comment:


  • vejbymats@gmail.com
    replied
    Unfortunately it is more than that I think. I disabled ipv6 without any change.
    Look at this thread: https://forum.flightradar24.com/thre...385#post106385

    Leave a comment:


  • Coxy
    replied
    Yup ran the disable and am now up and running

    Leave a comment:


  • tech007
    replied
    Just to let you know. Had a look. Seems to be ipv6 related. Disabled ipv6 and all connected. Something went wrong on DNS lookup for a PTR.

    not had change to dig into further, but maybe same for all.

    I disabled ipv6 with this command if you want to try

    sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1

    Leave a comment:


  • Oblivian
    replied
    And if you needed any more proof (still zapping new threads asking without checking first...)

    [feed][i]sent 4,0 AC
    send - failed to send 12 + 260 bytes in mode 0, code -1: No error
    [feed][i]sent 4,0 AC
    [feed][n]disconnected
    [feed][n]waiting 8 seconds
    2018-06-15 23:01:03.955+12:00 | 2056 | warning | aircraft send failed with code
    -1, meta length 4

    [bs][i]New client connected 127.0.0.1:59759
    [bs][i]Client disconnected, 1 left

    Leave a comment:


  • Oblivian
    replied
    If you hadnt worked it out my the 3 other new or resurrected threads. There's an obvious issue
    Sit back and let it go till they officially acknowledge

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • tech007
    replied
    I have same issue on previously working setup, Suddenly i get:

    Code:
    Validating email/location information...[e]Could not connect to feed.flightradar24.com, errno: 101
    Got no response or empty response from the server :(
    
    The Sharing Key and Email are correctly, Dump1090 ( v1.15~dev) works fine.[/QUOTE]
    
    I'm having same issue on a previously working setup, suddenly[main][i]FR24 Feeder/Decoder
    [main][i]Version: 1.0.19-15/generic
    [main][i]Built on Feb  6 2018 09:19:16 (HEAD-0bb4994.git/Linux/static_arm)
    [main][i]Running on: raspbian9
    [main][i]Local IP(s): {IP's Removed}
    [main][i]Copyright 2012-2018 Flightradar24 AB
    [main][i]DNS mode: PING
    [main][i]Automatic updates are ENABLED
    [main][i]Reader thread started
    [main][i]MLAT data feed started
    [reader][i]Initializing reader
    [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://127.0.0.1:30002)
    [master][i]Starting processing thread
    [mlat][i]Waiting for MLAT configuration
    [httpd][i]Server started, listening on 0.0.0.0:8754
    [reader][i]Connected to the receiver, configuring
    [reader][i]Configured, processing messages
    [reader][w]Setting new UTC offset: 0!
    [time][i]Synchronizing time via NTP
    [time][i]Time synchronized correctly, offset +0.0002 seconds
    [main][i]Feed Network client started
    [feed][i]Downloading configuration
    [e]Could not connect to feed.flightradar24.com, errno: 101
    ERROR
    [e]Could not retrieve configuration from Flightradar24
    [feed][i]Failed on start, Sleeping 120 seconds
    [feed][i]Downloading configuration
    [e]Could not connect to feed.flightradar24.com, errno: 101
    ERROR
    [e]Could not retrieve configuration from Flightradar24
    [feed][i]Failed on start, Sleeping 120 seconds
     won't connect.

    Leave a comment:


  • marcel2351
    replied
    Thank you, but i have a new problem.

    When i will use ssh and use the Setup wizzard fr24feed --singup i have the follow error:

    Validating email/location information...[e]Could not connect to feed.flightradar24.com, errno: 101
    Got no response or empty response from the server

    The Sharing Key and Email are correctly, Dump1090 ( v1.15~dev) works fine.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by marcel2351 View Post
    Hi Guys,

    i have an Problem with the Feed, Dump1090 works fine on the :8080.
    The Feeder canīt Track Aircrafts ( Aircraft Tracked:
    (ModeS & ADS-B):
    0
    Flightradar24 Feed Status Site:

    FR24 Link:
    Connected via UDP
    FR24 Radar Code:
    T-EDVE94
    Local IP(s):
    192.168.178.42 2001:16b8:6053:dd00:9fb9:28b6:89dd:1f46
    Aircraft Tracked:
    (ModeS & ADS-B)
    0
    Aircraft Uploaded:
    N/A
    Receiver:
    dvbt, Connected



    Raspberry PI FR24 Feed Status
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2018-06-13 20:36:19.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EDVE94.
    [ ok ] FR24 Tracked AC:.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    I need some help...
    If you HAD dump1090 installed on its own before update or changed feed type to 'DVBT' and then restarted, then that is why. It force installs its own copy and changes settings to start it again (when it already is) so fails

    Change feed type to BeastTCP:30005/AVRTCP:30002 and see if connects

    Else run the normal 'status checks' commands to see what is running on a fresh start and adjust accordingly
    https://forum.flightradar24.com/thre...ll=1#post74851

    Leave a comment:


  • marcel2351
    replied
    FR24 Feeder problem ( Raspyberry PI )

    Hi Guys,

    i have an Problem with the Feed, Dump1090 works fine on the :8080.
    The Feeder canīt Track Aircrafts ( Aircraft Tracked:
    (ModeS & ADS-B):
    0
    Flightradar24 Feed Status Site:

    FR24 Link:
    Connected via UDP
    FR24 Radar Code:
    T-EDVE94
    Local IP(s):
    192.168.178.42 2001:16b8:6053:dd00:9fb9:28b6:89dd:1f46
    Aircraft Tracked:
    (ModeS & ADS-B)
    0
    Aircraft Uploaded:
    N/A
    Receiver:
    dvbt, Connected



    Raspberry PI FR24 Feed Status
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2018-06-13 20:36:19.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EDVE94.
    [ ok ] FR24 Tracked AC:.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    I need some help...

    Leave a comment:

Working...
X