Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by helios View Post
    Is Raspi MLAT combined with regular MLAT, or are they only correlated with other Rpi-MLAT-Receivers?
    [ATTACH=CONFIG]6236[/ATTACH]
    From what I can understand, RasPi MLATs are used in combination with all the other data.

    Comment


    • Originally posted by wonk View Post
      I have updated to 1.0.13-9/generic and am also seeing the MLAT registration issue:

      2015-07-14 21:47:19 | [mlat][i]Configuring UDP connection udp://mlat-3.fr24.com:19788
      2015-07-14 21:47:19 | [mlat][i]Registering MLAT station
      2015-07-14 21:47:39 | [mlat][i]Registering MLAT station: FAILURE
      Restart and try again please, should be fixed.
      Last edited by vinnyspb; 2015-07-14, 13:42.

      Comment


      • 2015-07-14 22:23:00 | [time][i]Synchronizing time via NTP
        2015-07-14 22:23:04 | [time][i]Time synchronized correctly, offset -0.0001 seconds
        2015-07-14 22:23:05 | [feed][c]Timestamps: optional
        2015-07-14 22:23:34 | [mlat][e]Received MLAT timestamp error: -51808 seconds!

        Error is found...
        Is that my problem or program problem?
        ==============================
        2015-07-14 22:35:03 | [mlat][e]Received MLAT timestamp error: -52500 seconds!
        2015-07-14 22:48:04 | [mlat][e]Received MLAT timestamp error: -53283 seconds!
        2015-07-15 00:09:34 | [mlat][e]Received MLAT timestamp error: -58157 seconds!


        I just restart fr24feed aservice and notice the timestamp error second is increased...
        Last edited by Dundee; 2015-07-14, 16:12.
        T-VHST9: http://vhst9.hopto.org/
        (24/7)

        Comment


        • Originally posted by equi View Post
          Thanks vinnyspb, will Update it as soon as I'm back home
          Upgrade done
          Regards,
          T-EDDE7

          Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
          Banana Pi | Mystique SDR R820T2 | stock Antenna

          Comment


          • Originally posted by vinnyspb View Post
            Restart and try again please, should be fixed.
            Restarted and working now

            Comment


            • i'm also using new mlat featured feeder since today.

              FR24 Feeder/Decoder Process: running.
              FR24 Stats Timestamp: 2015-07-15 01:34:24.
              FR24 Link: connected [UDP].
              FR24 Radar: T-LOWL1.
              FR24 Tracked AC: 8.
              Receiver: connected (68712 MSGS/0 SYNC).
              FR24 MLAT: ok [UDP].
              FR24 MLAT AC seen: 8.

              it seems to work

              should i change mlat-without-gps="yes" to "no" if i have gps on my pi?
              and is the gps used for time and location with the "no" flag?
              do i have to change other settings to use the gps with mlat?
              does the feeder also work as normal feeder too or only as mlat feeder?
              Last edited by LOWL1; 2015-07-15, 01:46.

              Comment


              • It's working fine for me:

                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-07-15 02:46:54.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: (removed)
                [ ok ] FR24 Tracked AC: 1.
                [ ok ] Receiver: connected (2 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 1.

                I guess that "tracked" and "seen" only mean that I... "track" and "see" aircrafts, but at least 3 more MLAT receivers are needed near me, so together, we can contribute useful data to the FR24 servers. Is that right?

                Comment


                • Originally posted by LOWL1 View Post
                  should i change mlat-without-gps="yes" to "no" if i have gps on my pi?
                  and is the gps used for time and location with the "no" flag?
                  do i have to change other settings to use the gps with mlat?
                  does the feeder also work as normal feeder too or only as mlat feeder?
                  You don't need to change this option, GPS will not be used anyway. In order to use GPS for MLAT it has to be aligned with Mode-S signal.
                  The feeder app feeds ADS-B also as usual, not only MLAT.

                  Originally posted by mchvs View Post
                  at least 3 more MLAT receivers are needed near me, so together, we can contribute useful data to the FR24 servers. Is that right?
                  Right, those could be either Raspberry Pis or FR24 boxes.
                  Last edited by vinnyspb; 2015-07-15, 07:45.

                  Comment


                  • Are you tampering with the ADS-B aircraft in the RPi MLAT testing?
                    It seems like a lot of aircraft are traced unprecisely now. I'm looking at aircraft on approach to CPH/EKCH and most aircraft are landing next to the runway. Also I see unfamiliar receivers credited for ADS-B aircraft.

                    Comment


                    • Originally posted by Dundee View Post
                      2015-07-14 22:23:00 | [time][i]Synchronizing time via NTP
                      2015-07-14 22:23:04 | [time][i]Time synchronized correctly, offset -0.0001 seconds
                      2015-07-14 22:23:05 | [feed][c]Timestamps: optional
                      2015-07-14 22:23:34 | [mlat][e]Received MLAT timestamp error: -51808 seconds!

                      Error is found...
                      Is that my problem or program problem?
                      ==============================
                      2015-07-14 22:35:03 | [mlat][e]Received MLAT timestamp error: -52500 seconds!
                      2015-07-14 22:48:04 | [mlat][e]Received MLAT timestamp error: -53283 seconds!
                      2015-07-15 00:09:34 | [mlat][e]Received MLAT timestamp error: -58157 seconds!


                      I just restart fr24feed aservice and notice the timestamp error second is increased...
                      Could you please post a content of your /etc/fr24feed.ini config here?
                      And also I would like to verify that you use correct dump1090 utility that is bundled with fr24feed package. Can you please execute this and post an output?
                      Code:
                      $ md5sum /usr/lib/fr24/dump1090

                      Comment


                      • To vinnyspb , here it is:

                        fr24feed.ini
                        Code:
                        receiver="beast-tcp"
                        fr24key="xxxxxxxxxxxxxxxx"
                        host="192.168.x.x:30005"
                        bs="yes"
                        raw="yes"
                        logmode="3"
                        logpath="/root/fr24feed"
                        gt="300"
                        mlat="yes"
                        mlat-without-gps="yes"
                        md5sum of dump1090:
                        Code:
                        BF59938D917B23A447FFD885A8240C75
                        T-VHST9: http://vhst9.hopto.org/
                        (24/7)

                        Comment


                        • Have updated to 1.0.13-9. and all is well and appears to be working. What I did spot was that before I updated my co-ords were wrong. Now I know I put them in correctly as I cut and pasted them.

                          Lat was fine but the long. I pasted in was -0.2xxx but fr24 signed it up as 88 putting me well east of the Greenwich meridian

                          However the fact that is this perhaps a coding error somewhere that has now been corrected? just wondering if this is a 90 minus 2 = 88 somewhere (i.e. a modulus error??)

                          Anyway it's sorted now.

                          lcs

                          Comment


                          • Originally posted by Dundee View Post
                            Code:
                            receiver="beast-tcp"
                            host="192.168.x.x:30005"
                            MLAT is not supported via "beast-tcp" configuration (data has to be received directly from dump1090 utility), that's most likely why you receive timestamp errors. Please change it to "dvbt" and remove "host" parameter. MD5 is correct.

                            Comment


                            • vinnyspb, is it correct to assume that if an aircraft is traced by T-MLAT7, when it would not have been possible to trace it with FR24 issued receivers alone??

                              Comment


                              • Originally posted by Kpin View Post
                                vinnyspb, is it correct to assume that if an aircraft is traced by T-MLAT7, when it would not have been possible to trace it with FR24 issued receivers alone??
                                I think it's safe to say you are right with that!

                                Comment

                                Working...
                                X