Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by theoreticalking View Post
    Sorry for the stupid question, but how do I run the removal steps for v14? Thanks.
    I've just been looking into the upgrade script some more and change log.

    You are going to IP /dump1090 I take it? (thats what FR24feed is now enabling)

    Anyway, The standard commands

    pgrep -l dump1090
    sudo kill -n <ids that above will show>

    sudo apt-get remove dump1090-mutability

    Then proceed to do the standard .15-dev install abcd567 provided in the stickies

    Once it's back on hopefully all should be well as fr24feed will still be configured for AVRTCP/BeastTCP

    Leave a comment:


  • theoreticalking
    replied
    Originally posted by Oblivian View Post
    It will be defaulted and starting a 2nd copy of sum v14 they bundled.

    Just run removal steps for v14 a reconfigure feeder back to listen to your 15dev copy
    Sorry for the stupid question, but how do I run the removal steps for v14? Thanks.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by theoreticalking View Post
    The new fr24feed killed my dump1090-mutability v1.15dev live map whenever I have fr24feeder on. Map works fine with fr24feed off. Able to feed to fr24 with Beast node (tcp) 30005.

    Getting the following on dump1090.php:
    Problem fetching data from dump1090.
    The data from dump1090 hasn't been updated in a while. Maybe dump1090 is no longer running?
    The displayed map data will be out of date.
    It will be defaulted and starting a 2nd copy of sum v14 they bundled.

    Just run removal steps for v14 a reconfigure feeder back to listen to your 15dev copy

    Leave a comment:


  • theoreticalking
    replied
    The new fr24feed killed my dump1090-mutability v1.15dev live map whenever I have fr24feeder on. Map works fine with fr24feed off. Able to feed to fr24 with Beast node (tcp) 30005.

    Getting the following on dump1090.php:
    Problem fetching data from dump1090.
    The data from dump1090 hasn't been updated in a while. Maybe dump1090 is no longer running?
    The displayed map data will be out of date.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by littleclown View Post
    Stopped working again

    localhost fr24feed[692]: 2018-01-19 23:39:37 | [feed][n]working
    Jan 19 23:40:07 localhost fr24feed[692]: 2018-01-19 23:40:07 | [feed][n]ping 1
    Jan 19 23:40:08 localhost fr24feed[692]: 2018-01-19 23:40:08 | [feed][n]syncing stream result: 1
    Jan 19 23:40:37 localhost fr24feed[692]: 2018-01-19 23:40:37 | [feed][n]ping 2
    Jan 19 23:40:38 localhost fr24feed[692]: 2018-01-19 23:40:38 | [feed][n]syncing stream result: 1
    Jan 19 23:41:07 localhost fr24feed[692]: 2018-01-19 23:41:07 | [feed][n]ping 3
    Jan 19 23:41:08 localhost fr24feed[692]: 2018-01-19 23:41:08 | [feed][n]syncing stream result: 1
    Jan 19 23:41:37 localhost fr24feed[692]: 2018-01-19 23:41:37 | [feed][n]ping 4
    Jan 19 23:41:38 localhost fr24feed[692]: 2018-01-19 23:41:38 | [feed][n]syncing strea
    Wondos? Pi? Dvbt? Avrtcp? Dump1090 ver?

    That's not receiving data from dump1090 or device.

    More info.


    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • littleclown
    replied
    Stopped working again

    localhost fr24feed[692]: 2018-01-19 23:39:37 | [feed][n]working
    Jan 19 23:40:07 localhost fr24feed[692]: 2018-01-19 23:40:07 | [feed][n]ping 1
    Jan 19 23:40:08 localhost fr24feed[692]: 2018-01-19 23:40:08 | [feed][n]syncing stream result: 1
    Jan 19 23:40:37 localhost fr24feed[692]: 2018-01-19 23:40:37 | [feed][n]ping 2
    Jan 19 23:40:38 localhost fr24feed[692]: 2018-01-19 23:40:38 | [feed][n]syncing stream result: 1
    Jan 19 23:41:07 localhost fr24feed[692]: 2018-01-19 23:41:07 | [feed][n]ping 3
    Jan 19 23:41:08 localhost fr24feed[692]: 2018-01-19 23:41:08 | [feed][n]syncing stream result: 1
    Jan 19 23:41:37 localhost fr24feed[692]: 2018-01-19 23:41:37 | [feed][n]ping 4
    Jan 19 23:41:38 localhost fr24feed[692]: 2018-01-19 23:41:38 | [feed][n]syncing strea

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Lling View Post
    Thats the problem. With the old version, the raw data stream was on port 30002 with dvbt. But after i have to change to avr it doesn't work anymore.
    Yes,because it won't currently be running dump1090 or configured correctly so errors you can't see. . You need to work on fr24feed and look at the error

    Leave a comment:


  • Lling
    replied
    Thats the problem. With the old version, the raw data stream was on port 30002 with dvbt. But after i have to change to avr it doesn't work anymore.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Lling View Post
    Sry but i don't know, what you mean. Could you explane it a little bit more easy for me?
    Vrs is obviously not what collects the data. So if you have fr24feed, the issue is more likely with that.

    You have not shown any output of the feed software. So can only guess it has not started the output on 30002. You have to find out why.

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • Lling
    replied
    Sry but i don't know, what you mean. Could you explane it a little bit more easy for me?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Lling View Post
    So now i'm at home.
    In the screenshot, you can see my settings in my VRS-System. It works fine until the last update.

    [ATTACH=CONFIG]9118[/ATTACH]

    Now after i changed my settings to avr-tcp it doesn't work anymore.

    My fr24feed.ini settings are these:

    receiver="avr-tcp"
    fr24key="xxxxxxxxxxx"
    host="localhost:30002"
    bs="no"
    raw="yes"
    logmode="0"
    windowmode="0"
    logpath="/etc/"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"
    Go back a step and check the host software. Not the client (vrs)

    It's possibly for ---net switched off or not auto started dump1090

    Leave a comment:


  • Lling
    replied
    So now i'm at home.
    In the screenshot, you can see my settings in my VRS-System. It works fine until the last update.

    Screenshot_1.png

    Now after i changed my settings to avr-tcp it doesn't work anymore.

    My fr24feed.ini settings are these:

    receiver="avr-tcp"
    fr24key="xxxxxxxxxxx"
    host="localhost:30002"
    bs="no"
    raw="yes"
    logmode="0"
    windowmode="0"
    logpath="/etc/"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"

    Leave a comment:


  • Paperfriend
    replied
    as for me, the new 19-5 doesn't properly detect presence of a running instance of dump1090-mutability 1.15 dev,
    it has been replaced by the 1.14 packaged in the bundle.

    Leave a comment:


  • roofer
    replied
    I can't get my feed to FR24 working.

    Background:
    I have been running fr24feed on a RPi2 for nearly 5 years.
    At 07:05 on the 16th January 2018, fr24feed shut down (maybe an update happened then?) and it has taken me a few days to restart it.
    In the end, I had to reinstall the whole thing (version is now 1.0.19-5).
    Now, it's running fine and I can see the planes in my area at http://rpi2:8080/
    But I am not feeding to FR24, I have re-run

    Code:
    sudo fr24feed --signup
    and entered all the requested information (email, FR24 key, Lat, Lon, altitude etc.) but still no joy.

    Code:
    pi@rpi2:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2018-01-19 17:28:07.
    [FAIL] FR24 Link: unknown ... failed!
    [ ok ] Receiver: connected (287538 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    While dump1090-mutabi is happily tracking 43+ planes.

    Any suggestions?
    Last edited by roofer; 2018-01-19, 17:47. Reason: Version Number

    Leave a comment:


  • helios
    replied
    It broke my existing dump1090-mutability installation by changing the permissions of /run/dump1090-mutability somehow, but that was easy to fix.

    OT: does 1.0.18-5 for x86/x64 support MLAT too?

    Leave a comment:

Working...
X