Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Did you use the settings configuration editor at :8754/settings.html ? I did and it seems to wipe out the last couple of lines of the /etc/fr24feed.ini config file that enable MLAT, try adding:

    mlat="yes"
    mlat-without-gps="yes"

    Comment


    • #77
      There seems to be a probelm in the web view...
      ...when I change settings it always doesn't show my auth key an so it is missing after saving,... also the tracked aircraft list isn't working...
      T-EDDC46

      Comment


      • #78
        Trying to install this but cant even get the initial install to work. Any ideas? I get the following error when trying to install fr24feed:-


        root@piaware:~# sudo apt-get install fr24feed
        Reading package lists... Done
        Building dependency tree
        Reading state information... Done
        The following packages will be upgraded:
        fr24feed
        1 upgraded, 0 newly installed, 0 to remove and 99 not upgraded.
        Need to get 0 B/456 kB of archives.
        After this operation, 0 B of additional disk space will be used.
        (Reading database ... 71413 files and directories currently installed.)
        Preparing to replace fr24feed 1.0.13-2 (using .../fr24feed_1.0.13-6_armhf.deb) ...
        [ ok ] Stopping FR24 feeder: fr24feed.
        Unpacking replacement fr24feed ...
        dpkg: error processing /var/cache/apt/archives/fr24feed_1.0.13-6_armhf.deb (--unpack):
        trying to overwrite '/usr/lib/librtlsdr.so.0.5git', which is also in package dump1090 1.1-1
        dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

        Errors were encountered while processing:
        /var/cache/apt/archives/fr24feed_1.0.13-6_armhf.deb
        E: Sub-process /usr/bin/dpkg returned an error code (1)



        TIA
        lcs

        Comment


        • #79
          Originally posted by lcsneil View Post
          Trying to install this but cant even get the initial install to work. Any ideas? I get the following error when trying to install fr24feed:-


          root@piaware:~# sudo apt-get install fr24feed
          Reading package lists... Done
          Building dependency tree
          Reading state information... Done
          The following packages will be upgraded:
          fr24feed
          1 upgraded, 0 newly installed, 0 to remove and 99 not upgraded.
          Need to get 0 B/456 kB of archives.
          After this operation, 0 B of additional disk space will be used.
          (Reading database ... 71413 files and directories currently installed.)
          Preparing to replace fr24feed 1.0.13-2 (using .../fr24feed_1.0.13-6_armhf.deb) ...
          [ ok ] Stopping FR24 feeder: fr24feed.
          Unpacking replacement fr24feed ...
          dpkg: error processing /var/cache/apt/archives/fr24feed_1.0.13-6_armhf.deb (--unpack):
          trying to overwrite '/usr/lib/librtlsdr.so.0.5git', which is also in package dump1090 1.1-1
          dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

          Errors were encountered while processing:
          /var/cache/apt/archives/fr24feed_1.0.13-6_armhf.deb
          E: Sub-process /usr/bin/dpkg returned an error code (1)



          TIA
          lcs

          You may try " sudo apt-get remove fr24feed " than install it agn .
          T-ZSSS32 F-ZSSS1 force shutdown by local regulation

          Comment


          • #80
            Originally posted by mpegger2 View Post
            Did you use the settings configuration editor at :8754/settings.html ? I did and it seems to wipe out the last couple of lines of the /etc/fr24feed.ini config file that enable MLAT, try adding:

            mlat="yes"
            mlat-without-gps="yes"
            I noticed the same when I did some changes in the Webinterface (adding dump1090 arguments).

            @lcs:

            You have a seperate dump1090 package installed, remove it and the update will run fine.
            Regards,
            T-EDDE7

            Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
            Banana Pi | Mystique SDR R820T2 | stock Antenna

            Comment


            • #81
              Originally posted by iamnothere View Post
              You may try " sudo apt-get remove fr24feed " than install it agn .
              Tried that - same error

              Comment


              • #82
                Originally posted by equi View Post
                @lcs:

                You have a seperate dump1090 package installed, remove it and the update will run fine.
                Indeed a " sudo apt-get remove dump1090 " did the trick. Installed and working

                root@piaware:~# sudo service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-07-12 11:19:30.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-EGW***.
                [ ok ] FR24 Tracked AC: 28.
                [ ok ] Receiver: connected (17349 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 29.



                Thanks

                lcs

                Comment


                • #83
                  You are welcome
                  Regards,
                  T-EDDE7

                  Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                  Banana Pi | Mystique SDR R820T2 | stock Antenna

                  Comment


                  • #84
                    Beta test new Flightradar24 MLAT software for Raspberry Pi

                    Hi

                    Upgrade to MLAT enabled RPi feeder app. Location 300m south of RWY 03L VTBD. Hope it helps.

                    Kanok


                    Sent from my iPad using Tapatalk
                    T-VTBD1 : RadarBox 3km North of VTBD
                    T-VTBD2 : RPi MLAT 300m South of VTBD

                    Comment


                    • #85
                      Originally posted by Kanok View Post
                      Hi

                      Upgrade to MLAT enabled RPi feeder app. Location 300m south of RWY 03L VTBD. Hope it helps.

                      Kanok


                      Sent from my iPad using Tapatalk
                      Finally you can contribute to MLAT with your setup.

                      Comment


                      • #86
                        But... When I check service, sudo service fr24feed status, the timestamp is ever about 2h delay someone knows why?

                        Sent from my SM-N910F using Tapatalk

                        Comment


                        • #87
                          Because it is UTC and not GMT+2
                          Regards,
                          T-EDDE7

                          Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                          Banana Pi | Mystique SDR R820T2 | stock Antenna

                          Comment


                          • #88
                            Positions are now live on the map. Just filter for T-MLAT7

                            I though them will more accurate.

                            Comment


                            • #89
                              I bought Rpi2 yesterday, only to test this. Tired of feeding the data through my PC. Can't wait it to arrive as we already have good MLAT coverage around here, it can display MLAT AC from around 6k feet. One more receiver should lower that number I hope so!!

                              Comment


                              • #90
                                Originally posted by lcsneil View Post
                                dpkg: error processing /var/cache/apt/archives/fr24feed_1.0.13-6_armhf.deb (--unpack):
                                trying to overwrite '/usr/lib/librtlsdr.so.0.5git', which is also in package dump1090 1.1-1
                                dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
                                A request to the FR24 developers - could you either statically link against librtlsdr, or put your copies of the libraries in a private directory, or depend on the separate package (librtlsdr0) that provides it?
                                I have changed the FA dump1090 package to statically link, and dump1090-mutability to depend on librtlsdr0, for exactly that reason: putting the libraries in /usr/lib is going to conflict with anything and everything else that wants to use them.
                                Thanks.

                                Comment

                                Working...
                                X