Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • helios
    replied
    I ment to remove "/run/dump1090-mutability" from
    ExecStartPre=-/bin/chown -R nobody:nogroup /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt

    Leave a comment:


  • Oblivian
    replied
    Originally posted by ylis View Post
    Can anyone help with a solution - I can't connect using ip_of_pi:8754 and therefore cannot access the status and settings.

    Error Message says:

    This site can't be reached
    <ip_of_pi> refused to connect.
    ERR_CONNECTION_REFUSED
    That generally means there is a serious error and it is crashing/not currently running

    You will need to use commandline to find out why or edit the config file.

    Assuming you are on a RPi, some of the commands are outlined.. https://forum.flightradar24.com/thre...ll=1#post74851

    you can also edit
    sudo nano /etc/fr24feed.ini

    Leave a comment:


  • gleve
    replied
    Originally posted by helios View Post
    Ah there's the point, thank you. But is a chown for /run/dump1090-mutability even required? I guess that could be just removed as dump1090-mutability should set the permissions itself.
    No. Just change the file and restart. That will be a permanent fix.

    Remember to reload the services with systemctl daemon-reload before you reboot

    Leave a comment:


  • ylis
    replied
    Can anyone help with a solution - I can't connect using ip_of_pi:8754 and therefore cannot access the status and settings.

    Error Message says:

    This site can't be reached
    <ip_of_pi> refused to connect.
    ERR_CONNECTION_REFUSED

    Leave a comment:


  • helios
    replied
    Originally posted by gleve View Post
    Edit: I changed the service file in /etc/systemd/system/fr24feed.service and now in line 12 i have the correct user
    Now the map is working fine even after restarts
    Ah there's the point, thank you. But is a chown for /run/dump1090-mutability even required? I guess that could be just removed as dump1090-mutability should set the permissions itself.

    Leave a comment:


  • Oblivian
    replied
    If someone wants to play along and confirm it'd be great

    I think Post 1 in this thread is now out of date.
    I purged fr24feed and dump1090-mutability and started following the manual steps to find it fail.. badly

    (Reading database ... 60941 files and directories currently installed.)
    Removing fr24feed (1.0.19-5) ...
    (Reading database ... 60925 files and directories currently installed.)
    Purging configuration files for fr24feed (1.0.19-5) ...
    dpkg: warning: while removing fr24feed, directory '/usr/lib/fr24' not empty so not removed

    ^^ probably the screwed up permission or cause I didn't remove dump1090-mutability 1st

    Setting up fr24feed (1.0.19-5) ...
    You don't seem to have any dump1090 installed. On the fr24feed start it will automatically install dump1090-mutability.

    Err nope. It sure didn't!

    Now have NO copy of dump1090 on system. Auto config sets it up in AVRTCP localhost but fails.

    Pruned the /usr/bin/fr24 folder and retried
    If you follow the newly edited one linked from feed.flightradar24.com there is a little more success
    https://forum.flightradar24.com/thre...6479#post66479
    Started with the .14 as it suggests..

    pi@raspberrypi:/usr/lib $ sudo apt-get install fr24feed
    The following NEW packages will be installed:
    fr24feed
    0 upgraded, 1 newly installed, 0 to remove and 15 not upgraded.
    Need to get 0 B/1,195 kB of archives.
    After this operation, 563 kB of additional disk space will be used.
    Selecting previously unselected package fr24feed.
    (Reading database ... 60920 files and directories currently installed.)
    Preparing to unpack .../fr24feed_1.0.19-5_armhf.deb ...
    Unpacking fr24feed (1.0.19-5) ...
    Setting up fr24feed (1.0.19-5) ...
    Linking /usr/bin/dump1090-mutability to /usr/lib/fr24/dump1090

    The config is STILL not editiable 0.o (is anyone elses?)

    If anyone with the web issues wants to go through a total purge and the manual install and see if it fixes it, it'd soon tell the devs theres a script issue again.

    Leave a comment:


  • gleve
    replied
    Originally posted by helios View Post
    In my case the reason for that was, that my pre-existing dump1090-mutability didn't had access to /run/dump1090-mutability anymore after upgrading fr24feed. Changing the permissions of /run/dump1090-mutability so that the user/group dump1090 had access to it was the workaround.
    True, but you have to do it every time you restart.
    will try to figure out how fr24feed handles those permissions

    Edit: I changed the service file in /etc/systemd/system/fr24feed.service and now in line 12 i have the correct user

    ExecStartPre=-/bin/chown -R dump1090:nogroup /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt
    Now the map is working fine even after restarts
    Last edited by gleve; 2018-01-20, 09:21.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by theoreticalking View Post
    The new fr24feed killed my dump1090-mutability v1.15dev live map whenever I have fr24feeder on. Map works fine with fr24feed off. Able to feed to fr24 with Beast node (tcp) 30005.

    Getting the following on dump1090.php:
    Problem fetching data from dump1090.
    The data from dump1090 hasn't been updated in a while. Maybe dump1090 is no longer running?
    The displayed map data will be out of date.
    OK, I had a bung one too. Now fixed

    It needed httpd to be flushed to find the dump1090 install version

    Once you have the version of dump1090 you want installed:

    sudo apt-get remove --purge lighttpd
    sudo apt-get install lighttpd
    sudo lighty-enable-mod dump1090
    sudo service lighttpd force-reload

    Leave a comment:


  • helios
    replied
    Originally posted by gleve View Post
    After i re-install fr24feed the map will not work regardless if i stop the service or not.
    In my case the reason for that was, that my pre-existing dump1090-mutability didn't had access to /run/dump1090-mutability anymore after upgrading fr24feed, so it couldn't update the json files for the web interface.
    Changing the permissions of /run/dump1090-mutability so that the user/group dump1090 had access to it was the workaround.
    Last edited by helios; 2018-01-20, 08:55.

    Leave a comment:


  • Oblivian
    replied
    Running the install commands manually with output doesn't bode well

    pi@raspberrypi:/usr/lib/fr24 $ lighty-enable-mod dump1090
    failure: No such file or directory
    Run "service lighttpd force-reload" to enable changes

    It seems it doesn't recognise the virtual link to dump1090 for a start.

    https://forum.flightradar24.com/thre...debian-package

    Leave a comment:


  • gleve
    replied
    Originally posted by Oblivian View Post
    We've discovered some more quirks in the other thread for people with -15dev :/ and trying to get to bottom of it.

    Changes permissions of files somewhere it seems. Removing it may just be crashing out the copy it auto-launches.

    Was there 2 instances in pgrep showing?
    No, just one.
    After i re-install fr24feed the map will not work regardless if i stop the service or not. I have to uninstall it to make it work again.
    Can you post the link for the other thread?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by gleve View Post
    Didn't work.
    I removed fr24feed and now it's back again.
    We've discovered some more quirks in the other thread for people with -15dev :/ and trying to get to bottom of it.

    Changes permissions of files somewhere it seems. Removing it may just be crashing out the copy it auto-launches.

    Was there 2 instances in pgrep showing?

    Leave a comment:


  • gleve
    replied
    Originally posted by Oblivian View Post
    Followed from step 6 also I take it?

    There may be some new issues introduced with the changes FR24 team made, it also makes virtual links and enables the lighttpd service which may need to be reverted back

    Number of things to try. Add the :8080/dump1090
    Try without either specified
    Ctrl-F5 to force reload of the browser cache

    And of course ensure rebooting device when changing versions
    Didn't work.
    I removed fr24feed and now it's back again.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by gleve View Post
    This didn't work for me.
    Removed dump1090 as you say but when i installed the .15 version the map still does not work
    Followed from step 6 also I take it?
    https://forum.flightradar24.com/thre...-15-dev-on-RPi

    There may be some new issues introduced with the changes FR24 team made, it also makes virtual links and enables the lighttpd service which may need to be reverted back

    Number of things to try. Add the :8080/dump1090
    Try without either specified
    Ctrl-F5 to force reload of the browser cache

    And of course ensure rebooting device when changing versions

    Leave a comment:


  • gleve
    replied
    Originally posted by Oblivian View Post
    I've just been looking into the upgrade script some more and change log.

    You are going to IP /dump1090 I take it? (thats what FR24feed is now enabling)

    Anyway, The standard commands

    pgrep -l dump1090
    sudo kill -n <ids that above will show>

    sudo apt-get remove dump1090-mutability

    Then proceed to do the standard .15-dev install abcd567 provided in the stickies

    Once it's back on hopefully all should be well as fr24feed will still be configured for AVRTCP/BeastTCP
    This didn't work for me.
    Removed dump1090 as you say but when i installed the .15 version the map still does not work

    Leave a comment:

Working...
X