Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by lodervsm View Post
    I do not know whether this is related to the updates mentioned... but I was running Raspian Jessie for 6 months with the DVB-T tuner... and after 6 months ( I turn off the system every night), now when I turn on power, it is not sharing any data... the only workaround I found was to install a fresh fr24feed app every time I power up the system. Any help ? 10x
    It auto updated lots of people. So probably is. You will need to do the manual checks outlined in other thread to confirm, and get back to working 18-9. but if your sd card is full or damaged it will also not save changes (lots of things are done in RAM until reboot)

    Sent from my XT1092 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • Seems that now it is working after power down...

      I made a fresh install of Raspbian Stretch

      sudo apt-get update
      sudo apt-get install dirmngr
      sudo apt-get install librtlsdr0 and selected no to autostart dump1090
      sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

      Comment


      • I have made a fresh signup and it still doesn‘t work for me. So can you give us some news about a patch or a date for the new version?

        Comment


        • Quick update here. We are doing some tests now and are hoping to have a new build ready sometime tomorrow.
          --

          Comment


          • Originally posted by Khan View Post
            Quick update here. We are doing some tests now and are hoping to have a new build ready sometime tomorrow.
            Thanks for info! I was about to reinstall... :-)

            Comment


            • Originally posted by Khan View Post
              Quick update here. We are doing some tests now and are hoping to have a new build ready sometime tomorrow.
              Any news when this issue is solved ?

              Comment


              • Seems to be a 19-5 available and is working for me right now.
                Removed and installed via apt-get and also changed the fr24feed.ini from dvbt to avr-tcp, added host="localhost:30002" instead of path=/dev/... Not really sure what actually made the diffrence.

                Comment


                • New version 19-5 published. You can either leave your pi to be automatically upgraded to the new version or run

                  sudo /usr/lib/fr24/fr24feed_updater.sh

                  Changelog available at Release Information - Data sharing software
                  --

                  Comment


                  • Updated now and it works perfect!
                    Thanks to Khan, and all others involved!
                    Last edited by vejbymats@gmail.com; 2018-01-19, 14:33.

                    Comment


                    • Sorry but this update doesn‘t help alot. Why i can‘t use dvbt anymore in the settings? With AVR the port 300002 is blocked. But its important if you have your own radar server.
                      Last edited by Lling; 2018-01-19, 14:56.

                      Comment


                      • After the update, I'm getting this error:

                        Code:
                        pi@raspberrypi:~ $ sudo service fr24feed status
                        ● fr24feed.service - Flightradar24 Decoder & Feeder
                           Loaded: loaded (/etc/systemd/system/fr24feed.service; enabled)
                           Active: active (running) since Fri 2018-01-19 16:33:12 EET; 49s ago
                          Process: 674 ExecStartPre=/bin/chmod a+rwx /var/log/lighttpd (code=exited, status=0/SUCCESS)
                          Process: 666 ExecStartPre=/bin/chown -R nobody:nogroup /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt (code=exited, status=0/SUCCESS)
                          Process: 657 ExecStartPre=/bin/touch /dev/shm/decoder.txt (code=exited, status=0/SUCCESS)
                          Process: 651 ExecStartPre=/bin/mkdir -p /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /var/log/lighttpd (code=exited, status=0/SUCCESS)
                          Process: 594 ExecStartPre=/usr/lib/fr24/install_dump1090.sh (code=exited, status=0/SUCCESS)
                         Main PID: 683 (fr24feed)
                           CGroup: /system.slice/fr24feed.service
                                   └─683 /usr/bin/fr24feed
                        
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: Found 1 device(s):
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: 0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: usb_claim_interface error -6
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: Error opening the RTLSDR device: Device or resource busy
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: 2018-01-19 16:33:57 | [reader][i]Connection terminated
                        Jan 19 16:33:57 raspberrypi fr24feed[683]: 2018-01-19 16:33:57 | [main][i]Terminating child process 1352 with SIGTERM
                        Jan 19 16:33:58 raspberrypi fr24feed[683]: 2018-01-19 16:33:58 | [time][i]Synchronizing time via NTP
                        Jan 19 16:33:59 raspberrypi fr24feed[683]: 2018-01-19 16:33:59 | [time][e]Failed to synchronize time
                        Jan 19 16:34:01 raspberrypi fr24feed[683]: 2018-01-19 16:34:01 | [time][i]Synchronizing time via NTP
                        Jan 19 16:34:01 raspberrypi fr24feed[683]: 2018-01-19 16:34:01 | [time][e]Failed to synchronize time

                        Comment


                        • logmode="0" does not work anymore..this will harm my sd-card. reverting back to old version.

                          Comment


                          • @Lling you can change your fr24feed.ini to any setting you want. Whether its dvbt or avr. Currently, I have one dvbt and one avr setup to get data from 30002. Both are working fine. Please share your fr24feed.ini file here and explain exactly how you are trying to set it up.

                            @dotsi: New status checking command: fr24feed-status
                            --

                            Comment


                            • ok khan. i will do it, when i am at home today. thx for your help

                              Comment


                              • After upgrade:

                                [FAIL] FR24 Feeder/Decoder Process ... failed!


                                Jan 19 16:28:49 localhost fr24feed[6353]: /usr/bin/fr24feed --fr24key=[XXXXXXXXXXXX| Start feeding process manually (My sharing key is not XXXXX, I just edit this line )
                                Jan 19 16:28:49 localhost fr24feed[6353]: /usr/bin/fr24feed --signup | Sign up and configure
                                Jan 19 16:28:49 localhost fr24feed[6353]: /usr/bin/fr24feed --reconfigure | Change configuration
                                Jan 19 16:28:49 localhost fr24feed[6353]: /usr/bin/fr24feed --version | Show binary version number
                                Jan 19 16:28:49 localhost systemd[1]: fr24feed.service holdoff time over, scheduling restart.
                                Jan 19 16:28:49 localhost systemd[1]: Stopping Flightradar24 Decoder & Feeder...
                                Jan 19 16:28:49 localhost systemd[1]: Starting Flightradar24 Decoder & Feeder...
                                Jan 19 16:28:49 localhost systemd[1]: fr24feed.service start request repeated too quickly, refusing to start.
                                Jan 19 16:28:49 localhost systemd[1]: Failed to start Flightradar24 Decoder & Feeder.
                                Jan 19 16:28:49 localhost systemd[1]: Unit fr24feed.service entered failed state.



                                Please assist

                                EDIT: After reconfiguration and restart I have the following:

                                Jan 19 16:34:46 localhost install_dump1090.sh[1185]: dump1090 is not found, downloading dump1090-mutability...
                                Jan 19 16:34:47 localhost install_dump1090.sh[1185]: info: Trying to set 'dump1090-mutability/auto-start' [boolean] to 'false'
                                Jan 19 16:34:47 localhost install_dump1090.sh[1185]: info: Loading answer for 'dump1090-mutability/auto-start'
                                Last edited by littleclown; 2018-01-19, 16:36.

                                Comment

                                Working...
                                X