Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by jrf View Post
    So I think for MLAT the question is: FR24 Feeder Status says MLAT running = YES. What is the meaning in the log then saying: Stats 0/0?
    [ATTACH=CONFIG]7269[/ATTACH]
    [ATTACH=CONFIG]7270[/ATTACH]
    Except that for our RPi 3 installation it says "MLAT Running NO"

    Comment


    • Originally posted by Kpin View Post
      Have anybody succeeded in using the new Raspberry 3 AND getting MLAT to work?

      My friend started his new RPi3 today, but the MLAT status says 'NO' compared to my RPi status 'YES' and my Windows status 'N/A'
      Of course we said YES to contributing to MLAT in the set up.
      I have just setup a raspberry pi 2 with the fr24feed software and also do not have MLAT running. I said "yes" in the setup but it still shows as no.
      Maybe this is something about checking the data provided first from new setups?? Not sure

      Comment


      • Originally posted by jrf View Post
        So I think for MLAT the question is: FR24 Feeder Status says MLAT running = YES. What is the meaning in the log then saying: Stats 0/0?
        Edit: It is RPi3, Raspian.


        I have the same situation: PI3, latest version of the feeder (1.0.18-5) and "MLAT running: YES". But on the log I ALWAYS see "Stats 0/0".
        Last edited by awg; 2016-03-30, 16:40.

        Comment


        • Originally posted by awg View Post
          I have the same situation: PI3, latest version of the feeder (1.0.18-5) and "MLAT running: YES". But on the log I ALWAYS see "Stats 0/0".
          Stats on the main page do not seem to be accurate representation. Better to use 'sudo service fr24feed status' or the variables page.

          One thing to check is your GPS settings, if you set them in the wrong format during setup, anything you capture will be out of range and disabled/ignored.

          You will see this appear during startup if you stop the service and run as a standalone momentarily. Copy the co-ords into google maps and see if it lands on you.

          sudo service fr24feed stop
          sudo fr24feed start


          ctrl-c
          sudo service fr24feed start
          (A reboot may be required to start it as service again later)
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • Those of you having trouble with MLAT, it maybe worth doing as Oblivion suggested above and comparing the coordinates for feed and MLAT

            sudo service fr24feed stop
            sudo fr24feed start

            It seems that MLAT is cutting of the last 2 digits of the coordinates and rounding them up causing a 300m+ offset from your actual coordinates

            More info here
            http://forum.flightradar24.com/threa...7494#post77494

            Comment


            • Originally posted by spudd View Post
              Those of you having trouble with MLAT, it maybe worth doing as Oblivion suggested above and comparing the coordinates for feed and MLAT

              sudo service fr24feed stop
              sudo fr24feed start

              It seems that MLAT is cutting of the last 2 digits of the coordinates and rounding them up causing a 300m+ offset from your actual coordinates

              More info here
              http://forum.flightradar24.com/threa...7494#post77494
              Are you sure that you input the coordinates in the right format? Initially I used drg.mm.ss because my Google Earth gave it to me like that. And therefore I was more than a kilometer off. I noticed only by chance. FR24 will have no way of knowing this unless your error is so big that the ADS-B positions you give for aircraft make no sense - More than 300 km i think.

              Google map gives the right format in the URL and Google Earth can be set up to give this too.

              Comment


              • Originally posted by Kpin View Post
                Are you sure that you input the coordinates in the right format? Initially I used drg.mm.ss because my Google Earth gave it to me like that. And therefore I was more than a kilometer off. I noticed only by chance. FR24 will have no way of knowing this unless your error is so big that the ADS-B positions you give for aircraft make no sense - More than 300 km i think.

                Google map gives the right format in the URL and Google Earth can be set up to give this too.
                Yes. If you run fr24feed standalone instead of the service you get a lot more information. One of the first things it gives you is
                2016-03-30 22:15:45 | [main][i]Feed Network client started
                2016-03-30 22:15:45 | [feed][i]Downloading configuration
                2016-03-30 22:15:45 | [feed][c]Interval: 5s
                2016-03-30 22:15:45 | [feed][c]Latitude: xx.xxx
                2016-03-30 22:15:45 | [feed][c]Longitude: -x.xxxx
                2016-03-30 22:15:45 | [feed][c]GND: YES

                Those coordinates are correct and the ones i supplied in setup. Further down you get

                2016-03-30 22:15:46 | [mlat][i]Starting MLAT with preconfigured position: xx.xx,-x.xx,330.0
                These are shortened coordinates from above with the last 2 digits rounded up.

                This may just be in the way that the client is reporting it though.

                Comment


                • I'm having trouble with the Dump 1090 port 8080 graphical interface on a Pi installation. The FAQ says this:

                  Dump1090 Graphical Interface:
                  When --net option is added, a further option can be specified --net-http-port 8080 (or other such port)
                  When you then visit http://localhost:8080 (or other IP for host software) a map will be provided by Dump1090
                  See Dump1090 documentation for further assistance

                  But it doesn't want to work. I've tried --net-http-port 8080 and --net --net-http-port 8080, no go. What does work is --interactive --net --net-http-port 8080 but that stops the feeder uploading to FR24 and of course MLAT fails. Does anyone have the Dump 1090 gui working properly?

                  Thanks

                  Comment


                  • Originally posted by 41south View Post
                    I'm having trouble with the Dump 1090 port 8080 graphical interface on a Pi installation. The FAQ says this:

                    Dump1090 Graphical Interface:
                    When --net option is added, a further option can be specified --net-http-port 8080 (or other such port)
                    When you then visit http://localhost:8080 (or other IP for host software) a map will be provided by Dump1090
                    See Dump1090 documentation for further assistance

                    But it doesn't want to work. I've tried --net-http-port 8080 and --net --net-http-port 8080, no go. What does work is --interactive --net --net-http-port 8080 but that stops the feeder uploading to FR24 and of course MLAT fails. Does anyone have the Dump 1090 gui working properly?

                    Thanks
                    Tiz how I run mine at home. --net and --net-http-port 8080 together. Interactive will attempt to produce text output (mainly used for monitoring in windows version with just a stick and no other SW)

                    Stop the service and run without service, see if you can see the parameters being passed during startup as per normal. If you have done a piaware install however, dump1090 is possibly launching as a 3rd part on its own beforehand in background and may need to have it reconfigured there instead.
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • It's a FR24 install direct from the image so I'll try the manual start way and see what happens.

                      Comment


                      • Other alternate is if they have not included the normal 1090 in that image.. the command won't be known In which case will need to install -mutability or similar
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • just restart your dump1090 and all works fine

                          sudo /etc/init.d/dump1090.sh restart

                          Sent from my SM-N910F using Tapatalk

                          Comment


                          • So I can confirm that starting dump1090 with the arguments --net --net-http-port 8080 works just fine. I'm sure I've tried that before!

                            Comment


                            • Is there a propper way to replace dump1090 for the mutability one without messing things out please?

                              Comment


                              • Originally posted by RoSi View Post
                                Is there a propper way to replace dump1090 for the mutability one without messing things out please?
                                Configure via web for receiver of AVR-TCP port 30002. (save of course)
                                Sudo fr24feed service stop

                                install and configure dump1090 mutability accordingly

                                sudo fr24feed service start

                                Check via config webpage that working OK
                                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                                Comment

                                Working...
                                X