Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mgunther
    replied
    @jrf I wrote in more detail in the other thread (Feed issues / Dump1090 problem with latest package) about the 'User=nobody' entry which does not work for me. It works fine when I change this to 'User=root'. It may be the same for you.

    Leave a comment:


  • jrf
    replied
    Originally posted by Khan View Post
    Quick update. Version 19-6 released.
    You can update by running
    sudo apt update
    sudo /usr/lib/fr24/fr24feed_updater.sh
    Following RPI information:
    Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

    I did:
    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo /usr/lib/fr24/fr24feed_updater.sh
    fr24feed-status

    Result:
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2018-01-24 09:15:30.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EDNY19.
    [ ok ] FR24 Tracked AC:.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    On connecting through http://192.168.178.20:8754/, result in browser:
    Flightradar24 Feeder/Decoder
    Linux/generic/static_arm/1.0.19-6
    Updated: 10:19:05 GMT+0100

    FR24 Link: Connected via UDP
    FR24 Radar Code: T-EDNY19
    Aircraft Tracked (ModeS & ADS-B): 0
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO

    Not back in business yet...

    /edit reasons: readability
    Last edited by jrf; 2018-01-24, 09:23.

    Leave a comment:


  • mgunther
    replied
    I wrote in more detail n the other thread (Feed issues / Dump1090 problem with latest package) about the 'User=nobody' entry which does not work for me. It works fine when I change this to 'User=root'.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by JohnSunnyhills View Post

    Not sure what this means, I am ignoring it right now.ExecStartPre=-/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt
    User=nobody
    Just me highlighting for the powers that be and reminder later.

    When you run Sudo service fr24feed. That's what it does during startup. It's the service config. So it changes permissions etc etc to the specified user. In this case, nobody. While the actual app needs to be run as Sudo/root. So it contradicts the command we are giving it in the first place to start and causes write permission errors.

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • JohnSunnyhills
    replied
    Originally posted by Oblivian View Post
    ExecStartPre=-/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt


    User=nobody


    Uh-oh. Whats good for the goose isn't for the gander. Assuming you are starting with sudo infront of the sudo service fr24feed start', and so on.

    We may still have a prob. (or your copy hasn't updated). Need to check mine when I get home and plug the beast in to test (primary is a windows + beast feed, Pi is a pager decoder and DVBT tester)
    All I know is that my Beast with RPI was running fine as a SERVICE until 18.00 zulu time (7am NZ Time) when it went Offline. I assume an Auto Update occurred.
    Since then SUDO SERVICE FR24FEED RESTART does not work, stays Offline.

    I was running the Beast without SERVICE when I did the tests you requested.

    Not sure what this means, I am ignoring it right now.ExecStartPre=-/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt
    User=nobody

    Leave a comment:


  • Oblivian
    replied
    ExecStartPre=-/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt


    User=nobody


    Uh-oh. Whats good for the goose isn't for the gander. Assuming you are starting with sudo infront of the sudo service fr24feed start', and so on.

    We may still have a prob. (or your copy hasn't updated). Need to check mine when I get home and plug the beast in to test (primary is a windows + beast feed, Pi is a pager decoder and DVBT tester)

    Leave a comment:


  • JohnSunnyhills
    replied
    Originally posted by Oblivian View Post
    That is likely still a result of changes to permissions. In this case of importance and likely a huge help is more the technical data behind the results you see, over the results/observations itself.

    They have worked on the DVB stick setup for now (of greatest numbers of issues) and the changes to rectify may have effected the non dump1090 installs (including the beast which is native and doesn't start dump1090.. or shouldn't.)

    I suspect it's a result of the /decoder.txt file not being writable. This is where the LOCAL web page stats and status are generated (messages on sudo fr24feed-status) also.

    Can you please post the outcome of

    cat /etc/systemd/system/fr24feed.service

    And

    ls -lar /run/fr24feed

    To ease concerns, these are non destructive enquiries only that will help identify the change that needs to be considered by the developers for non DVB users.. poss another patch required

    Sent from my XT1092 using Tapatalk


    pi@raspnzaa4:~ $ cat /etc/systemd/system/fr24feed.service
    [Unit]
    Description=Flightradar24 Decoder & Feeder
    After=network-online.target

    [Service]
    Type=simple
    Restart=always
    LimitCORE=infinity
    ExecStartPre=-/usr/lib/fr24/install_dump1090.sh
    ExecStartPre=-/bin/mkdir -p /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /var/log/lighttpd
    ExecStartPre=-/bin/touch /dev/shm/decoder.txt
    ExecStartPre=-/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt
    ExecStartPre=-/bin/chmod a+rwx /run/dump1090-mutability
    ExecStart=/usr/bin/fr24feed
    User=nobody
    Group=nogroup
    PermissionsStartOnly=true
    StandardOutput=null

    [Install]
    WantedBy=multi-user.target

    pi@raspnzaa4:~ $ ls -lar /run/fr24feed
    total 0
    drwxr-xr-x 21 root root 720 Jan 24 08:22 ..
    drwxr-xr-x 2 nobody nogroup 40 Jan 24 08:22 .


    BY the way my statistics seem to be updating ok now but I am running this in a SSH window and not as a service.

    The status shows as:
    Flightradar24 Feeder/Decoder
    Linux/generic/static_arm/1.0.19-6
    Updated: 12:12:46 GMT+1300 (New Zealand Daylight Time)

    FR24 Link:
    Connected via UDP
    FR24 Radar Code:
    T-NZAA4
    Aircraft Tracked (ModeS & ADS-B):
    0
    Aircraft Uploaded:
    N/A
    Receiver:
    beast, Connected
    MLAT running:
    N/A

    Actions:
    Last edited by JohnSunnyhills; 2018-01-23, 23:15.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by JohnSunnyhills View Post
    The Beast is acting strangely as I observed earlier.
    Right now when running FR24FEED directly (ie not as a service) the log is showing aircraft activity as usual. However if I go into my browser using <ipno>:8754 and I select Show Tracked Aircraft List it displays the screen plus a message "Please Wait".
    The Radar Statistics page on the FR24 website shows the radar is ONLINE but the stat numbers aren't changing. The radar is NZAA4 if anyone cares to examine the shared stats themselves.
    That is likely still a result of changes to permissions. In this case of importance and likely a huge help is more the technical data behind the results you see, over the results/observations itself.

    They have worked on the DVB stick setup for now (of greatest numbers of issues) and the changes to rectify may have effected the non dump1090 installs (including the beast which is native and doesn't start dump1090.. or shouldn't.)

    I suspect it's a result of the /decoder.txt file not being writable. This is where the LOCAL web page stats and status are generated (messages on sudo fr24feed-status) also.

    Can you please post the outcome of

    cat /etc/systemd/system/fr24feed.service

    And

    ls -lar /run/fr24feed

    To ease concerns, these are non destructive enquiries only that will help identify the change that needs to be considered by the developers for non DVB users.. poss another patch required

    Sent from my XT1092 using Tapatalk

    Leave a comment:


  • JohnSunnyhills
    replied
    Originally posted by JohnSunnyhills View Post
    Today there has been a change in the operation of my two RPIs. Totally standard setup with no tweaking.

    One which is using a Beast was running normally until the last hour or so when it received an update, I assume.
    That stopped it and after I have tried restarting that in a SERVICE it falls over.
    If I run the direct command SUDO FR24 RESTART command it runs normally.

    With respect to the second one using a DVBT which has been out of action and offline since the update last week, this one is running normally today after the last update.
    So issues with my Beast...
    The Beast is acting strangely as I observed earlier.
    Right now when running FR24FEED directly (ie not as a service) the log is showing aircraft activity as usual. However if I go into my browser using <ipno>:8754 and I select Show Tracked Aircraft List it displays the screen plus a message "Please Wait".
    The Radar Statistics page on the FR24 website shows the radar is ONLINE but the stat numbers aren't changing. The radar is NZAA4 if anyone cares to examine the shared stats themselves.

    Leave a comment:


  • alemino
    replied
    Originally posted by abcd567 View Post
    Lucky you are still at 1.0.18-9 ! As already advised by Oblivian, just sit tight and wait for new upgrade due in few days.

    well this is the best advice so far.. ( thank you and all the others for the posting of helps and tricks)

    i have a couple of RPi running with the setup made by zahidulhasan ( thank you so much)
    which kept somehow running..

    then on sunday i did, from zero, assembly a new Rpi with DVTB dongle according the official instructions of FR24.
    It did work flawlessy. (ver 18-9).
    on monday morning he did upgrade to 19-5 and crashed.
    I did try few fixes here, but none did really the work.
    So i formatted the SD card, and again as offcial instrutions FR24 i got it run again. (ver-18-9). After that i found a link in forum in how to stop the upgrade. ( adding in a "upgrader file" a #)
    here how: https://forum.flightradar24.com/thre...eed_updater-sh

    and today kept running on ver 18-9. Let's see tomorrow...

    I think now i will wait till new version are released and proved to run flawlessy..before let it upgrade again..
    Last edited by alemino; 2018-01-23, 19:25.

    Leave a comment:


  • JohnSunnyhills
    replied
    Today there has been a change in the operation of my two RPIs. Totally standard setup with no tweaking.

    One which is using a Beast was running normally until the last hour or so when it received an update, I assume.
    That stopped it and after I have tried restarting that in a SERVICE it falls over.
    If I run the direct command SUDO FR24 RESTART command it runs normally.

    With respect to the second one using a DVBT which has been out of action and offline since the update last week, this one is running normally today after the last update.
    So issues with my Beast...
    Last edited by JohnSunnyhills; 2018-01-23, 20:02.

    Leave a comment:


  • Khan
    replied
    Quick update. Version 19-6 released.

    You can update by running

    sudo apt update
    sudo /usr/lib/fr24/fr24feed_updater.sh

    Leave a comment:


  • Oblivian
    replied
    Oops. Head so full of 19-5 rubbish I didn't spot it was still likely the -MR version that doesn't offload to lighttpd

    Leave a comment:


  • abcd567
    replied
    Originally posted by k5hmd View Post
    I'm unable to get the map using ip_of_pi:8080 or ip_of_pi/dump1090. Do I need to enable it someway? Using 1.0.18-9.

    Suggestions?

    Thanks,
    Joe
    Lucky you are still at 1.0.18-9 ! As already advised by Oblivian, just sit tight and wait for new upgrade due in few days.

    Meanwhile to see map, you have to add --net in Process Arguments. To do this, go to ip-of-pi:8754/settings.html, and in the field "Process arguments" add --net, as shown in screenshot below.

    IMPORTANT:
    1. Do NOT change any other setting on your settings page, even if they are different than those shown on the screenshot I have posted below.

    2. After adding --net, first click "Save" button, then click "Restart" button. Both these buttons are in the bottom-right corner of the settings page.

    FR24 Settings for map.png
    Last edited by abcd567; 2018-01-23, 00:14.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by k5hmd View Post
    I'm unable to get the map using ip_of_pi:8080 or ip_of_pi/dump1090. Do I need to enable it someway? Using 1.0.18-9.

    Suggestions?

    Thanks,
    Joe
    You are best to await the next release and see if it adjusts the permissions and issues directly (due today)

    It is likely related to the http server not reconfiguring for your partitular setup similarly to https://forum.flightradar24.com/thre...l=1#post100516

    Leave a comment:

Working...
X