Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Don't know if it's right thread to write this... but I try it.

    I'm a bit away from all this linux staff, but I have an idea, which hurts me a while.
    I have a ZyXel router with 2 USB ports onboard (ZyXel Keenetic Giga) this one

    And this router have an opportunity run root linux right on dedicated usb flash drive. Linux profi call him - opkg. In second usb port I insert RTL_dongle for a few minutes with dump1090 I can receive mode-s packages. But CPU in router only 384MHz and seems it's not enough to run long time. After several minutes dump1090 freezing and CPU load change from 100% to standard 2%.

    So finally a questions:
    1. This new MLAT_FR24_feed program for RPi can be installed on {opkg on Keenetic giga} or it must be special built?
    2. If dump1090 (with pre-installed lib_usb and rtl_usb) overload CPU - this new MLAT_FR24_feed program will use more or less then clear dump1090?

    Thanks for answers, and sorry for a little bit offtopic.
    T-UKKK11

    Comment


    • #32
      Hi vinnyspb/iamnothere

      Cheers for posting your ini file, it seems like the ini file isnt getting created properly when i upgraded, i added the lines regarding mlat and it now works. But a couple of questions if you dont mind.

      is host="127.0.0.1:30002" required?
      is raw="no" required (either yes/no) couldnt find anything to say what it actually does?
      and whats the significance of the procargs, there's not really much of an explanation on the arguments and if/when they are necessary

      Are the mlat setting options visible in the the localhost:8754/settings.html? they aren't in mine!

      Cheers
      Last edited by neebong; 2015-07-04, 02:20. Reason: edit

      Comment


      • #33
        Originally posted by neebong View Post
        Hi vinnyspb/iamnothere

        Cheers for posting your ini file, it seems like the ini file isnt getting created properly when i upgraded, i added the lines regarding mlat and it now works. But a couple of questions if you dont mind.

        is host="127.0.0.1:30002" required?
        is raw="no" required (either yes/no) couldnt find anything to say what it actually does?
        and whats the significance of the procargs, there's not really much of an explanation on the arguments and if/when they are necessary

        Are the mlat setting options visible in the the localhost:8754/settings.html? they aren't in mine!

        Cheers
        I using DVBT dongle , so I disable raw output avoid conflict since I set dump1090 --net , I think the fr24feed-manual.pdf do mentioned .

        yep , localhost:8754 did not show any mlat setting , so I add the line to the fr24feed.ini by my self : P
        T-ZSSS32 F-ZSSS1 force shutdown by local regulation

        Comment


        • #34
          I take it all the raw outputs are for other devices connecting for data.. I dont need that for just feeding to fr24?

          Comment


          • #35
            service fr24feed status
            [ ok ] FR24 Feeder/Decoder Process: running.
            [ ok ] FR24 Stats Timestamp: 2015-07-04 13:57:35.
            [ ok ] FR24 Link: connected [UDP].
            [ ok ] FR24 Radar: T-VHST9.
            [ ok ] FR24 Tracked AC: 11.
            [ ok ] Receiver: connected (486413 MSGS/0 SYNC).
            [ ok ] FR24 MLAT: ok [UDP].
            [ ok ] FR24 MLAT AC seen: 10.
            T-VHST9: http://vhst9.hopto.org/
            (24/7)

            Comment


            • #36
              service fr24feed status is giving me a different output.

              ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
              Loaded: loaded (/etc/init.d/fr24feed)
              Active: active (running) since Sun 2015-07-05 11:53:56 CEST; 1min 8s ago
              Process: 2913 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
              Process: 2953 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
              CGroup: /system.slice/fr24feed.service
              ├─2966 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt -...
              └─2982 /usr/lib/fr24/dump1090 --net --ppm 98 --raw --mlat

              Jul 05 11:53:56 pi fr24feed[2953]: Starting FR24 feeder: fr24feed.
              Jul 05 11:53:56 pi systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.


              pi:8080 is showing the map and pi:8754 shows the tracked aircrafts. So it seems to be running? I don't know whether MLAT is reported though.
              pi:8754 says:

              mlat-mode="UDP"
              mlat-number-seen="3"
              mlat-ok="YES"
              mlat-started="YES"
              mlat-time-last-ping="1436090376"
              mlat-time-last-push="1436090381"
              mlat-time-last-push_count="88"
              mlat-time-last-seen="1436090386"
              mlat-time-stats="1436090388"
              mlat-uplink-stats="0"
              mlat_problem="no-config"

              Comment


              • #37
                I have this setup on my rpi2 now - MLAT is "ok"

                Interested to see and get feedback on this interesting development, perhaps you can share some early results with us?

                We have a lot of traffic in/around EGSC that is not ADS-B so a good network for MLAT could really help here!

                Comment


                • #38
                  I agree. Could be very nice to share some early result and maybe using the Radar box on the plane detail to specify something like "T-MLAT-Dongle".

                  btw.. is this normal?

                  mlat-mode="UDP"
                  mlat-number-seen="13"
                  mlat-ok="YES"
                  mlat-started="YES"
                  mlat-time-last-ping="1436101969"
                  mlat-time-last-push="1436101978"
                  mlat-time-last-push_count="83"
                  mlat-time-last-seen="1436101979"
                  mlat-time-stats="1436101979"
                  mlat-uplink-stats="0"
                  mlat_problem="connection-broken"

                  It says MLAT ok.. and then... mlat_problem connection-broken.

                  And..:

                  [ ok ] FR24 Feeder/Decoder Process: running.
                  [ ok ] FR24 Stats Timestamp: 2015-07-05 13:14:50.
                  [ ok ] FR24 Link: connected [UDP].
                  [ ok ] FR24 Radar: T-LILQ1.
                  [ ok ] FR24 Tracked AC: 11.
                  [ ok ] Receiver: connected (34135126 MSGS/0 SYNC).
                  [ ok ] FR24 MLAT: ok [UDP].
                  [ ok ] FR24 MLAT AC seen: 11.

                  Comment


                  • #39
                    Code:
                    mlat_problem=no-config (or connection-broken)
                    is a bug in the decoder code, but it affects only this monitor file, it doesn't affect real MLAT processing, so please ignore it for now, output will be fixed in the next release. Thanks for the report!

                    MLAT settings are not visible in the web interface so far. Will most likely be implemented after a beta phase. Configuration for now could be done either through --signup wizard or through a configuration file.

                    KKS,
                    If your router can't handle just dump1090, I really doubt it would work with FR24's decoder, because it needs also to run dump1090.

                    Comment


                    • #40
                      iamnothere,

                      Can you please change this line
                      Code:
                      receiver="dvbt-mr”
                      to
                      Code:
                      receiver="dvbt”
                      and restart fr24feed?

                      Comment


                      • #41
                        Thanks for your feedback, vinnyspb.
                        Another question: Is it advantageous if i use LAN instead of WiFi? I imagine wireless has more jitter.

                        Comment


                        • #42
                          Right, preferable connection is ethernet if that's possible.

                          Comment


                          • #43
                            BTW what's the meaning of "[ ok ] Receiver: connected (486413 MSGS/0 SYNC)." copy from "service fr24feed status"
                            and
                            "2015-07-06 22:37:00 | [mlat][i]Stats 316/0" copy from fr24feed.log
                            ?
                            T-VHST9: http://vhst9.hopto.org/
                            (24/7)

                            Comment


                            • #44
                              So I'm a FR24 feeding newbie and this is the status output of my device I activated last night:

                              [ ok ] FR24 Feeder/Decoder Process: running.
                              [ ok ] FR24 Stats Timestamp: 2015-07-06 19:17:14.
                              [ ok ] FR24 Link: connected [UDP].
                              [ ok ] FR24 Radar: T-KPDX12.
                              [ ok ] FR24 Tracked AC: 4.
                              [ ok ] Receiver: connected (27692 MSGS/0 SYNC).
                              [ ok ] FR24 MLAT: ok [UDP].
                              [ ok ] FR24 MLAT AC seen: 3.

                              How can I tell if I'm feeding data OK?

                              Comment


                              • #45
                                Originally posted by vinnyspb View Post
                                iamnothere,

                                Can you please change this line
                                Code:
                                receiver="dvbt-mr”
                                to
                                Code:
                                receiver="dvbt”
                                and restart fr24feed?
                                Okay , change it to dvbt , I can't tell any different : P

                                pi@raspiblack /etc $ service fr24feed status

                                [ ok ] FR24 Feeder/Decoder Process: running.
                                [ ok ] FR24 Stats Timestamp: 2015-07-07 01:51:11.
                                [ ok ] FR24 Link: connected [UDP].
                                [ ok ] FR24 Radar: T-ZSSS32.
                                [ ok ] FR24 Tracked AC: 82.
                                [ ok ] Receiver: connected (25182 MSGS/0 SYNC).
                                [ ok ] FR24 MLAT: ok [UDP].
                                [ ok ] FR24 MLAT AC seen: 81.
                                T-ZSSS32 F-ZSSS1 force shutdown by local regulation

                                Comment

                                Working...
                                X