Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • same here.
    not sure what it is.

    Comment


    • vinnyspb,

      Can you please confirm I can feed Mode-S data for MLAT positions by using the receiver type of "avr-tcp".. If not, what types work besides "dvbt"?

      Thanks
      T-YBBN50 - Kallangur, QLD, Australia

      Comment


      • Now the status show this:

        mlat-mode="UDP"
        mlat-number-seen="0"
        mlat-ok="YES"
        mlat-started="YES"
        mlat-time-last-ping="1451964331"
        mlat-time-last-seen="1451964344"
        mlat-time-stats="1451964346"
        mlat-uplink-stats="0"
        mlat_problem="no-config"

        Can someone help.

        thanks!

        Comment


        • Times appear to be Linux Epoch time http://www.epochconverter.com/

          Mlat_problem appears to be a new addition, and until we hear on its meaning its not for us to diagnose

          As long as the "sudo service fr24feed status" indicates operational with the mlat-ok="YES"
          mlat-started="YES"

          I would suggest that's all we can rely on at this point. most the back end functions are still being worked on and not for general consumption to be concerned with
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • Problems Feeding to FR24 (RPI)

            Hello,

            I followed all the instructions posted in the "New Flightradar24 feeding software for Raspberry Pie" thread and tried to use the MLAT beta as instructed in the "Beta test new Flightradar24 MLAT software for Raspberry Pi" and no data seems to be being fed to FR24, according to my account page.

            I have been trying to get this working for hours to no avail. I am on a RPI 2 with Jessie.

            Any help would be appreciated.

            Thanks,

            Theo

            Comment


            • The jessie appears to be the current problem.

              Runs fine under the pre-tested Wheezy.

              You would have been better asking this in those threads, and copy pasted some of the start text and current settings and output etc.

              I'll move it now.
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • After installing Wheezy, followed the instructions on the "New Flightradar24 feeding software for Raspberry Pie" post, this is my output.

                cs.JPG

                These are my feeder settings:

                cs1.jpg

                Apparently when I CD to /usr/lib/fr24/dump1090 (the COM/DEV/PATH set by the feeder software on install) my PI tells me there is not a directory with that name in that location.

                What am I doing wrong?
                Last edited by Theo Bearman; 2016-01-09, 09:32.

                Comment


                • That is usually a sign of the USB stick being offline, or Dump1090 not starting.

                  Try

                  sudo service fr24feed stop
                  sudo fr24feed start
                  (without the service)

                  And copying us the first bunch of text it produces onscreen.

                  I suspect the USB drivers are still blacklisted or wrong path for Dump1090

                  /edit actually before that. Toggle the raw and BS options to NO/off
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • pastebin.com/raw/kkHjFzg6

                    Comment


                    • And there it is.

                      2016-01-09 10:08:15 | [bs][e]Could not bind socket to *:30003, errno=98
                      Found 1 device(s):
                      0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)

                      Kernel driver is active, or device is claimed by second instance of librtlsdr.
                      In the first case, please either detach or blacklist the kernel module
                      (dvb_usb_rtl28xxu), or enable automatic detaching at compile time.
                      Either Dump1090 is running, or You need to follow the USB blacklist fix.

                      Sudo dump1090 stop
                      (then re-run fr24feed)

                      or

                      Luckily a solution is pretty straightforward. In /etc/modprobe.d create a new file with sudo, named no-rtl.conf (the actual name is not important, but the .conf is).

                      cd /etc/modprobe.d
                      sudo nano no-rtl.conf
                      Add the following lines to the new file:

                      blacklist dvb_usb_rtl28xxu
                      blacklist rtl2832
                      blacklist rtl2830
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • Working. Thank you so much!

                        Comment


                        • Can anyone tell me if I can use my PiZero with this?

                          Thanks.
                          - Tony Sutton

                          Comment


                          • Hi, I am having problem with fr24feed failing.

                            pi@raspberrypi ~ $ sudo service fr24feed status
                            [FAIL] FR24 Feeder/Decoder Process ... failed!


                            for unknown reason. After restarting of the service, it works for some time and fails again.
                            I have no clue why.
                            Is there some chance to WatchDog the service please?

                            Comment


                            • Originally posted by RoSi View Post
                              Hi, I am having problem with fr24feed failing.

                              pi@raspberrypi ~ $ sudo service fr24feed status
                              [FAIL] FR24 Feeder/Decoder Process ... failed!


                              for unknown reason. After restarting of the service, it works for some time and fails again.
                              I have no clue why.
                              Is there some chance to WatchDog the service please?
                              Either run without the service
                              Sudo fr24feed start

                              And monitor the output when it fails. Or endable the logfile in the configuration http://_iphere_:8754 and paste the bit where it fails

                              Usual cause is USB shutting down or not enough power.
                              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                              Comment


                              • Originally posted by Oblivian View Post
                                _iphere_:8754
                                Good. I didn't know about these settings.
                                I am having log enabled Keep upto 48h, rotate 24h, but lg file location is empty and showing disabled.
                                Will set it to /home/pi/fr24.log and see.
                                Many thanks!

                                Comment

                                Working...
                                X