Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by bhaal View Post
    Can anyone tell me if the current version of fr24feed is taking data used for MLAT from port 30002/30005 of dump1090? Or does it still only support MLAT when fr24feed is starting dump1090 itself and reading from dump1090's STDOUT? As soon as I stopped fr24feed from being responsible for running dump1090 my load dropped off and my tracks per second rose dramatically... If fr24feed isn't getting MLAT data from 30002 or one of the other formats, when will it?
    I believe its 30002, as when running alongside FA you can independently start a separate version of D1090 first and both appear to tap in. As FR24 would normally be configured to run from AVRTCP
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • Originally posted by Oblivian View Post
      I believe its 30002, as when running alongside FA you can independently start a separate version of D1090 first and both appear to tap in. As FR24 would normally be configured to run from AVRTCP
      So either I don't understand what I am reading or there are not enough fr24feeds running mlat... But I get this:

      2015-12-29 18:39:57 | [mlat][i]Pinging the server
      2015-12-29 18:39:57 | [mlat][i]Stats 0/0

      All the time. And I *know* there are mlat aircraft up because I am seeing them on my dump1090/VRA thanks to FA mlat feedback... Really wish fr24 gave better feedback and stats, and heck even gave mlat feedback back to dump1090! Why don't they?
      T-YBBN50 - Kallangur, QLD, Australia

      Comment


      • I see that on startup, but as I have mine running as service on boot it reports differently when you use sudo service fr24feed status

        Just need to wait for something to come past my secondary test antenna, but fairly sure it changes.

        $ sudo service fr24feed status
        [ ok ] FR24 Feeder/Decoder Process: running.
        [ ok ] FR24 Stats Timestamp: 2015-12-29 08:47:12.
        [ ok ] FR24 Link: connected [UDP].
        [ ok ] FR24 Radar: T-NZCH26.
        [ ok ] FR24 Tracked AC:.
        [ ok ] Receiver: connected (2 MSGS/0 SYNC).
        [ ok ] FR24 MLAT: ok [UDP].
        [ ok ] FR24 MLAT AC seen: 0.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • ^^ thats with AVR(TCP) and port below as localhost:30002 as my dump1090 is independent

          /edit not sure what it seen as my good antenna hasn't. But:

          ok ] FR24 Feeder/Decoder Process: running.
          [ ok ] FR24 Stats Timestamp: 2015-12-29 08:58:16.
          [ ok ] FR24 Link: connected [UDP].
          [ ok ] FR24 Radar: T-NZCH26.
          [ ok ] FR24 Tracked AC: 1.
          [ ok ] Receiver: connected (1193 MSGS/0 SYNC).
          [ ok ] FR24 MLAT: ok [UDP].
          [ ok ] FR24 MLAT AC seen: 1.
          Last edited by Oblivian; 2015-12-29, 08:59.
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • This still makes no sense though, and never has:

            [ ok ] FR24 Feeder/Decoder Process: running.
            [ ok ] FR24 Stats Timestamp: 2015-12-29 09:04:14.
            [ ok ] FR24 Link: connected [UDP].
            [ ok ] FR24 Radar: T-YBBN50.
            [ ok ] FR24 Tracked AC: 19.
            [ ok ] Receiver: connected (1944017 MSGS/0 SYNC).
            [ ok ] FR24 MLAT: ok [UDP].
            [ ok ] FR24 MLAT AC seen: 17.


            I am tracking 19, 4 of which are MLAT (via FA)... Even if FR24 was getting MLAT positiions for 2, why does it say 17???
            T-YBBN50 - Kallangur, QLD, Australia

            Comment


            • I think its incremental since last start
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • I think it's not:

                root@radar:/etc# service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-12-29 08:51:04.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-YBBN50.
                [ ok ] FR24 Tracked AC: 24.
                [ ok ] Receiver: connected (1843163 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 22.
                root@radar:/etc# service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-12-29 09:04:14.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-YBBN50.
                [ ok ] FR24 Tracked AC: 19.
                [ ok ] Receiver: connected (1944017 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 17.
                root@radar:/etc# service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-12-29 09:05:14.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-YBBN50.
                [ ok ] FR24 Tracked AC: 18.
                [ ok ] Receiver: connected (1950137 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 17.
                root@radar:/etc# service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-12-29 09:22:18.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-YBBN50.
                [ ok ] FR24 Tracked AC: 22.
                [ ok ] Receiver: connected (2095293 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 21.
                T-YBBN50 - Kallangur, QLD, Australia

                Comment


                • There goes that theory then.

                  I don't get enough contacts at once on the Pi (its just a test bed) to confirm but it may well consider full adsb to be MLAT capable too. As it does use those as reference points. That would only leave a couple its either not got contact with at the time or have some other unexplained reason
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • Seems to be a fault with the config window Vs open ports

                    SBS Feed 10001: actually opens 20072 for relay out.
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • fr24feed status --> confused

                      Hi All,

                      I'm trying to setup a rpi with a realtek DVB-T stick.
                      installed the latest fr24feed from the beta repo.

                      Lots of pages on this forum are filled with status info, gathered with the 'sudo service fr24feed status' command.

                      When I enter this command, I see different data:

                      Code:
                      pi@raspberrypi:~ $ sudo service fr24feed status
                      ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
                         Loaded: loaded (/etc/init.d/fr24feed)
                         Active: active (running) since Thu 2015-12-31 16:31:14 CET; 21s ago
                        Process: 686 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
                        Process: 712 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
                         CGroup: /system.slice/fr24feed.service
                                 ├─725 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=1
                                 └─748 /usr/lib/fr24/dump1090 --net --net-http-port 8080 --raw --mlat
                      
                      Dec 31 16:31:14 raspberrypi fr24feed[712]: Starting FR24 feeder: fr24feed.
                      Dec 31 16:31:14 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
                      pi@raspberrypi:~ $
                      I'm wondering how to configure MLAT, no signs of it are found in the logs.....

                      can someone put me in the right direction ?

                      tnx !

                      Comment


                      • Originally posted by Cornmeister View Post
                        Hi All,

                        I'm trying to setup a rpi with a realtek DVB-T stick.
                        installed the latest fr24feed from the beta repo.

                        Lots of pages on this forum are filled with status info, gathered with the 'sudo service fr24feed status' command.

                        When I enter this command, I see different data:

                        Code:
                        pi@raspberrypi:~ $ sudo service fr24feed status
                        ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
                           Loaded: loaded (/etc/init.d/fr24feed)
                           Active: active (running) since Thu 2015-12-31 16:31:14 CET; 21s ago
                          Process: 686 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
                          Process: 712 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
                           CGroup: /system.slice/fr24feed.service
                                   ├─725 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=1
                                   └─748 /usr/lib/fr24/dump1090 --net --net-http-port 8080 --raw --mlat
                        
                        Dec 31 16:31:14 raspberrypi fr24feed[712]: Starting FR24 feeder: fr24feed.
                        Dec 31 16:31:14 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
                        pi@raspberrypi:~ $
                        I'm wondering how to configure MLAT, no signs of it are found in the logs.....

                        can someone put me in the right direction ?

                        tnx !
                        Use the web config http://iptoyourpi:8754 to confirm running and check MLAT option enabled (the --mlat and --raw indicates so) looks like that status request is only then starting it - as if you installed but did not start it correctly initially
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • MLAT works on Raspbian Jessie (RaspberryPi 2B)?

                          After updating, in log I see this:
                          2016-01-02 14:57:37 | [feed][n]connecting
                          2016-01-02 14:57:37 | [stats][i]Stats thread started
                          2016-01-02 14:57:38 | [mlat][i]MLAT configuration received, service ENABLED
                          2016-01-02 14:57:38 | [mlat][i]Starting MLAT with preconfigured position: XXXXXXX
                          2016-01-02 14:57:38 | [mlat][i]MLAT bandwidth reduction active, level 1
                          2016-01-02 14:57:38 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
                          2016-01-02 14:57:43 | [mlat][i]Registering MLAT station
                          2016-01-02 14:57:43 | [mlat][i]Registering MLAT station: SUCCESS
                          2016-01-02 14:57:52 | [mlat][i]Pinging the server
                          2016-01-02 14:57:52 | [mlat][i]Stats 0/0
                          2016-01-02 14:57:58 | [feed][n]connected via TCP (fd 13)
                          2016-01-02 14:57:58 | [feed][n]switching to UDP
                          2016-01-02 14:57:58 | [feed][n]working
                          2016-01-02 14:57:58 | [feed][i]sent 1 AC in 1 packet
                          2016-01-02 14:58:03 | [feed][i]sent 9 AC in 1 packet
                          2016-01-02 14:58:08 | [feed][i]sent 9 AC in 1 packet
                          2016-01-02 14:58:12 | [mlat][i]Pinging the server
                          2016-01-02 14:58:12 | [mlat][i]Stats 0/0
                          "sudo service fr24feed status":

                          ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
                          Loaded: loaded (/etc/init.d/fr24feed)
                          Active: active (running) since Thu 1970-01-01 03:00:10 MSK; 46 years 0 months ago
                          Process: 525 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
                          CGroup: /system.slice/fr24feed.service
                          ├─ 627 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=1
                          └─1538 /usr/lib/fr24/dump1090 --net --net-http-port 8081 --aggressive --enable-agc --raw --mlat
                          Jan 01 03:00:08 raspberrypi fr24feed[525]: Starting FR24 feeder: fr24feed.
                          Jan 01 03:00:10 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
                          T-UKCW1 / T-UKCK1 online since 2014.05.31
                          Antenna: 18 Elements Vertical Collinear / Reciver: RTL-SDR (R820T2) + RaspberryPi 2B (MLAT enabled)
                          Range / Area: T-UKCW1 - up to 286 nm (530 km) - reception range diagram / T-UKCK1 - up to 229 nm (424 km) - reception range diagram

                          Comment


                          • Hi,

                            I am getting this problem:

                            mlat-mode="UDP"
                            mlat-number-seen="20"
                            mlat-ok="YES"
                            mlat-started="YES"
                            mlat-time-last-ping="1451742605"
                            mlat-time-last-seen="1451742617"
                            mlat-time-stats="1451742620"
                            mlat-uplink-stats="0"
                            mlat_problem="connection-broken"

                            Comment


                            • looks ok.
                              mlat-ok="YES"

                              Comment


                              • Originally posted by Cornmeister View Post
                                looks ok.
                                mlat-ok="YES"
                                Thanks, gets me confuse the mlat_problem="connection-broken" thou.

                                Comment

                                Working...
                                X