Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Up and running!

    FR24 Feeder/Decoder Process: running.
    FR24 Stats Timestamp: 2015-07-01 19:55:37.
    FR24 Link: connected [UDP].
    FR24 Radar: T-ENCN5.
    FR24 Tracked AC: 1.
    Receiver: connected (61 MSGS/0 SYNC).
    FR24 MLAT: ok [UDP].
    FR24 MLAT AC seen: 1.

    Comment


    • #17
      Validating email/location information...ERROR

      There has been another feed (EDDN41) registered under this email address!
      If you have more than one receiver please contact us at support@flightradar24.com.

      If you have lost your sharing key please use the retrieval form at:
      http://feed.flightradar24.com/forgotten_key.php

      Would you like to try again?
      I`ll try again...

      Edit:

      Ok, I used my old key and it went on:

      I used autoconfig and I got a new radar id.

      And I got one error msg:

      Saving settings to /etc/fr24feed.ini...ERROR
      pi@fr24rasppi ~ $ sudo service fr24feed start
      [ ok ] Starting FR24 feeder: fr24feed.
      But it seems to be feeding. :-)

      We will see.


      Edit2:

      I had to do a
      sudo fr24feed --signup
      And a manual config instead of autoconfig.


      But then:

      It is running!
      sudo service fr24feed status
      [ ok ] FR24 Feeder/Decoder Process: running.
      [ ok ] FR24 Stats Timestamp: 2015-07-01 20:19:19.
      [ ok ] FR24 Link: connected [UDP].
      [ ok ] FR24 Radar: T-EDQD17.
      [ ok ] FR24 Tracked AC: 44.
      [ ok ] Receiver: connected (17310 MSGS/0 SYNC).
      [ ok ] FR24 MLAT: ok [UDP].
      [ ok ] FR24 MLAT AC seen: 44.
      Last edited by StDt; 2015-07-01, 20:24. Reason: More info available

      Comment


      • #18
        I follow the instruction and input my sharing key.
        Then, assigned new radar code.
        So, could you re-assign previous code again? because love previous radar code.


        After installation, please run the sign-up wizard even if you already have the sharing key:
        Code:
        $ fr24feed --signup

        Comment


        • #19
          Originally posted by vinnyspb View Post
          There is NTP synchronization. The problem is that's it's not enough for MLAT. When we speak in terms of speed of light, 100 microseconds error gives 30km difference.
          Would something like this help to improve time accuracy / MLAT though it is only down to microseconds accuracy when installed on the rpi 2? It is a GPS expansion board for rpi2 using Ublox MAX-M8Q.


          http://ava.upuaut.net/store/index.ph...product_id=117

          Shouldn't use much processing power and the rpi 2 shouldn't have problem running it with the decoding software.

          Comment


          • #20
            Installed and working here also:

            pi@pi ~ $ sudo service fr24feed status
            FR24 Feeder/Decoder Process: running.
            FR24 Stats Timestamp: 2015-07-02 04:51:19.
            FR24 Link: connected [UDP].
            FR24 Radar: T-YMEN20.
            FR24 Tracked AC: 13.
            Receiver: connected (17818 MSGS/0 SYNC).
            FR24 MLAT: ok [UDP].
            FR24 MLAT AC seen: 14.

            Comment


            • #21
              Uh Oh...

              FR24 Feeder/Decoder Process ... failed!

              After installing beta version and re-doing config

              :-(

              Any ideas?

              Comment


              • #22
                Ok.. re-did --signup.. Its verified my key but now im getting

                pi@neePi ~ $ sudo service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-07-02 06:14:57.
                [FAIL] FR24 Link: connecting ... failed!
                [ ok ] Receiver: connected (80 MSGS/0 SYNC).
                [FAIL] FR24 MLAT: not running ... failed!

                On looking at the website:8754 it is receiving data (i can see tracked aircraft).. but not transmitting it i think...

                Edit x 3 .. Changed back to the default DVBT stick (default) and now it connects.. Still failing on the MLAT tho..
                Last edited by neebong; 2015-07-02, 06:25. Reason: update info

                Comment


                • #23
                  iamnothere, neebong,

                  armv7l should work fine on B+, we tested that.
                  The problem you have may be related to a still running previous instance of fr24feed and/or dump1090.

                  Please try to check it:
                  Code:
                  $ sudo service fr24feed stop
                  $ pgrep -l fr24feed
                  $ pgrep -l dump1090
                  If anything of it is still running after you issue stop command, please try to kill it explicitly (PID will be given by pgrep output):
                  Code:
                  $ sudo kill -9 PID
                  And then restart fr24feed:
                  Code:
                  $ sudo service fr24feed start
                  If it still doesn't help, please enable logging through signup wizard and post the output here. You will be able to specify the path for logs, log name will be fr24feed.log.

                  Comment


                  • #24
                    StDt,
                    iPhone GPS would be just fine for that.

                    This error:
                    Saving settings to /etc/fr24feed.ini...ERROR
                    is most likely related to incorrect file permissions. pi user should normally be allowed to read/write to /etc/fr24feed.ini
                    Last edited by vinnyspb; 2015-07-02, 06:51.

                    Comment


                    • #25
                      pi@raspiblack ~ $ service fr24feed status
                      [ ok ] FR24 Feeder/Decoder Process: running.
                      [ ok ] FR24 Stats Timestamp: 2015-07-02 09:38:37.
                      [ ok ] FR24 Link: connected [UDP].
                      [ ok ] FR24 Radar: T-ZSSS32.
                      [ ok ] FR24 Tracked AC: 65.
                      [ ok ] Receiver: connected (17571 MSGS/0 SYNC).
                      [ ok ] FR24 MLAT: ok [UDP].
                      [ ok ] FR24 MLAT AC seen: 62.
                      pi@raspiblack ~ $ ntpq -p
                      remote refid st t when poll reach delay offset jitter
                      ================================================== ============================
                      +SHM(0) .GPS. 0 l 7 16 377 0.000 -15.876 5.839
                      192.168.123.255 .XFAC. 16 u - 64 0 0.000 0.000 0.001
                      +li763-114.membe 145.174.168.164 3 u 1 128 357 44.533 -56.281 9.169
                      *60-56-214-78f2. .GPS. 1 u 135 128 376 60.181 -49.480 13.513
                      pi@raspiblack ~ $

                      Oh Yeah ~
                      Last edited by iamnothere; 2015-07-02, 09:40. Reason: progress update
                      T-ZSSS32 F-ZSSS1 force shutdown by local regulation

                      Comment


                      • #26
                        Hi. Still nothing on the MLAT bit, still failing, ive tried a few config changes.
                        I cant post a link for my log since ive not posted 3 times.. so my next post will include a log file!

                        Comment


                        • #27
                          lol. and now its 4 posts

                          Comment


                          • #28
                            Oh.. come on :-p

                            Comment


                            • #29
                              Ok.. Finally here's my log

                              http://www.neebong.co.uk/files/fr24feed.log

                              Hope someone can help!

                              Cheers

                              Comment


                              • #30
                                Originally posted by neebong View Post
                                Ok.. Finally here's my log

                                http://www.neebong.co.uk/files/fr24feed.log

                                Hope someone can help!

                                Cheers

                                This is my fr24feed.ini , hope it help .

                                receiver="dvbt-mr”

                                fr24key="your fr24 sharing key"

                                path="/usr/lib/fr24/dump1090"

                                host="127.0.0.1:30002"

                                bs="no"

                                raw="no"

                                logmode="0"

                                procargs="--net --aggressive --ppm 1"

                                windowmode="0"

                                mpx="no"

                                mlat="yes"

                                mlat-without-gps=“yes"
                                T-ZSSS32 F-ZSSS1 force shutdown by local regulation

                                Comment

                                Working...
                                X