Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • YSWG, thanks, that was missed from the web interface. Fixed now in version 1.0.14-10. You can select "dvbt" option and use those dump1090 forks that you want. We need timestamps from dump1090, so "--mlat" option must be supported by these forks if you want to contribute to MLAT.

    Comment


    • Ok, have added "--mlat". Also changed to dump1090-mutability and also updated to FR24Feed 1.0.14-10, seems to be working ADSB but no ModeS only ac yet.
      F-YSWG1 and T-YSWG2

      Comment


      • Originally posted by vinnyspb View Post
        Astrofreak85, Berlin Bob,

        May I ask you to enable FR24Feeder logs and send it here?
        Status: Upgraded to today's build (fr24feed_1.0.14-10), reran fr24feed --signup, all working again.

        Comment


        • 1.0.14-10.... somebodyy??

          [ ok ] FR24 Feeder/Decoder Process: running.
          [ ok ] FR24 Stats Timestamp: 2015-08-27 17:13:37.
          [ ok ] FR24 Link: connected [UDP].
          [ ok ] FR24 Radar: T-EETU1.
          [ ok ] FR24 Tracked AC:.
          [FAIL] Receiver: down ... failed!
          [ ok ] FR24 MLAT: ok [UDP].
          [ ok ] FR24 MLAT AC seen: 0.
          Last edited by Tviki; 2015-08-27, 17:36.
          F-EETU1, F-EETU5, T-EETU1

          Comment


          • Originally posted by Tviki View Post
            1.0.14-10.... somebodyy??
            Me too.
            Bundled dump1090 dies:
            Code:
            /usr/lib/fr24/dump1090 --net --net-http-port 8080 --raw --mlat
            /usr/lib/fr24/dump1090: error while loading shared libraries: librtlsdr.so.0: cannot open shared object file: No such file or directory
            Installed dump1090-mutability.
            Changed /usr/lib/fr24/dump1090 to /usr/bin/dump1090-mutability in /etc/fr24feed.ini
            Now works!

            Edit
            syslog filled with
            Code:
             /usr/sbin/cron[2141]: (*system*fr24feed_updater) WRONG FILE OWNER (/etc/cron.d/fr24feed_updater)
            cowned to root, now updater must work ;-)
            Maybe other owner problems with dump1090?
            Last edited by 4l4R1; 2015-08-27, 18:24.
            T-EETN19

            Comment


            • Not working for me ((
              F-EETU1, F-EETU5, T-EETU1

              Comment


              • Thanks for the feedback. dump1090 that is bundled didn't include paths to librtlsdr.so that is also bundled in the package. This is fixed in a new version 1.0.14-11 and also cron file permissions fixed.

                Comment


                • Thanks for the update, back online without a problem after the update

                  on6bvk
                  T-EBOS18 & T-EBOS32

                  Comment


                  • back online
                    T-EDDC46

                    Comment


                    • Originally posted by on6bvk View Post
                      Thanks for the update, back online without a problem after the update

                      on6bvk
                      Originally posted by Astrofreak85 View Post
                      back online
                      I am sorry but how do you update from version 14-7 to 14-11? sudo apt-get says fr24feed is newest version but I checked it is still 14-7.

                      Comment


                      • sudo apt-get update
                        sudo apt-get upgrade
                        T-EETN19

                        Comment


                        • Originally posted by 4l4R1 View Post
                          sudo apt-get update
                          sudo apt-get upgrade
                          noted with thanks. upgraded and so far so good.

                          Comment


                          • Originally posted by North Borneo Radar View Post
                            I am sorry but how do you update from version 14-7 to 14-11? sudo apt-get says fr24feed is newest version but I checked it is still 14-7.
                            Also make sure you have "raspberrypi-beta" added to your /etc/apt/sources.list file. The complete line in there for the FR24 repos should be:

                            Code:
                            deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable raspberrypi-beta
                            Then do this...
                            Originally posted by 4l4R1 View Post
                            sudo apt-get update
                            sudo apt-get upgrade
                            T-EGJB6 here in Guernsey also upgraded and back online - looking good.

                            Comment


                            • for me auto-update still not working:

                              Code:
                              The following packages will be upgraded:
                                fr24feed
                              1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
                              Need to get 424 kB of archives.
                              After this operation, 0 B of additional disk space will be used.
                              Get:1   link removed (can't post)
                              debconf: unable to initialize frontend: Dialog
                              debconf: (TERM is not set, so the dialog frontend is not usable.)
                              debconf: falling back to frontend: Readline
                              debconf: unable to initialize frontend: Readline
                              debconf: (This frontend requires a controlling tty.)
                              debconf: falling back to frontend: Teletype
                              dpkg-preconfigure: unable to re-open stdin:
                              Fetched 424 kB in 1s (364 kB/s)
                              dpkg: warning: 'ldconfig' not found in PATH or not executable
                              dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
                              dpkg: error: 2 expected programs not found in PATH or not executable
                              Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
                              E: Sub-process /usr/bin/dpkg returned an error code (2)
                              /usr/lib/fr24/fr24feed_updater.sh: 28: /usr/lib/fr24/fr24feed_updater.sh: service: not found
                              T-EETN19

                              Comment


                              • Updated but it didn't auto start, had to be manually started.
                                F-YSWG1 and T-YSWG2

                                Comment

                                Working...
                                X