Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by zahidulhasan View Post
    Hi,

    Can you tell me how can i change Lat-long from existing fr24feed ?
    Are you trying to set the location for your receiver ?

    The only place I know it's set is the process arguments for dump1090 in /etc/fr24feed.ini

    Edit that file and you should see it.. fr24 get the settings as reported to fr24feed from dump1090 (or it pulls it from the argument string from the config file)
    T-YBBN50 - Kallangur, QLD, Australia

    Comment


    • Hi,

      Whats wrong????

      Found 1 device(s):
      0: L]�vP��v, , SN: @� (currently selected)
      usb_open error -3
      Please fix the device permissions, e.g. by installing the udev rules file rtl-sdr.rules
      Error opening the RTLSDR device: Permission denied
      2015-08-24 14:27:03 | [reader][i][0]Connection terminated
      2015-08-24 14:27:03 | [main][i]Terminating child process 3534 with SIGETERM
      F-EETU1, F-EETU5, T-EETU1

      Comment


      • I planned to place the feeder in one place, according to that location, i put the lat-long. Now plan changed, need to place in another position. in my fr24feed.ini file, i did not say the option to change the lat-long. At last i re install the frfeed sine up. That works.

        Thanks,
        Zahidul Hasan.

        Comment


        • Hi guys,

          We're pleased to announce new beta version of the feeder software (1.0.14-9) that is no longer bound to our own dump1090 build.
          Included dump1090 is now Malcolm Robb's fork and I would kindly ask you to also test how it works with other forks that you may wish to use and provide a feedback.

          In order to update the software just make sure that you are subscribed to beta repository in APT config and just run: sudo apt-get install fr24feed

          Thanks,
          Flightradar24 team

          Comment


          • Just upgraded from the pre MLAT FR24Feeder to the latest (following everything on page one) but had an issue with the .ini file

            Code:
            To start sending data now please execute:
            sudo service fr24feed start
            
            Saving settings to /etc/fr24feed.ini...ERROR
            So added the old settings from the old .ini file (with the MLAT settings remaining). Seems to be working now though.

            Code:
            pi@raspberrypi ~ $ sudo service fr24feed status
            [ ok ] FR24 Feeder/Decoder Process: running.
            [ ok ] FR24 Stats Timestamp: 2015-08-26 14:39:50.
            [ ok ] FR24 Link: connected [UDP].
            [ ok ] FR24 Radar: T-YSWG2.
            [ ok ] FR24 Tracked AC: 1.
            [ ok ] Receiver: connected (135 MSGS/0 SYNC).
            [ ok ] FR24 MLAT: ok [UDP].
            [ ok ] FR24 MLAT AC seen: 1.
            F-YSWG1 and T-YSWG2

            Comment


            • Originally posted by vinnyspb View Post
              We're pleased to announce new beta version of the feeder software (1.0.14-9) that is no longer bound to our own dump1090 build.
              Included dump1090 is now Malcolm Robb's fork and I would kindly ask you to also test how it works with other forks that you may wish to use and provide a feedback.
              Well done ! Thank you so much
              Regards,
              T-EDDE7

              Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
              Banana Pi | Mystique SDR R820T2 | stock Antenna

              Comment


              • since the update I get a Receiver down massage.... :-(

                pi@rasp-1090 ~ $ sudo service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-08-26 19:13:59.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-EDDC46.
                [ ok ] FR24 Tracked AC:.
                [FAIL] Receiver: down ... failed!
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 0.
                dmesg says:
                [ 228.185476] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
                [ 228.297498] usb 1-1.5: New USB device found, idVendor=0bda, idProduct=2838
                [ 228.297525] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
                [ 228.297542] usb 1-1.5: Product: RTL2838UHIDIR
                [ 228.297558] usb 1-1.5: Manufacturer: Realtek
                [ 228.297574] usb 1-1.5: SerialNumber: 00000001
                [ 228.329095] usb 1-1.5: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
                [ 228.383697] usb 1-1.5: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
                [ 228.383783] DVB: registering new adapter (Realtek RTL2832U reference design)
                [ 228.399592] i2c i2c-3: Added multiplexed i2c bus 4
                [ 228.399629] rtl2832 3-0010: Realtek RTL2832 successfully attached
                [ 228.399690] usb 1-1.5: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
                [ 228.400081] r820t 4-001a: creating new instance
                [ 228.412312] r820t 4-001a: Rafael Micro r820t successfully identified
                [ 228.430864] Registered IR keymap rc-empty
                [ 228.432250] input: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/rc/rc0/input2
                [ 228.433211] rc0: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/rc/rc0
                [ 228.435576] rc rc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
                [ 228.436889] input: MCE IR Keyboard/Mouse (dvb_usb_rtl28xxu) as /devices/virtual/input/input3
                [ 228.438140] usb 1-1.5: dvb_usb_v2: schedule remote query interval to 200 msecs
                [ 228.446875] usb 1-1.5: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected
                [ 228.447292] usbcore: registered new interface driver dvb_usb_rtl28xxu
                T-EDDC46

                Comment


                • Stop the Software and disconnect your stick for a Minute or two. Then reconnect it,wait a minute and Start the feeder again.

                  Viel Erfolg und Gre nach Dresden
                  Regards,
                  T-EDDE7

                  Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                  Banana Pi | Mystique SDR R820T2 | stock Antenna

                  Comment


                  • strange thing is, when I restart the feeder service, after I unpluged and pluged in the RTL, I get this in dmesg:

                    [ 1726.472383] usbcore: deregistering interface driver dvb_usb_rtl28xxu
                    [ 1726.683226] r820t 4-001a: destroying instance
                    [ 1726.684645] usb 1-1.4: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully deinitialized and disconnected
                    T-EDDC46

                    Comment


                    • Try to Reboot your Pi If you can
                      Regards,
                      T-EDDE7

                      Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                      Banana Pi | Mystique SDR R820T2 | stock Antenna

                      Comment


                      • this doesn't help, then the RTL-stick is initialiesd ant startup and get disconected shortly after...
                        how can I revert to the old version?
                        T-EDDC46

                        Comment


                        • Originally posted by Astrofreak85 View Post
                          this doesn't help, then the RTL-stick is initialiesd ant startup and get disconected shortly after...
                          how can I revert to the old version?
                          I have the same problem and same dmesg output as Astrofreak85 with today's version.

                          Comment


                          • Astrofreak85, Berlin Bob,

                            May I ask you to enable FR24Feeder logs and send it here?
                            Also do you use dump1090 bundled (MalcolmRobb's) or some other? Does it work with other dump1090 builds?

                            Comment


                            • I can send those logs tonight. I did get it to work last night by building Malcolm Robb's dump0190 and the RTL drivers from Github (previously only had the feeder software bundle which was working), but after more fiddling it has stopped working again.


                              Sent from my iPhone using Tapatalk

                              Comment


                              • Everything is working for me but looking the FR24Feed page, I've noticed that the "Receiver:" setting note states

                                Code:
                                Note: MLAT is now supported only with DVBT Stick setting (includes Malcolm Robb improvements)
                                I'm currently using ModeS Beast (TCP) [using the FA version of dump1090], should I change it to DVBT Stick (default) or DVBT Stick (Malcolm Robb)?

                                Screen Shot.png
                                Share key has been edited out.
                                Last edited by YSWG; 2015-08-27, 10:26.
                                F-YSWG1 and T-YSWG2

                                Comment

                                Working...
                                X