Announcement

Collapse
No announcement yet.

Archived - Beta test MLAT software for Raspberry Pi

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [FAIL] FR24 Feeder/Decoder Process ... failed!

    Saving settings to /etc/fr24feed.ini...ERROR
    Last edited by vicbeo; 2015-07-17, 22:29.
    Feeder: T-SCTI7

    Comment


    • I currently feed both FA and FR24 from the one Pi; I just noticed vinnyspb mention is a fork of Malcom Robb's dump1090 fork in regards to dump1090....

      I recieved an email from FA this week in regards to their MLAT setup, part of which said Aircraft being tracked with MLAT will be in blue on your local web interface hinting at possibly they are running a specific fork of dump1090 and the local html page.

      Has any one got a dual setup running succesgully yet with the FR24 beta and FA's new setup?

      Looks like I may have to buy another Pi and dongle to do some testing

      Andrew
      T-YSBK22

      Comment


      • I've been using this double setup (FA & FR24) on one RPi2 since march and all was well up to today when I updated fr24feed to 1.0.14-5. Now I've got no feed to FR24.

        pi@raspberrypi2 ~ $ sudo service fr24feed status
        ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
        Loaded: loaded (/etc/init.d/fr24feed)
        Active: active (exited) since Fri 2015-07-17 23:25:23 UTC; 9min ago
        Process: 2211 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
        Process: 2221 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)

        Jul 17 23:25:23 raspberrypi2 fr24feed[2221]: Starting FR24 feeder: fr24feed.
        Jul 17 23:25:23 raspberrypi2 systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
        FA works fine (PiAware pack), but fr24feed is not. Tried to remove it and install again, run wizard one more time and still nothing. :8754 webpage is not working either.

        EDIT:

        Ok, after 2 reboots it looks like this:

        pi@raspberrypi2 ~ $ sudo service fr24feed status
        ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
        Loaded: loaded (/etc/init.d/fr24feed)
        Active: active (running) since Fri 2015-07-17 23:50:27 UTC; 16min ago
        Process: 3291 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
        Process: 3303 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
        CGroup: /system.slice/fr24feed.service
        └─3313 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet

        Jul 17 23:50:27 raspberrypi2 fr24feed[3303]: Starting FR24 feeder: fr24feed.
        Jul 17 23:50:27 raspberrypi2 systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
        So changed from Active (Exiting) to (running). But still not online on feed page and no config page.

        Here is another one:

        pi@raspberrypi2 ~ $ sudo service fr24feed status
        ● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
        Loaded: loaded (/etc/init.d/fr24feed)
        Active: active (running) since Sat 2015-07-18 01:46:42 UTC; 12min ago
        Process: 524 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
        CGroup: /system.slice/fr24feed.service
        └─622 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet

        Jul 18 01:46:41 raspberrypi2 systemd[1]: Starting LSB: Flightradar24 Decoder & Feeder...
        Jul 18 01:46:41 raspberrypi2 fr24feed[524]: Starting FR24 feeder: fr24feed.
        Jul 18 01:46:42 raspberrypi2 systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.
        But still no success.
        Last edited by Gt4kill3r; 2015-07-18, 02:03. Reason: Added info

        Comment


        • Originally posted by vinnyspb View Post
          Does the problem persist constantly? Do you see something like this afterwards?
          Code:
          2015-07-17 13:17:22 | [time][i]Synchronizing time via NTP
          2015-07-17 13:17:26 | [time][i]Time synchronized correctly, offset +1684.0945 seconds
          Hi Vinny,

          I was about to write a bit about how I couldn't understand why it was happening... And then.. I thought of something.. .oO What if dhcp is assigning ntp servers Oo. And "ntpdc -c peers" confirmed this, and the server was really really slow.. It's still not syncing very quickly, a lot longer than the 10mins it stays sync'd for before it wants to check again... When it does sync there is no offset though which is good...

          Regards,
          T-YBBN50
          T-YBBN50 - Kallangur, QLD, Australia

          Comment


          • Originally posted by Gt4kill3r View Post
            I've been using this double setup (FA & FR24) on one RPi2 since march and all was well up to today when I updated fr24feed to 1.0.14-5. Now I've got no feed to FR24.



            FA works fine (PiAware pack), but fr24feed is not. Tried to remove it and install again, run wizard one more time and still nothing. :8754 webpage is not working either.

            EDIT:

            Ok, after 2 reboots it looks like this:



            So changed from Active (Exiting) to (running). But still not online on feed page and no config page.

            Here is another one:



            But still no success.
            I hope I am not breaking a cardinal rule by talking about other feeders

            You have to let the fr24feeder and it's version of dump1090 start first. Then the FA feeder can connect to the same dump1090, but you need to configure FA's MLAT beta so it doesn't try and feed MLAT positions back to dump1090 if you go through their forum post for their Pi MLAT beta test it will tell you how to do this (it's in relation to viewing MLAT data in VRS without sending it into dump1090 for display on it's own webpage)...
            T-YBBN50 - Kallangur, QLD, Australia

            Comment


            • Does this MLAT version of fr24feed expose the MLAT positions in a beast/basestation feed? so they can be plotted in VRS?
              T-YBBN50 - Kallangur, QLD, Australia

              Comment


              • Upgrade to 1.0.14-5 breaks my FR24 and FA. Used to run smoothly with dump1090 mutability. Have to scratch my head finding way to make them works again.

                Kanok


                Sent from my iPad using Tapatalk
                T-VTBD1 : RadarBox 3km North of VTBD
                T-VTBD2 : RPi MLAT 300m South of VTBD

                Comment


                • Originally posted by bhaal View Post
                  I hope I am not breaking a cardinal rule by talking about other feeders

                  You have to let the fr24feeder and it's version of dump1090 start first. Then the FA feeder can connect to the same dump1090, but you need to configure FA's MLAT beta so it doesn't try and feed MLAT positions back to dump1090 if you go through their forum post for their Pi MLAT beta test it will tell you how to do this (it's in relation to viewing MLAT data in VRS without sending it into dump1090 for display on it's own webpage)...
                  The simplest way to disable the feedback entirely is:
                  Code:
                  $ sudo piaware-config -mlatResults 0
                  $ sudo service piaware restart
                  Or as you say you can use piaware-config -mlatResultsFormat if you do want to receive MLAT results but show them separately e.g. in VRS.

                  FWIW, at the time this was released some weeks ago I contacted FR24 with details of how the feedback mechanism works and how to identify and ignore those messages if they want, but I've had no response at all.
                  Planefinder did respond and their feeder now directly handles that with no special config needed.

                  Note that the FlightAware mlat client requires an unmodified 12MHz timestamp as produced by stock dump1090 / dump1090-mutability / the Mode-S Beast / etc. This currently works with the modified FR24 dump1090 because the FR24 modifications only mangle the timestamp on the "raw" AVR output, and FlightAware uses the "binary" Beast output. That's mostly luck, though. I'd encourage FR24 to use a separate port for their modified timestamps to avoid breaking other software.

                  Comment


                  • Originally posted by obj View Post
                    FWIW, at the time this was released some weeks ago I contacted FR24 with details of how the feedback mechanism works and how to identify and ignore those messages if they want, but I've had no response at all.
                    Planefinder did respond and their feeder now directly handles that with no special config needed.

                    Note that the FlightAware mlat client requires an unmodified 12MHz timestamp as produced by stock dump1090 / dump1090-mutability / the Mode-S Beast / etc. This currently works with the modified FR24 dump1090 because the FR24 modifications only mangle the timestamp on the "raw" AVR output, and FlightAware uses the "binary" Beast output. That's mostly luck, though. I'd encourage FR24 to use a separate port for their modified timestamps to avoid breaking other software.
                    I really hope FR24 get on board with this. I am using this setup and it's working well, although I really wish MLAT planes could be colorised in VRS, I'm looking at the JS for VRS but I think the main code base for VRS needs mods first, as has been mentioned when people have asked questions about plane color changes... And hopefully "luck" prevails
                    T-YBBN50 - Kallangur, QLD, Australia

                    Comment


                    • vinnyspb,

                      Can I make a suggestion that a stick is made or the initial post for this thread is edited to contain a howto for people who feed multiple sites, for instance FR and FA, describing how to setup the MLAT version of fr24feed so that both FR and FA can benefit from these advances, because I've seen a number of people not going ahead with the upgrade because it breaks feeding to other sites without clear instructions on how to do things so it works all round? I replied to the Aussie feeders thread with a quick howto because there was some complaint about all this..

                      Also, thanks for all the work you and whoever else has worked on this have put in! It helps me see a lot more aircraft then I used to! Now I can sometimes see that pesky police helicopter which never turns it's ADS-B transponder on! Good work! But we need more feeders taking part, but I fear they won't unless they know how to make it work with as little effort as possible.. Thanks
                      T-YBBN50 - Kallangur, QLD, Australia

                      Comment


                      • i also upgraded to 1.0.14-5. all stopped working. --signup and choosing MLAT causes only to choose usb dongele as receiver
                        the version before gave me the option to use sbs1/3.
                        now it is gone. when i signup again and use MLAT no i get all hardware options back,
                        but when i switch on MLAT at the webinterface all is hanging up and webinterface is gone.
                        Last edited by LOWL1; 2015-07-18, 15:38.

                        Comment


                        • So, going back to my NTP issue... can an option to turn off ntp sync be added? or use the localhost ntp server? I can see that fr24feed is going it alone and using pool.ntp.org but for some reason it's not using any local servers by default.. Just would think that as you are relying on ADS-B transponder timestamps for then the local timestamp could be taken from system clock.. If anything, check for presence of ntp and make sure its running..? And Raspbian installs ntp by default..

                          I don't know what to suggest, I cannot see why fr24feed is not getting NTP sync very often... I have been watching the ntp traffic from that machine via my border router and ALL requests are being answered. Is there a debug mode which might expose the ntp requests and the responses and why they are being disregarded? Help?
                          T-YBBN50 - Kallangur, QLD, Australia

                          Comment


                          • #146
                            found a solution:
                            --signup without MLAT and change mlat to yes in fr24feed.ini not in webinterface.
                            restart service - ok!

                            Comment


                            • Originally posted by LOWL1 View Post
                              #146
                              found a solution:
                              --signup without MLAT and change mlat to yes in fr24feed.ini not in webinterface.
                              restart service - ok!
                              From what I have read the mlat feeding only works with the DVB-T dongles, no other inputs at this stage..
                              T-YBBN50 - Kallangur, QLD, Australia

                              Comment


                              • Originally posted by bhaal View Post
                                From what I have read the mlat feeding only works with the DVB-T dongles, no other inputs at this stage..
                                the version before it worked also with sbs1 and with the trick above it seems to work with 1.0.14-5 too:

                                webinterface:

                                Flightradar24 Feeder/Decoder
                                Linux/generic/armv7l/1.0.14-5
                                Updated: 18:38:56 GMT+0200 (CEST)

                                FR24 Link: Connected via UDP
                                FR24 Radar Code: T-LOWL1
                                Aircraft Tracked (ModeS & ADS-B): 156
                                Aircraft Uploaded: 134
                                Receiver: sbs1tcp, Connected
                                MLAT running: YES

                                terminal:

                                FR24 Feeder/Decoder Process: running.
                                FR24 Stats Timestamp: 2015-07-18 16:40:30.
                                FR24 Link: connected [UDP].
                                FR24 Radar: T-LOWL1.
                                FR24 Tracked AC: 134.
                                Receiver: connected (546843 MSGS/0 SYNC).
                                FR24 MLAT: ok [UDP].
                                FR24 MLAT AC seen: 136.

                                ... but maybe the shown info isn't correct?!
                                Last edited by LOWL1; 2015-07-18, 16:44.

                                Comment

                                Working...
                                X