Announcement

Collapse
No announcement yet.

Virtual Radar Server and Fr24feed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • abcd567
    replied
    Originally posted by dannyhef View Post
    does anybody know how I can change the map von google maps to another maps in VRS. I dont have the option to do so?
    Version 2.4.0 or before have Google Map only.
    Version 2.4.1 and v2.4.2 have option to select either Google Map or Leaflet-OpenStreet Map.

    How to Change Map? (ver 2.4.1 & 2.4.2)
    1. Click "Tools" >> "Options"
      VRS Switch Map-1.png

    2. Click "Data Source" >> Map Provider Drop-down, and from drop-down, choose Google or Leaflet. If you choose Leaflet, you will get a drop-down list of many map types. >> Click OK to save settings.
      VRS Switch Map-2.png

      VRS Switch Map-4.png

    3. If you choose Google Map, you get an option to add Google API Key. This key is not necessary to view map on your Local Network, but needed if you want your Map to be accessible on Internet. For Leaflet-OpenStreet Map, no key is required.
      VRS Switch Map-3.png



    Originally posted by dannyhef View Post
    My next question is how can I update VRS??
    1. Download latest Version 2.4.2 from this page
      http://virtualradarserver.co.uk/Download.aspx

      It will download a file "VirtualRadarSetup.exe"

    2. Close Virtual Radar Server if it is running
    3. Run the installation file "VirtualRadarSetup.exe"
    4. Start Virtual Radar Server, and open its map in browser. By default it shows Leaflet-OpenStreet Map.
    5. If you want to change to Google Map, use method shown above
    Last edited by abcd567; 2018-06-23, 20:19.

    Leave a comment:


  • dannyhef
    replied
    Hello,
    does anybody know how I can change the map von google maps to another maps in VRS. I dont have the option to do so? My next question is how can I update VRS??
    Thanks a lot
    Dan

    Leave a comment:


  • abcd567
    replied
    Originally posted by Laserboy View Post
    Are there any other changes needed in the FR24 Feeder Settings? Same faillure.
    Add --net in field "Process Arguments"

    FR24 -PI24.png
    Last edited by abcd567; 2018-06-20, 19:08.

    Leave a comment:


  • Laserboy
    replied
    Originally posted by abcd567 View Post
    Laserboy:
    Try port # 30005 instead of 30334
    Are there any other changes needed in the FR24 Feeder Settings? Same faillure. Knipsel.PNG

    Leave a comment:


  • abcd567
    replied
    Laserboy:
    In VRS settings, try port # 30005 instead of 30334

    This works for me

    VRS Pi 1.png
    Last edited by abcd567; 2018-06-20, 18:37.

    Leave a comment:


  • Laserboy
    replied
    Hello! I'm a day off from work. So i tried to connect Virtal Radar Server to my Raspberry Pi. I would like the put the flight data on my own map. I used the latest fr24-raspberry-pi-latest-images. It works very well, but Virtual Radar Server can't connect with my Pi.


    In case of the DVBT stick it is better to use another approach as some data is filtered out at
    an early signal processing stage. To do so, you will need to configure dump1090 to access
    your DVBT dongle directly (please refer to dump1090 manual) and enable networking by
    adding “--net” parameter to the command line. After you start dump1090 you can configure
    FR24 Decoder to use its RAW data stream. Please go to http://localhost:8754/settings.html
    and change receiver type to AVR (TCP) entering “localhost:30002” in the Host/IP field. Then
    save settings and restart decoder.
    Of course I also read the manual. The above quote also has no effect on the realization of the connection between my pc en Rpi.

    Can you help me?

    Knipsel.PNGKnipsel.PNGKnipsel.PNGKnipsel.PNG

    Leave a comment:


  • peerke63
    replied
    Originally posted by Oblivian View Post
    And the data format type? you have it set to basestation at present. Thats in a different format.

    And passphrase shouldn't be present. Thats actually more likely to give refusals
    Changed dataformat to VAR or Beast RAWfeed... and port to 22 (30005 gives a refusal) and cleared the passfraseline...

    Not seeing any messeges though... but a connection ca be made... that's little progress

    Leave a comment:


  • Oblivian
    replied
    Originally posted by peerke63 View Post
    So I should change them in VRS receiver-settings?
    If yes: I tried port 30005 and 30003 en 30002... all refused.
    And the data format type? you have it set to basestation at present. Thats in a different format.

    And passphrase shouldn't be present. Thats actually more likely to give refusals

    Leave a comment:


  • peerke63
    replied
    So I should change them in VRS receiver-settings?
    If yes: I tried port 30005 and 30003 en 30002... all refused.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by peerke63 View Post
    My settings...
    [ATTACH=CONFIG]6459[/ATTACH]

    I hope this is what you are refering to?
    Yep. Them. If you have the RPi using a DVB as your source feeder that's not quite right. Data type should be beast and port 30005 to ensure you get all your data passed
    30334 is for FR24 feed boxes and other devices if RAW is enabled.

    --net-ri-port <port> TCP raw input listen port (default: 30001)
    --net-ro-port <port> TCP raw output listen port (default: 30002)
    --net-sbs-port <port> TCP BaseStation output listen port (default: 30003)
    --net-bi-port <port> TCP Beast input listen port (default: 30004)
    --net-bo-port <port> TCP Beast output listen port (default: 30005)
    Last edited by Oblivian; 2015-09-26, 12:13.

    Leave a comment:


  • peerke63
    replied
    VRS settings

    Originally posted by Oblivian View Post
    Screenshot of VRS receiver settings?
    My settings...
    VRS-settings.png

    I hope this is what you are refering to?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by peerke63 View Post
    When I try to let VRS look at my FR24feed on RPi... I get an active connection refusal
    My settings of FR24feed as in pic.[ATTACH=CONFIG]6458[/ATTACH]

    Wht should I change?
    Screenshot of VRS receiver settings?

    Leave a comment:


  • peerke63
    replied
    What setting to change

    When I try to let VRS look at my FR24feed on RPi... I get an active connection refusal
    My settings of FR24feed as in pic.FR24 settings.jpg

    Wht should I change?

    Leave a comment:


  • F-SVBS1
    replied
    and ready to install it but I have problems with the base station have windows 7

    Leave a comment:


  • Oblivian
    replied
    I still dont understand what you are either asking, or trying to tell us.

    Follow the posts if you want VRS working locally.

    Configure VRS to use Beast/Raw on IP of FR24 box port 30334

    Leave a comment:

Working...
X