Announcement

Collapse
No announcement yet.

Cascading other software off FR24 Feeder Software (fr24feed)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by Bloods View Post
    No didn't really achieve what I was trying to. I couldn't get Plane Plotter to talk nicely to FR24feed without having BS in between. So that's what I have - frfeed24 > BS > PP > VRS
    In theory.. and speaking purely theoretical without being able to confirm..

    You should be able to configure Planeplotter to use the SBS as the primary device, and output basestation AVR on 30003, and use AVRTCP option in the feed software to connect to that output.

    However it is not clear if this still needs to happen with BaseStation software open.

    c) Ian Hind notes: another variation with the SBS-1e is to select in Options/Mode S receiver/Kinetic SBS family/SBS3 direct IP address, and then for the TCP/IP address add port 30006, eg 192.168.0.114:30006. In I/O for Mode-S/ADS-B select "SBS-1/3 direct TCP". Advantage is extra data is provided, usefully the assigned altitude as well as the current altitude. The default access port for SBS-1 is 30003 (same as RadarBox) but that is a simple basic connection - the lowest common denominator. Port 30006 access for Plane Plotter was introduced around the time of the SBS-3 - it is the direct binary output of the SBS-3. Then it was published that the SBS-1e/SBS-1er could also provide extra data for Plane Plotter. It doesn't affect MLAT ability, just increases Plane Plotter functionality, so it's really an improved TCP connection method.

    Leave a comment:


  • Bloods
    replied
    Originally posted by Fredrik View Post
    Hey guys,

    Bloods, have the same setup/equipment as you and want to avoid BS if possible. Did you get anywhere with the above thread? Before i read here i also tried most configurations but... nothing so far.
    No didn't really achieve what I was trying to. I couldn't get Plane Plotter to talk nicely to FR24feed without having BS in between. So that's what I have - frfeed24 > BS > PP > VRS

    Leave a comment:


  • Fredrik
    replied
    Hey guys,

    Bloods, have the same setup/equipment as you and want to avoid BS if possible. Did you get anywhere with the above thread? Before i read here i also tried most configurations but... nothing so far.

    Leave a comment:


  • Bloods
    replied
    OK, thanks OB for sticking with me on this one.

    I'll check it out in the morning when hopefully I'll be ready to tackle telnet and the associated techno hyper-babble

    Leave a comment:


  • Oblivian
    replied
    I can't confirm without having the SBS as the source data for it to relay back out.

    You may need the "--" infront if you have not.

    Way to check is install telnet onto a PC and go 'telnet <ip of fr24feed.exe> 10001 and see if you get a flashing cursor

    Leave a comment:


  • Bloods
    replied
    Originally posted by Oblivian View Post
    Err.. MPX enables 10001 BS relay. so the source becomes the FR24 feed IP instead of BS
    So doesn't that mean configuring PP with 127.0.0.1:10001 or 127.0.0.1:20072?

    Both of which I can't get to work

    Leave a comment:


  • Oblivian
    replied
    Err.. MPX enables 10001 BS relay. so the source becomes the FR24 feed IP instead of BS

    --mpx=BOOL - Defaults to “no” and decides whether or not the SBS1/3 compatible data
    stream should be enabled on port 10001. This option is only available when Kinetic
    Avionics receiver is used to enable Basestation connection

    Leave a comment:


  • Bloods
    replied
    Yes this is what I did.

    I enabled mpx=yes; raw=yes; bs=yes, all in fr24feed.exe

    So this should enable ports 20072; 30334 and 30003 respectively.

    fr24feed is talking to SBS-3 on port 10001

    So the issue as you say is in finding the right combination of data input format for Planeplotter.

    I'll keep trying. I haven't messed much with AVR. I'll give that a go.

    Thanks OB.

    Leave a comment:


  • Oblivian
    replied
    That means PP is not reading the right format. In any case, you want planeplotter to be connecting to TCP, but the address of the PC fr24feed is on. And either chosen as AVR TCP, or Basestation TCP format.

    And as long as you enabled both formats in the config web page in fr24feed (for AVR and RAW), its either going to be on 30034 or 30003.


    UNLESS you enable MPX on fr24feed, in which case it will also be on 10001, but a diff source IP


    I suggest you enable MPX option (--MPX=YES), both OUTPUTs on fr24feed config page. And walk away.

    Then focus on the different source formats in PP

    Leave a comment:


  • Bloods
    replied
    Well I've messed around with it for a while, but I can't get PP to upload any aircraft unless I go back to my original setup.

    I have fr24feed outputting on ports 30334 (raw), 30003 (BS format) and 20072 (?? format) and connecting to the SBS-3 on port 10001.

    I even changed the output of the SBS-3 to 10005 and tried connecting PP to 127.0.0.1:10001 but nothing.

    How do I "flag the output format correctly" exactly?

    But I can't get PP to connect to any of these ports.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Bloods View Post
    Thanks OB for the quick reply.

    Can I clarify a couple of things about your PP setup?

    1. Are you an approved Ground Station/Master user?
    Yes indeedy

    2. Under input/output settings > Mode-S/ADS-B > do you have Beast receiver TCP selected?
    Yep.. As thats my hardware.. may differ slightly if the raw output from fr isn't actually beast format

    3. Under Options > Mode-S receiver > Beast receiver > Setup TCP/IP client > do you have this set to 127.0.0.1:30334?
    *stops it for the first time in a month or so..* Correct
    4. Do you have a SBS-3 as your hardware receiver?
    Nope, but the theory is the same. As long as you flag the output format correctly.

    Give it a shot. Else theres 2 other modes you could try -
    AVR format and the port 30003 which will attach to fr24 feeds AVR out (if configured) - you will see '1 client connected' show on fr24feed sw

    Or add --MPX=YES to the extra args, and configure PP to SBS TCP on 10001 but point to the FR24 PCs address (may be localhost)

    Leave a comment:


  • Bloods
    replied
    Originally posted by Oblivian View Post
    I have Receiver -> FR24feed -> PP just fine.

    In my case, I enable RAW output on fr24feed configure planeplotter for Beast TCP and the IP/port. Works a treat.

    Anything else taps into the AVR output on 30003. You just have to be sure NOTHING else is re-broadcasting on 30003 also (turn off PP local avr sharing)

    The 30003 ouput allows up to 5 clients, and CAN connect together. Its when the data is unprocessed/raw or direct connected to the hardware it can't be shared
    Thanks OB for the quick reply.

    Can I clarify a couple of things about your PP setup?

    1. Are you an approved Ground Station/Master user?

    2. Under input/output settings > Mode-S/ADS-B > do you have Beast receiver TCP selected?

    3. Under Options > Mode-S receiver > Beast receiver > Setup TCP/IP client > do you have this set to 127.0.0.1:30334?

    4. Do you have a SBS-3 as your hardware receiver?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Bloods View Post
    After a fair bit of experimenting, this seems to be the only configuration I can find that allows all four (4) pieces of software to work together. FR24feed has to be at the top of the food-chain and you need BaseStation running to enable Planeplotter to connect to it, as I can't get PP to connect directly with FR24feed.

    Has anyone tried getting this software to play nicely together and if so, what config did/do you use?

    PS. Ideally, I would like to eliminate the use of Basestation but can't figure out how...
    I have Receiver -> FR24feed -> PP just fine.

    In my case, I enable RAW output on fr24feed configure planeplotter for Beast TCP and the IP/port. Works a treat.

    Anything else taps into the AVR output on 30003. You just have to be sure NOTHING else is re-broadcasting on 30003 also (turn off PP local avr sharing)

    The 30003 ouput allows up to 5 clients, and CAN connect together. Its when the data is unprocessed/raw or direct connected to the hardware it can't be shared

    Leave a comment:


  • Bloods
    replied
    After a fair bit of experimenting, this seems to be the only configuration I can find that allows all four (4) pieces of software to work together. FR24feed has to be at the top of the food-chain and you need BaseStation running to enable Planeplotter to connect to it, as I can't get PP to connect directly with FR24feed.

    Has anyone tried getting this software to play nicely together and if so, what config did/do you use?

    PS. Ideally, I would like to eliminate the use of Basestation but can't figure out how...

    Leave a comment:


  • Cascading other software off FR24 Feeder Software (fr24feed)

    Hi

    Wondering what the best setup is for running multiple software cascading off each other?

    Current setup is:

    SBS-3 (networked) Network address: 10.8.0.29:10001 >

    FR24 Feeder software (ver. 1.0.11.6) configured to 10.8.0.29:10001 > (running on PC Network address 10.8.0.7)

    Basestation configured as 127.0.0.1:20072 > (running on PC Network address 10.8.0.7)

    Planeplotter configured as 127.0.0.1:30006 > (running on PC Network address 10.8.0.7)

    Virtual Radar Server 10.8.0.7:30006 > (running on PC Network address 10.8.0.2)

    Surprisingly, both Planeplotter and VRS seem happy to share port 30006 coming from Basestation - I didn't think this was possible?

    The problem with this setup as I see it, is that if FR24 feeder software throws a "wobbly" the whole chain falls over?

    Any suggestions for a better setup?
Working...
X