Announcement

Collapse
No announcement yet.

Raspberry Pi:How To Install Raspian OS + Dump1090 + FR24 Data Feeder

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by dekema2 View Post
    Hello, I'm having some serious issues installing dump1090 on my Raspberry Pi 3B+. I followed the instructions on the first page and was able to setup FR24 and the web portal, but I got a message saying:

    "Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date."

    I have the FlightAware antenna and dongle setup properly to my Pi. I've looked all over the place for a solution and I can't find one.
    There's 3 methods here. Which. So we know what you have done. And did you do anything more than outlined by the steps for that ONE option. (Like mix and match)

    Searching 'ajax' finds all the issues around it and hints to look for. But if you used the mutability 1.15, that is probably why.

    https://forum.flightradar24.com/foru...-fetching-data

    In either case I'm un stickying this. As you can see it was last updated last year. The first option is the safest

    If you restart and use the pi24 quick start image, and don't re-run activation it Will likely work

    Leave a comment:


  • dekema2
    replied
    Hello, I'm having some serious issues installing dump1090 on my Raspberry Pi 3B+. I followed the instructions on the first page and was able to setup FR24 and the web portal, but I got a message saying:

    "Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date."

    I have the FlightAware antenna and dongle setup properly to my Pi. I've looked all over the place for a solution and I can't find one.

    Leave a comment:


  • Oblivian
    replied
    That's because you are starting it a 2nd time - You can't run sudo fr24feed while the status is showing OK/running (background running)

    sudo systemctl stop fr24feed
    sudo fr24feed (if you really need to see what it is doing)

    Then once finished reboot or

    sudo systemctl start fr24feed

    Leave a comment:


  • W4lRon
    replied
    hi all

    I use raspbian OS + Kinetic Puck 1090 + FR24Feed. I made all my configurations.
    I'm getting a beast output over modeSmixer 2


    When I apply the status command everything seems normal.

    pi@raspberrypi:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2020-05-07 11:01:08.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-LTBJ1.
    [ ok ] FR24 Tracked AC: 4.
    [ ok ] Receiver: connected (21051 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 4.



    but when i get into the application i see these errors.What is the reason?

    pi@raspberrypi:~ $ sudo fr24feed
    2020-05-07 11:55:45 | [feed][i]sent 4,0 AC
    2020-05-07 11:55:45 | error | write - missing monitor file pointer
    2020-05-07 11:55:45 | error | write - missing monitor file pointer
    2020-05-07 11:55:46 | error | write - missing monitor file pointer
    2020-05-07 11:55:46 | error | write - missing monitor file pointer
    2020-05-07 11:55:47 | error | write - missing monitor file pointer
    2020-05-07 11:55:47 | error | write - missing monitor file pointer
    2020-05-07 11:55:47 | [httpd][w]bind function failed, errno: 98, waiting 11 seconds





    Leave a comment:


  • Oblivian
    replied
    Originally posted by oliaros View Post
    Hello out there,

    [ ok ] Receiver: connected (0 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!

    2019-06-26 10:16:12 | [feed][n]ping 1
    2019-06-26 10:16:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:16:42 | [feed][n]ping 2
    2019-06-26 10:16:43 | [feed][n]syncing stream result: 1
    2019-06-26 10:17:12 | [feed][n]ping 3
    2019-06-26 10:17:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:17:42 | [feed][n]ping 4
    2019-06-26 10:17:43 | [feed][n]syncing stream result: 1
    2019-06-26 10:18:12 | [feed][n]ping 5
    2019-06-26 10:18:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:18:42 | [feed][n]ping 6
    2019-06-26 10:18:43 | [feed][n]syncing stream result: 1

    The program continues pinging.

    Do you have any hints for me?
    Thx for your support, regards
    oliaros
    https://forum.flightradar24.com/thre...ll=1#post74834

    2016-01-27 00:35:36 | [feed][n]ping 1
    2016-01-27 00:36:06 | [feed][n]ping 2
    2016-01-27 00:36:36 | [feed][n]ping 3
    2016-01-27 00:37:06 | [feed][n]ping 4
    2016-01-27 00:37:36 | [feed][n]ping 5
    2016-01-27 00:38:06 | [feed][n]ping 6
    2016-01-27 00:38:36 | [feed][n]ping 7
    No data is being received by hardware to upload
    - Check connections
    - Incorrect data format received from receiver or software for chosen receiver type
    - Wrong port/type specified from software supplying data

    Leave a comment:


  • oliaros
    replied
    Hello out there,
    I try to get flightradar24 run on my Pi. So far I failed:

    sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-06-26 11:07:58.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EDVE132.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (0 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!

    I use this dvbt-dongle:
    rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001
    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.

    The log says:
    2019-06-26 10:15:35 | ______ _ _ _ _ _ _____ ___
    2019-06-26 10:15:35 | | ___|| |(_) | | | | | | / __ \ / |
    2019-06-26 10:15:35 | | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
    2019-06-26 10:15:35 | | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
    2019-06-26 10:15:35 | | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
    2019-06-26 10:15:35 | \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
    2019-06-26 10:15:35 | __/ |
    2019-06-26 10:15:35 | |___/
    2019-06-26 10:15:35 | [main][i]FR24 Feeder/Decoder
    2019-06-26 10:15:35 | [main][i]Version: 1.0.23-8/generic
    2019-06-26 10:15:35 | [main][i]Built on Oct 11 2018 18:27:28 (HEAD-3c696a7.git/Linux/static_armel)
    2019-06-26 10:15:35 | [main][i]Running on: raspbian9
    2019-06-26 10:15:35 | [main][i]Local IP(s): 192.168.0.244
    2019-06-26 10:15:35 | [main][i]Copyright 2012-2018 Flightradar24 AB
    2019-06-26 10:15:35 | [main][i]hxxxs://wxw.flightradar24.com
    2019-06-26 10:15:35 | [main][i]DNS mode: PING
    2019-06-26 10:15:35 | [main][i]Automatic updates are ENABLED
    2019-06-26 10:15:35 | ERROR: rmmod: ERROR: Module dvb_usb_rtl28xxu is not currently loaded
    2019-06-26 10:15:35 | [main][i]Reader thread started
    2019-06-26 10:15:35 | [main][i]MLAT data feed started
    2019-06-26 10:15:35 | [mlat][i]Waiting for MLAT configuration
    2019-06-26 10:15:35 | [reader][i]Initializing reader
    2019-06-26 10:15:35 | [reader][i]Connecting to DVBT receiver via (exe:///usr/bin/dump1090-mutability --raw --mlat)
    2019-06-26 10:15:35 | [reader][i]Connected to the receiver, configuring
    2019-06-26 10:15:35 | [master][i]Starting processing thread
    2019-06-26 10:15:35 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2019-06-26 10:15:35 | [reader][i]Configured, processing messages
    2019-06-26 10:15:36 | [time][i]Synchronizing time via NTP
    2019-06-26 10:15:41 | [time][i]Time synchronized correctly, offset +0.0001 seconds
    2019-06-26 10:15:41 | [main][i]Feed Network client started
    2019-06-26 10:15:41 | [feed][i]Downloading configuration
    2019-06-26 10:15:41 | [feed][d]fetching configuration
    2019-06-26 10:15:42 | [feed][i]configuring decoder
    2019-06-26 10:15:42 | [feed][c]Max range AIR: 350.0nm
    2019-06-26 10:15:42 | [feed][c]Max range GND: 100.0nm
    2019-06-26 10:15:42 | [feed][i]configuration changed
    2019-06-26 10:15:42 | [feed][i]defined 3 servers
    2019-06-26 10:15:42 | [feed][c]Timestamps: optional
    2019-06-26 10:15:42 | [stats][i]Stats thread started
    2019-06-26 10:15:42 | [feed][n]EDVExxx@185.218.24.22:8099/UDP
    2019-06-26 10:15:42 | [feed][n]connecting
    2019-06-26 10:15:42 | [feed][n]connected via UDP (fd 15)
    2019-06-26 10:15:42 | [feed][i]Feed connected
    2019-06-26 10:15:42 | [feed][n]working
    2019-06-26 10:15:42 | info | Stopping ReceiverACSender threads for feed
    2019-06-26 10:15:42 | info | Configured ReceiverACSender: 185.218.24.22:8099,185.218.24.23:8099,185.218.24.2 4:8099, feed: EDVExxx, send_interval: 5s, max age: 15s, send metadata: true, mode: 1, filtering: true
    2019-06-26 10:15:42 | info | Network thread connecting to 185.218.24.22:8099 for feed EDVExxx
    2019-06-26 10:16:12 | [feed][n]ping 1
    2019-06-26 10:16:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:16:42 | [feed][n]ping 2
    2019-06-26 10:16:43 | [feed][n]syncing stream result: 1
    2019-06-26 10:17:12 | [feed][n]ping 3
    2019-06-26 10:17:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:17:42 | [feed][n]ping 4
    2019-06-26 10:17:43 | [feed][n]syncing stream result: 1
    2019-06-26 10:18:12 | [feed][n]ping 5
    2019-06-26 10:18:13 | [feed][n]syncing stream result: 1
    2019-06-26 10:18:42 | [feed][n]ping 6
    2019-06-26 10:18:43 | [feed][n]syncing stream result: 1

    The program continues pinging.

    Do you have any hints for me?
    Thx for your support, regards
    oliaros


    Edit:
    changing the antenna solved the problem. Flightradar24 now running on the Pi.
    Regards oliaros
    Last edited by oliaros; 2019-08-29, 10:56. Reason: Problem solved

    Leave a comment:


  • abcd567
    replied
    Seems result of installing two dump1090.

    Best option now is to write a fresh image to microSD card.

    Two years ago, I have posted a much more detailed guide, which is linked below.
    (I have updated versions & links today)
    Bake A Pi
    Last edited by abcd567; 2019-06-22, 08:28.

    Leave a comment:


  • wiedehopf
    replied
    You might want to have a look at these pages if you just set up your feeder:

    https://forum.flightradar24.com/thre...h-DVB-T-Dongle
    https://forum.flightradar24.com/thre...ange-I-can-Get

    Leave a comment:


  • wiedehopf
    replied
    If you want dump1090-fa instead of dump1090-mutability you might want to have a look at this page, it has some more info you might find useful:
    https://github.com/wiedehopf/adsb-wi...ng-dump1090-fa

    (just more reading, the instructions posted by abcd567 for the situation should work fine)

    Leave a comment:


  • abcd567
    replied
    Originally posted by darryls.cody View Post
    pi@raspberrypi:~ $ pgrep -fa dump1090
    520 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005
    You have installed dump1090-fa on Pi24, but you did not mention it in any of your posts.
    You have set fr24feed for "receiver=dvbt", so fr24feed has started its integral dump1090-mutability and trying to get data from it, while the stick is in use of dump1090-fa.

    DO NOT USE 2 TYPES OF DUMP1090 SIMULTANEOUSLY.

    Either
    stop dump1090-mutability of fr24feed by changing setting of fr24feed to following:
    Receiver = Beast (TCP)
    Host/Port = 127.0.0.1:30005
    FR24 settings - External dump1090 - BEAST-TCP.png



    OR
    uninstall dump1090-fa by following command:

    sudo apt-get remove dump1090-fa

    You can use following settings only after removal of dump1090-fa
    Receiver = DVBT Stick (default)
    FR24 settings - Integral dump1090.png
    Last edited by abcd567; 2019-06-22, 06:19.

    Leave a comment:


  • darryls.cody
    replied
    Originally posted by wiedehopf
    You need to run rtl_test after running the stop commands.
    The stop commands make sure that the dongle is not used by the other programs.

    Can you show the output for (execute in that order):

    pgrep -fa dump1090
    sudo systemctl stop fr24feed
    sudo rtl_test
    Thanks for this. I did run the rtl_test after running the stop commands.

    Here is what I have after running the above in that order:

    pi@raspberrypi:~ $ pgrep -fa dump1090
    520 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005 --max-range 360 --net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30 104 --net-bo-port 30005 --json-location-accuracy 1 --lat -41.15993 --lon 174.826 99 --write-json /run/dump1090-fa --quiet
    737 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --in put-type dump1090 --results beast,connect,localhost:30104 --results beast,listen ,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.191:5169:1 16732626
    pi@raspberrypi:~ $ sudo systemctl stop fr24feed
    pi@raspberrypi:~ $ sudo rtl_test
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.

    Leave a comment:


  • abcd567
    replied
    Agree with @wiedehopf. Works both ways for me too.

    Mr. Khan of "Team FR24" has posted without quotes here:

    https://forum.flightradar24.com/thre...l=1#post112854

    Leave a comment:


  • wiedehopf
    replied
    quotes or no quotes probably doesn't matter as long as the values after the = don't contain spaces or other special characters.

    works fine without quotes for me.

    Leave a comment:


  • AnonyMouse
    replied
    Should these lines

    use-http=yes
    http-timeout=10
    be formatted as

    use-http="yes"
    http-timeout="10"

    Leave a comment:


  • carlosmiranmm
    replied
    hello I have one (raspberry pi 3 + RTL2832U R820T2) I had this configuration with you and it worked wells.
    Code:
    receiver="avr-tcp"
    fr24key="key"
    host="127.0.0.1:30002"
    bs="no"
    raw="no"
    logmode="1"
    logpath="/var/log/fr24feed"
    mlat="yes"
    mlat-without-gps="yes"
    Currently it is connected but does not send data, and I have other feeder ok.

    Thanks in advance.

    Leave a comment:

Working...
X