Announcement

Collapse
No announcement yet.

Flightradar24 decoder/feeder BETA testing (Win/RPi/Linux/OSX)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • From what I noticed regarding this crash with my system, it's not a problem with the dongle, the USB port, or with the dump1090 process as a Virtual Radar Server connected to the same data stream is still working and plotting planes after the FR24 feeder crashes.
    F-LLBG3, T-LLBG17

    Comment


    • I've had RTL1090 and 1.2.3.2 running H24 since 28 April, with no problems. I've just stopped those and started 1.0.11.7 - I'll see how long before it crashes.

      Comment


      • can anyone tell me how to install FR24 Feed by manual instal using .tgz file?
        I checked the guide, but it gives instructions for only .deb file. No method is given for installation of .tgz file

        I tried following, but failed:
        Code:
        pi@raspberrypi ~ $ wget http://feed.flightradar24.com/raspberry-pi/fr24feed_1.0.12-3_armhf.tgz
        2015-05-03 04:22:13 (354 KB/s) - `fr24feed_1.0.12-3_armhf.tgz' saved [237980/237980]
        
        pi@raspberrypi ~ $ sudo tar zxf fr24feed_1.0.12-3_armhf.tgz
        # this created a directory  "fr24feed_rpi" containing "fr24feed  LICENSE.fr24feed  timestamper  version.txt"
        
        pi@raspberrypi ~ $ cd fr24feed_rpi
        pi@raspberrypi ~/fr24feed_rpi $ sudo ./configure
        sudo: ./configure: command not found
        pi@raspberrypi ~/fr24feed_rpi $ sudo make
        make: *** No targets specified and no makefile found.  Stop.
        pi@raspberrypi ~/fr24feed_rpi $ sudo make install
        make: *** No rule to make target 'install'.  Stop.
        Last edited by abcd567; 2015-05-03, 04:42.

        Comment


        • I don't know if anyone's interested in reports on version 1.0.11.7 - if not, say so and I'll stop posting.
          I've been persevering, and it ran H24 for just over four days without any problem. Then it crashed with the following two errors:

          Faulting application name: fr24feed.exe, version: 1.0.11.7, time stamp: 0x54cb9e7b
          Faulting module name: ntdll.dll, version: 6.1.7601.18798, time stamp: 0x5507b3e0
          Exception code: 0xc0000264
          Fault offset: 0x000a2785
          Faulting process id: 0x1c60
          Faulting application start time: 0x01d084fb45af7082
          Faulting application path: H:\SDR\FR24 feed\fr24feed.exe
          Faulting module path: C:\Windows\SysWOW64\ntdll.dll
          Report Id: a169aa22-f421-11e4-bde3-0030678f962e

          Faulting application name: fr24feed.exe, version: 1.0.11.7, time stamp: 0x54cb9e7b
          Faulting module name: fr24feed.exe, version: 1.0.11.7, time stamp: 0x54cb9e7b
          Exception code: 0xc0000005
          Fault offset: 0x0000b62a
          Faulting process id: 0x1c60
          Faulting application start time: 0x01d084fb45af7082
          Faulting application path: H:\SDR\FR24 feed\fr24feed.exe
          Faulting module path: H:\SDR\FR24 feed\fr24feed.exe
          Report Id: c6e1bc45-f421-11e4-bde3-0030678f962e

          I restarted it, and it's been running OK for the last two hours.

          Comment


          • Hi all,

            It seems the latest fr24feed 1.0.13-1 for RPi is not compatible with my RPi v1. I have tried to dpkg -i commands on both deb files but none of them are installed successfully.

            Here is the error log:

            dpkg -i fr24feed_1.0.13-1_armv6l.deb
            dpkg: error processing fr24feed_1.0.13-1_armv6l.deb (--install):
            package architecture (i386) does not match system (armhf)
            Errors were encountered while processing:
            fr24feed_1.0.13-1_armv6l.deb
            root@RPi-adsb-VPN:~/fr24feed# dpkg -i fr24feed_1.0.13-1_armv7l.deb
            dpkg: error processing fr24feed_1.0.13-1_armv7l.deb (--install):
            package architecture (i386) does not match system (armhf)
            Errors were encountered while processing:
            fr24feed_1.0.13-1_armv7l.deb
            My RPi Specification:

            cat /proc/cpuinfo
            processor : 0
            model name : ARMv6-compatible processor rev 7 (v6l)
            BogoMIPS : 2.00
            Features : half thumb fastmult vfp edsp java tls
            CPU implementer : 0x41
            CPU architecture: 7
            CPU variant : 0x0
            CPU part : 0xb76
            CPU revision : 7

            Hardware : BCM2708
            Revision : 000e
            Serial : 000000001a41f8f5

            cat /proc/version
            Linux version 3.18.12+ (dc4@dc4-XPS13-9333) (gcc version 4.8.3 20140303 (prerelease) (crosstool-NG linaro-1.13.1+bzr2650 - Linaro GCC 2014.03) ) #782 PREEMPT Tue Apr 28 19:49:16 BST 2015
            Last edited by Dundee; 2015-05-09, 03:01.
            T-VHST9: http://vhst9.hopto.org/
            (24/7)

            Comment


            • I am having the same issue as above on a Pi2, seems the deb file is for an i386 system not an ARM7. The .tgz does work, though certainly not convenient nor does it set up things cleanly.

              dpkg: error processing fr24feed_1.0.13-1_armv7l.deb (--install):
              package architecture (i386) does not match system (armhf)
              Errors were encountered while processing:
              fr24feed_1.0.13-1_armv7l.deb

              processor : 0
              model name : ARMv7 Processor rev 5 (v7l)
              BogoMIPS : 38.40
              Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
              CPU implementer : 0x41
              CPU architecture: 7
              CPU variant : 0x0
              CPU part : 0xc07
              CPU revision : 5

              Comment


              • Sorry about the .deb issue, it's fixed now.

                Comment


                • i walked through all threads but i didn't find an answer to my question.
                  i installed the latest Linux/generic/armv7l/1.0.13-2 on my raspberrry.
                  all funktions are ok, but i dont get the webpage of mr-dump1090.
                  i selected all parameters via the settings page of fr24feed and the resulting fr24feed.ini is:
                  receiver="sbs1tcp"
                  fr24key="key"
                  host="192.168.0.170:10001"
                  path="/usr/lib/fr24/mr-dump1090"
                  bs="no"
                  raw="no"
                  logmode="0"
                  procargs="--net --net-http-port 8082"
                  windowmode="0"
                  mpx="no"

                  i am sure there is no other instance or installation of dump1090
                  i tried lots of parameters, but the website is not working.
                  if i start mr-dump1090 with --net-only parameter from /usr/lib/fr24/ i can see the map (without planes)
                  "/usr/lib/fr24/mr-dump1090 --net-only --net-http-port 8080 --raw"
                  any idea whats wrong here?
                  fr24feed settings.png
                  Last edited by LOWL1; 2015-05-20, 11:33.

                  Comment


                  • You can't use dump1090 with a SBS1 receiver this way. Procargs are not even used for SBS1 receiver as it is supported natively and not with an external dump1090. If you really want to use the MR Dump1090 web interface you need to start it separately and point it to use raw data or tcp 30003 data from fr24feed, but this was not tested.

                    Comment


                    • Originally posted by piopawlu View Post
                      You can't use dump1090 with a SBS1 receiver this way. Procargs are not even used for SBS1 receiver as it is supported natively and not with an external dump1090. If you really want to use the MR Dump1090 web interface you need to start it separately and point it to use raw data or tcp 30003 data from fr24feed, but this was not tested.
                      tnx for the quick answer. maybe there will be an integrated solution sometimes

                      Comment


                      • hello
                        i can't get anymore my feeder up and running.
                        Did work fine, stopped and no more chance to have it feeding.
                        dump1090 is fine and works, but fr24feed always report "fail"
                        even after a clean install not a chance to have it run..
                        some ideas?
                        i should add is a Pi Model B.
                        Last edited by alemino; 2015-05-22, 06:11. Reason: adding and corrections

                        Comment


                        • Hi Piopawlu,

                          Yesterday, I sent support an issue with me trying to update my RPi using the armv61.deb file and I encountered a problem and I appreciate that a reply hasn't come back as yet.

                          However, today I thought I would keep my current Linux and dump1090 software and just attempt to download and install the armv61.tgz so that I can just update the FR24Feed software but whilst I could download the armv61.tgz file without a problem, I encountered the same issue as I did with the .deb file when trying to install using sudo dpkg -i etc

                          I am using Raspberry Pi Model B ver2.0

                          Please see attached screenshot and any ideas would be great.

                          Thank you in advance.

                          RPi Update.jpg
                          Last edited by Responder; 2015-05-25, 15:46.
                          T-EGBB16

                          Hardware: NooElec DVB-T2 Dongle, Raspi Pi2 Mod B, 6dB Collinear Antenna, Nevis Pre-Amp & 1090mhz SAW Filter, 9mtrs WF100 Cable and 28ft Mast.
                          Software: Rasbain Jessie Lite, FR24 Feeder, Dump1090mutab and VRS.
                          Stats for Mar 18, 2016. Uptime:100%. Aircraft seen:2,012. Positions Reported:486,817. Maximum Distance:243nm (Stats provided by FR24)

                          Comment


                          • Download the fr24feed_1.0.13-2_armv7l.deb and not the the tgz. Tgz is an archive and has to be extracted before you install it.

                            so make "wget http://feed.flightradar24.com/raspbe...3-2_armv7l.deb" and install it
                            Regards,
                            T-EDDE7

                            Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                            Banana Pi | Mystique SDR R820T2 | stock Antenna

                            Comment


                            • Originally posted by equi View Post
                              Download the fr24feed_1.0.13-2_armv7l.deb and not the the tgz. Tgz is an archive and has to be extracted before you install it.

                              so make "wget http://feed.flightradar24.com/raspbe...3-2_armv7l.deb" and install it
                              Hi equi,

                              Thanks for your reply. Any idea why you're suggesting the v71 file and not the v61 file? I have the RPi Model B, not RPi 2 (aka Model B+ in my opinion).
                              T-EGBB16

                              Hardware: NooElec DVB-T2 Dongle, Raspi Pi2 Mod B, 6dB Collinear Antenna, Nevis Pre-Amp & 1090mhz SAW Filter, 9mtrs WF100 Cable and 28ft Mast.
                              Software: Rasbain Jessie Lite, FR24 Feeder, Dump1090mutab and VRS.
                              Stats for Mar 18, 2016. Uptime:100%. Aircraft seen:2,012. Positions Reported:486,817. Maximum Distance:243nm (Stats provided by FR24)

                              Comment


                              • no, he's suggesting that you can't install a tar.gz. Unpack the archive or get the .deb.

                                Comment

                                Working...
                                X