Announcement

Collapse
No announcement yet.

Flightradar24 decoder/feeder BETA testing (Win/RPi/Linux/OSX)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • We actually did release the Windows build if that's what you are looking for,, just didn't announce it very much as it hasn't gotten that much testing:

    http://feed.flightradar24.com/windows/

    Comment


    • From a very quick look at the init.d file in the debian package, it looks like it wants to run the feeder as root, which is a bit of a showstopper given that there's no source to review.
      Can you either provide a way to run with limited privileges, or consider releasing the source for inspection?

      Comment


      • Originally posted by obj View Post
        From a very quick look at the init.d file in the debian package, it looks like it wants to run the feeder as root, which is a bit of a showstopper given that there's no source to review.
        Can you either provide a way to run with limited privileges, or consider releasing the source for inspection?
        The packages are provided for users who do not want to be bothered trying to set everything up by themselves. We will distribute standalone binaries as well that do not need to be run as root. I'm away for 3 days but on Wednesday I am planning to make those releases.

        Comment


        • Brilliant Read Thanks - I'll go and get a Raspberry Pi now !
          James Lazzari BSc (Hons)
          T-EGCC125
          http://www.ukjay.co.uk

          Comment


          • Originally posted by piopawlu View Post
            The packages are provided for users who do not want to be bothered trying to set everything up by themselves. We will distribute standalone binaries as well that do not need to be run as root. I'm away for 3 days but on Wednesday I am planning to make those releases.
            Thanks, I look forward to that release.

            However.. shouldn't the standard packages run as a normal user by default, too? You can create a suitable user automatically during package install.
            The feeder should only be doing network work - nothing that requires root.
            dump1090 (if started by the feeder) needs, at most, USB access - and that doesn't require root, only suitable udev rules.

            In particular, speaking as someone who's worked with the dump1090 code, I really hope you are not starting dump1090 as root - this is risky - it hasn't had anything like the review needed to safely run as root. (I've fixed one remotely-triggerable memory corruption bug already, and I wasn't really looking hard..)
            Last edited by obj; 2014-11-16, 12:48.

            Comment


            • Originally posted by obj View Post
              However.. shouldn't the standard packages run as a normal user by default, too? You can create a suitable user automatically during package install.
              The feeder should only be doing network work - nothing that requires root.
              dump1090 (if started by the feeder) needs, at most, USB access - and that doesn't require root, only suitable udev rules.

              In particular, speaking as someone who's worked with the dump1090 code, I really hope you are not starting dump1090 as root - this is risky - it hasn't had anything like the review needed to safely run as root. (I've fixed one remotely-triggerable memory corruption bug already, and I wasn't really looking hard..)
              I fully agree, running as non-root is a lot safer, and works well.

              I'm running dump1090 from MR git and fr24feed_arm-rpi_242 (and same dump1090 and fr24feed_x64_242 in my another feeder), and in addition to /etc/udev/rules.d/20-rtlsdr.rules (I added the user running dump1090 (and same user for fr24feed_arm-rpi_242) to rtlsdr group and I have GROUP="rtlsdr" in 20-rtlsdr.rules) I just needed to chown the log files under /var/log/ to this user. Of course dump1090 HTMLPATH needs to be somewhere this non-rooot user can read it.

              The only "hack" was that the USB PID:VID in the bigger box was not (the standard?) 0bda:2838 but I needed to change that to 15f4:0131, but lsusb told be easily what it needs to be.

              I need to say fr24feed service running as root was one reason for me to stop using it, I don't see any reason to run it as root so I don't (switched to stand-alone fr24feed_arch_ver binaries instead).

              -Paavo

              Comment


              • I'm new to this thread but not new to FR24, ADS-B, receivers or Linux. I found the instructions for getting this decoder/feeder for the RPL/DVBT incomplete as I could find no way to continue porting data in any format to PlanePlotter (Raw Beast or AVR) or BS (30003). I especially require 30003 to feed my Java script for putting ADS-B and Mode-S data into my MySQL database but couldn't achieve that or a display on PlanePlotter.

                After following the download instructions and reconfiguring the package with my sharing key the process continues with a confusing request for the dump1090 installation. I selected Malcom's fork and started the service hoping to see outputs in PP and 30003 but neither ports were offering me data. The HTML page alluded that a connection to FR24 was OK and I was sending 4 planes but the same page also said port 30002 was spewing out raw data and 30003 BS data but in reality neither appeared to be the case.

                After fluffing about for an hour I concluded that it was easier to run three apps, Dump1090, FR Feeder for the RPi and my java script. So that's where I am at the moment and will remain so until either the software matures or the documentation specifically tells me how to run a service AND provide outputs in these formats.

                Good night, and good luck!
                Michael
                Palmerston North,
                New Zealand
                ex-FR24 Feeder

                Comment


                • Well I've set things up on my Raspberry Pi, but Haven't got a sharing Key?
                  Not sure if it's because I normally use your SBS1 client to share my data, so I'm stuck as it knows about me (N-EGCC10)
                  I just hope my email for help regarding this can help me get things going?
                  It will then save me running my old PC all the time .....
                  James Lazzari BSc (Hons)
                  T-EGCC125
                  http://www.ukjay.co.uk

                  Comment


                  • If you're currently using SBS1 Client, you'll need a sharing key for the "T" feeder.
                    Mike


                    www.radarspotting.com

                    Radarspotting since 2005

                    Comment


                    • Ok Thanks Anmer - I can't do this via raspberry, as it already knows about me, I just hope some kind soul will email me a sharing key soon :-)
                      James Lazzari BSc (Hons)
                      T-EGCC125
                      http://www.ukjay.co.uk

                      Comment


                      • I have skipped the sharing key & carried on with the set-up & chosen sbs1usb but for some reason it asks me for a com port number 1or2?
                        As I have plugged my sbs1 into the usb port of my raspberry pi this doesn't seem to make any sense to me.
                        So I'm stumped again & may have to carry on using the sbs1 client on my old PC?
                        Could anyone please advise me about this?
                        com port.JPG
                        James Lazzari BSc (Hons)
                        T-EGCC125
                        http://www.ukjay.co.uk

                        Comment


                        • I seem to have got past the usb problem now by entering /dev/bus/usb

                          wait though - still no luck as failure connecting to receiver

                          HELP!!!
                          Last edited by ukjay; 2014-11-17, 16:18. Reason: update
                          James Lazzari BSc (Hons)
                          T-EGCC125
                          http://www.ukjay.co.uk

                          Comment


                          • Originally posted by ukjay View Post
                            I seem to have got past the usb problem now by entering /dev/bus/usb

                            wait though - still no luck as failure connecting to receiver

                            HELP!!!
                            Hi ukjay,

                            I'm not familiar with SBS1 at all, I just know a little bit about DVB-T sticks and Linux in general.

                            But /dev/bus/usb is not a valid device address, you need to add two 3-digit numbers after that,
                            the number of the bus and then the number of the device in that bus.

                            E.g. my DVB-T stick is /dev/bus/usb/001/006, see below. Hope this helps.

                            -Paavo

                            Code:
                            $ lsusb
                            Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
                            Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
                            Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
                            Bus 001 Device 004: ID 2101:8500 ActionStar
                            Bus 001 Device 005: ID 2101:8501 ActionStar
                            Bus 001 Device 006: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
                            
                            $ ls -axl /dev/rtl_sdr
                            lrwxrwxrwx 1 root root 15 Jan  1  1970 /dev/rtl_sdr -> bus/usb/001/006
                            
                            $ ls -axl /dev/bus/usb/001/006
                            crw-rw-r-T 1 root rtlsdr 189, 5 Nov 17 19:08 /dev/bus/usb/001/006
                            
                            $ cat /etc/udev/rules.d/20-rtlsdr.rules
                            SUBSYSTEM=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2838", GROUP="rtlsdr", MODE="0666", SYMLINK+="rtl_sdr"

                            Comment


                            • Hi Paavo
                              Thanks for the help, I did try adding 001 to the end but may have still not got it exactly right, but looking at your help, I'll try again
                              Cheers!

                              Jay
                              James Lazzari BSc (Hons)
                              T-EGCC125
                              http://www.ukjay.co.uk

                              Comment


                              • Originally posted by ukjay View Post
                                Hi Paavo
                                Thanks for the help, I did try adding 001 to the end but may have still not got it exactly right, but looking at your help, I'll try again
                                Cheers!

                                Jay
                                Hi

                                Try this
                                Code:
                                /dev/ttyUSB0
                                I had a problem with baudrate settings maybe a bug so my mode-s beast work with this string
                                Code:
                                /dev/ttyUSB0@3000000
                                and baudrate set to default.
                                | T-EDDB8 |T-EDDB28 | Virtual Radar | Dump1090 | ModesMixer2 |

                                Comment

                                Working...
                                X