Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Andy, Try swapping the PSU, or maybe you may need a powered USB hub - the Pi can be fickle (you got an IPad / Galaxy Pad or something you can borrow the PSU from)
    Power the hub
    Take the Pi power from a hub port
    Pi USB data socket goes to hub
    Tuner dongle + WIFI attach to the hub.
    ...
    I'm just wondering if the processing required to handle all those extra planes and the WiFi is drawing more power than the power supply can satisfy.
    Maybe you can do a simple test with a multimeter ... if you position your Pi so the GPIO connector pins are top - right then look at this diagram
    http://www.hobbytronics.co.uk/raspberry-pi-gpio-pinout
    check the voltage on pins 2 & 6 on the right hand side - should be 5v

    Copy and paste should work OK (keyboard coding is about where the keys are located on the keyboard, not what the code produced is), but there's always the possibility that google drive has changed some of the characters in the text file to 'prettier ones' (like word changing a hyphen to en em-dash [whatever that is?]).

    BTW: I never managed to get my active USB extender to work from the Pi with the tuner dongle at the remote end.

    You may need to attach a monitor to the Pi HDMI to see if the Pi complains about something *shrug*

    (the most I've ever seen on my Pi is about 70 planes - maybe when I get the antenna up another 10 feet / 3m - to about 13m - I'll see more.
    Last edited by peterhr; 2013-09-23, 16:44.

    Comment


    • Originally posted by Jayant View Post
      This one is for you, Peter. I noticed that newer versions of Debian / Wheezy don't like init scripts which don't specify the boot sequence dependencies. Because of this, apt-get pops up a warning about missing LSB tags, something like this:

      warning: script 'fr24' missing LSB tags and overrides

      I added a standard (slightly tweaked) LSB header to your script and the warnings seem to have gone away. Here's what I added:

      ### BEGIN INIT INFO
      # Provides: fr24
      # Required-Start: $remote_fs $syslog $time
      # Required-Stop: $remote_fs $syslog $time
      # Should-Start: $network
      # Should-Stop: $network
      # Default-Start: 2 3 4 5
      # Default-Stop: 0 1 6
      # Short-Description: Start 1090dump and fr24 at boot time
      # Description: Start the RTL-SDR decoder and FlightRadar24 feeder at boot
      ### END INIT INFO

      I've put network dependency as optional since the scripts can in theory be started up without the network being up. It may be useful for you to try this out and add it into that excellent tutorial you've put up.

      The Pi project is still a work in progress for me, with getting a proper antenna and rigging it up being the top priority. Also working on:

      1) PoE to run power over the network cable (thanks for the links to PoE gear you posted!)
      2) Keeping the Pi cool, and
      3) Trying to get 3G connectivity going, but that's on the back burner so far.

      Waiting for mail-order parts can be very frustrating! :-)
      I've added those lines to my fr24.sh script, just after
      #!/bin/bash

      Made no difference to me, and may well help others ... I'll update the doc + standard script in google drive. [done]

      Thanks Jayant, good work
      Last edited by peterhr; 2013-09-23, 16:57. Reason: added [done]

      Comment


      • Originally posted by andyk1 View Post
        One more problem. Doesn't work on a wifi dongle either. I does work when I log in and go to the main screen as I've set it up and connects to my main wifi network but not when I restart to run as a stand alone as per your directions.
        Yes I set up the dhcp server and address reservation, mac address and all to 192.168.1.11 which is the wifi address but doesn't connect on reboot. I know wifi is a pain on the Pi because I've been reading that a lot. Anyway I got it to work plug into the lan and it works. other than the before mentioned problems. Anyone have the same problem and or salutation for these? Really need to figure out how to set my db lower than the default which was 49.something db on set up which was the default in rtl mostly I'm guessing.

        Well thanks in advance for all your help and cheers
        I would be looking at the power supply myself initially on this one. I had similar where wifi would be very problematic (although in my case it dropped after about 30 minutes and needed a reboot to kick back in). I changed to a HTC power supply and the thing has been up perfectly ever since.

        Comment


        • Thank peterhr but psu is fine. 2amps and only dongle and wireless mouse/keyboard dongle. hdmi video also. No I need to set the db output from default 49.60db to maybe 30db to test but haven't been able to figure out how. the rtl-sdr -g command does nothing for me. And as far as your PDF file yes google or whoever changed some characters on my end but also maybe win8 (Which I hate very, very much) I have the output to Windows fixed. Forgot to set port forwarding to 8080 but http://192.168.1.9:8080 still doesn't refresh. have to close internet explore and load the page to get an updated view

          As fir wifi. I have read a lot of people having difficulty getting it to work. Mine works just not with this dump1090 and fr24.sh setup at boot. Works when in the gui fine though.

          If you want to see what it's doing look here... http://72.198.39.195:8080

          Only going to be open for testing on this port to make things simple for now.

          P.S. I used a 1 amp psu from an old HTC phone and it worked fine. has never hung or any problems. also have heat sinks on it I ordered at the same time. works great other than strange antenna problem and of course wifi dongle out of the gui
          Last edited by andyk1; 2013-09-23, 17:22. Reason: edited for spellin
          Andy T-KTIK1

          RPI - http://Temporarily off Line due to t...98.37.214:8080

          Comment


          • For the record, I first setup the Pi using a Samsung travel adapter - the 2A version shown here: http://www.youtube.com/watch?v=73_KU4qCDeU. It worked beautifully until I got my powered Belkin 4-port desktop hub (2.4A adapter) and switched to that. Random hanging and reboots are almost certainly due to either a bad power supply or (just possibly) a bad SD card, though the latter is unlikely.

            As for WiFi - I got the Edimax EW-7811Un which is supposed to run out of the box, but sure enough, it didn't. Took me 3 days of fiddling with wpa_supplicant and /etc/network/interfaces to get it running. The device is detected, the drivers load up fine, but it refused to get an IP address from my router via dhcp. What I finally managed to do is to define a static IP address and the network parameters in /etc/network/interfaces and restart networking. This worked. I then switched just the static option to dhcp, and that worked too. I now have it configured for dhcp with 100% reliability and have moved my clear text PSK (very insecure) to the encrypted one supported by wpa_supplicant.

            While it is possible to make it work using only the interfaces file and not use wpa_supplicant at all, I found that you cannot uninstall wpa_supplicant because that seems to kill off some dependent service which is used by my network's WPA encryption. So you will definitely need to install it. (sudo apt-get install wpasupplicant).

            Hope that helps - if your wifi problems are not solved by fixing the power supply, let me know, and I'll post my working config here for reference. The same config should work, even if your hardware is different, provided the hardware and it's driver loads up at boot.
            T-VABB7 | RTL dongle + Raspberry Pi + dump1090 + Bulgarian 5dBi collinear

            Comment


            • Thanks Jayant!!!

              Am using a psu from a nexus 7 which works great now. That's not my problem. Strange reception problem from the 15 meter tall antenna not receiving on the pi to the little cheap antenna working but works in wincrap8
              Last edited by andyk1; 2013-09-23, 17:38. Reason: spellin, again
              Andy T-KTIK1

              RPI - http://Temporarily off Line due to t...98.37.214:8080

              Comment


              • Originally posted by andyk1 View Post
                Thank peterhr but psu is fine. 2amps and only dongle and wireless mouse/keyboard dongle. hdmi video also. No I need to set the db output from default 49.60db to maybe 30db to test but haven't been able to figure out how. the rtl-sdr -g command does nothing for me. And as far as your PDF file yes google or whoever changed some characters on my end but also maybe win8 (Which I hate very, very much) I have the output to Windows fixed. Forgot to set port forwarding to 8080 but http://192.168.1.9:8080 still doesn't refresh. have to close internet explore and load the page to get an updated view

                As fir wifi. I have read a lot of people having difficulty getting it to work. Mine works just not with this dump1090 and fr24.sh setup at boot. Works when in the gui fine though.

                If you want to see what it's doing look here... http://72.198.39.195:8080

                Only going to be open for testing on this port to make things simple for now.

                P.S. I used a 1 amp psu from an old HTC phone and it worked fine. has never hung or any problems. also have heat sinks on it I ordered at the same time. works great other than strange antenna problem and of course wifi dongle out of the gui
                The @reboot cron job does a sleep, maybe that needs to have a much longer pause to give the WIFI a chance to get going.

                While you get no output elsewhere, what does
                top
                (in your putty session) tell you ... have you ran out of CPU?

                Just noticed dump1090 has --lat and --lon parameters - set those to your general location ( one decimal place) and the interactive map opens where you are.
                Last edited by peterhr; 2013-09-23, 17:42.

                Comment


                • Originally posted by peterhr View Post
                  The @reboot cron job does a sleep, maybe that needs to have a much longer pause to give the WIFI a chance to get going.

                  While you get no output elsewhere, what does
                  top
                  (in your putty session) tell you ... have you ran out of CPU?

                  Just noticed dump1090 has --lat and --lon parameters - set those to your general location ( one decimal place) and the interactive map opens where you are.
                  top - 12:46:11 up 11 min, 1 user, load average: 0.66, 0.58, 0.34
                  Tasks: 59 total, 2 running, 57 sleeping, 0 stopped, 0 zombie
                  %Cpu(s): 50.5 us, 6.6 sy, 0.0 ni, 41.9 id, 0.0 wa, 0.0 hi, 1.0 si, 0.0 st
                  KiB Mem: 383712 total, 63084 used, 320628 free, 8780 buffers
                  KiB Swap: 102396 total, 0 used, 102396 free, 24852 cached

                  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
                  2076 pi 20 0 14788 4972 864 R 54.6 1.3 6:04.03 dump1090
                  2173 pi 20 0 4664 1428 1028 R 1.3 0.4 0:00.60 top
                  Andy T-KTIK1

                  RPI - http://Temporarily off Line due to t...98.37.214:8080

                  Comment


                  • Originally posted by peterhr View Post
                    The @reboot cron job does a sleep, maybe that needs to have a much longer pause to give the WIFI a chance to get going.

                    While you get no output elsewhere, what does
                    top
                    (in your putty session) tell you ... have you ran out of CPU?

                    Just noticed dump1090 has --lat and --lon parameters - set those to your general location ( one decimal place) and the interactive map opens where you are.
                    I tried longer sleeps up to 30 but no help. Set it back to 5 for the eithernet connection
                    Andy T-KTIK1

                    RPI - http://Temporarily off Line due to t...98.37.214:8080

                    Comment


                    • Just noticed dump1090 has --lat and --lon parameters - set those to your general location ( one decimal place) and the interactive map opens where you are.

                      And how do I go about setting my lat and long. Save me some time looking it up as I am working on a bunch of different projects.... thanks
                      Andy T-KTIK1

                      RPI - http://Temporarily off Line due to t...98.37.214:8080

                      Comment


                      • Originally posted by andyk1 View Post
                        Code:
                        top - 12:46:11 up 11 min,  1 user,  load average: 0.66, 0.58, 0.34
                        Tasks:  59 total,   2 running,  57 sleeping,   0 stopped,   0 zombie
                        %Cpu(s): 50.5 us,  6.6 sy,  0.0 ni, 41.9 id,  0.0 wa,  0.0 hi,  1.0 si,  0.0 st
                        KiB Mem:    383712 total,    63084 used,   320628 free,     8780 buffers
                        KiB Swap:   102396 total,        0 used,   102396 free,    24852 cached
                        
                          PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
                         2076 pi        20   0 14788 4972  864 R  54.6  1.3   6:04.03 dump1090
                         2173 pi        20   0  4664 1428 1028 R   1.3  0.4   0:00.60 top
                        Dump1090 is certainly busy - mine tends to run at 40% with 50-60 planes, so you must have more. displaying the web page adds about 2%

                        find where you are in google maps, right click, select 'whats here' that give you your lat and lon which you can round so it doesn't mark your absolute location

                        something like this?

                        ./dump1090 --net --net-sbs-port 30003 --quiet --lat 35.5 --lon -97.5 > /dev/null
                        Last edited by peterhr; 2013-09-23, 17:57. Reason: --lat --lon

                        Comment


                        • "As for WiFi - I got the Edimax EW-7811Un which is supposed to run out of the box, but sure enough, it didn't. Took me 3 days of fiddling with wpa_supplicant and /etc/network/interfaces to get it running"

                          I have the B-link wifi dongle from amazon. Can't find the link as it's been 8-9 months and no longer on my orders page. Anyway the B-link surprised me as it was $4.99 or so at the time and now like $10:00 but it set up and work great. I hooked it up to the Pi when I got it and it recognized it right away and set up easily in the gui (whezzy) I have no problems it working in the GUI. just not with the cron start which I'll work on later.
                          Andy T-KTIK1

                          RPI - http://Temporarily off Line due to t...98.37.214:8080

                          Comment


                          • AndyK1 - Just to make sure: You have the PI connected to the 15m high antenna (and then no AC), but the same RTL dongle indoors on Wincrap with the magmount antenna (then you get AC).
                            Have you tested the antenna to make sure there's no short of bad connection?
                            Can you connect the outdoor antenna to the windows setup and see what you get then ?

                            Comment


                            • Originally posted by peterhr View Post
                              Dump1090 is certainly busy - mine tends to run at 40% with 50-60 planes, so you must have more. displaying the web page adds about 2%

                              find where you are in google maps, right click, select 'whats here' that give you your lat and lon which you can round so it doesn't mark your absolute location

                              something like this?

                              ./dump1090 --net --net-sbs-port 30003 --quiet --lat 35.5 --lon -97.5 > /dev/null
                              Hehe oh crap Ok. I just remembered reading that somewhere. Ya I know my lat and long so thanks.
                              Andy T-KTIK1

                              RPI - http://Temporarily off Line due to t...98.37.214:8080

                              Comment


                              • Ya I see it's working but see no output in 192.168.1.9:8080 or in putty. I read somewhere that you have to change and play with the db setting by lowering them if not receiving a/c
                                Andy T-KTIK1

                                RPI - http://Temporarily off Line due to t...98.37.214:8080

                                Comment

                                Working...
                                X