Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I've just set up a RPi2 and it appears to be feeding into the FR24 but if I check the status I get this....

    @raspberrypi ~ $ sudo service fr24feed status -l
    fr24feed.service - LSB: Flightradar24 Decoder & Feeder
    Loaded: loaded (/etc/init.d/fr24feed)
    Active: active (running) since Sun 2015-10-11 22:09:02 BST; 9min ago
    Process: 2214 ExecStop=/etc/init.d/fr24feed stop (code=exited, status=0/SUCCESS)
    Process: 2280 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/fr24feed.service
    2295 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=2
    2315 /usr/lib/fr24/mr-dump1090 --raw

    Oct 11 22:09:02 raspberrypi fr24feed[2280]: Starting FR24 feeder: fr24feed.
    Oct 11 22:09:02 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder & Feeder.

    Is there something wrong?

    Also is there any way to monitor my feeds?

    Comment


    • Originally posted by n6ly View Post
      I see my station (T-KOAR1) says online, but no stats or upload data rate.
      Hi! I think you might be feeding FlightAware MLAT data back to FR24. I notice that when non-ADS-B planes go over my station in the San Fernando Valley (T-KIZA1) and into the Central Valley they switch from T-MLAT2 to T-KOAR1.

      I'm not 100% sure, but I think Flightaware may have recently released new code that no longer does this.

      Comment


      • A step by step "how to guide" on Youtube would be a great help. I have been trying for about 5 days to get FR24 & Pi working without success.

        Thanks,

        Bob.

        Comment


        • You start with one. Get it working. And add the other. There is a guide on the FA forum for this. FA will auto detect half the stuff it needs are present already.
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • Hello, I got a problem with my PI2 and fr24feed:
            awnZdna.png

            So, after restarting the service, it will work for 1 day or maybe 2 days and then it will just exit.
            Fr24feed restart helps, but I forget about it and I have holes in sharing.

            Anyone had the similar problem and how did you solve it?
            Thanks!

            Comment


            • I picked up one of these dongles NooElec NESDR to use on my RPI 2B. Can't seem to get it to work though.

              $: lsusb prints

              Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
              So I have my COM/DEV/PATH set to: /dev/bus/usb/001/004

              Not sure if that's right either. Help plz!

              Comment


              • I set process arguments in settings on 8754 port as --net-http-port 8080 ,but after restarting I can not access map on 8080 port? How do I access map?

                Comment


                • You need to post the starting text to ensure you have it configured in the right spot. As if using wrong connector dump1090 may not be supported

                  Sent from my GT-I9300 using Tapatalk
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • You need "--net --net-http-port 8080", but dump1090 is running default on port 8080...
                    Regards,
                    T-EDDE7

                    Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                    Banana Pi | Mystique SDR R820T2 | stock Antenna

                    Comment


                    • Here's what I use for my feeder....IMAG0579.jpg
                      TRAXA PiCAT5 power over ethernet and matched injector and a Raspberry Pi2... Only one cable to run outdoors, and as it's not carrying the ADS-B rf signals it can be 10m long..
                      The only issues I have is random feed stops.. But a SUDO APT-GET UPDATE and SUDO APT-GET UPGRADE fixes the problems..

                      Paul.

                      Comment


                      • Does anyone used this type RLT-SDR modem as USB dongle? May i know its compatible with raspberry PI or not. Or any review of this how its works ?

                        SDR2.jpgSDR2-2.jpg

                        Thanks in advance.

                        Comment


                        • It says that it uses RTL2832 + R820T2, which is what's inside most DVB-T sticks.
                          Looks like they just put the hardware in a little box rather than a USB stick, so I would assume it should work.
                          I'd try setting it up as if it was a DVB-T stick and see what happens.

                          No guarantee though!!

                          Comment


                          • Hey can everyone help me? I installed the feeder with a DVB-T stick on a Raspberry Pi 2, later on a Orange Pi on. One both platforms the feeding won't work...

                            My logfile:
                            2016-04-26 16:26:54 | [main][i]FR24 Feeder/Decoder
                            2016-04-26 16:26:54 | [main][i]Version: 1.0.18-5/generic
                            2016-04-26 16:26:54 | [main][i]Built on Mar 4 2016 15:21:10
                            2016-04-26 16:26:54 | [main][i]Copyright 2012-2016 Flightradar24 AB
                            2016-04-26 16:26:54 | [main][i]fr24
                            2016-04-26 16:26:54 | [main][i]DNS mode: LIBC/PING
                            2016-04-26 16:26:54 | [main][i]Automatic updates are DISABLED
                            2016-04-26 16:26:54 | ERROR
                            2016-04-26 16:26:54 | [httpd][i]Server started, listening on 0.0.0.0:8754
                            2016-04-26 16:26:54 | [main][i]Reader thread started
                            2016-04-26 16:26:54 | [reader][i]Initializing reader
                            2016-04-26 16:26:54 | [main][i]Socket server started
                            2016-04-26 16:26:54 | [main][i]MLAT data feed started
                            2016-04-26 16:26:54 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090 --raw --mlat)
                            2016-04-26 16:26:54 | [master][i]Starting processing thread
                            2016-04-26 16:26:54 | [bs][i]Initializing server
                            2016-04-26 16:26:54 | [bs][i]Starting server on 0.0.0.0:30003
                            2016-04-26 16:26:54 | [reader][i]Connected to the receiver, configuring
                            2016-04-26 16:26:54 | [reader][i]Configured, processing messages
                            2016-04-26 16:26:54 | [mlat][i]Waiting for MLAT configuration
                            2016-04-26 16:26:55 | [time][i]Synchronizing time via NTP
                            2016-04-26 16:26:55 | [time][e]Failed to synchronize time
                            2016-04-26 16:26:55 | [main][w]Failed to synchronize time, waiting 5 seconds
                            2016-04-26 16:27:00 | [time][i]Synchronizing time via NTP
                            2016-04-26 16:27:13 | [time][i]Time synchronized correctly, offset +1.0105 seconds
                            2016-04-26 16:27:13 | [main][i]Feed Network client started
                            2016-04-26 16:27:13 | [main][i]RAW data server started
                            2016-04-26 16:27:13 | [feed][i]Downloading configuration
                            2016-04-26 16:27:13 | [raw][i]Initializing server
                            2016-04-26 16:27:13 | [raw][i]Starting server on 0.0.0.0:30002
                            2016-04-26 16:27:13 | [feed][c]Interval: 5s
                            2016-04-26 16:27:13 | [feed][c]Latitude: 46.2103
                            2016-04-26 16:27:13 | [feed][c]Longitude: 7.1662
                            2016-04-26 16:27:13 | [feed][c]GND: YES
                            2016-04-26 16:27:13 | [feed][c]NonADSB: YES
                            2016-04-26 16:27:13 | [feed][c]Timestamps: optional
                            2016-04-26 16:27:13 | [feed][c]Max range AIR: 350.0nm
                            2016-04-26 16:27:13 | [feed][c]Max range GND: 100.0nm
                            2016-04-26 16:27:13 | [stats][i]Stats thread started
                            2016-04-26 16:27:13 | [feed][i]defined 4 servers
                            2016-04-26 16:27:13 | [feed][n]LSZB49@83.149.28.97:8099/UDP
                            2016-04-26 16:27:13 | [feed][n]connecting
                            2016-04-26 16:27:13 | [feed][n]connected via UDP (fd 10)
                            2016-04-26 16:27:13 | [feed][n]working
                            2016-04-26 16:27:43 | [feed][n]ping 1
                            2016-04-26 16:27:44 | [feed][n]syncing stream: 1
                            2016-04-26 16:28:13 | [feed][n]ping 2
                            2016-04-26 16:28:14 | [feed][n]syncing stream: 1
                            2016-04-26 16:28:43 | [feed][n]ping 3
                            2016-04-26 16:28:44 | [feed][n]syncing stream: 1
                            2016-04-26 16:29:13 | [feed][n]ping 4
                            2016-04-26 16:29:14 | [feed][n]syncing stream: 1
                            2016-04-26 16:29:43 | [feed][n]ping 5
                            2016-04-26 16:29:44 | [feed][n]syncing stream: 1

                            This will continue until i stop fr24feeder....

                            root@orangepi:~# service fr24feed status
                            [ ok ] FR24 Feeder/Decoder Process: running.
                            [ ok ] FR24 Stats Timestamp: 2016-04-26 16:52:37.
                            [ ok ] FR24 Link: connected [UDP].
                            [ ok ] FR24 Radar: T-LSZB49.
                            [ ok ] FR24 Tracked AC:.
                            [ ok ] Receiver: connected (0 MSGS/0 SYNC).
                            [FAIL] FR24 MLAT: not running ... failed!

                            Comment


                            • @LSZB11:

                              (1) First try this:
                              If you know IP address of your R Pi on your LAN (find from your router/LAN setup), then you can type following in your browser

                              http://<IP address of your R Pi on LAN>:8754/settings.html

                              (example - my RPi's IP address on my LAN is 192.168.2.17, so I will type in browser http:// 192.168.2.17:8754/settings.html)

                              Then check/adjust your settings


                              (2) If above fails, do this:
                              First remove the fr24 datafeeder you have already installed on Raspberry Pi & Orange Pi, then follow instructions on the page linked below:

                              https://www.flightradar24.com/raspberry-pi

                              Then type following in your browser:

                              http://<IP address of your R Pi on LAN>:8754/settings.html

                              Then check/adjust your settings.
                              .
                              Last edited by abcd567; 2016-04-29, 06:35.

                              Comment


                              • Thanks for your help!

                                Still the same effect as before. I installed everything new on my PI (included Raspbian) and edited the settings on the webpanel.

                                I think, there are some troubles with my DVB-T stick. Maybe a chipset that is not supportet from fr24? On windows, the feeder from fr24 works perfectly with this receiver (Terratec Cinergy).

                                Output of dump1090, when fr24feed is not running: (/usr/lib/fr24/dump1090 --raw)
                                Found 1 device(s):
                                0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                                Found Elonics E4000 tuner
                                Max available gain is: 42.00
                                Setting gain to: 42.00
                                Exact sample rate is: 2000000.052982 Hz
                                Gain reported by device: 42.00
                                Failed to submit transfer 12!
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...
                                cb transfer status: 5, canceling...

                                (DVB stick on powered USB-Hub)
                                Last edited by LSZB11; 2016-04-30, 16:11.

                                Comment

                                Working...
                                X