Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi agardk,

    I use a 16GB SD Card and I have no problems with it. It works alot better too due to length of some log files that's used in the dump 1090.

    Here is a link for the latest Raspberry Pi software and Instructions on installation. you'll need the RPi 2 .deb file armv71.deb

    Software Link: http://feed.flightradar24.com/raspberry-pi/
    Instructions: http://feed.flightradar24.com/fr24feed-manual.pdf

    Hope that helps :-)
    T-EGBB16

    Hardware: NooElec DVB-T2 Dongle, Raspi Pi2 Mod B, 6dB Collinear Antenna, Nevis Pre-Amp & 1090mhz SAW Filter, 9mtrs WF100 Cable and 28ft Mast.
    Software: Rasbain Jessie Lite, FR24 Feeder, Dump1090mutab and VRS.
    Stats for Mar 18, 2016. Uptime:100%. Aircraft seen:2,012. Positions Reported:486,817. Maximum Distance:243nm (Stats provided by FR24)

    Comment


    • Hello guys,

      I just received today a DVB-T receiver and installed on my win laptop the drivers and software to feed to FR24, I wanted to ask you guys, when I'll receive the Raspbery Pi B can I install 2 dvb-t sticks and use one for FR24 and one for LiveATC ?

      Thank you.

      Comment


      • Hey all,

        im new in this forum and happy to be a member in this community. Its my first time use fr24 tracking with my raspberry (1) and i have some issue with submitting data. I try to use search-function in this forum but i canīt find a solution. I will post some informations now and it will be great if you can help me or give me a link to find out more about my problem.

        Fresh installation:

        pi@flightcenter /etc/modprobe.d $ cat /proc/version
        Linux version 3.18.11+ (dc4@dc4-XPS13-9333) (gcc version 4.8.3 20140303 (prerelease) (crosstool-NG linaro-1.13.1+bzr2650 - Linaro GCC 2014.03) ) #781 PREEMPT Tue Apr 21 18:02:18 BST 2015

        pi@flightcenter /etc/modprobe.d $ lsusb
        Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
        Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
        Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
        Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
        Bus 001 Device 012: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
        Bus 001 Device 006: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
        Bus 001 Device 007: ID 046d:c52b Logitech, Inc. Unifying Receiver

        pi@flightcenter /etc/modprobe.d $ sudo service fr24feed status
        [ ok ] FR24 Feeder/Decoder Process: running.
        [ ok ] FR24 Stats Timestamp: 2015-06-05 18:36:35.
        [ ok ] FR24 Link: connected [UDP].
        [ ok ] FR24 Radar: T-EDDL39.
        [ ok ] FR24 Tracked AC:.
        [ ok ] Receiver: connected (1 MSGS/0 SYNC).

        If i open the site in my browser on flightcenter:8754 it shows

        Flightradar24 Feeder/Decoder
        N/A
        Updated: N/A

        FR24 Link: ...
        FR24 Radar Code: ...
        Aircraft Tracked (ModeS & ADS-B): N/A
        Aircraft Uploaded: N/A
        Receiver: N/A

        After refresh

        Flightradar24 Feeder/Decoder
        Linux/generic/armv6l/1.0.13-2
        Updated: 20:38:17 GMT+0200

        FR24 Link: Connected via UDP
        FR24 Radar Code: T-EDDL39
        Aircraft Tracked (ModeS & ADS-B): 0
        Aircraft Uploaded: N/A
        Receiver: dvbt-mr, Connected

        After refresh itīs N/A again.

        Feel like that the software (or feed) is in restarting-loop. I hope you can give me some more informations!

        Thanks a lot and best regards,
        Flash
        T-EDDL150

        Comment


        • I think that the current software build has issues, because I can't get my feed to work for more than a few minutes, and it doesn't submit any aircraft. I'm using 2 different machines, with 2 different dongles and different OS's and the end result is the same. It was working fine 2 weeks ago when I was using the unsupported old version (which ran with no problems or machine reboots for 6+ months until the SD card wore out).

          Comment


          • Pu very strange...

            I now have my PI and Feed running! But if i try to use ./dump1090 (or option for web-output on 8080) it doesnīt work.

            pi@flightcenter ~ $ sudo service fr24feed status
            [ ok ] FR24 Feeder/Decoder Process: running.
            [ ok ] FR24 Stats Timestamp: 2015-06-06 19:01:34.
            [ ok ] FR24 Link: connected [UDP].
            [ ok ] FR24 Radar: T-EDDL39.
            [ ok ] FR24 Tracked AC:.
            [FAIL] Receiver: down ... failed!

            Without using 8080 for browser:

            pi@flightcenter ~ $ sudo service fr24feed status
            [ ok ] FR24 Feeder/Decoder Process: running.
            [ ok ] FR24 Stats Timestamp: 2015-06-06 19:11:33.
            [ ok ] FR24 Link: connected [UDP].
            [ ok ] FR24 Radar: T-EDDL39.
            [ ok ] FR24 Tracked AC: 7.
            [ ok ] Receiver: connected (7879 MSGS/0 SYNC).

            If this helps?

            pi@flightcenter ~ $ rtl_test -t
            Found 1 device(s):
            0: Realtek, RTL2838UHIDIR, SN: 00000001

            Using device 0: Generic RTL2832U OEM

            Kernel driver is active, or device is claimed by second instance of librtlsdr.
            In the first case, please either detach or blacklist the kernel module
            (dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

            usb_claim_interface error -6
            Failed to open rtlsdr device #0.

            In fr24feed.log i found:

            2015-06-06 20:50:58 | [reader][i][0]Connected to the receiver, authenticating
            2015-06-06 20:50:58 | [reader][i][0]Authenticated, processing messages
            2015-06-06 20:50:58 | [reader][i][0]Connection terminated
            2015-06-06 20:50:58 | [main][i]Terminating child process 2765 with SIGETERM
            2015-06-06 20:51:04 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090 --interactive --net --net-http-port 8080 --raw)

            Can i use FR24Feed only without ./dump1090 --net --interactive ?
            Last edited by Flash; 2015-06-06, 19:22.
            T-EDDL150

            Comment


            • Please Help
              I don't know what I'm doing wrong.

              My rpi2 is connected on internet via wifi dongle and it's work.

              Check this:
              pi@raspberrypi ~ $ service fr24feed status
              [ ok ] FR24 Feeder/Decoder Process: running.
              [ ok ] FR24 Stats Timestamp: 2015-07-22 19:28:04.
              [ ok ] FR24 Link: connected [UDP].
              [ ok ] FR24 Radar: T-LDZA19.
              [ ok ] FR24 Tracked AC:.
              [FAIL] Receiver: down ... failed!
              [ ok ] FR24 MLAT: ok [UDP].
              [ ok ] FR24 MLAT AC seen: 0.

              Why is receiver down?

              And I cant connect on hxxp:// rpi address:8080, only work with hxxp:// rpi address:8754/

              Comment


              • go to your address :8754 and change your donge type, probaly you have "dtbt-mr" change to dvbt, save and restart page, afther that you are getting the same error be patient wait 4/5m and all is working fine.

                post feedback

                cheers

                Comment


                • I already have dongle type "dvbt"

                  and this message:
                  Error opening the listening port 30002 (Raw TCP output): bind: Address already in use

                  Comment


                  • this is my settings hope that help you

                    settings.JPG

                    Comment


                    • Originally posted by pero View Post
                      I already have dongle type "dvbt"

                      and this message:
                      Error opening the listening port 30002 (Raw TCP output): bind: Address already in use
                      Ensure BS/RAW OUT on fr24 is off
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • Originally posted by pero View Post
                        Please Help
                        I don't know what I'm doing wrong.

                        My rpi2 is connected on internet via wifi dongle and it's work.

                        Check this:
                        pi@raspberrypi ~ $ service fr24feed status
                        [ ok ] FR24 Feeder/Decoder Process: running.
                        [ ok ] FR24 Stats Timestamp: 2015-07-22 19:28:04.
                        [ ok ] FR24 Link: connected [UDP].
                        [ ok ] FR24 Radar: T-LDZA19.
                        [ ok ] FR24 Tracked AC:.
                        [FAIL] Receiver: down ... failed!
                        [ ok ] FR24 MLAT: ok [UDP].
                        [ ok ] FR24 MLAT AC seen: 0.

                        Why is receiver down?

                        And I cant connect on hxxp:// rpi address:8080, only work with hxxp:// rpi address:8754/
                        Are you running dump1090 independently of fr24feed (either on its own, or with piaware)? If you are, change the fr24feed.ini file

                        Code:
                        sudo nano /etc/fr24feed.ini
                        Look for the line that reads
                        Code:
                        receiver="dvbt-mr"
                        and replace with
                        Code:
                        receiver="avr-tcp"
                        That's how I solved my problem, caused by running an outside instance of dump1090.

                        Comment


                        • Changing fr24fedd.ini or making changes on localhost:8754 is the same thing...... Anyway I'm glad that your problem as been solved. 👍

                          Sent from my SM-N910F using Tapatalk

                          Comment


                          • Originally posted by abcd567 View Post
                            @Scroggie:

                            How to enable dump1090 to display aircrafts on Google Map in a Browser:

                            In order to pin-point the problem, I decided to go step by step to see where the problem lies.
                            1. Formatted my microSD, erasing installed Raspbian+Dump1090+FR24 feeder.
                            2. Installed Raspbian (NOOBS), then Dump1090. Did NOT install FR24 feeder.
                            3. Booted RPi, and typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map did NOT display
                            4. opened Console & gave command:

                            cd dump1090
                            ./dump1090 --interactive --net --net-http-port 8080
                            Then again typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map Started DISPLAYING with aeroplanes

                            I then closed the console, Map became blank

                            5. ReBooted the RPi, typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map did NOT display

                            Cocnclusion: Net interface is active only if a command is given to start it & console is kept open.
                            Solution: Change .ini settings of Dump1090 to start net interface automatically at Boot & keep it open unless closed manually.
                            I checked web for any script or settings to do it, and found one script to automatically start net connection at http://www.satsignal.eu/raspberry-pi/dump1090.html.

                            I applied the procedure to my RPi & and now web interface works ok

                            Here is the procedure:

                            First create a blank script file "dump1090.sh" with the command:

                            sudo nano /etc/init.d/dump1090.sh
                            Now copy and paste the following code into the new file, and save the file (Ctrl+O), then exit nano text editor back to console (Ctrl+X):

                            #!/bin/bash
                            ### BEGIN INIT INFO
                            #
                            # Provides: dump1090
                            # Required-Start: $remote_fs
                            # Required-Stop: $remote_fs
                            # Default-Start: 2 3 4 5
                            # Default-Stop: 0 1 6
                            # Short-Description: dump1090 initscript

                            #
                            ### END INIT INFO
                            ## Fill in name of program here.
                            PROG="dump1090"
                            PROG_PATH="/home/pi/dump1090"
                            PROG_ARGS="--interactive --net --net-ro-size 500 --net-ro-rate 5"
                            PIDFILE="/var/run/dump1090.pid"

                            start() {
                            if [ -e $PIDFILE ]; then
                            ## Program is running, exit with error.
                            echo "Error! $PROG is currently running!" 1>&2
                            exit 1
                            else
                            ## Change from /dev/null to something like /var/log/$PROG if you want to save output.
                            cd $PROG_PATH
                            ./$PROG $PROG_ARGS 2>&1 >/dev/null &
                            echo "$PROG started"
                            touch $PIDFILE
                            fi
                            }

                            stop() {
                            if [ -e $PIDFILE ]; then
                            ## Program is running, so stop it
                            echo "$PROG is running"
                            killall $PROG
                            rm -f $PIDFILE
                            echo "$PROG stopped"
                            else
                            ## Program is not running, exit with error.
                            echo "Error! $PROG not started!" 1>&2
                            exit 1
                            fi
                            }

                            ## Check to see if we are running as root first.
                            ## Found at http://www.cyberciti.biz/tips/shell-...ck-script.html
                            if [ "$(id -u)" != "0" ]; then
                            echo "This script must be run as root" 1>&2
                            exit 1
                            fi

                            case "$1" in
                            start)
                            start
                            exit 0
                            ;;
                            stop)
                            stop
                            exit 0
                            ;;
                            reload|restart|force-reload)
                            stop
                            start
                            exit 0
                            ;;
                            **)
                            echo "Usage: $0 {start|stop|reload}" 1>&2
                            exit 1
                            ;;
                            esac
                            exit 0
                            Now make this file executable with the following command:

                            sudo chmod +x /etc/init.d/dump1090.sh
                            Now create the run level shortcuts with the command:

                            sudo update-rc.d dump1090.sh defaults
                            Reboot the RPi. You can now see Google map displayed in your browser by typing http://<IP address of your RPi on LAN>:8080.

                            If you want, you can stop or restart dump1090 manually with the commands:

                            sudo /etc/init.d/dump1090.sh stop
                            or
                            sudo /etc/init.d/dump1090.sh start
                            Dear abcd567 Bro,

                            Hope you are doing fine. I am installing some RPI for MLAT coverage in my area, but with all of your try, i could not bring the planes in google map. I think you are the only person to solve it. Planes feeding but i cannot see my coverage, thats a pain ! I added some screenshot for your reference. Plz tell me where is did the wrong, Plz help me.

                            Thanks,
                            Zahidul Hasan
                            T-VGHS1
                            T-VGHS2
                            T-VGHS10
                            F-VGCB1Settings.jpgStatus.pngStatus-2.png

                            Comment


                            • Originally posted by zahidulhasan View Post
                              Dear abcd567 Bro,

                              Hope you are doing fine. I am installing some RPI for MLAT coverage in my area, but with all of your try, i could not bring the planes in google map. I think you are the only person to solve it. Planes feeding but i cannot see my coverage, thats a pain ! I added some screenshot for your reference. Plz tell me where is did the wrong, Plz help me.

                              Thanks,
                              Zahidul Hasan
                              T-VGHS1
                              T-VGHS2
                              T-VGHS10
                              F-VGCB1[ATTACH=CONFIG]6361[/ATTACH][ATTACH=CONFIG]6362[/ATTACH][ATTACH=CONFIG]6363[/ATTACH]
                              Hi Zahid!
                              From screenshots of settings you have posted, apparently everything looks ok.
                              I have not yet installed new feeder with MLAT and still using the old feeder.
                              I therefore cannot guide you, unless I install it myself.
                              Regards
                              abcd

                              Comment


                              • Dear community,

                                today I installed raspbian on one of my spare RPi, equipped with an USB DVB-T stick:
                                Code:
                                pi@fr24feeder ~ $ lsusb
                                Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
                                Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
                                Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
                                Bus 001 Device 004: ID 15a4:9016 Afatech Technologies, Inc. AF9015 DVB-T USB2.0 stick
                                Bus 001 Device 005: ID 0c45:7000 Microdia
                                The problem is that the fr24feeder is showing receiver as down:

                                Code:
                                pi@fr24feeder ~ $ sudo service fr24feed status
                                [ ok ] FR24 Feeder/Decoder Process: running.
                                [ ok ] FR24 Stats Timestamp: 2015-09-22 21:53:49.
                                [ ok ] FR24 Link: connected [UDP].
                                [ ok ] FR24 Radar: T-LKPR61.
                                [ ok ] FR24 Tracked AC:.
                                [FAIL] Receiver: down ... failed!
                                [ ok ] FR24 MLAT: ok [UDP].
                                [ ok ] FR24 MLAT AC seen: 0.
                                The log says:
                                Code:
                                2015-09-22 21:54:22 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090  --raw --mlat)
                                2015-09-22 21:54:22 | [reader][i][0]Connected to the receiver, authenticating
                                2015-09-22 21:54:22 | [reader][i][0]Authenticated, processing messages
                                2015-09-22 21:54:22 | [reader][i][0]Connection terminated
                                2015-09-22 21:54:22 | [main][i]Terminating child process 6304 with SIGETERM
                                Do I need a special USB DVB-T stick to have it working?

                                Many thanks

                                Mike

                                Comment

                                Working...
                                X