Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dear friend,

    I have some experience to work with linux, and i already completed setup my feeder with RPI B+. Now its on service. Currently i am operating two feeder(T-VGHS1 & 2) in Dhaka Bangladesh.

    Thanks again for the extreme help.

    Thanks,
    Zahidul Hasan.

    Comment


    • @zahidulhasan:

      Hi Zahidul Hasan!
      Great to know that you know Linux and have already completed your setup.
      I was not aware of it. Since there was no feed back from you about your completion of setup, I felt may be you were not familiar with Linux commands, got terrified seeing a long list of commands, and quit . My last post was for this situation, not only for you, but for anyone unfamiliar with Linux.

      Comment


      • I had a look there and found:- "You can use the "--net" option but you must disable "basestation" and "raw" output in the fr24feed. It's mentioned in the manual and a few times in this thread. The problem is that the --net option duplicates the data feeds services."
        I just can't find how to do that. Also where can I find the "manual"

        Comment


        • Originally posted by Scroggie View Post
          I had a look there and found:- "You can use the "--net" option but you must disable "basestation" and "raw" output in the fr24feed. It's mentioned in the manual and a few times in this thread. The problem is that the --net option duplicates the data feeds services."
          I just can't find how to do that. Also where can I find the "manual"
          You have to do it in file "fr24feed.ini". Default location is /etc/fr24feed.ini. Open & edit this file by nano command:

          cd /etc
          sudo nano fr24feed.ini


          Change "yes" to "no" for bs & raw.
          Save the file (Ctrl+O, then press Enter).
          Reboot the RPi (sudo reboot).

          From Manual page 1:
          Currently supported operating systems:
          Linux (ARM=Raspberry Pi, BeagleBoard, x86, x64) MacOS X (10.9 Mavericks or later) Microsoft Windows (XP or later)

          Currently supported receivers:
          Kinetics SBS1, SBS1er, SBS3 - USB and Network Mode-S Beast - USB and Network Most DVBT sticks - USB and Network Most “AVR” compatible receivers - USB/Serial and Network

          2. Installation and Configuration
          2.1 Linux
          2.1.1 Requirements

          When using any receiver except for the DVBT dongle no special changes or dependencies are required.Most installations will work out of the box.For some USB connected receivers (SBS1/1er/3 & Mode-SBeast) ftdi_sio kernel module is required, but it comes with pretty much all modern Linux distributions. Other receivers use modem emulation and should work without any external drivers.

          DVBT stick, however requires both some kernel modules to be disabled as well as a few extra libraries to be present in the system.Our Raspberry Pi (ARM) and Debian (x86/x64) packages contain everything you need to start feeding immediately.

          2.1.2 Config file location
          The default config file location is /etc/fr24feed.ini"
          Download manual from here:
          http://feed.flightradar24.com/fr24feed-manual.pdf


          ALTERNATIVE:
          If you know IP address of your R Pi on your LAN (find from your router/LAN setup), then you can type following in your browser

          http://<IP address of your R Pi on LAN>:8754/settings.html

          (example - my RPi's IP address on my LAN is 192.168.2.17, so I will type in browser http:// 192.168.2.17:8754/settings.html)

          When settings page opens, change "RAW Data" & "SBS Feed" to "No".
          Click save button and then restart button (both buttons are at bottom right of the settings page).
          Last edited by abcd567; 2015-01-24, 08:32.

          Comment


          • Many thanks for that info. I had a look at the ini file and found bs and raw are already set to no. I have also got access to the settings from a windows browser as you suggested in your alternative and of course that shows them set to no also:- This is what I see in the setting page from windows browser-
            (I've removed the other columns from this list - the post removed all the formatting and it wasn't clear)
            Setting Config file
            Sharing key: *****************
            Receiver: DVBT Stick (Malcolm Robb)
            Host/IP:
            COM/DEV/PATH: /usr/lib/fr24/mr-dump1090
            Process arguments: --net-http-port 8080
            Baudrate: default
            RAW data (30002/30334): no
            Decoded data (30003): no
            Logfile mode: 1
            Window mode:

            With either --net-http-port 8080 or --net --net-http-port 8080 to the Process arguments I still see no Google maps page. I thought changing the path line to dump1090 instead of mr-dump1090 but that makes no difference either (Rebooting each time of course) I'm assuming I should see the web interface from 192.168.x.x:8080 (127.0.0.1:8080 doesn't work either)- I can see all the information and links showing the tracked aircraft list etc on port 8754 so I'm still rather baffled!
            Last edited by Scroggie; 2015-01-24, 11:22.

            Comment


            • Originally posted by peterhr View Post
              Excellent, hopefully not only do you have a working solution, but you also have gained a toehold into Linux and do know why each step was needed.

              Sent from my GT-P5110 using Tapatalk
              Hi peterhr,

              Where can I find this STEP by STEP guide????

              Want to check the way I did install dump1090 and fr24feed.....

              Receiver: down message when i asked for fr24feed status
              pi@raspberrypib ~ $ service fr24feed status
              [ ok ] FR24 Feeder/Decoder Process: running.
              [ ok ] FR24 Stats Timestamp: 2015-01-24 12:55:49.
              [ ok ] FR24 Link: connected [UDP].
              [ ok ] FR24 Radar: T-EHLW21.
              [ ok ] FR24 Tracked AC:.
              [FAIL] Receiver: down ... failed!
              pi@raspberrypib ~ $

              But dump1090 is producing output what I can see in browser viewing RPi:8080


              I'm a RPi newby....and don't know much about Linux..

              Thanks!!
              JoopT

              Comment


              • @JoopT:
                Hi Joop!
                I am using Piaware (Downloaded from Flight Aware and consisting of "Raspbian+Dump1090+FlightAwae Datafeeder client" as one .img file).
                I then downloaded and installed FR24 feeder Client from http://forum.flightradar24.com/threa...-BETA-testing-
                After I installed FR24 feed on Piaware, I faced the same problem as you have reported, i.e. when I gave command service fr24feed status, following was displayed:

                Code:
                pi@piaware ~ $ service fr24feed status
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2015-01-21 17:46:02.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-CYYZ9.
                [ ok ] FR24 Tracked AC:.
                [FAIL] Receiver: down ... failed!
                I checked Dump1090's display on my Desktop's web browser by typing http://<IP address of RPI on LAN>:8080, and it started displaying Google Map & Planes. See screenshot below.
                Piaware Dump1090.PNG


                I solved the problem by following method:

                Type http://<IP address of your R Pi on LAN>:8754/settings.html

                (example - my RPi's IP address on my LAN is 192.168.2.17, so I typed http:// 192.168.2.17:8754/settings.html in browser )

                When settings page opens, change:

                Receiver setting to "AVR(TCP)"
                HOST/IP setting to "localhost:30002
                RAW Data setting to "NO" (if it is not already NO)
                SBS Feed setting to "NO" (if it is not already NO)

                Then click "save" button and then "restart" button (both buttons are at bottom right of the settings page).

                Type command service fr24feed status in console to check status.
                Alternatively you can check status of feed by typing http://<IP address of your R Pi on LAN>:8754/ in your browser.

                Please see 3 screenshots below:

                FR24 setup on PiAware-1.PNG . FR24 setup on PiAware-2.PNG . FR24 setup on PiAware-3.PNG
                Last edited by abcd567; 2015-01-24, 17:03.

                Comment


                • @ Scroggie:

                  use this command to see status of your FR24 Receiver:

                  service fr24feed status

                  If response shows [FAIL] Receiver: down ... failed!, you have to make changes to your setting as in my post #1026 above.

                  Comment


                  • No the response isn't "fail" - the receiver has been working fine from the installation 2 weeks ago - reporting over 2000 aircraft and 300,000 positions per day, up to 250 nm away. I just expected to be able to utilise the Google map display locally. I haven't tried running a browser on the pi itself to see if it works, maybe that would that be worth a try. EDIT No that doesn't work either!
                    The settings option "Host/IP: is blank - does that matter?
                    Should "Process Arguments" be --net-http-port 8080 or --net --net-http-port 8080 (I've tried both)
                    Is there any difference in COM/DEV/PATH: between /usr/lib/fr24/mr-dump1090 and /usr/lib/fr24/dump1090

                    This is the debug data:-
                    ac_map_size="1600"
                    build_arch="armv6l"
                    build_flavour="generic"
                    build_os="Linux"
                    build_revision="master-17bc89d.git"
                    build_timetamp="20141222-1532"
                    build_version="1.0.9-3"
                    cfg_baudrate=""
                    cfg_bs="no"
                    cfg_host=""
                    cfg_mpx=""
                    cfg_path="/usr/lib/fr24/mr-dump1090"
                    cfg_raw="no"
                    cfg_receiver="dvbt-mr"
                    cfg_windowmode="0"
                    d11_map_size="32"
                    feed_alias="T-EGSY1"
                    feed_current_mode="UDP"
                    feed_current_server="83.140.21.66"
                    feed_last_ac_sent_num="18"
                    feed_last_ac_sent_time="1422140669"
                    feed_last_attempt_time="1422122265"
                    feed_last_config_attempt="1422122177"
                    feed_last_config_info=""
                    feed_last_config_result="success"
                    feed_last_connected_time="1422122268"
                    feed_last_disconnected_time="1422121839"
                    feed_num_ac_tracked="21"
                    feed_status="connected"
                    feed_status_code="-1"
                    feed_status_message=""
                    fr24key="*****************"
                    last_json_utc="1422140609"
                    last_rx_connect_status="OK"
                    last_rx_connect_time="1422136247"
                    last_rx_connect_time_s="2015-01-24 21:50:47"
                    last_rx_global_timeout="1422136242"
                    msg_ring_full="0"
                    msg_ring_length="0"
                    num_global_timeouts="13"
                    num_messages="5739045"
                    num_resyncs="0"
                    rx_connected="1"
                    shutdown="no"
                    time_update_utc="1422140663"
                    time_update_utc_s="2015-01-24 23:04:23"
                    timing_is_valid="1"
                    timing_last_drift="+0.0018"
                    timing_last_offset="-0.0031"
                    timing_last_result="success"
                    timing_time_last_attempt="1422140527"
                    timing_time_last_success="1422140527"
                    timing_time_since_last_success="154"
                    Last edited by Scroggie; 2015-01-24, 23:35.

                    Comment


                    • @Scroggie:

                      How to enable dump1090 to display aircrafts on Google Map in a Browser:

                      In order to pin-point the problem, I decided to go step by step to see where the problem lies.
                      1. Formatted my microSD, erasing installed Raspbian+Dump1090+FR24 feeder.
                      2. Installed Raspbian (NOOBS), then Dump1090. Did NOT install FR24 feeder.
                      3. Booted RPi, and typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map did NOT display
                      4. opened Console & gave command:

                      cd dump1090
                      ./dump1090 --interactive --net --net-http-port 8080
                      Then again typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map Started DISPLAYING with aeroplanes

                      I then closed the console, Map became blank

                      5. ReBooted the RPi, typed in browser the address http://<IP address of RPi on LAN>:8080, Google Map did NOT display

                      Cocnclusion: Net interface is active only if a command is given to start it & console is kept open.
                      Solution: Change .ini settings of Dump1090 to start net interface automatically at Boot & keep it open unless closed manually.
                      I checked web for any script or settings to do it, and found one script to automatically start net connection at http://www.satsignal.eu/raspberry-pi/dump1090.html.

                      I applied the procedure to my RPi & and now web interface works ok

                      Here is the procedure:

                      First create a blank script file "dump1090.sh" with the command:

                      sudo nano /etc/init.d/dump1090.sh
                      Now copy and paste the following code into the new file, and save the file (Ctrl+O), then exit nano text editor back to console (Ctrl+X):

                      #!/bin/bash
                      ### BEGIN INIT INFO
                      #
                      # Provides: dump1090
                      # Required-Start: $remote_fs
                      # Required-Stop: $remote_fs
                      # Default-Start: 2 3 4 5
                      # Default-Stop: 0 1 6
                      # Short-Description: dump1090 initscript

                      #
                      ### END INIT INFO
                      ## Fill in name of program here.
                      PROG="dump1090"
                      PROG_PATH="/home/pi/dump1090"
                      PROG_ARGS="--interactive --net --net-ro-size 500 --net-ro-rate 5"
                      PIDFILE="/var/run/dump1090.pid"

                      start() {
                      if [ -e $PIDFILE ]; then
                      ## Program is running, exit with error.
                      echo "Error! $PROG is currently running!" 1>&2
                      exit 1
                      else
                      ## Change from /dev/null to something like /var/log/$PROG if you want to save output.
                      cd $PROG_PATH
                      ./$PROG $PROG_ARGS 2>&1 >/dev/null &
                      echo "$PROG started"
                      touch $PIDFILE
                      fi
                      }

                      stop() {
                      if [ -e $PIDFILE ]; then
                      ## Program is running, so stop it
                      echo "$PROG is running"
                      killall $PROG
                      rm -f $PIDFILE
                      echo "$PROG stopped"
                      else
                      ## Program is not running, exit with error.
                      echo "Error! $PROG not started!" 1>&2
                      exit 1
                      fi
                      }

                      ## Check to see if we are running as root first.
                      ## Found at http://www.cyberciti.biz/tips/shell-...ck-script.html
                      if [ "$(id -u)" != "0" ]; then
                      echo "This script must be run as root" 1>&2
                      exit 1
                      fi

                      case "$1" in
                      start)
                      start
                      exit 0
                      ;;
                      stop)
                      stop
                      exit 0
                      ;;
                      reload|restart|force-reload)
                      stop
                      start
                      exit 0
                      ;;
                      **)
                      echo "Usage: $0 {start|stop|reload}" 1>&2
                      exit 1
                      ;;
                      esac
                      exit 0
                      Now make this file executable with the following command:

                      sudo chmod +x /etc/init.d/dump1090.sh
                      Now create the run level shortcuts with the command:

                      sudo update-rc.d dump1090.sh defaults
                      Reboot the RPi. You can now see Google map displayed in your browser by typing http://<IP address of your RPi on LAN>:8080.

                      If you want, you can stop or restart dump1090 manually with the commands:

                      sudo /etc/init.d/dump1090.sh stop
                      or
                      sudo /etc/init.d/dump1090.sh start
                      Last edited by abcd567; 2015-01-25, 08:14.

                      Comment


                      • Hi abcd567,

                        I followed this morning your advice and it seems the solution.
                        I've seen on the FR24 live screen so far a few ac's using my radar code T-EHLW21 .........as it did when I'm feeding by windows and using my SBS1 receiver input.

                        T-EHLW21-2.jpg


                        But RPi is 24/7 on line and my PC isn't.... so I wanna switch to the RPi (magic-box)

                        I didn't know where I filled some wrong items in configuring the FR24FEED utility but ... I will monitor this forum on a almost daily base the next time so I can learn more about FR24 items.
                        Thank you very much so far!!!

                        JoopT

                        Comment


                        • Thanks so much for that, I haven't yet had time to do everything you suggest but the clue was in "Did NOT install FR24 feeder." I stopped the feed, ran the --net command and left the console open and sure enough the web interface was now working. Does this mean it isn't possible to feed FR24 and have the web interface available at the same time?

                          Comment


                          • @Scroggie:
                            No the clue is not FR24 feeder. The problem is NOT caused by FR24

                            I did not install FR24 to find out if the problem is caused by FR24. The problem remained even without FR24.

                            The problem is in Dump1090. It displays Google Map only when"./dump1090 --net" is executed by console command and stops when console is closed. Try this by exiting/closing console, and Google map will disappear.

                            The script will automatically start --net and will keep it running throughout the period Pi is running, so the browser will always show Google map.

                            After installing and success of script, I installed FR24, and now both FR24 & Google map are running simultaneously without manually starting "./dump --net" from console every time I wants to see Google map. I dont have to start & leave the console running
                            .
                            Last edited by abcd567; 2015-01-25, 15:31.

                            Comment


                            • place this at the end of the line if you running in a console and what it to continue after closing the console > /dev/null &

                              the >/dev/null send the output to nowhere (so you see nothing on screen) and the & basically disassociates it from the console instance, so its running in the background and not tied to that window.
                              T-EGLF8

                              Comment


                              • Thanks again - I will try the script when I can. I'm happy for now to just stop the FR24 feed temporarily and run the --net command when I want to see the map. The main use for it will be if I experiment with a different antenna to get an idea if the changes improve the overall coverage. The coverage I have now is pretty good, restricted only by the hills to the west of me - just 120 nm in that direction compared to 260 nm to the East over the North Sea. I don't know what others achieve with a similar installation but I'm very satisfied with what is a very basic setup.

                                Comment

                                Working...
                                X