Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have purchased an RCA 7" Android Tablet for Can $49.99 from Wallmart Canada. This was special price during boxing week. Now it is Can $69.99.

    For DVB-T USB, there is a driver zdiag for windows & linux. Is the driver avaiable for Android also? If there is a driver available, then this tablet can be used to feed ADS-B data.

    This will be the cheapest stand-alone solution. It is like a RPi+Case+Power Supply+Keyboard+Mouse+Monitor+WiFi, all for Can $70 = US $59.43 = €49.59
    Last edited by abcd567; 2015-01-14, 00:40.

    Comment


    • equi, what kind of CPU utilization do you see with those settings on the Banana? I've got a deployment I'm doing that needs to have a little more overhead than the RPi can provide.

      Comment


      • Benchmarking of Raspberry Pi vs. Banana Pi:
        http://gleenders.blogspot.ca/2014/07...ana-pi-vs.html

        banana2.png . banana3.png . banana1.png
        Last edited by abcd567; 2015-01-14, 19:51.

        Comment


        • Pi B+ Composite Video & Audio Lead

          Pi B+ composite video & audio lead looks identical to leads for camcorder & other devices.
          R Pi Composite udio Video TRRS to RCA-1.JPG . Composite Video Audio Cable TRRS to RCA-2.JPG.jpeg

          But all leads do not work in Pi B+ as the connections differ.

          Camcorders and some other devices use the sleeve as Ground and Ring as Video.

          Pi B+ & Apple devices (iPod, iPad, iPhone etc) and Zune use the Sleeve as Video, and Ring as Ground.

          Please see the diagram below:

          Model B+ Audio Video Jack.png
          Last edited by abcd567; 2015-01-15, 07:13.

          Comment


          • I want to temporarily stop the FR24 feed but keep dump1090 running. What do I need to comment out in the scripts and where?

            I'm running the Beta software on a Raspberry Pi
            T-EGUB1

            Comment


            • Originally posted by abcd567 View Post
              Is the driver avaiable for Android also?
              https://play.google.com/store/apps/d....rtl_tcp_andro

              But not available feed software on Android.

              Comment


              • Originally posted by Chriso View Post
                https://play.google.com/store/apps/d....rtl_tcp_andro

                But not available feed software on Android.
                Thank you!

                Comment


                • Originally posted by trigger View Post
                  I want to temporarily stop the FR24 feed but keep dump1090 running. What do I need to comment out in the scripts and where?

                  I'm running the Beta software on a Raspberry Pi
                  I'd log in to the Pi using Putty and then just type at the prompt:
                  Killall fr24feed_arm_rpi-242 (assuming this is the same Beta version you have). If not change it to the version on your Pi.

                  John
                  T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

                  Comment


                  • Originally posted by milair View Post
                    I'd log in to the Pi using Putty and then just type at the prompt:
                    Killall fr24feed_arm_rpi-242 (assuming this is the same Beta version you have). If not change it to the version on your Pi.

                    John
                    Hi John, I'm using fr24feed_1.0.10-3_armhf.deb which seems to start dump1090 and fr24feed automatically. I'm a non-Linux user but getting there
                    T-EGUB1

                    Comment


                    • I am using decoder "RTL1090" for my Windows-XP & Windows-7 computers.
                      What is the equivalent decoder software for Raspbian on my new Raspberry Pi B+ ?

                      Comment


                      • To install dump1090 on my RPi B+, I gave following commands:
                        Code:
                        sudo apt-get install git-core
                        sudo apt-get install git 
                        sudo apt-get install cmake
                        sudo apt-get install libusb-1.0-0-dev
                        sudo apt-get install build-essential
                        
                        git  clone  git://git.osmocom.org/rtl-sdr.git
                        cd  rtl-sdr
                        mkdir  build
                        cd  build
                        cmake  ../ -DINSTALL_UDEV_RULES=ON
                        make
                        sudo  make  install
                        sudo  ldconfig
                        
                        cd ~
                        sudo  cp  ./rtl-sdr/rtl-sdr.rules  /etc/udev/rules.d/
                        sudo  reboot
                        cd  ~ 
                        git  clone  git://github.com/MalcolmRobb/dump1090.git
                        cd  dump1090
                        make
                        ./dump1090 --interactive --net
                        I got this error message

                        Code:
                        Found 1 device(s):
                        0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                        
                        Kernel driver is active, or device is claimed by second instance
                        In the first case, please either detach or blacklist the kernel
                        (dvb_usb_rtl28xxu), or enable automatic detaching at compile tim
                        
                        usb_claim_interface error -6
                        Error opening the RTLSDR device: Device or resource busy
                        How to solve this problem?
                        Last edited by abcd567; 2015-01-18, 09:15.

                        Comment


                        • Originally posted by @abcd567 View Post
                          Code:
                          Kernel driver is active, or device is claimed by second instance
                          In the first case, please either detach or blacklist the kernel
                          (dvb_usb_rtl28xxu), or enable automatic detaching at compile tim
                          
                          usb_claim_interface error -6
                          Error opening the RTLSDR device: Device or resource busy
                          "sudo rmmod dvb_usb_rtl28xxu", or reboot.
                          The blacklisting of the kernel module only prevents it being loaded in the future, it won't unload an already-loaded module, so you have to fix it by hand once.

                          edit: Oh, you did reboot. Mm. Check "lsmod" to see if dvb_usb_rtl28xxu is loaded. Check whether something else (e.g. the fr24 feeder) has started a separate copy of dump1090 itself on boot.

                          Comment


                          • Originally posted by obj View Post
                            "sudo rmmod dvb_usb_rtl28xxu", or reboot.
                            The blacklisting of the kernel module only prevents it being loaded in the future, it won't unload an already-loaded module, so you have to fix it by hand once.

                            edit: Oh, you did reboot. Mm. Check "lsmod" to see if dvb_usb_rtl28xxu is loaded. Check whether something else (e.g. the fr24 feeder) has started a separate copy of dump1090 itself on boot.
                            Problem:
                            Code:
                            Found 1 device(s):
                            0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                            
                            Kernel driver is active, or device is claimed by second instance
                            In the first case, please either detach or blacklist the kernel
                            (dvb_usb_rtl28xxu), or enable automatic detaching at compile tim
                            
                            usb_claim_interface error -6
                            Error opening the RTLSDR device: Device or resource busy

                            I solved the problem! Here is how:


                            First I checked the blacklist file for rtl-sdr.
                            I did NOT find find the file rtl-sdr-blacklist.conf in the directory /etc/modprobe.d

                            I was in GUI, and tried to create this file, but it refused to create.
                            I then opened console and typed this command:

                            sudo leafpad /etc/modprobe.d/rtl-sdr-blacklist.conf, and the file was created.

                            I then opened the newly created blank file and typed in the file:

                            blacklist dvb_usb_rtl28xxu
                            blacklist e4000
                            blacklist rtl2832

                            Then saved the file, rebooted, and gave command

                            cd dump1090
                            ./dump1090 --interactive

                            and bingo, the dump1090 started working. Showing lots of plane with whip which came with DVB-T USB Stick!

                            DSC03530-R.JPG


                            Edit:
                            (1) Leafpad command creates file only when given to RPi console directly. It does not create file in SSH mode. In SSH mode, new file can be created by nano command i.e sudo nano /etc/modprobe.d/rtl-sdr-blacklist.conf.
                            (2) It is not necessary to use name rtl-sdr-blacklist.conf. Any name can be used, but the extension should always be .conf
                            (3) To see the plane plotted on google map, following command is to be given:

                            cd dump1090
                            ./dump1090 --interactive --net --net-http-port 8080

                            This will open port 8080 on RPi, and then typing http://127.0.0.1:8080 in browser will display planes plotted on Google map
                            Last edited by abcd567; 2015-01-19, 03:53.

                            Comment


                            • Sorry to hijack your thread but I'm not sure where to ask this question.
                              I've been feeding FR24 for a couple of weeks after setting up a receiver attached to a Raspberry Pi and finally getting an 8 element home brew colinear up on the roof.
                              The success of this so far has far exceeded what I expected, given my great age (71) and inexperience of the pi and programming!. I can see about 2000 aircraft per day from here in the north of England with distances of up to 260 nm to the North, East and South with some distance restriction to the West due the the proximity of the Pennine Hills.
                              Reporting about 330,000 positions per day must mean I've got it about as good as is possible from this particular location.
                              One thing however is taxing my ageing brain. I see elsewhere that I should be able to see my received positions on Google Maps with the built-in web server provided by dump1090, but when I enter http://192.168.0.41:8080 or http://127.0.0.1:8080 I get nothing. I've tried adding the extra arguments in the settings (--net-http-port 8080) via the access from a windows browser on port 8754, but that makes no difference. I'm running /usr/lib/fr24/mr-dump1090 and thought that perhaps I needed to be running dump1090 and not mr-dump1090 in order to get the web server but even when I switch to that the result is the same.
                              Can anyone explain what I'm missing here?

                              Comment


                              • Hi Scroggie, welcome
                                Well done getting so far. I'm sorry but I can't help with your specific problem but everyting looks OK to me. I had a similar problem when I first started with FR24 but I changed so many things I can't say what cured it. I believe you don't need the --net-http-port 8080 as dump1090 defaults to port 8080 by default. That parameter is used if you have something else on port 8080.
                                Hopefully a couple of the experts will put you right.
                                What is your feeder code so I can keep an eye out for you?

                                It would be helpful to other if you post details of your antenna on the "Best Antenna" thread.
                                Cheers
                                Last edited by trigger; 2015-01-19, 18:47.
                                T-EGUB1

                                Comment

                                Working...
                                X