Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Great, thank you Jayant
    Regards,
    T-EDDE7

    Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
    Banana Pi | Mystique SDR R820T2 | stock Antenna

    Comment


    • Since this morning I'm being unable to feed FR24 from my RPi board. It worked flawlessly for quite a long time, but now it seems that the IP address exported in the last lines of the fr24.sh script is no longer valid. I'm using the RPi specific feeder, version 242.
      Thank you in advance and please disregard any idiomatic mistake.
      Last edited by Andres; 2014-12-09, 20:02.
      T-SABE8 - Raspberry Pi + RTL2832U / R820T USB + dump1090

      Comment


      • Hi,

        I had the same issue - just remove the FR24AUTH Entry and restart your Script.
        Regards,
        T-EDDE7

        Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
        Banana Pi | Mystique SDR R820T2 | stock Antenna

        Comment


        • equi,
          Thank you, I'll do it immediately.
          Best regards.
          T-SABE8 - Raspberry Pi + RTL2832U / R820T USB + dump1090

          Comment


          • De nada, mi amigo
            Regards,
            T-EDDE7

            Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
            Banana Pi | Mystique SDR R820T2 | stock Antenna

            Comment


            • Originally posted by equi View Post
              Hi,

              I had the same issue - just remove the FR24AUTH Entry and restart your Script.
              My RPi did not restart the feed after the crontab ran last night although the local Dump1090 is showing well.
              I am travelling abroad tomorrow for a couple of months and had hoped to leave the Rpi running unattended.
              Forgive my ignorance but could you please explain more about this FR24Auth Entry and where it is so that I can restart everything before I run for the airport tomorrow.

              Comment


              • Hi,

                yes for sure Andres & I had the following line in our Script

                Code:
                FR24AUTHIP=83.140.247.20
                Regarding to http://forum.flightradar24.com/threa...ll=1#post21668 it is not longer necessary to connect.

                Hopefully that helps for you,

                Greetings from Germany
                Regards,
                T-EDDE7

                Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                Banana Pi | Mystique SDR R820T2 | stock Antenna

                Comment


                • I didn't had this issue, maybe it occurs when restarting the feeder.
                  My last restart was more than a week ago.

                  Comment


                  • Well, the issue occured from Sunday to Monday (I have a Cron which restarts the Script everyday at 0:30am GMT+1). I don't know if it would happen today because I deleted the affected entry.
                    Regards,
                    T-EDDE7

                    Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                    Banana Pi | Mystique SDR R820T2 | stock Antenna

                    Comment


                    • Hi Equi, Many thanks. Although it was running fine with it before I have commented that line out by (inserting #) #export FR24AUTHIP=83.140.247.20
                      Re-ran fr24.sh and my EGGW26 is now reported to be online. So far so good, but waiting for an hour or so to see if it reports any stats, at the moment it is still reporting only up until when crontab restarted at 0053Z yesterday tuesday. And strangely the Polar Plot seems to have next to nothing in the southern 2 quadrants. The antenna is unchanged and dump is showing planes more than 150nm to the south.
                      Puzzled also, without that IP address in the script how does it know where to send the data?
                      Sorry for my questions, my 30 year old knowledge of linux is lost in the grey cells under many other years worth of crap.
                      I fly out to Ghana this afternoon, thus the panic to get it running in my absence.
                      p.s. Stats now showing from about 0830 this morning and polar plot almost normal. Hooray.
                      Thanks again. Malcolm

                      Comment


                      • Hi Malcolml,

                        glad to see that you are back Online with your feed. Personally I guess the Devs included the Authentication/Target Host in the binary file. I guess its time to open a Port for SSH from external (and to monitor the Pi), will do that on the weekend.

                        Have a good flight.
                        Regards,
                        T-EDDE7

                        Debian 8 Server | jetvision ADS-B USB Dongle | ADS-B Collinear Antenna
                        Banana Pi | Mystique SDR R820T2 | stock Antenna

                        Comment


                        • Originally posted by Malcolml View Post
                          Hi Equi, Many thanks. Although it was running fine with it before I have commented that line out by (inserting #) #export FR24AUTHIP=83.140.247.20
                          Help guys - tried commenting out as suggested by Michael, but FR still reports offline. I am still running the version 233 software, I'm a complete idiot with Linux, can anyone tell me in simple terms how to replace 233 with the latest version 242 ? Dump1090 is working fine btw. Should I just download from the dropbox link, unpack etc, then kill the 233, rename to 233sOLD, then mod fr24.sh to read "fr24feed_arm-rpi_242 --fr24key=YOUR_SHARING_KEY" to run the software

                          Thanks for any help

                          John
                          T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

                          Comment


                          • I can also report a similar error. Linux based, nothing changed, except power outtage, and a manual reboot once I discovered its not feeding:

                            ~$ tail -f /tmp/fr24feed.log
                            10-12-14 - 23:01:52 [i]FR24Feed v242 - built on Apr 23 2014/10:19:07
                            10-12-14 - 23:01:53 [i]Downloading configuration...[e]HTTP Response: [HTTP/1.1 404 Not Found]
                            10-12-14 - 23:01:53 ERROR

                            Comment


                            • Just to advise I have updated to fr24 v242, removed the export FR24AUTHIP line in fr24.sh and (obviously) changed the version details in fr24.sh as well

                              Mine was this version
                              ARM Raspberry-Pi, dynamically linked (07/05/2014):
                              https://dl.dropboxusercontent.com/u/...rm-rpi_242.tgz
                              Use "fr24feed_arm-rpi_242 --fr24key=YOUR_SHARING_KEY" to run the software.

                              Now feeding FR24 ok on my test RPi, will update main 24/7 one tomorrow once I'm sure all ok.

                              Herman - maybe this will help you ?

                              John
                              T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

                              Comment


                              • milair,

                                Indeed! Thanks for that one! Had such a hectic day (on the farm and actually visually tracked some AC overhead!) and was not near anything computer-like to fiddle with it.
                                Am using build _x86_242, but the problem was with the line export FR24AUTHIP=83.140.247.20. Seems like something changed server side and it caused some issues for some feeders?

                                tail -f /tmp/fr24feed.log
                                11-12-14 - 22:53:58 [n]FAKM1@83.140.21.66:8099/UDP
                                11-12-14 - 22:53:58 [n]connecting
                                11-12-14 - 22:53:58 [i][stats]Stats thread started
                                11-12-14 - 22:53:59 [n]connected
                                11-12-14 - 22:53:59 [n]switching to UDP
                                11-12-14 - 22:54:00 [n]working
                                11-12-14 - 22:54:03 [i]Source defined as Basestation
                                11-12-14 - 22:54:03 [b]connecting to 192.168.0.188:30003
                                11-12-14 - 22:54:03 [b]connected
                                11-12-14 - 22:54:03 [b]working
                                Last edited by HermanZA; 2014-12-11, 20:59.

                                Comment

                                Working...
                                X