Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by peterhr View Post
    327nm is unlikely - aircraft at 40000ft go over the horizon at about 250nm - but who knows, maybe you got a signal that bounced off something, or it's a glitch ... have to see if it happens often.
    I'm running several FR24 receivers and frequently see >300 nm ranges on them. Not only with exceptional tropo but several days a week. When weather is less favourable, range backs down do 250-260nm as you say.

    /M
    F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
    P-ESGR, P-ESIA, P-ESIB, P-ESGF
    mrmac (a) fastest.cc

    Comment


    • Originally posted by MrMac View Post
      I'm running several FR24 receivers and frequently see >300 nm ranges on them. Not only with exceptional tropo but several days a week. When weather is less favourable, range backs down do 250-260nm as you say.

      /M
      Just curious - what is favourable? People have reported greater range with rain about others when it's clear.

      The Radarcape is a an exceptional receiver - I'd be really surprised if got 300nm on a $10 dongle, but who knows

      Comment


      • Originally posted by peterhr View Post
        Just curious - what is favourable? People have reported greater range with rain about others when it's clear.
        If it is clear I get 300-335NM on my FR24 box, rain drops it to around 250NM
        Ben.

        Stats for: 2014-06-13
        Uptime (as % of available time): 100%
        Aircraft seen: 4,243
        Positions reported: 951,885
        Maximum distance: 301nm
        FR24 F-EGLF1, Blitzortung station 878, OGN Aldersht2, PilotAware PWAldersht, PlanePlotter M7.

        Comment


        • good afternoon

          I am thinking of buying a raspberry but the raspberry is just to stay on during the day and no monitor, turn off the router at night

          Now I wonder if it is possible to configure the router when connecting it to start sending data to the FR24

          And also like to know how to install the software on raspberry

          Already have a dvb-t and I feed but only in windows system

          If someone can help me I am grateful

          Comment


          • This shouldnt be too much of a problem as you can set the raspberry pi to stop the feed software a few minutes before you will turn your router off, and then make it start the software a few minutes after your router will have turned on again..

            You may also need to set it to refresh the IP lease from the router just incase it looses scope of the network.

            The guide at the start of this thread on page 1, post 8 has a great guide that is easy to follow.

            Comment


            • Great but

              I have the system on windows fr24feeds, but the raspberry is linux

              Where can I find the link program to the feed in linux?

              Or is it that I have in windows?

              thank you

              Comment


              • Hey - its all in post 8 of this thread... that will link you through to both an image file that you can write to the RPI SD card, or follow the document and that will get you sorted..

                You'll then have a self enclosed Raspberry Pi installation that does both retrieving the signal, and publishing it to FR24.

                Comment


                • Originally posted by ptruicp View Post
                  Great but

                  I have the system on windows fr24feeds, but the raspberry is linux

                  Where can I find the link program to the feed in linux?

                  Or is it that I have in windows?

                  thank you
                  As SgtBash says ... read the instructions, get the Pi working.

                  If it's unhappy with the router being switched off at night - let us know here, we might ask for information then we'll get it sorted out.

                  Once you get past the uncertainty that comes with doing something new, it's easy (like learning to ride a bicycle)

                  Comment


                  • Originally posted by peterhr View Post
                    Once you get past the uncertainty that comes with doing something new, it's easy (like learning to ride a bicycle)
                    2nd that one - I'm a relative newbie to Linux & RPI but found the guide really easy to follow.
                    The ONLY bit I got stuck on was the expanding of the filesystem, but its quite easy:

                    I did the following:
                    Download and unzip IMG file
                    Burn to SD card using ‘Win32DiskImager’
                    Load into Raspberry Pi
                    Log in via SSH
                    run command: “df -h” which gave me the rundown of where my filesystem was, in this case “/dev/mmcblk0p1″
                    run command: “fdisk /dev/mmblk0″
                    run commands: “d”, “3″, “d”, “2″, “n”, “p”, “2″, “return”, “return”, “w”

                    (Breakdown on what that has just done)
                    d – delete
                    3 – third partition (in my case, the swap partition)
                    d – delete
                    2 – second partition (the root filesystem, 1 is the BOOT partition and shouldn’t be touched)
                    n – create new partition
                    p – primary
                    2 – location
                    return – confirm start block
                    return – confirm end block
                    w – write

                    run command: “reboot” to reboot the system
                    run command: “resize2fs /dev/mmcblk0″ to resize the new partition

                    Done =)

                    Also you need to run:
                    dpkg-reconfigure locales
                    dpkg-reconfigure console-data
                    dpkg-reconfigure tzdata

                    once done to configure some more stuff and I also ran a:
                    run command: apt-get install localepurge
                    then
                    localepurge

                    which cleared about 65mb of unrequired locale files...

                    now running a version 1 raspberry pi B (256mb model) that boots in under 10 seconds...

                    Comment


                    • ... that all said, I'm running on the 1Gb unexpanded image with the timezone set to UTC - so the changes are not mandatory to get a working feeder ...

                      on the original question, I think the Pi will probably reconnect and just keep right on processing, however it woudn't be difficult to do a script to test the router connection do a sleep loop 'till it's available, then start the feeder.

                      Comment


                      • Hi folks...I need a little help to get up and running.

                        I have used the Raspbian image and updated FR24 to version 242. I can access the Raspberry Pi over the web and see plenty of tracks! Which is great! But...I am trying feed to FR24, and FR24 is not showing any data received from me. Here is my log:
                        [i]FR24Feed v242 - built on May 7 2014/13:05:06
                        [i]Downloading configuration...OK
                        [i]Parsing configuration...OK
                        [c]Interval: 5s
                        [c]Latitude: 34.0400
                        [c]Longitude: -118.4500
                        [c]GND: YES
                        [c]NonADSB: YES
                        [i]Source defined as Basestation
                        [b]connecting to 127.0.0.1:33002
                        [e]could not connect to BS
                        [i]waiting 5 seconds
                        [n]defined 1 server
                        [n]KLAX2@83.140.21.66:8099/UDP
                        [n]connecting
                        [i][stats]Stats thread started
                        [n]connected
                        [n]switching to UDP
                        [n]working
                        [i]Source defined as Basestation
                        [b]connecting to 127.0.0.1:33002
                        [e]could not connect to BS
                        [i]waiting 5 seconds
                        And then the last 4 lines just keep repeating...

                        I would love to get this feeding, but don't know how to fix this issue. Any ideas? It looks like I am authorizing at FR24 okay, right? It's just not getting it the data...thanks for any help.
                        Last edited by imokruok; 2014-06-20, 06:21.

                        Comment


                        • Originally posted by imokruok View Post
                          Hi folks...I need a little help to get up and running.

                          I have used the Raspbian image and updated FR242 to version 242. I can access the Raspberry Pi over the web and see plenty of tracks! Which is great! But...I am trying feed to FR24, and FR24 is not showing any data received from me. Here is my log:

                          And then the last 4 lines just keep repeating...

                          I would love to get this feeding, but don't know how to fix this issue. Any ideas? It looks like I am authorizing at FR24 okay, right? It's just not getting it the data...thanks for any help.
                          I'm not at the Pi at the moment so can't check, but

                          connecting to 127.0.0.1:33002 <---- should this be on port 30003 ... might be a parameter on the fr24 feed line (if you have no parameter, it may need a call to support to get the parameters they pass down to your feeder updated)

                          also do update the feeder to the new RPi one
                          Last edited by peterhr; 2014-06-20, 06:29.

                          Comment


                          • Maybe...but I'm looking at my fr24.sh file and there isn't even a reference to 33002 in it. Just --net-sbs-port 30003 and --net-ro-port 31001. So I don't know what's calling 33002. Anyhow, please let me know when you do. I didn't touch any fr24.sh parameters other than to add in the "export..." line and my key.

                            Also, yes, I am on rpi_242 for the feeder.

                            Thanks--

                            Comment


                            • Originally posted by imokruok View Post
                              Maybe...but I'm looking at my fr24.sh file and there isn't even a reference to 33002 in it. Just --net-sbs-port 30003 and --net-ro-port 31001. So I don't know what's calling 33002. Anyhow, please let me know when you do. I didn't touch any fr24.sh parameters other than to add in the "export..." line and my key.

                              Also, yes, I am on rpi_242 for the feeder.

                              Thanks--
                              I had a look at the write up, it suggests the feeder should be using port 30003 - unfortunately the port to use may be coming down from the FR24 servers as a response to processing your sharing key.

                              try running up the feeder from the console with '--help' as a parameter ... to see if you can specify a port to use, otherwise you many need to contact support to get the parameters they pass back to the feeder changed.

                              Comment


                              • That did it! I ran with the --help parameter. It showed how to add an alternative port in the fr24.sh file. I put in 30003, and it's feeding data. Thanks!

                                Two quick questions:

                                - How do I update my base lat/long? I recently moved (only about a mile) from my old location.
                                - Are there any instructions on how to set up a wifi dongle on the raspbian shell? I want to move this outside!

                                Comment

                                Working...
                                X