Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Have you tried bumping up max_allowed_packet setting? That's just one of the possibilities..

    Comment


    • I've already reached 512M at max_allowed_packet.

      Comment


      • Originally posted by tvengineer View Post
        Hello all... First post to this forum...
        Just got my RasPi up and running with dump1090 and fr24dfeed_arm-le_242s... using the instructions in this thread.. pretty easy..
        I am feeding in but have not got my antenna up in the air yet.
        Next is to mount the raspi in a weatherproof box and set it up for Power over Ethernet.. and build an antenna. (hopefully done by next week)..
        One question.. is it ok to mount the RTL dongle and the pi in very close proximity inside a weatherproof box, or should the dongle be sheilded away from the Pi.
        I usually mount my pi s in plastic electrical outlet boxes with weather covers (pi cam security cameras)... wonder if the pi would cause interference to the RTL dongle jammed into that small a box.

        Anyway... this if fun.. and even though my area has pretty good coverage already.. it is fun to see my radar ID show up or the flightradar24 website :-)
        I'm a long time RaspberryPi user, There is a lot of thereads in the RPi forum about the temperatures.

        Please have a look at: http://www.raspberrypi.org/forums/vi...327517#p327517

        Also, is very easy to monitor the RPi SoC system temperature with the /opt/vc/bin/vcgencmd measure_temp, on the other hand you can hookup a DS18B20 temp sensor directly to the GPIO and use it for monitoring the enclosure box temperature.

        Good Luck!

        PS: Sorry to mods for posting a reference to other non-related Forum.
        Last edited by YV1HX; 2014-04-30, 19:16. Reason: added addtional info, corrected grannmar & typos
        Marco-Luis
        YV1HX
        F-SVMC1

        http://twitter.com/meteoven
        http://yv1hx.no-ip.org
        http://www.meteoven.org

        Comment


        • Just had to power down my Pi and RTL which has been running since January 24/7. Upon bringing up again it is not connecting to fr24 but is working fine in Dump1090 and Virtual Radar. I've noticed some remarks that the fr24 software appears to be 242s but my version is still 233s. It reports errno 111 if I try to connect to fr server ?

          Any ideas please

          John
          T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

          Comment


          • feeder version 241s will give you access to the statistics info about your feeder in premium, and indeed the download page does say 242 came available 23 April 2014 (have to try it )

            http://forum.flightradar24.com/threa...-Flightradar24

            Have a look at the download page re error 111.

            Comment


            • Panic over, just loaded image onto the SD card again and all working now including fr24 feed. Guess must have had a glitch somewhere.
              I'm leaving well alone now !!
              T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

              Comment


              • switch to feeder 242s on Pi, seems OK - I don't see the zombie processes that 241s created.

                Comment


                • Originally posted by peterhr View Post
                  switch to feeder 242s on Pi, seems OK - I don't see the zombie processes that 241s created.
                  Oh yes I do!

                  'PS -e' shows one new defunct process every 10 minutes - you have to stop the owning job to get rid of these ... that means stop and restart the feeder with a cron job once a day

                  Comment


                  • Holy crap.

                    Sent from my Nexus 4 using Tapatalk

                    Comment


                    • Hey guys, I've posted this in the Flightradar24 thread too, but got no reply.
                      I'll try my luck here too.
                      The issue is that my DDNS has been changed and since then fr24 it's not sensing me as online.
                      In "the Daily availability" I look as connected, but the Polar plot, Histogram, Aircraft seen and Hits and positions reported is 0 (zero).
                      Could this be related to my ddns address? I know that I had to give a DDNS address when I signed up as feeder.
                      Locally, dump1090 it is showing airplanes, so it's not an antenna issue.

                      Comment


                      • I doubt your DDNS has anything to do this problem, since the FR24 does not use your DDNS for anything. Give us some more info on your setup, and the collective might be able to give you some pointers and ideas as to what can be the cause of the problem.

                        Sent from my Z30 using Tapatalk

                        Comment


                        • Originally posted by loplo View Post
                          Hey guys, I've posted this in the Flightradar24 thread too, but got no reply.
                          I'll try my luck here too.
                          The issue is that my DDNS has been changed and since then fr24 it's not sensing me as online.
                          In "the Daily availability" I look as connected, but the Polar plot, Histogram, Aircraft seen and Hits and positions reported is 0 (zero).
                          Could this be related to my ddns address? I know that I had to give a DDNS address when I signed up as feeder.
                          Locally, dump1090 it is showing airplanes, so it's not an antenna issue.
                          Are u using the --bs-ip=127.0.0.1 option when running the feeder software?
                          FR24 logged your IP when you first registered as a feeder.. when the feeder software starts up, it gets its configuration information from FR24 every time.
                          FR24 tells your feeder program the IP address that DUMP1090 was running on when you registered.
                          Use 127.0.0.1 (localhost) if dump1090 and the feeder are on the same machine.
                          Hope that helps.

                          Comment


                          • The local IP of the raspi is the same.
                            The fr24feeder has no options, and regarding the IP I registered with a DYNDNS, and since DYDNS is payware I had to change.
                            This is why I think it related to that DNS.
                            I'll wait two more days and I'll contact the guys via the contact form.

                            Comment


                            • I too doubt if it's anything to do with DDNS - it's something few people would use.

                              I'd have a look at the feeder log file - or what it outputs to the console if run from the command line.

                              Comment


                              • Log:
                                Code:
                                [c]GND: YES
                                [c]NonADSB: YES
                                [i]Source defined as Basestation
                                [n]defined 1 server
                                [n]EDDK23@83.140.21.66:8099/UDP
                                [n]connecting
                                [i][stats]Stats thread started
                                [b]connecting to ******.dyndns.info:30003
                                [e]could not connect to BS
                                [i]waiting 5 seconds
                                [n]connected
                                [n]switching to UDP
                                [n]working
                                [i]Source defined as Basestation
                                [b]connecting to ******.dyndns.info:30003
                                [e]could not connect to BS
                                [i]waiting 5 seconds
                                [i]Source defined as Basestation
                                [b]connecting to ******.dyndns.info:30003
                                [e]could not connect to BS
                                [i]waiting 5 seconds
                                It looks like DDNS to me.

                                Comment

                                Working...
                                X