Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The dongle usually comes with a whip antenna about 150mm on a magnetic mount with maybe a 1.3m cable - no adapters.

    Adapters from ebay maybe,,,

    Comment


    • #17
      I have my Raspberry PI up and running now for at least 4 months and working fine
      With 5 meters ECOFLEX15 Plus and TMRF-1090.

      http://82.75.94.67/VirtualRadar/
      Last edited by T-EHTW3; 2014-02-04, 14:07. Reason: ip change
      http://www.twenteradar.nl

      Comment


      • #18
        T-EHTW3 : And it just keeps on working, in the true sense of a Linux device? No need for reboots or anything ?

        Comment


        • #19
          No need te reboot at all, it keeps on working
          http://www.twenteradar.nl

          Comment


          • #20
            Originally posted by peterhr View Post
            The dongle usually comes with a whip antenna about 150mm on a magnetic mount with maybe a 1.3m cable - no adapters.
            I got one from http://1090mhz.com/ today and a SMA to MCX adapter was included.

            Poul
            T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

            Comment


            • #21
              I'm on-line (T-EKCH5) .
              By now only with the whip antenna included the dongle, so I'm overruled by some heavy feeders.

              Shouldn't the Raspberry Pi auto start? After power down I have to star it via PuTTY (./fr24.sh) is there something I haven't set right? (I'm not a Linux guy yet)

              Poul
              T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

              Comment


              • #22
                Originally posted by attigliano View Post
                I'm on-line (T-EKCH5) .
                By now only with the whip antenna included the dongle, so I'm overruled by some heavy feeders.

                Shouldn't the Raspberry Pi auto start? After power down I have to star it via PuTTY (./fr24.sh) is there something I haven't set right? (I'm not a Linux guy yet)

                Poul
                the @reboot line in the cron job should start the script after reboot

                do
                ps aux | grep dump1090 | grep -v grep
                and
                ps aux | grep fr24feed | grep -v grep
                to see if the jobs are running

                ps = list the process states to standard output (usually the screen)
                | capture standard output and use it as standard input to the next command
                grep is a command-line utility for searching plain-text data sets for lines matching a regular expression - buy default it reads from standard input and writes to standard output, which means we could see two lines reported ... one for the task that's running, and the second for the grep task since it has the same string that we're looking for as a parameter.

                so we use the second grep to say don't show me lines that have the text 'grep' on them

                (sorry, not near a Pi system to verify this)

                ----

                By the way, My radar T-EGBB19 very rarely appears on FR24 due to many local network feeders, standalone feeders and FR24 boxes covering the area where I am, which makes me disinclined to spend lots of money on a fancy antenna ... but I'll spend a little to extend the coverage area
                Last edited by peterhr; 2013-08-29, 14:01.

                Comment


                • #23
                  Originally posted by peterhr View Post
                  the @reboot line in the cron job should start the script after reboot

                  do
                  ps aux | grep dump1090 | grep -v grep
                  and
                  ps aux | grep fr24feed | grep -v grep
                  to see if the jobs are running
                  I have tried these dump1090 is running (have done it all the time I had used "my Pi IP:8080 and had up to 16 planes on the map) the fr24feed not running! I think I maybe have typed wrong under editing (is typing ~ in linux the same as in windows (space and then AltGr ~)?)

                  I can also see on my FR24 Premium account if I'm feeding or not.

                  Poul
                  Last edited by attigliano; 2013-08-29, 15:08.
                  T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

                  Comment


                  • #24
                    Originally posted by attigliano View Post
                    I have tried these dump1090 is running (have done it all the time I had used "my Pi IP:8080 and had up to 16 planes on the map) the fr24feed not running! I think I maybe have typed wrong under editing (is typing ~ in linux the same as in windows (space and then AltGr ~)?)

                    I can also see on my FR24 Premium account if I'm feeding or not.

                    Poul
                    replace "cd ~" with "cd /home/pi"

                    it means change to the home directory of the logon account ... we can specify the home directory explicitly

                    If it's not feeding, make sure you entered your FR24 key into the file correctly

                    Also try running the fr24feed line on the console - exactly as it is in the file, but with the "> /dev/nul &" taken off the end ... see if you get an error message.
                    Last edited by peterhr; 2013-08-29, 18:41.

                    Comment


                    • #25
                      Replacement fr24.sh (I'll drop this with the other files too)

                      This puts the output of the FR24 feed to a file /tmp/fr24feed.log this file gets re-created every time the script is run
                      - you can check this using the command...

                      tail -f /tmp/fr24feed.log

                      On Raspberry Pi Wheezy, the /tmp folder is actually in memory, so doesn't shorten the life of the SD card

                      (don't do the same with dump1090 ... it outputs too much stuff and will fill memory quickly)

                      Wheezy + dump1090 + fr24feed seem to be using about 90k of memory ... the Pi B has 512K so we have room for a small log file
                      Code:
                      #!/bin/bash
                      #updated 2013-08-29 -  write /tmp/fr24feed.log
                      #
                      #make sure fr24feed and dump1090 software are not running
                      #
                      killall fr24feed_arm-le_233s
                      killall dump1090
                      #
                      #start dump1090 we dont want output so throw it into a black hole
                      # (the null device)
                      #the symbol at the end of the line says dont wait for this to finish, just move
                      # onto  the next command
                      #
                      cd /home/pi/dump1090
                      ./dump1090 --net --net-sbs-port 30003 --quiet > /dev/null &
                      cd ~
                      #
                      #start the fr24 feeder(use you own key)
                      #log output to /tmp/fr24feed.log ... this is actually im memory
                      #create a new file each time we start
                      #view the file using tail -f /tmp/fr24feed.log
                      #(dont do this with dump1090 ... too much output ... will fill memory)
                      #
                      #
                      export FR24AUTHIP=83.140.247.20
                      ./fr24feed_arm-le_233s --fr24key=1234567890abcdef > /tmp/fr24feed.log &

                      Comment


                      • #26
                        Still not working.

                        1: My raspberry PI didn't like the .(dots) before /dump1090 and /fr24feed_arm-le it said no program.

                        I have removed them.

                        2: This is what I got after power down

                        Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
                        permitted by applicable law.
                        Last login: Thu Aug 29 19:08:48 2013 from 192.168.0.12
                        pi@raspberrypi ~ $ tail -f /tmp/fr24feed.log
                        [i]FR24Feed v233 - built on Jul 9 2013/11:17:49
                        [i]Downloading configuration...ERROR
                        [e]Could not retrieve configuration from Flightradar24

                        3: Then gave it a start command (./fr24.sh)

                        pi@raspberrypi ~ $ ./fr24.sh
                        fr24feed_arm-le_233s: no process found
                        pi@raspberrypi ~ $ Found 1 device(s):
                        0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                        Found Rafael Micro R820T tuner
                        Max available gain is: 49.60
                        Setting gain to: 49.60
                        Exact sample rate is: 2000000.052982 Hz
                        Gain reported by device: 49.60
                        tail -f /tmp/fr24feed.log
                        [i]Data feed time difference OK abs(19:15:51.050 - 19:15:51.029)=0
                        [i]sent 6 planes in 1 packets
                        [i]sent 5 planes in 1 packets
                        [i]sent 6 planes in 1 packets
                        [i]sent 4 planes in 1 packets
                        [i]sent 7 planes in 1 packets
                        [i]sent 6 planes in 1 packets
                        [i]sent 7 planes in 1 packets
                        [i]sent 7 planes in 1 packets
                        [i]sent 9 planes in 1 packets
                        [i]sent 7 planes in 1 packets
                        [i]sent 7 planes in 1 packets
                        ^C
                        pi@raspberrypi ~ $
                        T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

                        Comment


                        • #27
                          Originally posted by attigliano View Post
                          Still not working.

                          1: My raspberry PI didn't like the .(dots) before /dump1090 and /fr24feed_arm-le it said no program.

                          I have removed them.

                          2: This is what I got after power down

                          Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
                          permitted by applicable law.
                          Last login: Thu Aug 29 19:08:48 2013 from 192.168.0.12
                          pi@raspberrypi ~ $ tail -f /tmp/fr24feed.log
                          [i]FR24Feed v233 - built on Jul 9 2013/11:17:49
                          [i]Downloading configuration...ERROR
                          [e]Could not retrieve configuration from Flightradar24

                          3: Then gave it a start command (./fr24.sh)

                          pi@raspberrypi ~ $ ./fr24.sh
                          fr24feed_arm-le_233s: no process found
                          pi@raspberrypi ~ $ Found 1 device(s):
                          0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                          Found Rafael Micro R820T tuner
                          Max available gain is: 49.60
                          Setting gain to: 49.60
                          Exact sample rate is: 2000000.052982 Hz
                          Gain reported by device: 49.60
                          tail -f /tmp/fr24feed.log
                          [i]Data feed time difference OK abs(19:15:51.050 - 19:15:51.029)=0
                          [i]sent 6 planes in 1 packets
                          [i]sent 5 planes in 1 packets
                          [i]sent 6 planes in 1 packets
                          [i]sent 4 planes in 1 packets
                          [i]sent 7 planes in 1 packets
                          [i]sent 6 planes in 1 packets
                          [i]sent 7 planes in 1 packets
                          [i]sent 7 planes in 1 packets
                          [i]sent 9 planes in 1 packets
                          [i]sent 7 planes in 1 packets
                          [i]sent 7 planes in 1 packets
                          ^C
                          pi@raspberrypi ~ $
                          so it's working...
                          the ./filename says run it from the current directory

                          without the "." - you just have the / ... and that means this is the absolute place the program is

                          /home/pi/dump1090/dump1090

                          and

                          /home/pi/fr234feed...
                          should work as absolute file locations

                          Comment


                          • #28
                            Originally posted by peterhr View Post
                            so it's working...
                            the ./filename says run it from the current directory

                            without the "." - you just have the / ... and that means this is the absolute place the program is

                            /home/pi/dump1090/dump1090

                            and

                            /home/pi/fr234feed...
                            should work as absolute file locations
                            Yes it working after i startet it in PuTTY with the command ./fr24.sh

                            But if I had shut down the power to Raspberry PI and turned the power on again the dump1090 is starting up and running and I can see planes on the browser (My Pi IP:8080) but the fr24feed didn't start. What is that configuration it can't download from flightradar24?
                            T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

                            Comment


                            • #29
                              Originally posted by peterhr View Post
                              so it's working...
                              the ./filename says run it from the current directory

                              without the "." - you just have the / ... and that means this is the absolute place the program is

                              /home/pi/dump1090/dump1090

                              and

                              /home/pi/fr234feed...
                              should work as absolute file locations
                              Can I have a directory failure? with the "." the programs couldn't be found. Could something had gone wrong when saving after edit?
                              T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

                              Comment


                              • #30
                                Originally posted by attigliano View Post
                                Yes it working after i startet it in PuTTY with the command ./fr24.sh

                                But if I had shut down the power to Raspberry PI and turned the power on again the dump1090 is starting up and running and I can see planes on the browser (My Pi IP:8080) but the fr24feed didn't start. What is that configuration it can't download from flightradar24?
                                don't know - the internal workings of the fr24 feed progarm are a mystery to me

                                I wonder is a 'sleep 5' might help before the fr24feed (maybe the network isn't quite ready)

                                ---

                                the dot notation is the same in windows (except the / is replaced by \)

                                If it's working without the dot I don't know how it is.

                                check the non-comment lines of the script carefully.
                                Last edited by peterhr; 2013-08-29, 20:02.

                                Comment

                                Working...
                                X