Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by peterhr View Post
    That would work, just have to use fr24feed with a parameters to tell it the port basestation 30003 machine.

    Sent from my Nexus 4 using Tapatalk
    So parameter is needed to tell the PI using machine instead of Dongle, like need to tell the IP address, port of machine using?
    So how to do that?
    T-VHST9: http://vhst9.hopto.org/
    (24/7)

    Comment


    • Originally posted by Dundee View Post
      So parameter is needed to tell the PI using machine instead of Dongle, like need to tell the IP address, port of machine using?
      So how to do that?
      Code:
      pi@raspberrypi ~ $ ./fr24feed_arm-le_233s --help
      [i]FR24Feed v233 - built on Jul  9 2013/11:17:49
      ./fr24feed_arm-le_233s --fr24key=YOUR_SHARING_KEY
      ./fr24feed_arm-le_233s --fr24key=YOUR_SHARING_KEY --bs-ip=xxx.xxx.xxx.xxx --bs-port=NNNNN
      pi@raspberrypi ~ $
      In fact on my setup I had to use parameters of --bs-ip=127.0.0.1 --bs-port=30003 due the FR24 feed servers passing back saved out of date data back to the feeder.
      Last edited by peterhr; 2014-02-07, 18:31.

      Comment


      • Thanks for details!
        I just got the RPi and facing the another issue.

        The RPI cannot obtain an IP address from Router via DHCP. The FDX, LNK, 100 Light from RPI/Lan Light of Router is switched on but it still cannot obtain an IP address...
        I just read from #111 post and I think my situation is similar to the post, but I am not familiar with Linux, so how can I type some command like the post in order to solve it?

        Thanks!

        Reference:
        Router - TP-LINK TL-WR841N with original Firmware
        Last edited by Dundee; 2014-02-16, 23:52.
        T-VHST9: http://vhst9.hopto.org/
        (24/7)

        Comment


        • Assuming you are using a wired connection to the router - if wireless it gets more complicated

          Please see http://www.cyberciti.biz/faq/howto-l...nt-ip-address/

          There is lots to find on stuff like this, when googling try 'wheezy', 'Debian' and 'Linux' in that order when constructing your queries

          To find out what is going on you probably will need to connect the Pi to a TV to get a display, and to attach a USB keyboard to drive it
          ... the Pi setup doesn't usually have the GUI interface enabled - so theres little point in connecting a mouse.

          Then do 'ifconfig' to see the status of the network interface.

          Comment


          • My first foray into ADSB and Raspberry pi. Thanks peterhr for the brilliant instructions.

            I've followed Peter's instructions to the letter and almost success.

            However, when dump1090 starts (./dump1090 --interactive --net) the dongle light goes out and I get no data from the dongle. I do get the dump1090 headings though (Hex, Mode, Sqwk,Flight etc). I suspect my problem is a dodgy power supply. I don't have a powered hub so before I splash out on one, can one of you experts confirm the symptoms point to a power problem.

            rtl_test -t confirms the dongle can be seen.

            I did have to make a blacklist as I got an error message about the device is claimed by a second instance ...

            I'm using Wheezy from the Noobs distribution
            T-EGUB1

            Comment


            • Originally posted by trigger View Post
              My first foray into ADSB and Raspberry pi. Thanks peterhr for the brilliant instructions.

              I've followed Peter's instructions to the letter and almost success.

              However, when dump1090 starts (./dump1090 --interactive --net) the dongle light goes out and I get no data from the dongle. I do get the dump1090 headings though (Hex, Mode, Sqwk,Flight etc). I suspect my problem is a dodgy power supply. I don't have a powered hub so before I splash out on one, can one of you experts confirm the symptoms point to a power problem.

              rtl_test -t confirms the dongle can be seen.

              I did have to make a blacklist as I got an error message about the device is claimed by a second instance ...

              I'm using Wheezy from the Noobs distribution
              Welcome to the ADSB Pi club :-)

              The driver which now comes with the Wheezy kernel does cause problems, and can be removed by either making a blacklist (as you did) or by compiling the rtl-sdr driver source with the -DDETACH_KERNEL_DRIVER=ON option. This is given in Peter's document. The built-in driver shouldn't cause any problems after this.

              The problem of the dongle going off when you start dump1090 is most likely a power supply problem, as you suspect. What are you using to power the Pi? You need a 5V power supply with at least a 1 Amp capacity to drive the Pi and the dongle. If you're using a mobile phone charger, check the maximum current capacity of the charger. It's usually printed on the adapter. If you're using a WiFi dongle, this consumes additional power. I had to use a powered USB hub when I was using a wifi dongle because my Samsung phone charger wasn't able to drive the Pi + RTL dongle + Edimax WiFi dongle.

              If you're not using a WiFi dongle and want to test before buying a powered hub, see if you can borrow a Samsung travel charger (it's the white one they usually ship with their tablets and the Note 2 or 3). This can supply 2 Amps (according to the label) and should be able to run the Pi and the RTL dongle.

              Hope this helps.
              Jayant
              T-VABB7 | RTL dongle + Raspberry Pi + dump1090 + Bulgarian 5dBi collinear

              Comment


              • Originally posted by trigger View Post
                My first foray into ADSB and Raspberry pi. Thanks peterhr for the brilliant instructions.

                I've followed Peter's instructions to the letter and almost success.

                However, when dump1090 starts (./dump1090 --interactive --net) the dongle light goes out and I get no data from the dongle. I do get the dump1090 headings though (Hex, Mode, Sqwk,Flight etc). I suspect my problem is a dodgy power supply. I don't have a powered hub so before I splash out on one, can one of you experts confirm the symptoms point to a power problem.

                rtl_test -t confirms the dongle can be seen.

                I did have to make a blacklist as I got an error message about the device is claimed by a second instance ...

                I'm using Wheezy from the Noobs distribution
                I did new instruction earlier this year that used a minimal Wheezy build that didn't have the RTL drivers in the kernel - avoiding the issues Jayant mentioned and that will run on a 1Gb SDcard. I would get another SD card, and start there.

                The Noobs wheezy is now very bloated and has a lot of stuff included you just don't need (are trying to compete with Microsoft & Windows but on a single board computer).

                I agree about the power supply - I do have a suspicion the the nooelec RTL dongle (maybe 5cm long) uses more power than the little square one (1.5cm square) - the long one seems to get warmer. if you have an adequet power supply the pi is quite capable of running the dongle. If the poer supply isn't up to it and you try to use it to power a USB hub, Pi and dongle - then it'll probably be worse.

                Do try the dongle in the other USB port too, just in case it makes a difference.

                Comment


                • Hi Jayant,

                  I've found a 5v 2a power supply.

                  I went back to the cmake and added the extra bit you suggested then followed the instructions again. I'm still not getting any data but the dongle light dims then brightens again when I do ./dump1090 --interactive.
                  I'm now getting:-

                  Found 1 device
                  Found Rafael Micro Micro R820T tuner
                  Max available gain is 49.60
                  Setting gain to 49.60
                  Exact sample rate is 2000000.052982 Hz
                  Gain reported by device is 49.60
                  I then get the Hex, Mode, Sqwk headings but no data

                  The antenna I'm using is one that works fine on a PC. I'm running the session via PuTTY on a PC.
                  T-EGUB1

                  Comment


                  • Peter, you posted whilst I was composing my response to Jayant. I will try the other usb port first.
                    T-EGUB1

                    Comment


                    • Originally posted by trigger View Post
                      I'm now getting:-

                      Found 1 device
                      Found Rafael Micro Micro R820T tuner
                      Max available gain is 49.60
                      Setting gain to 49.60
                      Exact sample rate is 2000000.052982 Hz
                      Gain reported by device is 49.60
                      I then get the Hex, Mode, Sqwk headings but no data

                      The antenna I'm using is one that works fine on a PC. I'm running the session via PuTTY on a PC.
                      What does top show you when dump1090 is running? Dump1090 should be using up around 30% CPU or more.


                      Sent from my GT-I9500 using Tapatalk
                      T-VABB7 | RTL dongle + Raspberry Pi + dump1090 + Bulgarian 5dBi collinear

                      Comment


                      • Originally posted by Dundee View Post
                        The RPI cannot obtain an IP address from Router via DHCP. The FDX, LNK, 100 Light from RPI/Lan Light of Router is switched on but it still cannot obtain an IP address...
                        I just read from #111 post and I think my situation is similar to the post, but I am not familiar with Linux, so how can I type some command like the post in order to solve it?

                        Thanks!

                        Reference:
                        Router - TP-LINK TL-WR841N with original Firmware
                        Hi Dundee,

                        Can you confirm whether you're using a wired or a wifi connection? If it's a problem related to a wifi dongle, you may need to configure it by installing wpasupplicant on your Pi and configuring it. Please also post the dongle model you're using, if you're on wifi.

                        Best,
                        Jayant
                        T-VABB7 | RTL dongle + Raspberry Pi + dump1090 + Bulgarian 5dBi collinear

                        Comment


                        • Originally posted by Jayant View Post
                          Hi Dundee,

                          Can you confirm whether you're using a wired or a wifi connection? If it's a problem related to a wifi dongle, you may need to configure it by installing wpasupplicant on your Pi and configuring it. Please also post the dongle model you're using, if you're on wifi.

                          Best,
                          Jayant
                          Just a thought - RTL 820T Dongle + Wifi dongle may be beyond Raspberry Pi USB power capability. Might need a powered USB hub to run both.

                          Comment


                          • Some success. I've borrowed a powered hub. The pi is wired to the hub so no wireless to confuse matters.

                            On the pi web page (192.168.1.75) I get the occasional plane. My antenna when connected to my PC will typically pick up 30 to 40 planes.

                            The dump1090 screen is showing the header (Hex, Mode, Sqwk,Flight etc) for each line of data. Also I got about 30 lines of just the header when I first ran dump1090.

                            Any suggestions? If not, I've got a 2Gb SD card which I can sacrifice so I'm tempted to start from scratch.
                            Many thanks for your help so far.
                            Last edited by trigger; 2014-02-17, 14:43. Reason: forgot something
                            T-EGUB1

                            Comment


                            • Originally posted by trigger View Post
                              Some success. I've borrowed a powered hub. The pi is wired to the hub so no wireless to confuse matters.

                              On the pi web page (192.168.1.75) I get the occasional plane. My antenna when connected to my PC will typically pick up 30 to 40 planes.

                              The dump1090 screen is showing the header (Hex, Mode, Sqwk,Flight etc) for each line of data. Also I got about 30 lines of just the header when I first ran dump1090.

                              Any suggestions? If not, I've got a 2Gb SD card which I can sacrifice so I'm tempted to start from scratch.
                              Many thanks for your help so far.
                              Should do much better than that - click the link in my sig ... that is a Pi+dongle+home built co-linear (with an amplifier that didn't make much difference), I don't see much eastwards because the house roof gets in the way (need to do some antenna work)

                              Comment


                              • Originally posted by trigger View Post
                                Some success. I've borrowed a powered hub. The pi is wired to the hub so no wireless to confuse matters.

                                On the pi web page (192.168.1.75) I get the occasional plane. My antenna when connected to my PC will typically pick up 30 to 40 planes.

                                The dump1090 screen is showing the header (Hex, Mode, Sqwk,Flight etc) for each line of data. Also I got about 30 lines of just the header when I first ran dump1090.

                                Any suggestions? If not, I've got a 2Gb SD card which I can sacrifice so I'm tempted to start from scratch.
                                Many thanks for your help so far.
                                Hmmm... I'm guessing here, but it looks like you may have a dodgy dump1090 installation. I would suggest that you delete the rtl-sdr driver directory and the dump1090 directory completely, download them again and recompile according to Peter's instructions. You could also try running dump1090 with the --aggressive option on the command line to see if this makes any difference.

                                I am assuming that the antenna and dongle are exactly the same when you run RTL1090 and the Windows version of the FR24 feeder. If not, try with the same antenna and dongle on both installations.
                                T-VABB7 | RTL dongle + Raspberry Pi + dump1090 + Bulgarian 5dBi collinear

                                Comment

                                Working...
                                X