Announcement

Collapse
No announcement yet.

Raspberry Pi type B + DVB-T Dongle to feed FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone ran an upgrade on a stock raspbian? I'm not feeling comfortable doing an upgrade without knowing that the kernel/driver problems have been resolved or not.

    Comment


    • If you're happy with the way it works - don't upgrade
      If you really do want to upgrade, make a copy or image of the SD card first ... in fact it's probably keeping such a copy anyway, just in case the [running] card fails.

      My main concern in doing the rewrite was to be sure that new users had an instruction they could follow that would work.

      (co incidentally, that new write up would also work for the BeagleBone Black .... just need to start with the BBB version of Wheezy)

      Comment


      • I'm happy with the way it works. The problem is that I'm running other things on the raspi too, and some of them need to be upgraded.

        Comment


        • Your document is a very good step-by-step guide (thanks!). As I'm short on time, I tried the shortcut and just downloaded the image file (thanks again!) and set it up on a 2 GBy card, without partition resizing, etc. My RPi boots fine, but I'm unable to log in, either the usual "login-password" pair is not valid for this case or there are other problems.

          SSH way: PuTTY access was not possible (is SSH enabled on the OS image by default?), although the same RPi board can be accessed via PuTTY without any problems when using different SD cards for booting. The IP address reservation was done at my local DHCP server, and works OK (verified) when booting with the other SD cards.

          USB way: I have 2 wireless keyboards (hardware RF oriented, not Bluetooth), both work OK for Raspbian and XBMC SD cards without asking for any drivers, but the OS on this image file, even if it recognizes the keyboards, tends to get repeating keypresses (even if the small USB receiver is pulled out!). Because of this, I was unable to login.

          I wonder if SSH is disabled on the image file.

          Any suggestion will be welcome. Regrettably, I don't have any wired USB keyboard at hand.

          Edited: I suppose you have a Version 2 Model B Raspberry Pi (512 MBy). I have one of the early, Version 1, 256 MBy RAM units, and there are subtle hardware differences, perhaps these differences prevent the image file to work in my RPi.

          Thank you in advance, best regards.

          [please disregard any idiomatic mistake]
          Last edited by Andres; 2014-01-15, 00:05. Reason: Added mention to 256 MBy RPi model B
          T-SABE8 - Raspberry Pi + RTL2832U / R820T USB + dump1090

          Comment


          • New image is based on a minimal wheezy build.
            * SSH is enabled
            * user: root
            * password: raspberry

            Are you sure you know what IP address it's on?

            (BTW. I use free andriod app "Fing" to find these - excellent - et even decodes the manufacturer of the device it's pinging ... probably be MAC address decode ... the Pi shows as 'Raspberry pi foundation'
            Last edited by peterhr; 2014-01-15, 07:15.

            Comment


            • Hi, thank you for your answer.

              After feeling locked about using SSH on the image-file-generated SD card, I started over with a fresh Raspbian card, following your guide step by step. SSH worked perfectly this time. Actually, I forgot changing to root, but did everything as "pi" with the extra attention to "sudo" each command line.

              When trying to do the "quick test to ensure tuner can be found", I obtain the following answer:

              ----------------------------------------
              pi@Raspbian140115$ rtl_test -t

              Found 1 device(s):
              0: Generic RTL2832U OEM

              Using device 0: Generic RTL2832U OEM

              Kernel driver is active, or device is claimed by second instance of librtlsdr.
              In the first case, please either detach or blacklist the kernel module
              (dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

              usb_claim_interface error -6
              Failed to open rtlsdr device #0.
              ----------------------------------------

              I guess that the OS has a native, default driver for the rtl-sdr (oriented to classic DTV usage), and that I should "detach" or "blacklist" it before using it with Dump1090. However, I was unable to find the way to detach (if possible, it would be convenient to remove the dvb_usb_rtl28xxu from the kernel, altogether).

              Do you know how can this be achieved?

              Thank you in advance, best regards.

              Update: editing a file in etc/modprobe.d/ as documented in http://www.raspberrypi.org/forum/vie...l28xxu#p386363 solved this conflict, so I will be able to advance to the next step.
              Last edited by Andres; 2014-01-16, 00:24. Reason: solved!
              T-SABE8 - Raspberry Pi + RTL2832U / R820T USB + dump1090

              Comment


              • The maim raspbarian release does have a kernel mode driver, at the time of writing the second install guide - the minimal release (user root) did not. Read back a few pages in this thread to see what others did with the main rasperian.

                A quick thought.

                can you just check there isn't any rtl_test or dump1090 running before you start dump1090 (maybe power cycle) since that would claim the dongle ... since this will definitely cause the message you're seeing (just tested it on my rig to be sure )

                If you run rtl_test without any parameters, it seems not to exit - it says it will, but it doesn't
                rtl_test survives a "killall rtl_test",
                doing a kill -9 on it's pid can kill the console session - that just needs a login again.
                Last edited by peterhr; 2014-01-16, 08:07.

                Comment


                • Edit: ignore.. got it working... looking good.
                  Last edited by t-kclt2; 2014-01-16, 22:10.

                  Comment


                  • Originally posted by t-kclt2 View Post
                    Edit: ignore.. got it working... looking good.
                    What was the problem (do we need to modify the document so someone else doesn't get the same problem)

                    Comment


                    • I ran into a few things that got resolved by a reboot.. Initially, when doing rtl_test, it listed the device as found but would also list a bunch of messages how things errored out -- however, upon reboot all those went away. Then had an issue with "port in use" and that was taken care of by a reboot too (now that I have it auto-start dump1090). Killall did not help with that, so not sure what happened or why it thought that the port was in use. (it's been a LONG time since I last played with Linux so not sure if ps -e would list all processes running?)

                      One suggestion for the document would be to do the detach kernel driver option which was not in the doc but I did it anyways.. so never ran into the driver conflict some mentioned (though I started with that minimal image mentioned in the doc). Did not need to do the blacklist config file.

                      Now just need a better antenna

                      Comment


                      • The full Wheezy needs the RTL driver detached from the kernel, luckily it's not included in the minimal (yet)

                        The prebuilt image includes a fr24.sh script to start / restart dump1090 and the fr24feed software ... much easier than doing it as services, and also includes a cron job with @reboot to run the script first time as well as a schedule to restart it periodically (downtime is about 5s when this happens)

                        for antennas se http://forum.flightradar24.com/threa...1-best-antenna - http://www.balarad.net/ - there is a youtube for this too.

                        Comment


                        • Off topic matters. Just to mention:

                          1) FA is working on a program that allows Rpi users to upload their data to FA in the future.
                          2) Their own ads-b hardware FlightFeeder is powered by Rpi.

                          Source: http://discussions.flightaware.com/a...4f5e862109317e

                          Comment


                          • Has anybody of the Linux Feeders noticed a problem with feeding? I have 2 Pi up and running and both programs - dump1090 and the Linux feeding software are working fine:

                            PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
                            7517 pi 20 0 14792 5032 920 S 37.2 1.1 11:28.45 dump1090
                            7518 pi 20 0 10072 796 692 S 2.9 0.2 1:04.95 fr24feed_arm-le

                            I can also see both Receivers on my local Virtual Radar (including the planes :-) ). Internet Connection is also up and running. But my premium account says: offline, last feed was exactly today at 1pm GMT+1. Do you have any idea what could be wrong? I restarted the Pis and also my Internet Connection already but no success.

                            Thanks very much in advance.
                            T-EDDM 2
                            2 x Raspberry Pi with dump 1090 and Linux Feeder Software

                            Comment


                            • Originally posted by T-EDDM2 View Post
                              Has anybody of the Linux Feeders noticed a problem with feeding? I have 2 Pi up and running and both programs - dump1090 and the Linux feeding software are working fine:

                              PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
                              7517 pi 20 0 14792 5032 920 S 37.2 1.1 11:28.45 dump1090
                              7518 pi 20 0 10072 796 692 S 2.9 0.2 1:04.95 fr24feed_arm-le

                              I can also see both Receivers on my local Virtual Radar (including the planes :-) ). Internet Connection is also up and running. But my premium account says: offline, last feed was exactly today at 1pm GMT+1. Do you have any idea what could be wrong? I restarted the Pis and also my Internet Connection already but no success.

                              Thanks very much in advance.
                              Phew - I have exactly the same problem - I rebooted and even wrote a new image to my SD card, like you Dump1090 is fine and I can ping the FR24 server from the RPi. Mine stopped at: 2014-01-30 01:21:27

                              At least it must be something we have not done therefore, maybe they have updated the software ?

                              John
                              Last edited by milair; 2014-01-30, 20:44.
                              T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

                              Comment


                              • Seems like this. Probably peterhr - as the Pi-god :-) - could check as well and give a reply.
                                T-EDDM 2
                                2 x Raspberry Pi with dump 1090 and Linux Feeder Software

                                Comment

                                Working...
                                X