Announcement

Collapse
No announcement yet.

Linux feeder software for Flightradar24 (Old software)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello there!
    I'm new here and I am willing to provide data using the flightaware raspberry pi machine: flightfeeder.
    But I am trying to share the data that it provides from the built in dump1090.

    When I try to feed it directly from the pi, it keeps flooding the command line with messages like this:

    [e]Data feed time difference too big abs( - 15:52:37.855)=56310
    [e]Data feed time difference too big abs( - 15:52:37.857)=56310
    [e]Data feed time difference too big abs( - 15:52:37.859)=56310

    I don't know what I am doing wrongly.
    But it is providing live data to Planeplotter and flightaware.
    I am currently using it to feed data to FlightRadar24, but the best would be if everything runs on the FlightFeeder.

    Thank you!

    Comment


    • Originally posted by luizin View Post
      Hello there!
      I'm new here and I am willing to provide data using the flightaware raspberry pi machine: flightfeeder.
      But I am trying to share the data that it provides from the built in dump1090.

      When I try to feed it directly from the pi, it keeps flooding the command line with messages like this:

      [e]Data feed time difference too big abs( - 15:52:37.855)=56310
      [e]Data feed time difference too big abs( - 15:52:37.857)=56310
      [e]Data feed time difference too big abs( - 15:52:37.859)=56310

      I don't know what I am doing wrongly.
      But it is providing live data to Planeplotter and flightaware.
      I am currently using it to feed data to FlightRadar24, but the best would be if everything runs on the FlightFeeder.

      Thank you!
      that is rather interesting, flightaware (who have no low level coverage in this area) told me they do not support linux, so I'm curious how an RPi can be feeding them, or is this a very recent change? (URL?)

      Comment


      • Originally posted by Ressy View Post
        that is rather interesting, flightaware (who have no low level coverage in this area) told me they do not support linux, so I'm curious how an RPi can be feeding them, or is this a very recent change? (URL?)
        They only support linux when you use their machine which is based on RPi (FlightFeeder http://flightaware.com/adsb/flightfeeder/). All the software is ready OOtB. I don't think they will release their RPi-Linux software for use elsewhere.
        The thing is that they allow us to share the obtained data to any other project if you want to. I am using the PlanePlotter to share its data with FR24, but this is annoying. And the FlightFeeder provides data directly in Basestation format, but the FR24 software is not accepting it. That's why I am asking for help here.

        Comment


        • Originally posted by luizin View Post
          They only support linux when you use their machine which is based on RPi (FlightFeeder http://flightaware.com/adsb/flightfeeder/). All the software is ready OOtB. I don't think they will release their RPi-Linux software for use elsewhere.
          The thing is that they allow us to share the obtained data to any other project if you want to. I am using the PlanePlotter to share its data with FR24, but this is annoying. And the FlightFeeder provides data directly in Basestation format, but the FR24 software is not accepting it. That's why I am asking for help here.
          So you are tampering with their device, adding FR24 feeder software on their device?
          If you are using a PC to poll their device for data to submit to FR24, it does work? Just not with FR24 software?
          What version of FR24 software are you using?
          At a guess (not knowing their device) perhaps the device resources are exceeded, lagging it. does it show anything else? does it show it's feeding? what is the device time? is NTPd running?

          Mine runs on a real linux PC not an RPi since it feeds many places except flughtaware), it was last restarted sunday week ago (installed new kernel)

          [i]FR24Feed v242 - built on Apr 23 2014/10:19:07
          [i]Downloading configuration...OK
          [i]Parsing configuration...OK
          [c]Interval: 5s
          [c]Latitude: -27.xxxx
          [c]Longitude: 152.xxxx
          [c]GND: YES
          [c]NonADSB: YES
          [i]Source defined as Basestation
          [b]connecting to localhost:30003
          [b]connected
          [b]working
          [n]defined 1 server
          [n]YBBN30@83.140.21.66:8099/UDP
          [n]connecting
          [i][stats]Stats thread started
          [i]Data feed time difference OK abs(13:10:17.963 - 13:10:17.958)=0
          [n]connected
          [n]switching to UDP
          [n]working
          [i]sent 23 planes in 1 packets

          .. all subsequent loggings are sent xx planes and ping messages,

          Is that what you see, or do you see other "e" messages?

          Comment


          • Originally posted by Ressy View Post
            So you are tampering with their device, adding FR24 feeder software on their device?
            If you are using a PC to poll their device for data to submit to FR24, it does work? Just not with FR24 software?
            What version of FR24 software are you using?
            At a guess (not knowing their device) perhaps the device resources are exceeded, lagging it. does it show anything else? does it show it's feeding? what is the device time? is NTPd running?

            Mine runs on a real linux PC not an RPi since it feeds many places except flughtaware), it was last restarted sunday week ago (installed new kernel)

            [i]FR24Feed v242 - built on Apr 23 2014/10:19:07
            [i]Downloading configuration...OK
            [i]Parsing configuration...OK
            [c]Interval: 5s
            [c]Latitude: -27.xxxx
            [c]Longitude: 152.xxxx
            [c]GND: YES
            [c]NonADSB: YES
            [i]Source defined as Basestation
            [b]connecting to localhost:30003
            [b]connected
            [b]working
            [n]defined 1 server
            [n]YBBN30@83.140.21.66:8099/UDP
            [n]connecting
            [i][stats]Stats thread started
            [i]Data feed time difference OK abs(13:10:17.963 - 13:10:17.958)=0
            [n]connected
            [n]switching to UDP
            [n]working
            [i]sent 23 planes in 1 packets

            .. all subsequent loggings are sent xx planes and ping messages,

            Is that what you see, or do you see other "e" messages?
            It doesn't work, even when connecting it from a PC.

            It give's a message saying that maybe the basestation version is old and the messages are delayed by 5 minutes (which they aren't). I am guessing that the file format that the flightfeeder dump1090 is different than the expected. (It gives just a single timestamp, while FR24 software is expecting two, one with the current time and another one of the message time). Maybe the only thing to do would be detecting that just one timestamp is present and ignore the difference.

            And no, the device resources are a lot more than needed. It's a rev 2 version B Raspberry Pi. It have 512 MB ram, while it uses about 100 MB on normal conditions. And an ARM CPU that the use never got over 10%. And you can log in to a linux bash terminal in it using a keyboard directly connected to the device, it's not tampering with it. :P

            NTPd is up and running. And the device time is correct.
            Last edited by luizin; 2014-07-16, 00:25.

            Comment


            • A very quick word - I've tried the current RPi setup on the new RPi B+ (the one with 4 USB ports).

              The old release of Wheezy doesn't enable the USB device (that also means the network since that runs through USB). If you're itching to buy a Pi to start feeding, buy the old model - if you can wait a week or two for operating systems (besides noobs) to be released - then wait.

              Comment


              • Got some strange effect using the Raspberry Pi software. For some reason the heading and speed are not changed on the FR24 site. The output of dump1090 is OK. For images see thread: forum.flightradar24.com/threads/6133-Raspberry-Pi-type-B-DVB-T-Dongle-to-feed-FR24/page74 post #735 and #737. Any solutions?

                Comment


                • Originally posted by peterhr View Post
                  Do you give the world access to an unlocked screen on your windows PC?

                  If you are using the Pi in the way described here http://forum.flightradar24.com/threa...e-to-feed-FR24 - then it does a few things that are insecure.

                  we run the software as root - we could create a user level account and run the software from there (see http://www.debian-administration.org...ding_new_users )
                  we have not changed the root password

                  I admit I haven't bothered much with the security - I see the Pi feeder as a tool to do a specific job not as a multi-function multi-user machine, If I had another task that needs running I would get another Pi (interestingly I have Pi B+ with 4 USB ports on order, delivery tomorrow)

                  it would probably be better in the first instance that we ensured that the world don't get the access on the Pi they require to run 'ps' in the first place, if they do get that level of access, they can probably read the scripts and the keyfile.
                  My RasPi is accessible only to me so there is no issue of someone getting at my setup. However, it is certainly possible that someone less fortunate might have the information exposed. I am not a fan of security by obscurity having worked in IT almost 30 years so it is just a reflexive action on my part when I see holes. When I see an exposed *nix command line in "ps", it reminds me of this old rec.humor.funny posting from back in 1996 of a "ps" display (see http://www.netfunny.com/rhf/jokes/96/Dec/rn.html):
                  Code:
                  Should we tell morse that he does not have to specify a newsgroup
                  when he fires up rn? :-)
                  
                    2:32pm  up 6 days, 21:32,  7 users,  load average: 0.31, 0.65, 0.34
                  User     tty       login@  idle   JCPU   PCPU  what
                  jda      console  11:02am  3:29   9:10   9:07  xterm -sb -bg navy -bd purple -m
                  jda      ttyp0     2:24pm            1         w 
                  jda      ttyp1    11:03am     1      1         -sh 
                  jda      ttyp2    11:03am  2:00                -sh 
                  mark     ttyp3    Mon 5pm    44   9:56     19  /usr/local/bin/less 
                  jda      ttyp4    11:04am     5      1         -sh 
                  morse    ttyp5    12:57pm  1:31      2      2  rn alt.sex.incest
                  T-KISP3 feeder covering KFRG and KISP airports on Long Island.

                  Comment


                  • A lot of the reason for putting the instructions as they are is to make it as simple as possible for someone who doesn't know Linux to get a system up and running

                    If someone wants to change the password on their Pi the command is passwd - just answer the questions (probably a good idea to do this if other people can access your network)

                    To create a new user do adduser username
                    answer the questions

                    move the feeder & dump1090 to the new user
                    list crontab contents to the newuser
                    change all file ownerships to be owned by the new user

                    mv * /home/username
                    crontab -l /home/username/cron.txt
                    chown -R username:username /home/username/*

                    now do crontab -e and remove all the stuff from root crontab

                    logon as the new user and load the saved cron entries into crontab
                    do crontab <cron.txt

                    restart the feeder.

                    That should do it (note though ... I've not tried this)
                    ----------------------------------------------------
                    30 years ago was when DNS was introduced - surely alt.sex was just one of those new fangled domain names like com. and gov.
                    Last edited by peterhr; 2014-07-19, 15:50.

                    Comment


                    • @aardvark (must be Dutch...)
                      The root password should be changed on first use! I agree on that one.
                      I made a new 'non-root' extra user but I am wondering if that increases or decreases security. My own security wrt f***ing up things in the OS: yes. For the outside world an extra user means an extra entry to the system and thus extra vulnarability.

                      Comment


                      • Originally posted by Harrie45 View Post
                        @aardvark (must be Dutch...)
                        The root password should be changed on first use! I agree on that one.
                        I made a new 'non-root' extra user but I am wondering if that increases or decreases security. My own security wrt f***ing up things in the OS: yes. For the outside world an extra user means an extra entry to the system and thus extra vulnarability.
                        but if someone finds a way to do a url hack on dump1090 web page (if published), it's not running trusted ?

                        Comment


                        • Originally posted by peterhr View Post
                          but if someone finds a way to do a url hack on dump1090 web page (if published), it's not running trusted ?
                          In fact you are running a web server (T-EGBB19) that is accessible from the outside. For that more complex security precautions apply. To name one: buffer overrun attacks.

                          Comment


                          • Originally posted by Harrie45 View Post
                            Got some strange effect using the Raspberry Pi software. For some reason the heading and speed are not changed on the FR24 site. The output of dump1090 is OK. For images see thread: forum.flightradar24.com/threads/6133-Raspberry-Pi-type-B-DVB-T-Dongle-to-feed-FR24/page74 post #735 and #737. Any solutions?
                            I found out that dump1090 does not output any TCP30003 message carrying speed and track when the plane has landed.
                            See some (1-plane filtered) output here.
                            -1 at the end of line means: on ground

                            Comment


                            • see this page http://www.satsignal.eu/raspberry-pi/dump1090.html (includes and email address for Malcolm Rob)
                              make sure you are running the latest version of dump1090 (just a few days old - always do keep the prior version, just in case)

                              Comment


                              • LOWL1,

                                Any succes yet?

                                I have the same configuration, and don't know how to start?


                                Originally posted by LOWL1 View Post
                                hello to all!

                                my situation:
                                SBS-3 only connectet to lan
                                Raspberry Pi also connected to lan.
                                no usb or serial connections

                                what i want:
                                feed my data from sbs-3 with my raspberry pi to fr24 without usb or serial connection.

                                what i have installed to my raspberry pi:
                                remserial 1.4, to create a virtual serial port to my sbs-3
                                adsbox(-latest), for decoding
                                fr24feed_arm-le_225s, to feed the data

                                1st ssh window (192.168.170 is my sbs3, remserial1 is the virtual serial port):
                                pi@raspberrypi /etc/fr24/remserial $ sudo ./remserial -r 192.168.0.170 -p 10001 -l /dev/remserial1 /dev/ptmx &
                                [1] 2014
                                pi@raspberrypi /etc/fr24/remserial $
                                =>serial port is running

                                2nd ssh window:
                                pi@raspberrypi /etc/fr24/adsbox sudo ./adsbox -s /dev/remserial1 --baud 3000000 -l 48.2300 -g 14.1800
                                adsbox ADS-B decoder version 20120728.
                                Your lat 48.23000 lon 14.18000
                                Init database.
                                Using /dev/remserial1 as input serial device.
                                Run SBS-1 data server on port 30003
                                Run HTTP server on port 8080

                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:10
                                DF:1
                                DF:10
                                DF:10

                                =>seems to connect but no plane data. when i connect with basestation lots of planes are shown.

                                3rd ssh window:
                                pi@raspberrypi /etc/fr24 $ ./fr24-225s --fr24key=xxxxxxxxxxxxx
                                [i]FR24Feed v225 - built on Oct 8 2012/09:38:58
                                [i]Downloading configuration...OK
                                [i]Parsing configuration...OK
                                [c]Interval: 5s
                                [c]Latitude: 48.2300
                                [c]Longitude: 14.1800
                                [c]GND: YES
                                [c]NonADSB: YES
                                [i]Source defined as Basestation
                                [b]connecting to localhost:30003
                                [b]connected
                                [b]working
                                [n]LOWL1@83.140.247.21:8099/UDP
                                [n]connecting
                                [n]connected
                                [n]switching to UDP
                                [n]working
                                [n]ping
                                [n]ping

                                =>no data sending, because of no data from adsbox

                                i killed the remserial process (2014) an made a telnet to my sbs-3 port 10001:
                                telnet 192.168.0.170 10001 and strange data appeared:
                                E????`/?K?إL?(0`^?;?xd?HA?h???"??:>;?;?;?????}0???<I&?~?? <I&??mg???`/?K?u??? 0?E?N??;???(?BI?
                                6?ᠾo6???7?Q0??|k???W8???K?h?b????~k:
                                ?E?NQ?;?;?;?dQ?
                                ???`/d?<2\;?;?;???? ?K??o;??A????8???WǓ??a??K?A?W?;?;???? ?Dz??w;??f????j)L???;?;?;?????D?? 8);??c?(
                                K??y<n?]K???;?;?;?=??<Q??;?;??????5#5 ?PlE?;?;?????.u??????[?E? ?$\`
                                ?G?;?;?;?;?3 ?gV??;?;?;?x?? ?@
                                ????.
                                D?UM;?G?? ?H?
                                ?/;?U'?(L?M
                                ??I;?;?;?;??D? Pr?`"?;?;?I? ;?;?;??:?(L?M?PE?($@
                                D?q0;?|? ?Dz?o~;??n]<dF??;? ?]9F???;??5?@fo?E????;?;?ug_Dz?߱T??@dY???2;?;????@f? E????P;?;?;?;??]<Mg??;?;??? ?L?M?;?;???
                                L?eq
                                ;?;?j?
                                ?<Q8P??
                                (L?M??;?;?;?;?;?;?;?V?(?L?e?#?w?@
                                ՙE? ??;?;??u?9F?`?Qy?7?;?;??S&yA%??!;???9F?s??mI;????D ?`??7I??y???D??W?$?8??0?y?$ DX??N]@dY?;?>? ?Dz??(;?;?w????S?-?DX??;? J]F???1;?;??????8DX*;?;?;?;?;?;?;?;?;?;?;?c%?<I&???? ????;?;?;?.X ?K??X???`??;??? ?E?N?!;?t!(?K?]?2*!?8?80<dF?A?P!(E?N?;?;??b"?<dF ?7`8 ?v;?8Y#(E?Nf?;?;?;?;?;?@?%(E?N???% ?.???
                                &?$??0 dF6l;?

                                any idea what i have done wrong?
                                please help!
                                Ken
                                Near EBAW

                                Comment

                                Working...
                                X