Announcement

Collapse
No announcement yet.

Linux feeder software for Flightradar24 (Old software)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by peterhr View Post
    the raspberry pi thread maybe?
    I'm not sure where this is and there's nothing on this thread!
    Michael
    Palmerston North,
    New Zealand
    ex-FR24 Feeder

    Comment


    • Originally posted by nzradar View Post
      I'm not sure where this is and there's nothing on this thread!
      http://forum.flightradar24.com/threa...e-to-feed-FR24
      - post 8 links to info to putting a Pi + dongle based receiver together
      - post 460 (thread is presently 466 long so 6 from the end) - output from dump1090

      Comment


      • My fr24.sh script:

        #updated 2014-01-27 - write /tmp/fr24feed.log
        killall fr24feed_x86_240
        pkill -9 frfeed24_x86
        killall dump1090
        cd /home/pi/dump1090
        /home/pi/dump1090/dump1090 --enable-agc --aggressive --net-http-port 8090 --net --net-sbs-port 30003 --net-ro-port 30002 --net-bo-port 30005 --quiet --lat -27.912 --lon 25.162 > /dev/null &
        cd ~
        export FR24AUTHIP=83.140.247.20
        /home/pi/fr24feed_x86_240 --fr24key=my-key-goes-here 2>&1 | while read line; do echo $(date +"%d-%m-%y - %H:%M:%S") "$line"; done > /tmp/fr24feed.log &


        And when executed, this is all that I can see on the terminal....

        pi@ADS-B:~$ ./fr24.sh
        fr24feed_x86_240: no process found
        dump1090: no process found
        pi@ADS-B:~$ Found 1 device(s):
        0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
        Found Rafael Micro R820T tuner
        Max available gain is: 49.60
        Setting gain to: 49.60
        Exact sample rate is: 2000000.052982 Hz
        Gain reported by device: 49.60
        pi@ADS-B:~$

        ..... Then its active
        The box is called PI, tho its not actually a Pi. :-)

        Comment


        • Originally posted by HermanZA View Post
          My fr24.sh script:

          snip...
          cd /home/pi/dump1090
          /home/pi/dump1090/dump1090 --enable-agc --aggressive --net-http-port 8090 --net --net-sbs-port 30003 --net-ro-port 30002 --net-bo-port 30005 --quiet --lat -27.912 --lon 25.162 > /dev/null &
          snip...

          ..... Then its active
          The box is called PI, tho its not actually a Pi. :-)
          But the standard output from dump1090 is suppressed and is being dispatch into the black hole in this example...

          Comment


          • Suppressing those commands, then it looks like this:

            Found 1 device(s):
            0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
            Found Rafael Micro R820T tuner
            Max available gain is: 49.60
            Setting gain to: 49.60
            Exact sample rate is: 2000000.052982 Hz
            Gain reported by device: 49.60
            *8d00b20558b984cd4ce8ffb9690b;
            CRC: 000000 (ok)
            DF 17: ADS-B message.
            Capability : 5 (Level 2+3+4 (DF0,4,5,11,20,21,24,code7 - is airborne))
            ICAO Address : 00b205
            Extended Squitter Type: 11
            Extended Squitter Sub : 0
            Extended Squitter Name: Airborne Position (Baro Altitude)
            F flag : odd
            T flag : non-UTC
            Altitude : 36000 feet
            Latitude : 26278 (not decoded)
            Longitude: 59647 (not decoded)

            *5d00b085bba1c0;
            CRC: 000000 (ok)
            DF 11: All Call Reply.
            Capability : 5 (Level 2+3+4 (DF0,4,5,11,20,21,24,code7 - is airborne))
            ICAO Address: 00b085
            IID : II-00

            *8d00b205994520a2e0044ff0b2d4;
            CRC: 161c5e (wrong)
            No. of bit errors fixed: 1
            DF 17: ADS-B message.
            Capability : 5 (Level 2+3+4 (DF0,4,5,11,20,21,24,code7 - is airborne))
            ICAO Address : 00b205
            Extended Squitter Type: 19
            Extended Squitter Sub : 1
            Extended Squitter Name: Airborne Velocity
            EW status : Valid
            EW velocity : -287
            NS status : Valid
            NS velocity : -278
            Vertical status : Valid
            Vertical rate src : 0
            Vertical rate : 0
            and so on ....

            Comment


            • Originally posted by peterhr View Post
              The problem is no one here is running the same system as you, so to some extent people are guessing what to say since they cant try it first

              It's simpler to use method 2 and if cron is running, it allows other timed events to occur, so lets test if cron is running...
              Thank you for reply.
              Here is result of my cron test:

              Code:
               odroid@odroid:~$ ps aux | grep cron | grep -v grep
              root      2181  0.0  0.0   1324   480 ?        Ss   07:57   0:00 anacron -s
              root      2184  0.0  0.0   2320   844 ?        Ss   07:57   0:00 cron
              Last edited by Dauren; 2014-02-26, 16:19.
              F-UAAR1 T-UAAR3

              Comment


              • so cron is running, you should be able to use cron to start the script


                do 'crontab -e' to edit the table of cronjobs

                first line is to start the feeder when the machine starts (allow 10 seconds for the networking to get started and settle down)

                @reboot sleep 10;/home/pi/fr24.sh

                (you will need to fix the file location)

                you might want to put a job in to restart the feeder occasionally

                see http://www.thegeekstuff.com/2009/06/...ntab-examples/

                for example to restart every 00:04 6:04 12:04 18.04 you might add a line ...

                04 */6 * * * /home/pi/fr24.sh

                The 04 is the minute to do it
                the */6 says take the hour number divide it by 6, if there is no remainder run the job

                Comment


                • Hi, this is my tmux session with dump1090 @ odroid- u3

                  scaled_full_b1c50786378f8da90616.png

                  but i have problems with fr24feed_arm-le_241s after 10-20 min feeding i become:

                  Code:
                  Speicherzugriffsfehler (Speicherabzug geschrieben)
                  (Written dump (memory access error)
                  Please help
                  Last edited by EDVE-15; 2014-02-26, 22:28.
                  vy 73 de DG7ABL

                  EDVE - Odroid- U3 - Dump1090 - Arch Linux / Debian

                  Comment


                  • Originally posted by peterhr View Post
                    so cron is running, you should be able to use cron to start the script


                    do 'crontab -e' to edit the table of cronjobs

                    first line is to start the feeder when the machine starts (allow 10 seconds for the networking to get started and settle down)

                    @reboot sleep 10;/home/pi/fr24.sh

                    (you will need to fix the file location)

                    you might want to put a job in to restart the feeder occasionally

                    see http://www.thegeekstuff.com/2009/06/...ntab-examples/

                    for example to restart every 00:04 6:04 12:04 18.04 you might add a line ...

                    04 */6 * * * /home/pi/fr24.sh

                    The 04 is the minute to do it
                    the */6 says take the hour number divide it by 6, if there is no remainder run the job
                    Thanks, but
                    I tried adding command line to cron, and also to rc.local . But no result. I checked manual execution of file. And it is ok.
                    F-UAAR1 T-UAAR3

                    Comment


                    • These problems seem to be odriod related - I wonder if they should go into their own thread.

                      Will cron start other things - like echo "some text" > file.txt.

                      Comment


                      • I got it!
                        I added to cron /bin/sleep 30
                        Code:
                         @reboot /bin/sleep 30; /home/odroid/fr24.sh
                        0 */6 * * * /home/odroid/fr24.sh
                        I don't know is it right solution but it works.
                        It seems happens because cron starts earlier than /home directory mounts. And it can't find sh file to execute...
                        F-UAAR1 T-UAAR3

                        Comment


                        • Originally posted by Dauren View Post
                          I got it!
                          I added to cron /bin/sleep 30
                          Code:
                           @reboot /bin/sleep 30; /home/odroid/fr24.sh
                          0 */6 * * * /home/odroid/fr24.sh
                          I don't know is it right solution but it works.
                          It seems happens because cron starts earlier than /home directory mounts. And it can't find sh file to execute...
                          If it works in an acceptable way, then it's as good a way to do it as any other.

                          Comment


                          • Originally posted by HermanZA View Post
                            Suppressing those commands, then it looks like this:

                            [SIZE=1][FONT=Courier New]Found 1 device(s):
                            0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                            Found Rafael Micro R820T tuner
                            Max available gain is: 49.60
                            Setting gain to: 49.60
                            Exact sample rate is: 2000000.052982 Hz
                            Gain reported by device: 49.60
                            *8d00b20558b984cd4ce8ffb9690b;
                            CRC: 000000 (ok)
                            DF 17: ADS-B message.
                            Capability : 5 (Level 2+3+4 (DF0,4,5,11,20,21,24,code7 - is airborne))
                            ICAO Address : 00b205
                            Extended Squitter Type: 11
                            Extended Squitter Sub : 0
                            Extended Squitter Name: Airborne Position (Baro Altitude)
                            F flag : odd
                            T flag : non-UTC
                            Altitude : 36000 feet
                            Latitude : 26278 (not decoded)
                            Longitude: 59647 (not decoded)

                            and so on ....
                            Yep, I got the same output when I was mucking around with the code.

                            Been doing some brain storming (more like frying my brain) as to why I couldn't get the fr24 feeder to work, seems Ubuntu didn't like
                            Code:
                            > /tmp/fr24feed.log &
                            . Since removing it, it now starts up after dump1090 has started, though need to get the cron to work when the feed terminates (or I ended up being offline more then being online with the fr24 feed).

                            My fr24.sh [with the fr24 key removed], based right off the pdf that was posted on Raspberry Pi type B + DVB-T Dongle to feed FR24.
                            Code:
                            #!/bin/bash
                            ### BEGIN INIT INFO
                            # Provides: fr24
                            # Required-Start: $remote_fs $syslog $time
                            # Required-Stop: $remote_fs $syslog $time
                            # Should-Start: $network
                            # Should-Stop: $network
                            # Default-Start: 2 3 4 5
                            # Default-Stop: 0 1 6
                            # Short-Description: Start 1090dump and fr24 at boot time
                            # Description: Start the RTL-SDR decoder and FlightRadar24 feeder at boot
                            ### END INIT INFO
                            #
                            #updated 2013-08-29 - write /tmp/fr24feed.log
                            #updated 2013-09-23 - Add INIT INFO section supplied by Jayant
                            #
                            #make sure fr24feed and dump1090 software are not running
                            #
                            killall fr24feed_x64_241
                            killall dump1090
                            #
                            #start dump1090 Ė we donít want output so throw it into a black hole (the null device)
                            #the symbol at the end of the line says donít wait for this to finish, just move
                            #onto the next command (note dump 1090 needs to run the dump1090 folder
                            #for the built in web page to work)
                            #
                            cd ~/dump1090
                            ./dump1090 --enable-agc --fix --net --net-sbs-port 30003 --net-ro-port 31001 --interactive > /dev/null &
                            cd ~
                            #
                            #start the fr24 feeder(use you own key)
                            #
                            export FR24AUTHIP=83.140.247.20;
                            ./fr24feed_x64_241 --fr24key=yourkeyforfr24feedgoeshere
                            F-YSWG1 and T-YSWG2

                            Comment


                            • I've had to kill the crontab, keeps killing my feed.

                              fr24.sh runs fine when I run it via Terminal but when the crontab runs it, line 34 [./fr24feed_x64_241 --fr24key=yourkeyforfr24feedgoeshere] of the script causes it to terminate. Just when I thought I made a step forward, I've made two steps back.
                              F-YSWG1 and T-YSWG2

                              Comment


                              • Originally posted by YSWG View Post
                                I've had to kill the crontab, keeps killing my feed.

                                fr24.sh runs fine when I run it via Terminal but when the crontab runs it, line 34 [./fr24feed_x64_241 --fr24key=yourkeyforfr24feedgoeshere] of the script causes it to terminate. Just when I thought I made a step forward, I've made two steps back.
                                is the script trying to run it from the right place ... change the 'cd ~/dump1090' to a 'cd /home/whatever/dump1090' (to wherever the dump1090 executable lives)

                                also don't need the line export FR24AUTHIP=83.140.247.20

                                Comment

                                Working...
                                X