Announcement

Collapse
No announcement yet.

Linux feeder software for Flightradar24 (Old software)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Works for me (static version).
    Now there is no "Segmentation fault" when I'm starting feeder with FR24 key only in parameters.
    Thanks.

    Comment


    • Originally posted by piopawlu View Post
      There's now a new build available (241) in the first post that should resolve the incorrect coordinates reported issue as well as eliminate the need of exporting FR24AUTHIP for the static build. Please report any issues here.
      Thanks for the info. Would try it tonight. Hopes it works. Greetings Foxconn11

      Gesendet mit der 4. galaxy von samsung und Tapatalk
      Feeding With dump1090 and a DVB-T stick oh i forgot: on a raspberry pi

      Comment


      • Initial Impression: 241s seems to work well on Pi

        Wish: To save internet bandwidth
        Transmit interval to back off from 5 to 30 - 60 seconds if there are no aircraft to report (infrequent, but not so infrequent that FR24 thinks the feeder has died - just log 'feed skipped - no aircaft to report')

        Comment


        • Calling all Dump1090 users!

          I've just compiled and installed Dump1090 on my Debian Intel box with an RTL R820T and when I run Dump1090 with this command (or any other combination):

          ./dump1090 --net --gain 30 --net-sbs-port 30003 --quiet --lat -40.3 --lon 175.6 > /dev/null &

          all I get is this response and nothing after:

          mike@blitzer:~/dump1090$ Found 1 device(s):
          0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
          Found Rafael Micro R820T tuner
          Setting gain to: 30.00
          Exact sample rate is: 2000000.052982 Hz
          Gain reported by device: 30.00

          I see no data when using a variety of tools, PP, Telnet and when configured for http nothing either.

          Any clues guys?
          Michael
          Palmerston North,
          New Zealand
          ex-FR24 Feeder

          Comment


          • try it with

            ./dump1090 --interactive

            first

            all the other options are to set it into basestation mode to quietly feed data into other programs

            --net = open web server on port 8080
            --gain 30 = without this the gain would be 49 or something
            --net-sbs-port 30003 = work in basestation mode
            --quiet = minimal output
            > /dev/null = discard the output
            & = run as a detached process (release the console)

            Comment


            • Just the same output Captain PeterHR.
              Michael
              Palmerston North,
              New Zealand
              ex-FR24 Feeder

              Comment


              • Originally posted by nzradar View Post
                Just the same output Captain PeterHR.
                HermanZA has (had?) this running on Ubuntu 12.04 on an old PC, maybe he can help if he sees this.

                Comment


                • Never noticed this before. Still on Ubuntu. The PI resellers here in South Africa dont even bother to reply to queries if the thing is under guarantee is its 5 months old.

                  Killed the dump1090 processes, then restarted them with only: ./dump1090 --interactive
                  And I too get: Segmentation fault (core dumped)
                  Then played around with starting parameters, seems I get the Segmentation Fault the moment I do Ctrl-C on whatever the Dump screen is. With all my start up parameters or just plain old DUMP1090 it self.

                  Killing the process (with a kill command) seems to terminate normally, cant see the error as in above cases.

                  Comment


                  • Is there an alternative way of autostarting fr24 feeder software on linux than http://forum.flightradar24.com/threa...ll=1#post37302? I've moved from Raspberry Pi on ODROID-U3 platform with XUbuntu 13.10 and got problems with autostaring. Script works but dooesn't autorun at startup. I tried crontab, rc.local, init.d ...
                    F-UAAR1 T-UAAR3

                    Comment


                    • Does the script run run correctly if you start it manually?
                      - if it does than the problem is with cron

                      The software could be run as a service, but while you are investigating that - it would be worth checking if the cron service is starting (I'm guessing here since I don't have a Debian system nearby) by doing a 'service cron status'.

                      Comment


                      • Script works well if I start it manually. I'm going to install newest version of Xubuntu 13.10 (currently installed previous version). Maybe it help to solve my problem. I'll post results of it.
                        F-UAAR1 T-UAAR3

                        Comment


                        • The problem still remains.
                          Any ideas?
                          F-UAAR1 T-UAAR3

                          Comment


                          • Originally posted by Dauren View Post
                            The problem still remains.
                            Any ideas?
                            The problem is no one here is running the same system as you, so to some extent people are guessing what to say since they cant try it first

                            there are two ways to run scripts at start up

                            1. Run the jobs as a service
                            2. Run the jobs as a timed job with a schedule to start the job as the system starts

                            It's simpler to use method 2 and if cron is running, it allows other timed events to occur, so lets test if cron is running...

                            Code:
                            pi@raspberrypi:~$ ps aux | grep cron | grep -v grep
                            root      1954  0.0  0.1   3792   784 ?        Ss   Feb19   0:02 /usr/sbin/cron
                            If cron is present on the system, I'd try to fix the service that starts cron - then use cron to start the feeder, and so on

                            see http://askubuntu.com/questions/9382/...run-at-startup
                            and
                            https://help.ubuntu.com/community/UbuntuBootupHowto

                            Comment


                            • This is the output when I run dump1090:
                              Originally posted by nzradar View Post
                              mike@blitzer:~/dump1090$ Found 1 device(s):
                              0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                              Found Rafael Micro R820T tuner
                              Setting gain to: 30.00
                              Exact sample rate is: 2000000.052982 Hz
                              Gain reported by device: 30.00
                              Could someone post what they get when they run dump1090 please, I'd like to see what comes after my last line.
                              Thanks
                              Michael
                              Palmerston North,
                              New Zealand
                              ex-FR24 Feeder

                              Comment


                              • I thought I'd done that Sunday evening (Monday morning to you) in the raspberry pi thread maybe?

                                Sent from my Nexus 4 using Tapatalk

                                Comment

                                Working...
                                X