Announcement

Collapse
No announcement yet.

Linux feeder software for Flightradar24 (Old software)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi,
    I have my RPi and soon should receive a RTL2832U+R820T USB stick. I'd like to set it up for FR24. Reading through this thread leaves me confused since it's both full of what to do and how to fix.
    Would it be possible to do a new 'How To' thread that just has the facts of
    These are the logical blocks to put together to make this work (in my case 'RTL2832U+R820T + RPi to feed FR24' ) and these are the software steps needed to install everything needed - Maybe by Roofer (helpful guy )
    The next item might be 'Micro-USB stick + Windows 7 to feed FR24'
    The next getting GPS to work with RPi for FR24 - with whatever prerequisites are required (building on what has already been described)
    ...and so on.
    The author of the original item edits it to keep it up to date - discussions / questions are directed to a thread elsewhere set up for the purpose to discus the particular config.

    Comment


    • This post should help you http://forum.flightradar24.com/threa...Tuner-Decoding

      If you get any problems there is always someone on here to help.
      AMS Daily Fight Information: http://schiphol.dutchplanespotters.nl/

      Comment


      • Hello peterhr,

        Welcome to FR24!

        I am sorry that it isn't immediately obvious how to set up a RPi to work with all this stuff (RTL2832U+R820T, GPS stick etc.)

        The trouble is that linux is changing (improving) every day, and it is very difficult to keep up-to-date and current.

        I managed to feed to FR24 with my RPi and my USB RTL2838 DVB-T by following this very thread.

        I realise it is a long thread, and it certainly is not "click & play", but by following it, and trying things out, all the information was eventually good, and it worked for me.

        Sometimes, when I am playing with linux I make copious notes, about what, exactly, I did, what happened, and what I did to fix it and make it work.

        Unfortunately, this is not one of those times, so I cannot just send you my notes.

        I invite you to make a start, and do your best. If /when you run into problems, perhaps post here as that might be the place for the RPi and FR24 and linux, as opposed to "linux feeder software for FR24", because your question isn't so much about which version of the FR24 feeder software to use but is more about "How to make linux on the RPi work with FR24?"

        Best wishes.

        Comment


        • Today I saw that fr24feed v 232s had connected to australia.fr24.com which is some incredible 330ms from me, despite latency to European servers is just 39ms. Could it be that there's an issue with the server selection routine in this version? Given this delay it's hardly surprising that I haven't seen a single flight fed by me all day.
          feeding data as EDDS9 through a Raspberry Pi with RTL2832U+R820T USB stick

          Comment


          • Hi all
            I've been using fr24feed_arm-le_232 for a few days. Unfortenately it hangs after some hours of usage.
            I use an fully updated rpi with following kernel:
            Linux rpi 3.6.11+ #371 PREEMPT Thu Feb 7 16:31:35 GMT 2013 armv6l GNU/Linux
            The usage pattern always ends with following traces
            [i]sent 3 planes in 1 packets
            [i]sent 3 planes in 1 packets
            [i]sent 3 planes in 1 packets
            [n]pinging the server
            [n]disconnected
            [n]waiting 8 seconds
            [n]ESGP1@australia.fr24.com:8099/UDP
            [n]connecting
            [n]connected
            [n]switching to UDP
            [n]working
            Ending the program and restarting again runs it for another couple of hours.

            /t

            Comment


            • Is that using the dynamicly linked feeder software or the static (I'm sure someone said static is more reliable)

              BTW - for the static version, the instruction ...
              Use "FR24AUTHIP=83.140.247.20 ./fr24feed_arm-le_232s --fr24key=YOUR_SHARING_KEY" to run the software.

              should read
              Use "export FR24AUTHIP=83.140.247.20; ./fr24feed_arm-le_232s --fr24key=YOUR_SHARING_KEY" to run the software.

              Disclaimer: I'm no expert I've just been using theis 2 days

              Comment


              • I also witnessed the same problem (reported several posts ago) on both dynamic and static versions of 232. I rolled back to 225 which seems stable.
                T-KCLT1, Also the man behind the curtain working on the dump1090 webgui and the dump1090-helper project.

                Comment


                • Originally posted by peterhr View Post
                  BTW - for the static version, the instruction ...
                  Use "FR24AUTHIP=83.140.247.20 ./fr24feed_arm-le_232s --fr24key=YOUR_SHARING_KEY" to run the software.

                  should read
                  Use "export FR24AUTHIP=83.140.247.20; ./fr24feed_arm-le_232s --fr24key=YOUR_SHARING_KEY" to run the software.
                  Hi Peter

                  Both commands will work.

                  The first method (prepend a command with a VARIABLE=) sets the FR24AUTHIP variable for this instance of the fr24feed_arm-le_232s process only. It is a handy way of quickly setting variables that don't affect anything else.
                  The second method is in fact two commands seperated by a ; and you could run them on seperate lines. The first sets a "global" variable using the export command. All subsequent processes run within that shell will have access to that variable which is why the subsequent ./fr24feed command (after the ; ) doesn't have the variable prepended.

                  Also, if your fr24feed process stops working every few hours you could use the following dirty little trick to automatically restart the process every hour:

                  First add an entry for the system scheduler "cron" to automatically kill any running fr24feed process every hour

                  Code:
                  crontab -e
                  An editor will come up, at the bottom of that file add this line:
                  Code:
                  0 * * * * killall fr24feed_arm-le_232s
                  And then do the following that sets the global variable, and then runs the fr24feed process in a loop - if it dies or is killed it waits 10 seconds and then starts it up again.

                  Code:
                  export FR24AUTHIP=83.140.247.20
                  while true
                  do
                     ./fr24feed_arm-le_232s --fr24key=YOUR_SHARING_KEY
                    sleep 10
                  done
                  - Matt
                  T-YPPH2

                  Comment


                  • Hello!

                    I've got some linux developer board and now i'm trying to use this for feeding data. But:
                    I installed RTLSDR, ADSBOX and FR24Feeder.
                    RTL_ADSB works
                    ADSBOX works
                    FR24Feeder works BUT I get messages like:
                    [e]Data feed time difference too big abs( - )=33015
                    [i]sent 0 planes in 0 packets

                    ntpd on the board is running, time is very correct. How to fix this?

                    Thank you!

                    Regards
                    Skyscraper

                    Comment


                    • I have the same problem with with stopping feeding data after x hours with linux fr24feed_arm-le_232s
                      In console i have:
                      Code:
                      ...
                      [n]UKKK6@europe.fr24.com:8099/UDP
                      [n]connecting
                      [n]waiting 18 seconds
                      [n]UKKK6@europe.fr24.com:8099/UDP
                      [n]connecting
                      [n]waiting 24 seconds
                      [n]UKKK6@83.140.247.21:8099/UDP
                      [n]connecting
                      [n]waiting 5 seconds
                      [n]UKKK6@australia.fr24.com:8099/UDP
                      [n]connecting
                      [n]waiting 14 seconds
                      [n]UKKK6@australia.fr24.com:8099/UDP
                      [n]connecting
                      [n]waiting 15 seconds
                      [n]UKKK6@europe.fr24.com:8099/UDP
                      [n]connecting
                      [n]waiting 24 seconds
                      [n]UKKK6@83.140.247.21:8099/UDP
                      [n]connecting
                      [n]connected
                      [n]switching to UDP
                      [n]working
                      [i]Removed 1 of 2 AC
                      After restarting all is ok, but, imho, this is not the best solution (

                      Comment


                      • There are reports of fr24feed_arm-le_232s failing as you describe.
                        Some of us have reverted to using the older (and more stable) version fr24feed_arm-le_225s

                        Comment


                        • roofer, where i can find them?

                          Comment


                          • Originally posted by zend View Post
                            roofer, where i can find them?
                            https://dl.dropboxusercontent.com/u/...rm-le_225s.tgz

                            Comment


                            • Thank you!
                              This version works great without any messages like:
                              [e]Data feed time difference too big abs( - )=33015

                              Comment


                              • adsbox stopping after some time

                                Hello FR24-Feeders

                                I have the following installation which is basically working, but is stopping after some random time (see below for problem):

                                Hardware:

                                MicroADSB-Stick --> Raspberry Pi (New B Model 512MB RAM) --> USB WLAN Dongle
                                iPad2 Power Plug

                                Software:

                                adsbox --> fr24feed_arm-le_225s

                                My start Script:
                                Code:
                                #!/bin/bash
                                
                                BAUD=3000000
                                FR24FEEDER=fr24feed_arm-le_225s
                                FR24KEY=123456789
                                
                                # stop/start decoder
                                echo Stop/start adsbox...
                                killall -v adsbox
                                cd /home/pi/adsb/adsbox
                                ./adsbox --daemon --baud $BAUD --serial /dev/ttyACM0 --lat XX.XXXX --lon Y.Y --seed --seed-port 30004
                                echo adsbox started
                                echo ----
                                
                                # wait and let decoder start
                                sleep 1
                                
                                # stop/start feeder
                                echo Stop/start feeder...
                                killall -v $FR24FEEDER
                                cd /home/pi/adsb
                                export FR24AUTHIP=83.140.247.20
                                #./$FR24FEEDER --fr24key=$FR24KEY > /dev/null &
                                echo feeder started
                                As I wrote, basically everything works. But only for some time. And as opposed to others, who are seeing the fr24 feeder script stopping, I see the adsbox decoder stopping. Sometimes after a few seconds, sometimes after 3 hours.

                                I can check the status of adsbox at port 8080 where I can monitor its flight table being updated - until it stops.
                                Or at port 30003, where the decoded message are sent - until it stops.

                                I am not sure, but it could be the serial usb interface between the stick and the raspberry pi. I have the feeling, that it stops earlier, if I am using a higher baudrates. And I have the feeling, that it stops earlier if there is more traffic. If I am using 576000 baud and the antenna is in my room (with reduced packet reception), it seems to run a bit longer than with the antenna placed on the outside.

                                Does anybody have an idea what this could be?
                                • Overload of the serial communication the the Pi?
                                • Missconfiguration of the serial communication?
                                • Should I send an init string to the stick in order to filter the packets?
                                • Hardware fault?
                                • Power stability problem? (I have tried several recommended power plugs without any change)


                                Thanks & have a nice weekend!

                                Thomas
                                Last edited by thowe; 2013-06-02, 07:30. Reason: lat/lon hidden

                                Comment

                                Working...
                                X