Announcement

Collapse
No announcement yet.

No data due to Dump1090 not being Launched

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No data due to Dump1090 not being Launched

    Hi guys,
    in the last weeks I've spotted my setup (OrangePi Zero + RTLSDR directly feeding only FR24 through the built in Decoder) as marked with "Online - No Data" flag in the stats page multiple times.

    Today I had the chance to investigate the problem and I've found that the issue seems to be related to the fact that FR24 service is able to start correctly after daily reboot but somehow Dump1090 (again the one provided with the FR24 feeder) fails to launch sometimes leading to no aircrafts being detected.

    The very strange thing is that this doesn't happen constantly but more of in a random way (so when it happens usually a reboot solves the issue).

    Is there anything in the Feeder/Armbian configuration that I could do to prevent this?

    Thanks!
    You do not have permission to view this gallery.
    This gallery has 1 photos.

  • #2
    It's not clear in your post, but is your intention to have dump1090 talking to the receiver rather than fr24 (i.e., receiver -> dump1090 -> fr24)?

    dump1090 isn't being launched because fr24 is talking to the receiver directly. I've had this happen a few times. The software is trying to be too smart.

    If you want dump1090 to be talking to the receiver rather than fr24, you need to change the configuration.

    Here are the required settings:

    Code:
    receiver="avr-tcp"
    fr24key="REDACTED"
    host="127.0.0.1:30002"
    bs="no"
    raw="no"
    mlat="no"
    mlat-without-gps="no"​
    I suggest that you revise the settings by using this command:

    Code:
    sudo nano /etc/fr24feed.ini
    After you save the settings, manually start dump1090, then restart fr24 using the revised configuration.

    If that works, then you need to change the setting for dump1090 so it automatically starts.

    You could also try manually starting dump1090, then running the account setup:

    Code:
    sudo fr24feed --signup
    Be sure you answer the questions correctly.

    As long as fr24 is talking directly to the receiver, it will prevent dump1090 from automatically starting.

    Sometimes the above works. If it doesn't, perhaps someone else has another suggestion, but left with no other suggestion, try uninstalling and reinstalling the software.

    Comment

    Working...
    X