Announcement

Collapse
No announcement yet.

FR24 install from PiAware fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24 install from PiAware fails

    I am following the FR24 online instructions to install an FR24 feed for a PiAware system. The install script fails. System is a Pi4b with 4GB RAM, 32GB SD running the latest PiAware image. Here is the output (note, this is my first post so I have obfuscated the urls (with "xxx") in this output in case it gets blocked).

    pi@piaware:~ $ sudo bash -c "$(wget -O - xxx/install_fr24_rpi.sh)"
    --2023-11-07 23:25:51-- xxx/install_fr24_rpi.sh
    Resolving repo.feed.flightradar24 (xxx)... 52.217.232.80, 52.216.145.197, 52.217.0.166, ...
    Connecting to repo.feed.flightradar24 (xxx)|52.217.232.80|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1428 (1.4K) [application/x-sh]
    Saving to: ‘STDOUT’

    - 100%[=================================================>] 1.39K --.-KB/s in 0s

    2023-11-07 23:25:51 (41.0 MB/s) - written to stdout [1428/1428]

    Hit:1 xxx/mirror/raspbian/raspbian bullseye InRelease
    Hit:2 xxx/adsb/piaware/files/packages bullseye InRelease
    Hit:3 xxx/mirror/raspberrypi/debian bullseye InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    dirmngr is already the newest version (2.2.27-2+deb11u2).
    0 upgraded, 0 newly installed, 0 to remove and 109 not upgraded.
    bash: line 29: /etc/apt/keyrings/flightradar24.gpg: No such file or directory
    --2023-11-07 23:25:58-- xxx/flightradar24.pub
    Resolving repo-feed.flightradar24 (repo-feed.flightradar24.com)... 104.16.59.181, 104.16.58.181, 104.16.60.181, ...
    Connecting to xxx (xxx)|104.16.59.181|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5287 (5.2K) [application/x-mspublisher]
    Saving to: ‘STDOUT’

    - 0%[ ] 0 --.-KB/s in 0s


    Cannot write to ‘-’ (Broken pipe).
    pi@piaware:~ $​

  • #2
    If FR24 installation script is giving problems, use following commands to directly download and install the latest fr24feed deb package:
    Code:
    wget http://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.44-0_armhf.deb
    
    sudo dpkg -i fr24feed_1.0.44-0_armhf.deb
    The 2nd commans above will install fr24feed package, and at the end will automatically start signup process. If it does not start signup procedure, use following command to start signup:
    Code:
    sudo fr24feed --signup
    NOTE:
    (1) During signup if asked, do NOT select receiver DVB-T, select AVR (TCP).
    (2) It may ask to accept “autoconfig (yes/no)”. Type yes.and press Enter Key.

    Comment


    • #3
      Many thanks for the help.

      It turns out I had mistakenly used "http[url]" instead of "https[url]". When I corrected that and reran the script all worked fine. Who knew!

      Thanks again.

      Comment


      • #4
        I have the same problem, I reported it to support and they sent me a couple of emails with instructions but it didn't work, it is still offline.... HELP
        You do not have permission to view this gallery.
        This gallery has 3 photos.

        Comment


        • #5
          You literally cannot make anything out that's helpful on those black screens.

          Console and copy/ paste the text
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            what is output of following command?
            Code:
            sudo fr24feed-status


            Comment


            • #7
              pi@piaware:~ $ sudo fr24feed-status
              FR24 Feeder/Decoder Process: running.
              FR24 Stats Timestamp: 2023-11-11 16:37:36.
              FR24 Link: unknown ... failed!
              Receiver: connected (0 MSGS/0 SYNC).
              FR24 MLAT: not running ... failed!


              I am having the same problem with the installation of the script, it just works and the few emails I have received from support have not helped at all.

              Comment


              • #8
                Please copy-paste here the output of following command
                (when posting in forum, replace actual value of fr24key by xxxxxxxxx)

                Code:
                cat /etc/fr24feed.ini

                Comment


                • #9
                  image.png
                  You do not have permission to view this gallery.
                  This gallery has 1 photos.

                  Comment


                  • #10
                    So it's there, it's installed, it's got a configuration.

                    Soooo why trying to run the install script again? It will detect it there and skip everything
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #11
                      My apologies but if you sent an email to support is for something and if you posted in the forum is for a very logical reason, don't you think? The only three emails that answered me in support still have not solved the problem despite doing all the steps mentioned and show them that even my receiver does not work and now you ask me to do the same and yet the problem persists, one tries to keep the service active and uninterrupted but the problem is yours and not mine as they do not solve it, for my part I do not know what else to do to the receiver I share with 7 feeders I am not just anyone.

                      Check my profile is offline 🤷what I can do? Very thanks
                      You do not have permission to view this gallery.
                      This gallery has 1 photos.

                      Comment


                      • #12
                        You've gone off on a total tangent. We are NOT support. FR24 staff do not use Forums for support.

                        And you started with 'I have the same problem' , You did not disclose the real issue. You did not disclose you have contacted anyone prior. Or the steps they got you to follow to now. Or anything about your setup. Just 'I have the same problem'


                        This thread is about, not being able to install the scripted installer.



                        What you should have done is started a thread. And explained more than 'I have same problem'

                        Because it's not. He couldn't even install FR24feed. You already have - So I replied as such

                        Had you started with clearly 'I have it installed, and multiple feeders installed, but it is reporting offline and cannot connect the services' you would have got a different result. But you didn't.


                        I'm out. Can't help people quick to tell me the lack of detail provided is 'my problem' and don't help us know what they have an issue with.

                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • #13
                          Hey you know what? you are right I owe you an apology. I did not know how to explain myself well my language is Spanish and I have a hard time with English, even so using translator, but I give you a huge apology, you have had the will to help me and answer and that deserves respect so I apologize again. The script I have put it lots of times but in this last vex a sd was corrupted and I reinstalled again just putting the script but it did not work as they usually work all the previous times I had done it when the memories were damaged. Oblivian

                          Comment

                          Working...
                          X