Announcement

Collapse
No announcement yet.

Step by step guide to feeding FR24+FA

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Step by step guide to feeding FR24+FA

    As the title says. I need a step by step guide to setup a RPi to feed both FR24 and FA(Flightaware). What image, how to set it up and how to have the data shared with 2 separate sites.


  • #2
    It can be done by any of the three following images. All these images are capable of feeding multiple sites. You can use any one of these.

    Raspberry Pi OS Bullseye Lite image
    Flightradar24 Pi24 image
    Flightaware Piaware SD Card image

    Comment


    • #3
      STEP-1: Download Necessary Software 1.1 - Download PI24 image (zip) on your Desktop/Laptop Download page: https://www.flightradar24.com/build-your-own Direct download link: https://repo-feed.flightradar24.com/...latest.img.zip (https://repo-feed.flightradar24.com/rpi_images/fr24-raspberry-pi-latest.img.zip) 1.2 - Download

      I guess if I would follow this I will make it

      Comment


      • #4
        After you successfully install Pi24 image, and your FR24 feeder is working ok, then you can install piaware package from Flightaware site.

        To make Flightaware feeder "piaware" to work smoothly, you will need to make following changes in two files of Pi24:

        (1) Open file /etc/fr24feed.ini for editing

        Code:
        sudo nano /etc/fr24feed.ini
        In this file delete following line
        Code:
        ​​​​​​receiver="dvbt"
        ​​​​​​After deleting above line, add following two lines by copy-paste

        Code:
        receiver="beast-tcp"
        host="127.0.0.1:30005"
        Save and Close file


        (2) Open file /etc/default/dump1090-mutability

        Code:
        sudo nano /etc/default/dump1090-mutability
        In the file opened scrol down. Near start of file you will see following line:

        START_DUMP1090="no"

        Change "no" to "yes", so the line becomes as below

        START_DUMP1090="yes"

        Save and Close the file.

        (3) REBOOT PI


        (4) Installing Flightaware feeder "piaware" on Pi24 image
        .
        Download and install the FlightAware APT repository package, which tells your Pi's package manager (apt) how to find FlightAware's software packages in addition to the packages provided by Raspbian.

        Code:
        wget https://www.flightaware.com/adsb/piaware/files/packages/pool/piaware/f/flightaware-apt-repository/flightaware-apt-repository_1.1_all.deb  
        
        ​​​​​​
        sudo dpkg -i flightaware-apt-repository_1.1_all.deb
        Update your apt package sources and install PiAware. This will install all the required dependencies on your Raspberry Pi.

        Code:
        sudo apt-get update  
        
        sudo apt-get install piaware
        Enable automatic and manual (web-based, via your request) PiAware software updates. These updates are disabled by default. To leave updates disabled, skip this step.

        Code:
        sudo piaware-config allow-auto-updates yes  
        
        sudo piaware-config allow-manual-updates yes


        .​
        Last edited by abcd567; 2023-10-03, 03:38.

        Comment


        • #5
          What I ended up doing was installing a RPi that feeds the data to FR24 from the flightfeedeer.
          Everything was fine with the flightfeedeer before setting up the RPi alongside it.
          Now the FF starts to randomly go offline sometimes.
          I had to reconfigure the RPi again from scratch because it also had moments of going offline.
          This morning the FF was offline but the rpi online (without sending data obviously). Restarting the FF solved the issue but only temporarily because now the RPi doesn't upload any data despite being online 🤦
          I had configured the router before so both have their IP address locked. The installation of the image and the packages for the Rpi was done exactly as instructions said and no errors whatsoever.
          What am I doing wrong what is happening
          Edit: Now it is offline again.(the RPi)
          Last edited by hardstyl3; 2023-10-23, 15:18.

          Comment


          • #6
            Also did a ping test. The RPi pinged despite not showing up anymore on the router's config webpage
            You do not have permission to view this gallery.
            This gallery has 1 photos.

            Comment


            • #7
              So in the end I used some commands like stop and restart and it works again. This doesn't mean much because I am not certain it won't happen again.
              If this helps: I was unable to use http://rpi-ip:8754 before the restart but now I am. Even though the Rpi seemed to be connected because it pinged.
              I have also disabled something in the router settings like "smart connect" which has something to do about automatically changing devices from 2.4 GHz and 5 GHz bands. Now let's see if this really does something.

              Comment


              • #8
                Yep
                offline again

                Comment


                • #9
                  FR24 Link: Disconnected (http_error 0)

                  Update: after clicking "restart software " and a power reset the Pi doesn't even connect to the WiFi.
                  I'm giving up
                  You do not have permission to view this gallery.
                  This gallery has 2 photos.
                  Last edited by hardstyl3; 2023-10-27, 18:52.

                  Comment

                  Working...
                  X