Announcement

Collapse
No announcement yet.

Is there a problem with the /account/feed-stats/?id=***** page?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is there a problem with the /account/feed-stats/?id=***** page?

    Past week or so the /account/feed-stats/?id=***** page has shown my feed as fractured - lots of gaps as though it keeps going offline.

    From my end the Pi says it's connected on the :8754 screen. The router says it's connected. Even on the feed-stats page it says "Online" whenever I've looked.

    Now it's showing this at the top:

    Screenshot 2022-07-29 at 01.11.42.png

    even though it says it currently "Online" below that.

    I'd just like to know it's at FR24's end and not mine!

    Last edited by aka_pseudonym; 2022-07-29, 00:47.

  • #2
    Online does not equal uploading data.

    Mine is fine.

    But the whole thing isn't reliable to use for looking at your feed - use the local map/stats

    The stats server is separate from the feed server. It's also housed on cloud. So not everyone uploads to the same cluster/region.

    If you are concerned, local the local map and keep an eye on it. Or run the script for local logging/data . Your stick /antenna/receiver may be playing up. The server will still say online, it just wont get anything sent to it.

    https://github.com/wiedehopf/graphs1090
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      OK, thanks Oblivian. The Aircraft seen/Positions reported/Hits reported increment as expected, and look about right for my location. The data for the last six days has reappeared now - but still fractured. The dump1090 log looks OK too. I'll try the local map.

      But one thing did occur to me - if I swap to go though a VPN and my IP address changes would that cause FR24 to think I'd vanished? I have been experimenting with some free ones recently.

      Edit: But thinking about it that can't be it! A VPN running on the computer won't change the IP address for the Pi Zero feed will it.
      Last edited by aka_pseudonym; 2022-07-29, 01:41.

      Comment


      • #4
        I have seen this many times the first hour after UTC 0:00.
        T-EKCH5: Raspberry Pi 4-B (Buster) + FlightAware Pro Stick Plus + FlightAware 1090MHz Bandpass Filter Dark Blue + A3-ADS-B Antenna

        Comment


        • #5
          Depends on where the vpn is set. On a single device, no
          but if its router level/all devices behind it may geo locate your source outbound traffic to a different region to your known feeder locale suddenly and confuse it.. that's sure a possibility depending on how many layers of data filtering/spoofing protection is in place
          But it would kill it for the period of establishment rather than sporadically I would suggest

          But reinforcing again.. the stats server is hardly accurate.

          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            My feed is now de-fractured so I thought I should report what happened although I have no idea why!

            Looking through the logs I found that FR24 was occasionally re-booting itself. The Pi Zero wasn't, no problem there.

            The log looks like this and gives no indication why the FR24 software should suddenly decide to re-start itself between 23:08:30 and 23:08:57. Very odd -

            All working fine before .....

            2022-07-30 23:06:22 | [feed][i]sent 0,1 AC
            2022-07-30 23:06:28 | [feed][i]sent 0,1 AC
            2022-07-30 23:06:34 | [feed][i]sent 0,1 AC
            2022-07-30 23:06:48 | [feed][i]sent 0,1 AC
            2022-07-30 23:06:49 | [feed][i]filtering out 2 overlapping AC (saving bandwidth)
            2022-07-30 23:06:54 | [feed][i]sent 0,1 AC
            2022-07-30 23:06:59 | [feed][i]sent 0,1 AC
            2022-07-30 23:07:05 | [feed][i]sent 0,1 AC
            2022-07-30 23:07:12 | [feed][i]sent 0,1 AC
            2022-07-30 23:07:18 | [feed][i]sent 0,1 AC
            2022-07-30 23:07:24 | [feed][i]sent 0,1 AC
            2022-07-30 23:07:54 | [feed][n]ping 1
            2022-07-30 23:07:54 | send - failed to send 12 + 212 bytes in mode 1, code -1: Network is unreachable
            2022-07-30 23:07:54 | [feed][n]disconnected
            2022-07-30 23:07:54 | info | [feed][n]waiting 16 seconds
            2022-07-30 23:08:10 | [feed][n]EGOV11@185.218.24.22:8099/UDP
            2022-07-30 23:08:10 | [feed][n]connecting
            2022-07-30 23:08:10 | info | Network thread connecting to 185.218.24.22:8099 for feed EGOV11
            2022-07-30 23:08:10 | send - failed to send 12 + 51 bytes in mode 1, code -1: Network is unreachable
            2022-07-30 23:08:10 | [feed][n]Error: Could not connect feed! (result -1, fd -1)
            2022-07-30 23:08:10 | info | [feed][n]waiting 20 seconds
            2022-07-30 23:08:30 | [feed][n]EGOV11@185.218.24.23:8099/UDP
            2022-07-30 23:08:30 | [feed][n]connecting
            2022-07-30 23:08:30 | info | Network thread connecting to 185.218.24.23:8099 for feed EGOV11
            2022-07-30 23:08:30 | send - failed to send 12 + 51 bytes in mode 1, code -1: Network is unreachable
            2022-07-30 23:08:30 | [feed][n]Error: Could not connect feed! (result -1, fd -1)
            2022-07-30 23:08:30 | info | [feed][n]waiting 26 seconds
            2022-07-30 23:08:57 | ______ _ _ _ _ _ _____ ___
            2022-07-30 23:08:57 | | ___|| |(_) | | | | | | / __ \ / |
            2022-07-30 23:08:57 | | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
            2022-07-30 23:08:57 | | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
            2022-07-30 23:08:57 | | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
            2022-07-30 23:08:57 | \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
            2022-07-30 23:08:57 | __/ |
            2022-07-30 23:08:57 | |___/
            2022-07-30 23:08:57 | [main][i]FR24 Feeder/Decoder
            2022-07-30 23:08:57 | [main][i]Version: 1.0.29-8/generic
            2022-07-30 23:08:57 | [main][i]Built on Feb 2 2022 12:34:09 (HEAD-2331de4.git/Linux/static_armel)
            2022-07-30 23:08:57 | [main][i]Running on: raspbian10
            2022-07-30 23:08:57 | [main][i]Local IP(s): fe80::80e2:478b:c899:cffd
            2022-07-30 23:08:57 | [main][i]Copyright 2012-2022 Flightradar24 AB
            2022-07-30 23:08:57 | [main][i]https://www.flightradar24.com
            2022-07-30 23:08:57 | [main][i]DNS mode: PING
            2022-07-30 23:08:57 | [main][i]Automatic updates are ENABLED
            2022-07-30 23:08:57 | [e]PacketSenderConfiguration::fetch_config(): Unable to fetch configuration for yoda receiver
            2022-07-30 23:08:57 | info | [httpd]Server started, listening on :::8754
            2022-07-30 23:08:58 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
            2022-07-30 23:08:58 | [main][i]Reader thread started
            2022-07-30 23:08:58 | [time][i]Synchronizing time via NTP
            2022-07-30 23:08:58 | [reader][i]Initializing reader

            So suddenly it re-starts and off it goes again. I don't know what caused/causes it. I would have thought it'd just go on trying to connect until it did - not do a complete re-start.

            Anyway I cleaned the SDcard contacts, USB contacts, and anything else I thought might benefit from my Ambersil Ambertron contact cleaner. And now it seems fine again.

            If you have any idea Oblivian I'd like to know for the future!



            Comment

            Working...
            X