Announcement

Collapse
No announcement yet.

Build 1.0.29-8

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Build 1.0.29-8

    First of all, we are very sorry for the confusion revolving around 1.0.29-7. There was a rather large oversight that had been made and as a result, the build was rushed. Many apologies about this.

    We are currently working on a release, the changelog and notes of which will follow.

    Thanks, and apologies again.

  • #2
    Originally posted by FR24_Gordon View Post
    First of all, we are very sorry for the confusion revolving around 1.0.29-7. There was a rather large oversight that had been made and as a result, the build was rushed. Many apologies about this.

    We are currently working on a release, the changelog and notes of which will follow.

    Thanks, and apologies again.
    Hi Gordon,
    Thanks for the update.
    Does it explain N/As on RPI feeding status and no updates to your servers ? issue met by several users.
    Regards,

    Comment


    • #3
      Also my rpi does not work since a few days (doesn't see any aircrafts), is it possible to install an older, working version.
      fr24feed-status shows me [FAIL] Receiver: down ... failed! -> seems that this problem comes with the new version... is this possible?

      [ ok ] FR24 Feeder/Decoder Process: running.

      [ ok ] FR24 Stats Timestamp: 2022-02-11 19:58:39.

      [ ok ] FR24 Link: connected [UDP].

      [ ok ] FR24 Radar: T-xxxx.

      [ ok ] FR24 Tracked AC: 0.

      [FAIL] Receiver: down ... failed!
      Last edited by tyrolean; 2022-02-11, 20:17.

      Comment


      • #4
        I have been updating data for a few years now, noticed to be online but NO Data being received .
        Checked the fr24feed-status

        ok FR24 Feeder/Decoder Process: running

        ok FR24 Stats Timestamp: 2022-02-16 08:44:05.

        ok FR24 Link; connected [UDP]

        ok FR24 Radar: T-EXXX.

        ok FR24 Tracked AC: 0.

        Receiver: down ... failed

        FR24 MLAT; not running ... failed


        Any fix available

        Comment


        • #5
          Originally posted by tyrolean View Post
          [ ok ] FR24 Tracked AC: 0.
          [FAIL] Receiver: down ... failed!


          Originally posted by Donny56 View Post
          ok FR24 Tracked AC: 0.
          Receiver: down ... failed
          FR24 MLAT; not running ... failed
          What are the output of following command


          Code:
          cat /etc/fr24feed.ini | grep receiver  
          
          cat /etc/fr24feed.ini | grep host
          
          cat /etc/default/dump1090-mutability | grep START_DUMP1090


          Last edited by abcd567; 2022-02-16, 23:09.

          Comment


          • #6
            My feeder stopped sending data. It is running 1.0.29-8. It's remote, has bias tee, ModeS Beest (TCP), Dump1090 v1.15~dev.

            This site is usually ranked in the top 10 feeders. Rank is now dropping past 29,000. Thanks for the update

            I followed abcd567 posts, to get this:


            pi@raspberrypi:~ $ cat /etc/fr24feed.ini
            receiver="beast-tcp"
            fr24key="bb10b3f7a6232c98"
            host="127.0.0.1:30005"
            bs="no"
            raw="no"
            logmode="0"
            windowmode="0"
            logpath="/var/log"
            mpx="no"
            mlat="yes"
            mlat-without-gps="yes"
            pi@raspberrypi:~ $ cat /stc/fr24feed.ini | grep host
            cat: /stc/fr24feed.ini: No such file or directory
            pi@raspberrypi:~ $ cat /etc/default/dump1090-mutability | grep START_DUMP1090
            START_DUMP1090="no"
            pi@raspberrypi:~ $

            UPDATE:

            nano into: /etc/default/dump1090-mutability and fixed it by turning on dump1090
            START_DUMP1090="yes"


            Last edited by radionerd; 2022-02-17, 05:10.

            Comment


            • #7
              Commands output


              cat /etc/fr24feed.ini | grep receiver

              receiver= "avrc-tcp"

              -------------------------------------------------------------------------------


              cat /etc/fr24feed.ini | grep receiver

              cat; /etcfr24feed.ini: No such file or directory

              -------------------------------------------------------------------------------------



              cat /etc/default/dump1090-mutability | grep START_DUMP1090

              START_DUMP="no"




              Comment


              • #8
                Originally posted by Donny56 View Post
                Commands output

                cat /etc/fr24feed.ini | grep receiver
                receiver= "avrc-tcp"


                cat /etc/default/dump1090-mutability | grep START_DUMP1090
                START_DUMP="no"
                culprit is wrong setting
                START_DUMP="no"

                It should be changed to
                START_DUMP="yes"

                Give following command:
                Code:
                sudo nano /etc/default/dump1090-mutability
                In file opened, locate the line
                START_DUMP1090="no"

                Change "no" to "yes" so the line becomes:
                START_DUMP1090="yes"

                Save file (press Ctrl and o keys together) and close file (press Ctrl and x keys together)

                Reboot RPi
                Code:
                sudo reboot


                An alternative method is to issue following reconfigure command.
                Code:
                sudo dpkg-reconfigure dump1090-mutability

                It will open a window with first question about auto start. It was set to "NO" by ver 1.0.29-7 update. Change it to "YES", then keep on pressing Enter key to accept all other settings till the window closes, and REBOOT RPi, and you are done with.

                reconfigure dump1090-mutability.png
                Last edited by abcd567; 2022-02-17, 11:58.

                Comment


                • #9
                  Thanks for all that input.

                  After sudo reboot

                  Run the fr24feed-status

                  The result being:-

                  [ok] FR24 Feeder/Decoder Process: running

                  {ok] FR24 Stats Timestamp; 2022-02-17 16:36:32.

                  [ok] FR24 Link: connected [UDP].

                  [ok] FR24 Radar; T-EXXXXX

                  [ok] FR24 Tracked AC: 6.

                  [ok] Receiver: connected (2052 MSGS/0 SYNC).

                  [FAIL] FR24 MLAT: not running ... failed!

                  Comment


                  • #10
                    That's normal. Mlat only for dvbt receiver type (noone feeding other sites will likely set that)
                    and doesn't work without 4 contacts to calculate.
                    It says tracked 6. It's fine.
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #11
                      Originally posted by abcd567 View Post

                      culprit is wrong setting
                      START_DUMP="no"

                      It should be changed to
                      START_DUMP="yes"

                      Give following command:
                      Code:
                      sudo nano /etc/default/dump1090-mutability
                      In file opened, locate the line
                      START_DUMP1090="no"

                      Change "no" to "yes" so the line becomes:
                      START_DUMP1090="yes"

                      Save file (press Ctrl and o keys together) and close file (press Ctrl and x keys together)

                      Reboot RPi
                      Code:
                      sudo reboot


                      An alternative method is to issue following reconfigure command.
                      Code:
                      sudo dpkg-reconfigure dump1090-mutability

                      It will open a window with first question about auto start. It was set to "NO" by ver 1.0.29-7 update. Change it to "YES", then keep on pressing Enter key to accept all other settings till the window closes, and REBOOT RPi, and you are done with.

                      reconfigure dump1090-mutability.png
                      I do the above (tried both methods) and when rebooting the Pi the setting reverts to "no"... ? And yes I am su.
                      Last edited by hansp; 2022-02-20, 14:46.

                      Comment


                      • #12
                        Originally posted by hansp View Post

                        I do the above (tried both methods) and when rebooting the Pi the setting reverts to "no"... ? And yes I am su.
                        This is another disease of fr24feed : "read-only file system"

                        Please issue following command to make your file system "read and write", then try to make & save the config change again

                        Code:
                        sudo mount -o remount,rw /
                        The above change from "read-only" to "read-and-write" will disappear on reboot, and you will have to again issue above command to change your file system to "read-and-write" when you want to edit & save something.


                        The problem is caused by updater script in some versions of fr24feed due to defective code
                        Some users delete the updater script to get rid of this problem.

                        Code:
                        sudo nano /usr/lib/fr24/fr24feed_updater.sh

                        Scroll-down to find following piece of code.
                        This is mine which works OK. Check and compare with it your one:

                        Near the start of file:
                        Code:
                        mount | grep " on / " | grep rw || {
                                NEEDS_REMOUNT=true
                                mount -o remount,rw /
                        }

                        At bottom of file:
                        Code:
                        if [ "${NEEDS_REMOUNT}" = true ]; then
                               mount -o remount,ro / || echo "Could not remount to read-only"
                        fi

                        Comment


                        • #13
                          "Excellent", he said bitterly. Thanks again abcd567! Will do next time I travel to that remote, non-ssh/vpn-available station.

                          Comment


                          • #14
                            Originally posted by hansp View Post

                            I do the above (tried both methods) and when rebooting the Pi the setting reverts to "no"... ? And yes I am su.

                            Originally posted by hansp View Post
                            "Excellent", he said bitterly. Thanks again abcd567! Will do next time I travel to that remote, non-ssh/vpn-available station.

                            The situation you described in first quote above can be happen by any one of following two independent causes:

                            (1) The file system is "read-only"

                            OR

                            (2) Your configuration is set as receiver="dvbt"


                            FIX FOR ITEM (1) ABOVE:
                            To check if your file system is "read-and-write" OR "read-only", copy-paste following command in terminal / PuTTY:
                            Code:
                            mount | grep " on / "
                            If output of above command contains rw like shown below, your file system is "read-and-write".
                            /dev/mmcblk0p2 on / type ext4 (rw,noatime)
                            This is OK, and you dont have to do anything about it.

                            If output of above command contains ro like shown below, your file system is "read-and-write".
                            /dev/mmcblk0p2 on / type ext4 (ro,noatime)
                            This is NOT OK. To fix it, please copy-paste following command in terminal / PuTTY:
                            Code:
                            sudo mount -o remount,rw /
                            After above command, you can save changes you make to dump1090-mutability configuration. On reboot, the changes to dump1090 configuration wont be lost. However on reboot, the file system will again become "read-only", and if you want to make any further changes in config, you will have to again make it "read-and-write" by command given above.


                            FIX FOR ITEM (2) ABOVE:
                            To make sure of receiver type which has been set, copy-paste following command in terminal / PuTTY. It's output will show what receiver type is.

                            Code:
                            cat /etc/fr24feed.ini | grep receiver
                            If the output of above command is receiver="avr-tcp" or receiver="beast-tcp", your setting is OK. Then the issue is read-only file system.

                            If the output of above command is receiver="dvbt", your setting is the cause of problem. First you have to correct the settings by following method:

                            Open file fr24feed.ini for editing by copy-pasting following command in terminal / PuTTY:
                            Code:
                            sudo nano /etc/fr24feed.ini
                            In above file you will see following line:
                            receiver="dvbt"

                            Delete above line, and in its place copy-paste following two lines:

                            receiver="avr-tcp"
                            host="127.0.0.1:30002"

                            Save file (Ctrl+O) and close file (Ctrl+X)

                            Now change start dump1090 from "no" to "yes" by any of the two methods described in my above post.
                            Reboot Pi and after check again if start dump1090 is still "yes" or again changed to "no".
                            Last edited by abcd567; 2022-02-22, 08:56.

                            Comment


                            • #15
                              I'm facing the same problem....can't connect..why no help came???
                              Attached Files

                              Comment

                              Working...
                              X