Announcement

Collapse
No announcement yet.

Fr24 under Docker running Raspberry Pi 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fr24 under Docker running Raspberry Pi 4

    I have installed Fr24 feeding station in Docker using mikenye/docker-flightradar24. I had to use docker bcz I am running home assistant on this rpi4. The receiver is online but not updating any aircraft. Here is my log file.
    Code:
    [s6-init] making user provided files available at /var/run/s6/etc...exited 0.,
    [s6-init] ensuring user provided files have correct perms...exited 0.,
    [fix-attrs.d] applying ownership & permissions fixes...,
    [fix-attrs.d] done.,
    [cont-init.d] executing container initialization scripts...,
    [cont-init.d] 01-fr24feed: executing... ,
    [cont-init.d] 01-fr24feed: exited 0.,
    [cont-init.d] done.,
    [services.d] starting services,
    [services.d] done.,
    2021-06-21 07:44:35 | ______ _ _ _ _ _ _____ ___ ,
    2021-06-21 07:44:35 | | ___|| |(_) | | | | | | / __ \ / |,
    2021-06-21 07:44:35 | | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |,
    2021-06-21 07:44:35 | | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |,
    2021-06-21 07:44:35 | | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |,
    2021-06-21 07:44:35 | \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/,
    2021-06-21 07:44:35 | __/ | ,
    2021-06-21 07:44:35 | |___/ ,
    2021-06-21 07:44:35 | info | [httpd]Server started, listening on 0.0.0.0:8754,
    2021-06-21 07:44:37 | [i]PacketSenderConfiguration::fetch_config(): Yoda configuration for this receiver is disabled,
    2021-06-21 07:44:37 | [d]TLSConnection::ctor(): Enable verify_peer in production code!,
    2021-06-21 07:44:37 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:44:38 | [feed][d]fetching configuration,
    2021-06-21 07:44:40 | [feed][c]Max range AIR: 350.0nm,
    2021-06-21 07:44:40 | [feed][c]Max range GND: 100.0nm,
    2021-06-21 07:44:40 | [feed][c]Timestamps: optional,
    2021-06-21 07:44:40 | info | Stopping ReceiverACSender threads for feed ,
    2021-06-21 07:44:40 | info | Configured ReceiverACSender: 185.218.24.22:8099,185.218.24.23:8099,185.218.24.2 4:8099, feed: OPLA6, send_interval: 5s, max age: 15s, send metadata: true, mode: 1, filtering: true,
    2021-06-21 07:44:40 | info | Network thread connecting to 185.218.24.22:8099 for feed OPLA6,
    2021-06-21 07:44:40 | info | [stats]Stats thread started,
    2021-06-21 07:44:42 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:44:47 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:44:52 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:44:57 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:45:02 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:45:07 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:45:12 | [reader][e]Could not connect to tcp://beasthost:30005,
    2021-06-21 07:45:17 | [reader][e]Could not connect to tcp://beasthost:30005,

  • #2
    You should read the entire guide: https://mikenye.gitbook.io/

    You need to run at least the readsb container as well as it talks to the SDR.

    Comment


    • #3
      Code:
        [ATTACH=JSON]{"data-align":"none","data-size":"full","title":"Screenshot 2021-06-21 181508.png","data-attachmentid":204916}[/ATTACH]
      Is this correct?
      Attached Files

      Comment


      • #4
        Just continue ..... if it doesn't work you can still ask.
        But no that error is not an issue.

        Comment


        • #5
          Originally posted by wiedehopf View Post
          Just continue ..... if it doesn't work you can still ask.
          But no that error is not an issue.
          what I should do now??
          Screenshot 2021-06-21 212918.png

          Comment


          • #6
            Read the complete guide from the start.

            You missed this section: https://mikenye.gitbook.io/ads-b/set...docker-compose

            Comment


            • #7

              I didn't miss that step but even after updated version is from 2018
              Screenshot 2021-06-21 234528.png
              and even after I have created the "/etc/modprobe.d/blacklist-rtl2832.conf" file
              operation not permitted
              Screenshot 2021-06-21 234814.pngAfter attaching the rtl2832u device
              Screenshot 2021-06-21 235513.png


              Another error
              Screenshot 2021-06-22 000328.png
              Last edited by raptor22; 2021-06-21, 19:05.

              Comment


              • #8
                The rmmod showing an error is normal and expected.

                Are you already using the SDR for something else?

                Seems /opt is read-only and you can't use it to create that directory ... you'll have to find a non temp directory you can actually write to and use that ;P

                Comment


                • #9
                  No, I am not using sdr for anything else. which directory I should use for writing to?
                  this is giving me nuts
                  Screenshot 2021-06-22 121341.png

                  Comment


                  • #10
                    I don't know home assistant.

                    Maybe you enabled overlayfs enabled or something leading to you not being able to make permanent changes to the disk.
                    Maybe you have some sd-card issues or something ... i don't know ;P

                    With the cd at the end, you're using a leading / which means it will not interpret it as relative but rather absolute path.
                    You can google ... unix absolute relative path and should find info ....

                    I mean instead of /opt/adsb ...
                    You could check
                    mount

                    And see which stuff is mounted where and what is read-only.
                    Lots of directories instead of /opt/adsb could work ... you could even do /adsb if you wanted ;p
                    But again i don't know what is writeable.
                    You could go against all good taste and use /home/adsb (even though no such user exists ... it would usually be his home directory).

                    Comment


                    • #11
                      I
                      have tried installed another docker package
                      https://hub.docker.com/r/nicosingh/rpi-fr24feed
                      at least it changed my status to online.
                      Only issue is data not being sent fr24 log. I have only change IP and location for posting only.
                      Code:
                      Could not open /var/log/fr24feed/fr24feed.log for writing!,
                      ______ _ _ _ _ _ _____ ___ ,
                      | ___|| |(_) | | | | | | / __ \ / |,
                      | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |,
                      | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |,
                      | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |,
                      \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/,
                      __/ | ,
                      |___/ ,
                      [main][i]FR24 Feeder/Decoder,
                      [main][i]Version: 1.0.19-15/generic,
                      [main][i]Built on Feb 6 2018 09:19:16 (HEAD-0bb4994.git/Linux/static_arm),
                      [main][i]Running on: raspbian9,
                      [main][i]Local IP(s): 172.17.0.5,
                      [main][i]Copyright 2012-2018 Flightradar24 AB,
                      [main][i]https://www.flightradar24.com,
                      [main][i]DNS mode: PING,
                      [main][i]Automatic updates are ENABLED,
                      ERROR,
                      [w]Detected --net argument for dump1090, disabling internal RAW feed!,
                      [ATTACH=JSON]{"data-align":"none","data-size":"large","data-attachmentid":204959}[/ATTACH] [httpd][i]Server started, listening on 0.0.0.0:8754,
                      [main][i]Reader thread started,
                      [main][i]MLAT data feed started,
                      [mlat][i]Waiting for MLAT configuration,
                      [master][i]Starting processing thread,
                      [reader][i]Initializing reader,
                      [reader][i]Connecting to DVBT receiver via (exe:///dump1090/dump1090 --net --fix --aggressive --enable-agc --stats-every 60 --modeac --net-beast --raw --mlat),
                      [reader][i]Connected to the receiver, configuring,
                      [reader][i]Configured, processing messages,
                      Found 1 device(s):,
                      0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected),
                      Found Rafael Micro R820T tuner,
                      Max available gain is: 49.60,
                      Setting gain to: 49.60,
                      Exact sample rate is: 2000000.052982 Hz,
                      Gain reported by device: 49.60,
                      [time][i]Synchronizing time via NTP,
                      [reader][w]Setting new UTC offset: 0!,
                      [time][i]Time synchronized correctly, offset +0.0007 seconds,
                      [main][i]Feed Network client started,
                      [feed][i]Downloading configuration,
                      [feed][c]Interval: 5s,
                      ed][c]Latitude: 31.5303,
                      [feed][c]Longitude: 74.4183,
                      [feed][c]GND: YES,
                      [feed][c]NonADSB: YES,
                      [feed][c]Timestamps: optional,
                      [feed][c]Max range AIR: 350.0nm,
                      [feed][c]Max range GND: 100.0nm,
                      ed][i]defined 4 servers,
                      [stats][i]Stats thread started,
                      [feed][n]OPXXY@1XX.2XX.XX.22:8099/UDP,
                      [feed][n]connecting,
                      [mlat][i]MLAT configuration received, service ENABLED,
                      [mlat][i]Starting MLAT with preconfigured position: 31.53,74.42,218.0,
                      [mlat][i]MLAT bandwidth reduction active, level 1,
                      [mlat][i]Configuring UDP connection udp://sin.fr24.com:19788,
                      [feed][n]connected via UDP (fd 5),
                      [feed][n]working,
                      [mlat][i]Registering MLAT station,
                      [mlat][i]Registering MLAT station: SUCCESS,
                      [mlat][i]No ADS-B time reference available (0/0),
                      [mlat][i]Pinging the server,
                      [mlat][i]Stats 0/0,
                      [mlat][i]No ADS-B time reference available (0/0),
                      Screenshot 2021-06-22 141717.png
                      Screenshot 2021-06-22 141502.png
                      Attached Files

                      Comment


                      • #12
                        Solution found.
                        just install and config this docker "thomx/fr24feed-piaware"
                        https://hub.docker.com/r/thomx/fr24feed-piaware
                        Proof of pi is in eating it. Hopefully it keeps on working.
                        Screenshot 2021-06-22 152135.pngScreenshot 2021-06-22 151829.png

                        Comment


                        • #13
                          Steps outlined in this post
                          https://community.home-assistant.io/...evice/317356/2

                          Comment


                          • #14
                            mikes containers should also have docker run command lines explained.
                            if the docker-compose was the issue .... just use docker run

                            Comment


                            • #15
                              Now it is even easier to setup Fr24 feeder in Homeassistant using the new add-on check this thread. https://community.home-assistant.io/...aware/345563/9

                              Link to add-on https://github.com/MaxWinterstein/homeassistant-addons. It is even easier than Fr24 raspberry-pi setup.

                              @admins please sticky this.

                              Comment

                              Working...
                              X